]> git.pld-linux.org Git - packages/adapter.git/commitdiff
- export pkgconfigdir
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 22 Feb 2010 08:23:26 +0000 (08:23 +0000)
committerElan Ruusamäe <glen@pld-linux.org>
Mon, 22 Feb 2010 08:23:26 +0000 (08:23 +0000)
- versionize awk and shell script dependency
- allow adapter.awk to return non-ok exit code
- update copyright year

Changed files:
    adapter.awk -> 1.439
    adapter.sh -> 1.44

adapter.awk
adapter.sh

index 2c5eebf88d8a6e63b4025d3a9c884361bb010652..07131523b819d7c0d20f2bb15e0aae60d85148fd 100644 (file)
@@ -2,7 +2,7 @@
 #
 # Adapter adapts .spec files for PLD Linux.
 #
-# Copyright (C) 1999-2008 PLD-Team <feedback@pld-linux.org>
+# Copyright (C) 1999-2010 PLD-Team <feedback@pld-linux.org>
 # Authors:
 #      Michał Kuratczyk <kura@pld.org.pl>
 #      Sebastian Zagrodzki <s.zagrodzki@mimuw.edu.pl>
@@ -137,7 +137,7 @@ function b_makekey(a, b,    s) {
                while (getline)         # print the rest of spec as it is
                        print
                do_not_touch_anything = 1 # do not touch anything in END()
-               exit 0
+               exit(rc = 0)
        }
 
        # Generally, comments are printed without touching
@@ -975,8 +975,9 @@ preamble == 1 {
 
 
 END {
-       if (do_not_touch_anything)
-               exit 0
+       if (do_not_touch_anything) {
+               exit(rc)
+       }
 
        # TODO: need to output these in proper place
        if (BR_count > 0) {
@@ -1092,6 +1093,9 @@ function use_macros()
        gsub("%{_datadir}/pixmaps", "%{_pixmapsdir}")
        gsub("%{_datadir}/java", "%{_javadir}")
 
+       gsub("%{_libdir}/pkgconfig", "%{_pkgconfigdir}")
+       gsub(pkgconfigdir, "%{_pkgconfigdir}")
+
        gsub(libdir, "%{_libdir}")
        gsub(javadir, "%{_javadir}")
 
@@ -1724,7 +1728,13 @@ function import_rpm_macros() {
        if (!topdir) {
                print "adapter.awk should not not be invoked directly, but via adapter script" > "/dev/stderr"
                do_not_touch_anything = 1
-               exit(1);
+               exit(rc = 1);
+       }
+
+       if (!ENVIRON["ADAPTER_REVISION"] || ENVIRON["ADAPTER_REVISION"] < 1.44) {
+               print "adapter shell script is outdated, please cvs up it" > "/dev/stderr"
+               do_not_touch_anything = 1
+               exit(rc = 1);
        }
 
        # get cvsaddress for changelog section
@@ -1748,6 +1758,7 @@ function import_rpm_macros() {
        desktopdir = ENVIRON["_desktopdir"]
        pixmapsdir = ENVIRON["_pixmapsdir"]
        javadir = ENVIRON["_javadir"]
+       pkgconfigdir = ENVIRON["_pkgconfigdir"]
 
        perl_sitearch = ENVIRON["perl_sitearch"]
        perl_archlib = ENVIRON["perl_archlib"]
index f3b25054ec57fe2ff1d746fb355c3415d8cefae6..94a1c3d4d26ea2d2924df29f8e00e87034ddbba7 100644 (file)
 # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
 
 RCSID='$Id$'
-r=${RCSID#* * }
-rev=${r%% *}
-VERSION="v0.35/$rev"
+REVISION=${RCSID#* * } REVISION=${REVISION%% *}
+VERSION="v0.35/$REVISION"
 VERSIONSTRING="\
 Adapter adapts .spec files for PLD Linux.
-$VERSION (C) 1999-2009 Free Penguins".
+$VERSION (C) 1999-2010 Free Penguins".
 
 PROGRAM=${0##*/}
 dir=$(d=$0; [ -L "$d" ] && d=$(readlink "$d"); dirname "$d")
@@ -194,6 +193,7 @@ import_rpm_macros() {
        _desktopdir
        _pixmapsdir
        _javadir
+       _pkgconfigdir
 
        perl_sitearch
        perl_archlib
@@ -231,19 +231,21 @@ import_rpm_macros() {
        export _cvsmailfeedback='%{?_cvsmailfeedback}%{!?_cvsmailfeedback:PLD Team <feedback@pld-linux.org>}'
        "
 
+       export ADAPTER_REVISION=$REVISION
+
        eval $(rpm --eval "$(echo -e $eval_expr)")
 }
 
 adapterize() {
        local workdir
-       workdir=$(mktemp -d ${TMPDIR:-/tmp}/adapter-XXXXXX) || exit
+       workdir=$(mktemp -d ${TMPDIR:-/tmp}/adapter-XXXXXX) || exit $?
        awk=gawk
 
-       local tmp=$workdir/$(basename $SPECFILE) || exit
+       local tmp=$workdir/$(basename $SPECFILE) || exit $?
 
        import_rpm_macros
 
-       LC_ALL=en_US.UTF-8 $awk -f $adapter $SPECFILE > $tmp || exit
+       LC_ALL=en_US.UTF-8 $awk -f $adapter $SPECFILE > $tmp || exit $?
 
        if [ "$outputonly" = 1 ]; then
                cat $tmp
This page took 0.116224 seconds and 4 git commands to generate.