]> git.pld-linux.org Git - packages/adapter.git/commitdiff
add %systemduserunitdir handling
authorElan Ruusamäe <glen@delfi.ee>
Sat, 5 Apr 2014 17:14:11 +0000 (20:14 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 5 Apr 2014 17:14:11 +0000 (20:14 +0300)
adapter.awk
adapter.sh

index 738c25d7f99663266e77b761453b11bc608e66fb..3e0cda4e0efb52590812380f57de26e24afc752e 100644 (file)
@@ -1127,6 +1127,8 @@ function use_macros()
 
        gsub("%{_unitdir}", "%{systemdunitdir}")
        gsub(systemdunitdir, "%{systemdunitdir}")
+       gsub("%{_userunitdir}", "%{systemduserunitdir}")
+       gsub(systemduserunitdir, "%{systemduserunitdir}")
        gsub(systemdtmpfilesdir, "%{systemdtmpfilesdir}")
 
        gsub("%{_datadir}/applications", "%{_desktopdir}")
@@ -1852,7 +1854,7 @@ function import_rpm_macros(  v) {
        }
 
        # update this version dep each time some new macro export is added
-       v = 1.51
+       v = 1.52
        if (!ENVIRON["ADAPTER_REVISION"] || ENVIRON["ADAPTER_REVISION"] < v) {
                printf("adapter shell script is outdated: Need %s, got %s. Please update it.\n", v, ENVIRON["ADAPTER_REVISION"]) > "/dev/stderr"
                do_not_touch_anything = 1
@@ -1914,6 +1916,7 @@ function import_rpm_macros(  v) {
        tmpdir = ENVIRON["tmpdir"]
 
        systemdunitdir = ENVIRON["systemdunitdir"]
+       systemduserunitdir = ENVIRON["systemduserunitdir"]
        systemdtmpfilesdir = ENVIRON["systemdtmpfilesdir"]
 }
 
index 761eeb967559adaaa685144df70c42c46486be2b..2b1e987107713b7bad171a25eaedd53cdbbc3e0c 100755 (executable)
@@ -12,7 +12,7 @@
 #
 # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
 
-REVISION=1.51
+REVISION=1.52
 VERSION="v0.35/$REVISION"
 VERSIONSTRING="\
 Adapter adapts .spec files for PLD Linux.
@@ -231,6 +231,7 @@ import_rpm_macros() {
        tmpdir
 
        systemdunitdir
+       systemduserunitdir
        systemdtmpfilesdir
 "
        eval_expr=""
This page took 0.085543 seconds and 4 git commands to generate.