]> git.pld-linux.org Git - packages/adapter.git/commitdiff
adapter: recognize ruby_specdir macro
authorElan Ruusamäe <glen@delfi.ee>
Sat, 26 Oct 2013 16:30:29 +0000 (19:30 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 26 Oct 2013 16:30:29 +0000 (19:30 +0300)
adapter.awk
adapter.sh

index 57f1e632df75bd3d2051c9398091c89afb63250f..cd6e688a4785b89acac9b6bcc86ad815416f1d7b 100644 (file)
@@ -1114,6 +1114,7 @@ function use_macros()
        gsub(ruby_rubylibdir, "%{ruby_rubylibdir}") # deprecated
        gsub(ruby_rdocdir, "%{ruby_rdocdir}")
        gsub(ruby_ridir, "%{ruby_ridir}")
+       gsub(ruby_specdir, "%{ruby_specdir}")
 
        gsub("%{_unitdir}", "%{systemdunitdir}")
        gsub(systemdunitdir, "%{systemdunitdir}")
@@ -1840,7 +1841,7 @@ function import_rpm_macros(  v) {
        }
 
        # update this version dep each time some new macro export is added
-       v = 1.49
+       v = 1.51
        if (!ENVIRON["ADAPTER_REVISION"] || ENVIRON["ADAPTER_REVISION"] < v) {
                printf("adapter shell script is outdated: Need %s, got %s. Please update it.\n", v, ENVIRON["ADAPTER_REVISION"]) > "/dev/stderr"
                do_not_touch_anything = 1
@@ -1895,6 +1896,7 @@ function import_rpm_macros(  v) {
        ruby_rubylibdir = ENVIRON["ruby_rubylibdir"] # deprecated
        ruby_rdocdir = ENVIRON["ruby_rdocdir"]
        ruby_ridir = ENVIRON["ruby_ridir"]
+       ruby_specdir = ENVIRON["ruby_specdir"]
 
        php_pear_dir = ENVIRON["php_pear_dir"]
        php_data_dir = ENVIRON["php_data_dir"]
index d5c786648e0409c1f00b8ccb0b6528d1efc28ea2..761eeb967559adaaa685144df70c42c46486be2b 100755 (executable)
@@ -12,7 +12,7 @@
 #
 # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
 
-REVISION=1.50
+REVISION=1.51
 VERSION="v0.35/$REVISION"
 VERSIONSTRING="\
 Adapter adapts .spec files for PLD Linux.
@@ -224,6 +224,7 @@ import_rpm_macros() {
        ruby_rubylibdir
        ruby_rdocdir
        ruby_ridir
+       ruby_specdir
 
        php_pear_dir
        php_data_dir
This page took 0.035992 seconds and 4 git commands to generate.