]> git.pld-linux.org Git - packages/accel-ppp.git/blob - accel-ppp.spec
- initial
[packages/accel-ppp.git] / accel-ppp.spec
1 #
2 # TODO:
3 #
4 # - change libdir from /usr/lib to %{_libdir}
5 # - check accel-ppp.tmpfiles
6 # - add bconds
7 #
8 Summary:        High performance PPTP/L2TP/PPPoE server
9 Name:           accel-ppp
10 Version:        1.6.1
11 Release:        0.1
12 License:        GPL v2+
13 Group:          Networking
14 URL:            http://sourceforge.net/projects/accel-ppp/
15 Source0:        http://downloads.sourceforge.net/accel-ppp/%{name}-%{version}.tar.bz2
16 # Source0-md5:  8985ab9f743b952396f6dc53d6fd56a8
17 Source1:        %{name}.tmpfiles
18 Patch0:         %{name}-cmake.patch
19 BuildRequires:  cmake >= 2.6
20 BuildRequires:  libnl1-devel
21 BuildRequires:  openssl-devel
22 BuildRequires:  pcre-devel
23 BuildRequires:  net-snmp-devel >= 5.0
24
25 %description
26 The ACCEL-PPP is completly new implementation of PPTP/PPPoE/L2TP
27 which was written from scratch. Userspace daemon has its own PPP
28 implementation, so it does not uses pppd and one process
29 (multi-threaded) manages all connections. ACCEL-PPP uses only
30 kernel-mode implementations of pptp/l2tp/pppoe.
31
32 Features:
33 - PPTP server
34 - PPPoE server
35 - L2TPv2 server
36 - Radius CoA/DM(PoD)
37 - Built-in shaper (tbf)
38 - Command line interface (telnet)
39 - SNMP
40 - IPv6 (including builtin Neighbor Discovery and DHCPv6)
41
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 install -d build
49 cd build
50 %{cmake} \
51           -DSHAPER=TRUE \
52           -DRADIUS=TRUE \
53           -DNETSNMP=TRUE \
54           -DLOG_PGSQL=FALSE \
55           ../
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} -C build install/fast \
61           DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} $RPM_BUILD_ROOT%{systemdtmpfilesdir}
64 install -d $RPM_BUILD_ROOT/var/{log/accel-ppp,run/accel-ppp}
65 install %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
66 echo "0" > $RPM_BUILD_ROOT/var/run/accel-ppp/seq
67
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc COPYING README
75 %{_sysconfdir}/accel-ppp.conf.dist
76 %attr(755,root,root) %{_sbindir}/accel-pppd
77 /usr/lib/accel-ppp
78 %dir /var/run/%{name}
79 /var/run/%{name}/seq
80 %{systemdtmpfilesdir}/%{name}.conf
81 %{_datadir}/accel-ppp/
82 %{_mandir}/man5/accel-ppp.conf.5*
This page took 0.078895 seconds and 3 git commands to generate.