]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
Release 2 (by relup.sh)
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
4 #
5 # Conditional build:
6 %bcond_without  tests   # disable pythontests
7 %bcond_with     rpm5    # build with rpm5
8
9 %define         libreport_ver   2.13.0
10 Summary:        Automatic bug detection and reporting tool
11 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
12 Name:           abrt
13 Version:        2.14.4
14 Release:        5
15 License:        GPL v2+
16 Group:          Applications/System
17 #Source0Download: https://github.com/abrt/abrt/releases
18 Source0:        https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  c7583c001464cb2ec0067afb08cdc6cb
20 Source1:        %{name}.init
21 Patch0:         %{name}-rpm5.patch
22 Patch2:         %{name}-link.patch
23 Patch3:         %{name}-split-usr.patch
24 URL:            https://abrt.readthedocs.org/
25 BuildRequires:  asciidoc
26 %{?with_tests:BuildRequires:    augeas}
27 BuildRequires:  autoconf >= 2.50
28 BuildRequires:  automake
29 BuildRequires:  dbus-devel
30 BuildRequires:  docbook-dtd45-xml
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.55.1
33 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
34 BuildRequires:  gtk+3-devel >= 3.0
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  json-c-devel
37 BuildRequires:  libgomp-devel
38 BuildRequires:  libnotify-devel >= 0.7.0
39 BuildRequires:  libreport-devel >= %{libreport_ver}
40 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
41 BuildRequires:  libreport-web-devel >= %{libreport_ver}
42 BuildRequires:  libselinux-devel
43 BuildRequires:  libsoup-devel >= 2.4
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2
46 BuildRequires:  pkgconfig
47 BuildRequires:  polkit-devel
48 BuildRequires:  python3-devel >= 1:3.6
49 BuildRequires:  python3-modules >= 1:3.6
50 %{?with_tests:BuildRequires:    python3-nose}
51 %{?with_tests:BuildRequires:    python3-pytest}
52 BuildRequires:  rpm-build >= 4.6
53 BuildRequires:  rpm-devel >= 4.5-28
54 BuildRequires:  rpm-pythonprov
55 BuildRequires:  rpmbuild(macros) >= 1.752
56 BuildRequires:  satyr-devel >= 0.21
57 BuildRequires:  sphinx-pdg-3
58 BuildRequires:  systemd-devel >= 1:209
59 BuildRequires:  xmlto
60 Requires(postun):       /usr/sbin/groupdel
61 Requires(postun):       /usr/sbin/userdel
62 Requires(pre):  /bin/id
63 Requires(pre):  /usr/bin/getgid
64 Requires(pre):  /usr/sbin/groupadd
65 Requires(pre):  /usr/sbin/useradd
66 Requires:       %{name}-libs = %{version}-%{release}
67 Provides:       group(abrt)
68 Provides:       user(abrt)
69 Obsoletes:      abrt-addon-coredump-helper < 2.13.0
70 Obsoletes:      abrt-addon-python < 2.13.0
71 Obsoletes:      abrt-atomic < 2.13.0
72 Obsoletes:      abrt-cli < 2.13.0
73 Obsoletes:      abrt-plugin-catcut < 2.1
74 Obsoletes:      abrt-plugin-filetransfer < 2.1
75 Obsoletes:      abrt-plugin-rhfastcheck < 2.1
76 Obsoletes:      abrt-plugin-rhticket < 2.1
77 Obsoletes:      abrt-plugin-runapp < 2.1
78 Obsoletes:      abrt-plugin-sosreport < 2.1
79 Obsoletes:      abrt-plugin-sqlite3 < 1.0.7
80 Obsoletes:      abrt-plugin-ticketuploader < 2.1
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 ABRT is a tool to help users to detect defects in applications and to
85 create a bug report with all informations needed by maintainer to fix
86 it. It uses plugin system to extend its functionality.
87
88 %description -l pl.UTF-8
89 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
90 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
91 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
92 system wtyczek do rozszerzania funkcjonalności.
93
94 %package -n bash-completion-abrt
95 Summary:        Bash completion for abrt command
96 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla polecenia abrt
97 Group:          Applications/Shells
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       bash-completion
100 Requires:       python3-argcomplete
101 BuildArch:      noarch
102
103 %description -n bash-completion-abrt
104 Bash completion for abrt command.
105
106 %description -n bash-completion-abrt -l pl.UTF-8
107 Bashowe dopełnianie parametrów dla polecenia abrt.
108
109 %package libs
110 Summary:        ABRT shared library
111 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
112 Group:          Libraries
113 Requires:       glib2 >= 1:2.55.1
114 Requires:       libreport >= %{libreport_ver}
115
116 %description libs
117 ABRT shared library.
118
119 %description libs -l pl.UTF-8
120 Biblioteka współdzielona ABRT.
121
122 %package devel
123 Summary:        Header files for ABRT livrary
124 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
125 Group:          Development/Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127 Requires:       glib2-devel >= 1:2.55.1
128 Requires:       libreport-devel >= %{libreport_ver}
129
130 %description devel
131 Header files for ABRT livrary.
132
133 %description devel -l pl.UTF-8
134 Pliki nagłówkowe biblioteki ABRT.
135
136 %package addon-ccpp
137 Summary:        ABRT's C/C++ addon
138 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       %{name}-retrace-client = %{version}-%{release}
142 Requires:       cpio
143 Requires:       elfutils
144 Requires:       gdb >= 7.0-3
145 Requires:       satyr >= 0.21
146 Obsoletes:      abrt-atomic < 2.13
147
148 %description addon-ccpp
149 This package contains hook for C/C++ crashed programs and abrt's C/C++
150 analyzer plugin.
151
152 %description addon-ccpp -l pl.UTF-8
153 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
154 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
155
156 %package addon-kerneloops
157 Summary:        ABRT's kerneloops addon
158 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
159 Group:          Libraries
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       curl
162 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
163 Obsoletes:      abrt-plugin-kerneloops < 0.0.7.2
164 Obsoletes:      abrt-plugin-kerneloopsreporter < 1.0.7
165 Obsoletes:      kerneloops < 0.0.7.2
166
167 %description addon-kerneloops
168 This package contains plugin for collecting kernel crash information
169 from system log.
170
171 %description addon-kerneloops -l pl.UTF-8
172 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
173 logu systemowego.
174
175 %package addon-pstoreoops
176 Summary:        ABRT's pstoreoops addon
177 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
178 Group:          Libraries
179 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
180 Obsoletes:      abrt-addon-uefioops < 2.1.7
181
182 %description addon-pstoreoops
183 This package contains plugin for collecting kernel oopses from pstore
184 storage.
185
186 %description addon-pstoreoops -l pl.UTF-8
187 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
188
189 %package addon-python3
190 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
191 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
192 Group:          Libraries
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       %{name}-python3 = %{version}-%{release}
195 # for detecting package name containing offending file
196 %{!?with_rpm5:Suggests: python3-rpm}
197 # for logging to journal
198 Suggests:       python3-systemd
199
200 %description addon-python3
201 This package contains Python hook and Python analyzer plugin for
202 handling uncaught exception in Python 3 programs.
203
204 %description addon-python3 -l pl.UTF-8
205 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
206 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
207 Pythonie 3.
208
209 %package addon-upload-watch
210 Summary:        ABRT's upload addon
211 Summary(pl.UTF-8):      Dodatek upload do ABRT
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214
215 %description addon-upload-watch
216 This package contains hook for uploaded problems.
217
218 %description addon-upload-watch -l pl.UTF-8
219 Ten pakiet zawiera uchwyt dla problemów przysłanych.
220
221 %package addon-vmcore
222 Summary:        ABRT's vmcore addon
223 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
227 Requires:       crash
228
229 %description addon-vmcore
230 This package contains plugin for collecting kernel crash information
231 from vmcore files.
232
233 %description addon-vmcore -l pl.UTF-8
234 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
235 plików vmcore.
236
237 %package addon-xorg
238 Summary:        ABRT's Xorg addon
239 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
240 Group:          Libraries
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       curl
243
244 %description addon-xorg
245 This package contains plugin for collecting Xorg crash information
246 from Xorg log.
247
248 %description addon-xorg -l pl.UTF-8
249 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
250 logu Xorg.
251
252 %package plugin-bodhi
253 Summary:        ABRT's bodhi plugin
254 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       libreport-web >= %{libreport_ver}
258 Obsoletes:      libreport-plugin-bodhi < 2.0.16
259
260 %description plugin-bodhi
261 Plugin to search for a new updates in bodhi server.
262
263 %description plugin-bodhi -l pl.UTF-8
264 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
265
266 %package retrace-client
267 Summary:        ABRT's retrace client
268 Summary(pl.UTF-8):      Klient Retrace dla ABRT
269 Group:          Libraries
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       xz
272
273 %description retrace-client
274 This package contains the client application for Retrace server which
275 is able to analyze C/C++ crashes remotely.
276
277 %description retrace-client -l pl.UTF-8
278 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
279 potrafi zdalnie przeanalizować awarię programu w C/C++.
280
281 %package dbus
282 Summary:        ABRT DBus service
283 Summary(pl.UTF-8):      Usługa DBus ABRT
284 Group:          Applications/System
285 Requires:       %{name} = %{version}-%{release}
286 Requires:       libreport >= %{libreport_ver}
287
288 %description dbus
289 ABRT DBus service which provides org.freedesktop.problems API on DBus
290 and uses PolicyKit to authorize to access the problem data.
291
292 %description dbus -l pl.UTF-8
293 Usługa DBus ABRT, udostępniająca poprzez DBus API
294 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
295 do danych o problemach.
296
297 %package python3
298 Summary:        ABRT Python 3 API
299 Summary(pl.UTF-8):      API Pythona 3 do ABRT
300 Group:          Libraries/Python
301 Requires:       %{name} = %{version}-%{release}
302 Requires:       python3-libreport >= %{libreport_ver}
303 Obsoletes:      abrt-python < 2.13.0
304
305 %description python3
306 High-level API for querying, creating and manipulating problems
307 handled by ABRT in Python.
308
309 %description python3 -l pl.UTF-8
310 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
311 Pythona 3 problemów obsługiwanych przez ABRT.
312
313 %package gui
314 Summary:        ABRT's GUI
315 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
316 Group:          X11/Applications
317 Requires(post,postun):  /sbin/ldconfig
318 Requires(post,postun):  gtk-update-icon-cache
319 Requires(post,postun):  hicolor-icon-theme
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       %{name}-dbus = %{version}-%{release}
322 Requires:       %{name}-gui-libs = %{version}-%{release}
323 Suggests:       gnome-abrt
324 Provides:       abrt-applet = %{version}-%{release}
325 Obsoletes:      abrt-applet < 0.0.5
326 Conflicts:      abrt-applet < 0.0.5
327
328 %description gui
329 GTK+ wizard for convenient bug reporting.
330
331 %description gui -l pl.UTF-8
332 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
333
334 %package gui-libs
335 Summary:        ABRT's GUI library
336 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
337 Group:          X11/Libraries
338 Requires:       %{name}-libs = %{version}-%{release}
339 Requires:       gtk+3 >= 3.0
340
341 %description gui-libs
342 ABRT's GUI library.
343
344 %description gui-libs -l pl.UTF-8
345 Biblioteka graficznego interfejsu użytkownika ABRT.
346
347 %package gui-devel
348 Summary:        Header files for ABRT GUI library
349 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
350 Group:          X11/Development/Libraries
351 Requires:       %{name}-devel = %{version}-%{release}
352 Requires:       %{name}-gui-libs = %{version}-%{release}
353 Requires:       gtk+3-devel >= 3.0
354
355 %description gui-devel
356 Header files for ABRT GUI library.
357
358 %description gui-devel -l pl.UTF-8
359 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
360
361 %package desktop
362 Summary:        Virtual package to install all necessary packages for usage from desktop environment
363 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
364 Group:          X11/Applications
365 # This package should be installed when anything requests bug-buddy;
366 # installing abrt-desktop should result in the abrt which works without
367 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
368 Requires:       %{name} = %{version}-%{release}
369 Requires:       %{name}-addon-ccpp = %{version}-%{release}
370 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
371 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
372 Requires:       %{name}-addon-python3 = %{version}-%{release}
373 Requires:       %{name}-addon-vmcore = %{version}-%{release}
374 Requires:       %{name}-addon-xorg = %{version}-%{release}
375 Requires:       %{name}-gui = %{version}-%{release}
376 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
377 Requires:       %{name}-retrace-client = %{version}-%{release}
378 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
379 Requires:       libreport-plugin-logger >= %{libreport_ver}
380 Requires:       libreport-plugin-ureport >= %{libreport_ver}
381 Provides:       bug-buddy
382 Obsoletes:      bug-buddy < 2.33
383
384 %description desktop
385 Virtual package to make easy default installation on desktop
386 environments.
387
388 %description desktop -l pl.UTF-8
389 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
390 graficznych.
391
392 %package console-notification
393 Summary:        ABRT console notification script
394 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
395 Group:          Applications/System
396 Requires:       %{name} = %{version}-%{release}
397
398 %description console-notification
399 A small script which prints a count of detected problems when someone
400 logs in to the shell.
401
402 %description console-notification -l pl.UTF-8
403 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
404 się do powłoki.
405
406 %prep
407 %setup -q
408 %{?with_rpm5:%patch0 -p1}
409 %patch2 -p1
410 %patch3 -p1
411
412 %{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
413
414 echo -n %{version} > abrt-version
415
416 %build
417 %{__libtoolize}
418 %{__gettextize}
419 %{__intltoolize}
420 %{__aclocal} -I m4
421 %{__autoconf}
422 %{__autoheader}
423 %{__automake}
424 %configure \
425         AUGPARSE=/usr/bin/augparse \
426         PYTHON_NOSE=/usr/bin/nosetests-%{py3_ver} \
427         --enable-dump-time-unwind \
428         --enable-native-unwinder \
429         --disable-silent-rules \
430         %{!?with_tests:--without-pythontests} \
431         --with-systemdsystemunitdir=%{systemdunitdir}
432
433 %{__make}
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 %{__make} install \
438         DESTDIR=$RPM_BUILD_ROOT \
439         systemdsystemunitdir=%{systemdunitdir} \
440         python3dir=%{py3_sitescriptdir}
441
442 # obsoleted by pkg-config
443 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
444
445 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
446 install -d $RPM_BUILD_ROOT/var/cache/%{name}
447 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
448 install -d $RPM_BUILD_ROOT/var/run/%{name}
449
450 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
451 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
452 d /var/run/%{name} 0755 root root -
453 EOF
454
455 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
456 # examples
457 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
458 # packaged as %doc
459 %{__rm} $RPM_BUILD_ROOT%{_docdir}/abrt/README.md
460
461 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
462 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
463
464 %find_lang %{name}
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %pre
470 %groupadd -g 248 abrt
471 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
472
473 %post
474 /sbin/chkconfig --add abrtd
475 %service abrtd restart
476 %systemd_post abrtd.service
477
478 %preun
479 if [ "$1" = "0" ]; then
480         %service abrtd stop
481         /sbin/chkconfig --del abrtd
482 fi
483 %systemd_preun abrtd.service
484
485 %postun
486 if [ "$1" = "0" ]; then
487         %userremove abrt
488         %groupremove abrt
489 fi
490
491 %post   libs -p /sbin/ldconfig
492 %postun libs -p /sbin/ldconfig
493
494 %post addon-ccpp
495 %systemd_post abrt-ccpp.service
496 %systemd_post abrt-journal-core.service
497 %journal_catalog_update
498
499 %preun addon-ccpp
500 %systemd_preun abrt-ccpp.service
501 %systemd_preun abrt-journal-core.service
502
503 %post addon-kerneloops
504 %systemd_post abrt-oops.service
505 %journal_catalog_update
506
507 %preun addon-kerneloops
508 %systemd_preun abrt-oops.service
509
510 %post addon-pstoreoops
511 %systemd_post abrt-pstoreoops.service
512
513 %preun addon-pstoreoops
514 %systemd_preun abrt-pstoreoops.service
515
516 %post addon-python3
517 %journal_catalog_update
518
519 %post addon-upload-watch
520 %systemd_post abrt-upload-watch.service
521
522 %preun addon-upload-watch
523 %systemd_preun abrt-upload-watch.service
524
525 %post addon-vmcore
526 %systemd_post abrt-vmcore.service
527 %journal_catalog_update
528
529 %preun addon-vmcore
530 %systemd_preun abrt-vmcore.service
531
532 %post addon-xorg
533 %systemd_post abrt-xorg.service
534 %journal_catalog_update
535
536 %preun addon-xorg
537 %systemd_preun abrt-xorg.service
538
539 %post gui
540 %update_icon_cache hicolor
541
542 %postun gui
543 %update_icon_cache hicolor
544
545 %post   gui-libs -p /sbin/ldconfig
546 %postun gui-libs -p /sbin/ldconfig
547
548 %files -f %{name}.lang
549 %defattr(644,root,root,755)
550 %doc CHANGELOG.md README.md changelog
551 %attr(755,root,root) %{_bindir}/abrt
552 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
553 %attr(755,root,root) %{_bindir}/abrt-action-notify
554 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
555 %attr(755,root,root) %{_bindir}/abrt-handle-upload
556 %attr(755,root,root) %{_bindir}/abrt-watch-log
557 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
558 %attr(755,root,root) %{_sbindir}/abrt-server
559 %attr(755,root,root) %{_sbindir}/abrtd
560 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
561 %attr(755,root,root) %{_libexecdir}/abrt-action-save-container-data
562 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
563 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
564 %{py3_sitescriptdir}/abrtcli
565 %dir %{_datadir}/%{name}
566 %{_datadir}/augeas/lenses/abrt.aug
567 %dir %{_sysconfdir}/%{name}
568 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
569 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
570 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
571 %dir %{_sysconfdir}/%{name}/plugins
572 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
573 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/machine-id_event.conf
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/sosreport_event.conf
576 %attr(754,root,root) /etc/rc.d/init.d/abrtd
577 %{systemdunitdir}/abrtd.service
578 %attr(775,root,abrt) %dir /var/cache/%{name}
579 %dir /var/run/%{name}
580 %{systemdtmpfilesdir}/abrt.conf
581 %{_mandir}/man1/abrt.1*
582 %{_mandir}/man1/abrt-action-analyze-python.1*
583 %{_mandir}/man1/abrt-action-notify.1*
584 %{_mandir}/man1/abrt-action-save-package-data.1*
585 %{_mandir}/man1/abrt-auto-reporting.1*
586 %{_mandir}/man1/abrt-handle-upload.1*
587 %{_mandir}/man1/abrt-server.1*
588 %{_mandir}/man1/abrt-watch-log.1*
589 %{_mandir}/man5/abrt.conf.5*
590 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
591 %{_mandir}/man5/abrt_event.conf.5*
592 %{_mandir}/man5/report_event.conf.5
593 %{_mandir}/man5/gpg_keys.conf.5*
594 %{_mandir}/man5/smart_event.conf.5*
595 %{_mandir}/man8/abrtd.8*
596
597 %files -n bash-completion-abrt
598 %defattr(644,root,root,755)
599 /etc/bash_completion.d/abrt.bash_completion
600
601 %files libs
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
604 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
605
606 %files devel
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/libabrt.so
609 %dir %{_includedir}/abrt
610 %{_includedir}/abrt/abrt-dbus.h
611 %{_includedir}/abrt/hooklib.h
612 %{_includedir}/abrt/libabrt.h
613 %{_includedir}/abrt/problem_api.h
614 %{_pkgconfigdir}/abrt.pc
615
616 %files addon-ccpp
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
619 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
620 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
621 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
622 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
623 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
624 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
625 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
626 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
627 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
628 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
629 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
630 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
631 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
632 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
633 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
634 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
635 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_journal_ccpp_format.conf
637 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
638 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
639 %{_datadir}/libreport/events/analyze_CCpp.xml
640 %{_datadir}/libreport/events/analyze_LocalGDB.xml
641 %{_datadir}/libreport/events/collect_GConf.xml
642 %{_datadir}/libreport/events/collect_vimrc_system.xml
643 %{_datadir}/libreport/events/collect_vimrc_user.xml
644 %{_datadir}/libreport/events/collect_xsession_errors.xml
645 %{_datadir}/libreport/events/post_report.xml
646 %{systemdunitdir}/abrt-journal-core.service
647 %{_prefix}/lib/systemd/catalog/abrt_ccpp.catalog
648 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
649 %{_mandir}/man1/abrt-action-analyze-c.1*
650 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
651 %{_mandir}/man1/abrt-action-analyze-core.1*
652 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
653 %{_mandir}/man1/abrt-action-generate-backtrace.1*
654 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
655 %{_mandir}/man1/abrt-action-install-debuginfo.1*
656 %{_mandir}/man1/abrt-action-list-dsos.1*
657 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
658 %{_mandir}/man1/abrt-action-trim-files.1*
659 %{_mandir}/man1/abrt-dump-journal-core.1*
660 %{_mandir}/man5/abrt-CCpp.conf.5*
661 %{_mandir}/man5/ccpp_event.conf.5*
662 %{_mandir}/man5/ccpp_retrace_event.conf.5*
663 %{_mandir}/man5/gconf_event.conf.5*
664 %{_mandir}/man5/vimrc_event.conf.5*
665
666 %files addon-kerneloops
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
669 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
670 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
671 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
672 %attr(755,root,root) %{_bindir}/abrt-dump-oops
673 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
674 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_koops_format.conf
675 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
676 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
677 %{systemdunitdir}/abrt-oops.service
678 %{_prefix}/lib/systemd/catalog/abrt_koops.catalog
679 %{_mandir}/man1/abrt-action-analyze-oops.1*
680 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
681 %{_mandir}/man1/abrt-dump-journal-oops.1*
682 %{_mandir}/man1/abrt-dump-oops.1*
683 %{_mandir}/man5/abrt-oops.conf.5*
684 %{_mandir}/man5/koops_event.conf.5*
685
686 %files addon-pstoreoops
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
689 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
690 %{systemdunitdir}/abrt-pstoreoops.service
691 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
692 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
693 %{_mandir}/man1/abrt-merge-pstoreoops.1*
694
695 %files addon-python3
696 %defattr(644,root,root,755)
697 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
698 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
699 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_python3_format.conf
700 %{py3_sitescriptdir}/abrt_exception_handler3.py*
701 %{py3_sitescriptdir}/abrt_exception_handler3_container.py*
702 %{py3_sitescriptdir}/abrt3.pth
703 %{py3_sitescriptdir}/abrt3_container.pth
704 %{py3_sitescriptdir}/__pycache__/abrt_exception_handler3*.cpython-*.py[co]
705 %{_prefix}/lib/systemd/catalog/python3_abrt.catalog
706 %{_mandir}/man5/python3_event.conf.5*
707 %{_mandir}/man5/python3-abrt.conf.5*
708
709 %files addon-upload-watch
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
712 %{systemdunitdir}/abrt-upload-watch.service
713 %{_mandir}/man1/abrt-upload-watch.1*
714
715 %files addon-vmcore
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
718 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
719 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
720 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
721 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_vmcore_format.conf
722 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
723 %{_datadir}/libreport/events/analyze_VMcore.xml
724 %{systemdunitdir}/abrt-vmcore.service
725 %{_prefix}/lib/systemd/catalog/abrt_vmcore.catalog
726 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
727 %{_mandir}/man1/abrt-harvest-vmcore.1*
728 %{_mandir}/man5/abrt-vmcore.conf.5*
729 %{_mandir}/man5/vmcore_event.conf.5*
730
731 %files addon-xorg
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
734 %attr(755,root,root) %{_bindir}/abrt-dump-journal-xorg
735 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
736 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_xorg_format.conf
739 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
740 %{systemdunitdir}/abrt-xorg.service
741 %{_prefix}/lib/systemd/catalog/abrt_xorg.catalog
742 %{_mandir}/man1/abrt-action-analyze-xorg.1*
743 %{_mandir}/man1/abrt-dump-journal-xorg.1*
744 %{_mandir}/man1/abrt-dump-xorg.1*
745 %{_mandir}/man5/abrt-xorg.conf.5*
746 %{_mandir}/man5/xorg_event.conf.5*
747
748 %files plugin-bodhi
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_bindir}/abrt-action-find-bodhi-update
751 %attr(755,root,root) %{_bindir}/abrt-bodhi
752 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/bodhi_event.conf
753 %{_datadir}/libreport/events/analyze_BodhiUpdates.xml
754 %{_mandir}/man1/abrt-action-find-bodhi-update.1*
755 %{_mandir}/man1/abrt-bodhi.1*
756
757 %files retrace-client
758 %defattr(644,root,root,755)
759 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
760 %attr(755,root,root) %{_bindir}/abrt-retrace-client
761 %{_datadir}/libreport/events/analyze_RetraceServer.xml
762 %{_mandir}/man1/abrt-retrace-client.1*
763
764 %files dbus
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_sbindir}/abrt-dbus
767 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_dbus_event.conf
768 /etc/dbus-1/system.d/dbus-abrt.conf
769 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
770 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.xml
771 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Entry.xml
772 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Session.xml
773 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Task.xml
774 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
775 %{_datadir}/polkit-1/actions/abrt_polkit.policy
776 %{_mandir}/man8/abrt-dbus.8*
777 %{_docdir}/abrt-dbus-%{version}
778
779 %files python3
780 %defattr(644,root,root,755)
781 %dir %{py3_sitedir}/problem
782 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
783 %{py3_sitedir}/problem/*.py*
784 %{py3_sitedir}/problem/__pycache__
785 %{_mandir}/man5/python3-abrt.5*
786
787 %files gui
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/abrt-applet
790 %attr(755,root,root) %{_bindir}/system-config-abrt
791 %dir %{_datadir}/%{name}
792 %{_datadir}/%{name}/ui
793 %{_iconsdir}/hicolor/scalable/apps/abrt.svg
794 %{_iconsdir}/hicolor/symbolic/apps/abrt-symbolic.svg
795 %{_sysconfdir}/xdg/autostart/org.freedesktop.problems.applet.desktop
796 %{_datadir}/dbus-1/services/org.freedesktop.problems.applet.service
797 %{_mandir}/man1/abrt-applet.1*
798 %{_mandir}/man1/system-config-abrt.1*
799
800 %files gui-libs
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
803 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
804
805 %files gui-devel
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libabrt_gui.so
808 %{_includedir}/abrt/abrt-config-widget.h
809 %{_includedir}/abrt/system-config-abrt.h
810 %{_pkgconfigdir}/abrt_gui.pc
811
812 %files desktop
813 %defattr(644,root,root,755)
814
815 %files console-notification
816 %defattr(644,root,root,755)
817 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.153106 seconds and 3 git commands to generate.