]> git.pld-linux.org Git - packages/WindowMaker.git/commitdiff
- updated for 0.63.1.
authorkloczek <kloczek@pld-linux.org>
Sun, 7 Jan 2001 22:48:05 +0000 (22:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    WindowMaker-shared.patch -> 1.4
    WindowMaker-singleclick.patch -> 1.4

WindowMaker-shared.patch
WindowMaker-singleclick.patch

index fe28a06ed8609cb2c5384662039dd2e34795f9cd..bc73c77f4e0d5695340fcab35e15710c07426b6c 100644 (file)
@@ -1,95 +1,79 @@
-diff -Nru WindowMaker-0.62.1/WINGs/Makefile.am WindowMaker-0.62.1.new/WINGs/Makefile.am
---- WindowMaker-0.62.1/WINGs/Makefile.am       Tue Aug  8 00:51:57 2000
-+++ WindowMaker-0.62.1.new/WINGs/Makefile.am   Tue Aug  8 00:41:38 2000
-@@ -10,11 +10,12 @@
-       -lm @LIBPL@
+diff -Nru WindowMaker-0.63.1/WINGs/Makefile.am WindowMaker-0.63.1.new/WINGs/Makefile.am
+--- WindowMaker-0.63.1/WINGs/Makefile.am       Sun Jan  7 00:21:58 2001
++++ WindowMaker-0.63.1.new/WINGs/Makefile.am   Sun Jan  7 23:25:42 2001
+@@ -4,10 +4,6 @@
  
+ SUBDIRS = . Documentation Resources Examples Extras Tests
  
--#lib_LTLIBRARIES = libWINGs.la
-+lib_LTLIBRARIES = libWINGs.la libWUtil.la
--lib_LIBRARIES = libWINGs.a libWUtil.a
-+#lib_LIBRARIES = libWINGs.a libWUtil.la
+-
+-
 -#libWINGs_la_LDFLAGS = -version-info 1:1:0
-+libWINGs_la_LDFLAGS = -version-info 1:1:0
-+libWUtil_la_LDFLAGS = -version-info 1:1:0
- include_HEADERS = WINGs.h WUtil.h WINGsP.h
-@@ -24,39 +25,39 @@
- testmywidget_SOURCES = testmywidget.c mywidget.c mywidget.h
--testmywidget_LDADD = libWINGs.a $(LIBLIST)
-+testmywidget_LDADD = libWINGs.la $(LIBLIST)
- fontl_SOURCES = fontl.c
+-
+ # is this a kluge? if so, how should i do it?
+ includedir = @includedir@/WINGs
  
--fontl_LDADD = libWINGs.a $(LIBLIST)
-+fontl_LDADD = libWINGs.la $(LIBLIST)
+@@ -15,16 +11,17 @@
  
- wtest_SOURCES = wtest.c
--wtest_LDADD = libWINGs.a $(LIBLIST)
-+wtest_LDADD = libWINGs.la $(LIBLIST)
--wtest_DEPENDENCIES = libWINGs.a
-+wtest_DEPENDENCIES = libWINGs.la
- wmfile_SOURCES = wmfile.c 
--wmfile_LDADD = libWINGs.a $(LIBLIST)
-+wmfile_LDADD = libWINGs.la $(LIBLIST)
-       
- testcolorpanel_SOURCES = testcolorpanel.c
+ bin_SCRIPTS = get-wings-flags get-wutil-flags
  
--testcolorpanel_LDADD = libWINGs.a $(LIBLIST)
-+testcolorpanel_LDADD = libWINGs.la $(LIBLIST)
- wmquery_SOURCES = wmquery.c 
--wmquery_LDADD = libWINGs.a $(LIBLIST)
-+wmquery_LDADD = libWINGs.la $(LIBLIST)
- connect_SOURCES = connect.c
+-lib_LIBRARIES = libWINGs.a libWUtil.a
+-
++lib_LIBRARIES = libWINGs.la libWUtil.la
  
--connect_LDADD = libWUtil.a @LIBRARY_SEARCH_PATH@ @NETLIBS@ @LIBPL@
-+connect_LDADD = libWUtil.la @LIBRARY_SEARCH_PATH@ @NETLIBS@ @LIBPL@
+-LDADD= libWINGs.a $(top_builddir)/wrlib/libwraster.la @LIBPL@
++libWINGs_la_LDFLAGS = -version-info 1:1:0
++libWUtil_la_LDFLAGS = -version-info 1:1:0
  
++LDADD= libWINGs.la $(top_builddir)/wrlib/libwraster.la @LIBPL@
  
- EXTRA_DIST = logo.xpm BUGS
+ EXTRA_DIST = BUGS
  
  # wbutton.c 
 -libWINGs_a_SOURCES =  \
 +libWINGs_la_SOURCES =         \
        WINGs.h \
        WINGsP.h \
-       configuration.c \
-@@ -108,7 +109,7 @@
-       usleep.c
+       array.c \
+@@ -80,7 +77,7 @@
+       wwindow.c
  
  
 -libWUtil_a_SOURCES =  \
 +libWUtil_la_SOURCES =         \
        WINGs.h \
        WINGsP.h \
-       bagarray.c \
-diff -Nru WindowMaker-0.62.1/src/Makefile.am WindowMaker-0.62.1.new/src/Makefile.am
---- WindowMaker-0.62.1/src/Makefile.am Fri Jan 14 17:30:56 2000
-+++ WindowMaker-0.62.1.new/src/Makefile.am     Tue Aug  8 00:52:09 2000
-@@ -114,7 +114,7 @@
+       array.c \
+diff -Nru WindowMaker-0.63.1/WPrefs.app/Makefile.am WindowMaker-0.63.1.new/WPrefs.app/Makefile.am
+--- WindowMaker-0.63.1/WPrefs.app/Makefile.am  Sun Jan  7 00:21:58 2001
++++ WindowMaker-0.63.1.new/WPrefs.app/Makefile.am      Sun Jan  7 23:23:08 2001
+@@ -46,10 +46,10 @@
+ INCLUDES = -I$(top_srcdir)/wrlib -I$(top_srcdir)/WINGs @HEADER_SEARCH_PATH@ 
+-WPrefs_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.a
++WPrefs_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
+ WPrefs_LDADD = \
+-      $(top_builddir)/WINGs/libWINGs.a\
++      $(top_builddir)/WINGs/libWINGs.la\
+       $(top_builddir)/wrlib/libwraster.la \
+       @LIBPL@ \
+       @INTLIBS@
+diff -Nru WindowMaker-0.63.1/src/Makefile.am WindowMaker-0.63.1.new/src/Makefile.am
+--- WindowMaker-0.63.1/src/Makefile.am Sun Jan  7 00:21:58 2001
++++ WindowMaker-0.63.1.new/src/Makefile.am     Sun Jan  7 23:23:08 2001
+@@ -113,7 +113,7 @@
  
  
  wmaker_LDADD = \
 -      $(top_builddir)/WINGs/libWINGs.a\
 +      $(top_builddir)/WINGs/libWINGs.la\
        $(top_builddir)/wrlib/libwraster.la\
-       @LIBRARY_SEARCH_PATH@ \
        @LIBPL@ \
-diff -Nru WindowMaker-0.62.1/test/Makefile.am WindowMaker-0.62.1.new/test/Makefile.am
---- WindowMaker-0.62.1/test/Makefile.am        Tue Aug  8 00:51:57 2000
-+++ WindowMaker-0.62.1.new/test/Makefile.am    Tue Aug  8 00:41:38 2000
+       @XLIBS@ \
+diff -Nru WindowMaker-0.63.1/test/Makefile.am WindowMaker-0.63.1.new/test/Makefile.am
+--- WindowMaker-0.63.1/test/Makefile.am        Sun Jan  7 00:21:58 2001
++++ WindowMaker-0.63.1.new/test/Makefile.am    Sun Jan  7 23:23:08 2001
 @@ -8,7 +8,7 @@
  
  wtest_SOURCES = wtest.c
@@ -99,31 +83,31 @@ diff -Nru WindowMaker-0.62.1/test/Makefile.am WindowMaker-0.62.1.new/test/Makefi
  
  
  INCLUDES = -g -D_BSD_SOURCE @XCFLAGS@ -I$(top_srcdir)/wmlib 
-diff -Nru WindowMaker-0.62.1/util/Makefile.am WindowMaker-0.62.1.new/util/Makefile.am
---- WindowMaker-0.62.1/util/Makefile.am        Tue Aug  8 00:51:57 2000
-+++ WindowMaker-0.62.1.new/util/Makefile.am    Tue Aug  8 00:41:38 2000
-@@ -31,7 +31,7 @@
- geticonset_LDADD= $(liblist)
+diff -Nru WindowMaker-0.63.1/util/Makefile.am WindowMaker-0.63.1.new/util/Makefile.am
+--- WindowMaker-0.63.1/util/Makefile.am        Sun Jan  7 00:21:58 2001
++++ WindowMaker-0.63.1.new/util/Makefile.am    Sun Jan  7 23:23:08 2001
+@@ -46,7 +46,7 @@
+       @DLLIBS@
  
  wmsetbg_LDADD = \
 -      $(top_builddir)/WINGs/libWINGs.a \
 +      $(top_builddir)/WINGs/libWINGs.la \
        $(top_builddir)/wrlib/libwraster.la \
-       @LIBRARY_SEARCH_PATH@ \
        @LIBPL@ \
-diff -Nru WindowMaker-0.62.1/wmlib/Makefile.am WindowMaker-0.62.1.new/wmlib/Makefile.am
---- WindowMaker-0.62.1/wmlib/Makefile.am       Tue Aug  8 00:51:57 2000
-+++ WindowMaker-0.62.1.new/wmlib/Makefile.am   Tue Aug  8 00:41:38 2000
+       @DLLIBS@
+diff -Nru WindowMaker-0.63.1/wmlib/Makefile.am WindowMaker-0.63.1.new/wmlib/Makefile.am
+--- WindowMaker-0.63.1/wmlib/Makefile.am       Sun Jan  7 00:21:58 2001
++++ WindowMaker-0.63.1.new/wmlib/Makefile.am   Sun Jan  7 23:23:51 2001
 @@ -1,13 +1,13 @@
  
  AUTOMAKE_OPTIONS = no-dependencies
  
 -lib_LIBRARIES = libWMaker.a
-+lib_LTLIBRARIES = libWMaker.la
++lib_LIBRARIES = libWMaker.la
  
  include_HEADERS = WMaker.h
  
- INCLUDES = @DFLAGS@ @XCFLAGS@
+ INCLUDES = $(DFLAGS) @XCFLAGS@
  
 -libWMaker_a_SOURCES =         \
 +libWMaker_la_SOURCES =        \
@@ -135,19 +119,3 @@ diff -Nru WindowMaker-0.62.1/wmlib/Makefile.am WindowMaker-0.62.1.new/wmlib/Make
        menu.h  
  
 +libWMaker_la_LDFLAGS = -version-info 1:1:1
-diff -Nru WindowMaker-0.62.1/WPrefs.app/Makefile.am WindowMaker-0.62.1.new/WPrefs.app/Makefile.am
---- WindowMaker-0.62.1/WPrefs.app/Makefile.am  Sun Apr  2 23:18:15 2000
-+++ WindowMaker-0.62.1.new/WPrefs.app/Makefile.am      Tue Aug  8 01:20:38 2000
-@@ -48,10 +48,10 @@
-       -I$(top_srcdir)/wrlib \
-       -I$(top_srcdir)/WINGs @HEADER_SEARCH_PATH@ 
--WPrefs_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.a
-+WPrefs_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
- WPrefs_LDADD = \
--      $(top_builddir)/WINGs/libWINGs.a\
-+      $(top_builddir)/WINGs/libWINGs.la\
-       $(top_builddir)/wrlib/libwraster.la \
-       @LIBRARY_SEARCH_PATH@ \
-       @LIBPL@ \
index ce73713c14beb7621fcdfeeb2b9b69053c658498..c5ad6c1febb2a1dc4de924e4b7c22ee80637c053 100644 (file)
@@ -1,43 +1,43 @@
-diff -Nru WindowMaker-0.62.1/WPrefs.app/Expert.c WindowMaker-0.62.1.new/WPrefs.app/Expert.c
---- WindowMaker-0.62.1/WPrefs.app/Expert.c     Mon Aug  7 23:18:24 2000
-+++ WindowMaker-0.62.1.new/WPrefs.app/Expert.c Mon Aug  7 23:19:12 2000
-@@ -53,6 +53,7 @@
-     WMSetButtonSelected(panel->swi[3], GetBoolForKey("UseSaveUnders"));
-     WMSetButtonSelected(panel->swi[4], GetBoolForKey("DisableBlinking"));
+diff -Nru WindowMaker-0.63.1/WPrefs.app/Expert.c WindowMaker-0.63.1.new/WPrefs.app/Expert.c
+--- WindowMaker-0.63.1/WPrefs.app/Expert.c     Sat Jan  6 23:43:21 2001
++++ WindowMaker-0.63.1.new/WPrefs.app/Expert.c Sun Jan  7 23:06:09 2001
+@@ -54,6 +54,7 @@
+     WMSetButtonSelected(panel->swi[4], GetBoolForKey("WindozeCycling"));
      WMSetButtonSelected(panel->swi[5], GetBoolForKey("DontConfirmKill"));
+     WMSetButtonSelected(panel->swi[6], GetBoolForKey("DisableBlinking"));
 +    WMSetButtonSelected(panel->swi[6], GetBoolForKey("SingleClickLaunch"));
  }
  
  
-@@ -66,7 +67,7 @@
+@@ -67,7 +68,7 @@
      WMResizeWidget(panel->frame, FRAME_WIDTH, FRAME_HEIGHT);
      WMMoveWidget(panel->frame, FRAME_LEFT, FRAME_TOP);
  
--    for (i=0; i<6; i++) {
-+    for (i=0; i<7; i++) {
+-    for (i=0; i<7; i++) {
++    for (i=0; i<8; i++) {
        panel->swi[i] = WMCreateSwitchButton(panel->frame);
        WMResizeWidget(panel->swi[i], FRAME_WIDTH-40, 25);
        WMMoveWidget(panel->swi[i], 20, 20+i*25);
-@@ -78,6 +79,7 @@
-     WMSetButtonText(panel->swi[3], _("Use SaveUnder in window frames, icons, menus and other objects"));
-     WMSetButtonText(panel->swi[4], _("Disable cycling color highlighting of icons."));
-     WMSetButtonText(panel->swi[5], _("Disable confirmation panel for the Kill command."));
+@@ -80,6 +81,7 @@
+     WMSetButtonText(panel->swi[4], _("Use Windoze style cycling"));
+     WMSetButtonText(panel->swi[5], _("Disable confirmation panel for the Kill command"));
+     WMSetButtonText(panel->swi[6], _("Disable cycling color highlighting of icons"));
 +    WMSetButtonText(panel->swi[6], _("Launch applications and restore windows with a single click"));
  
      WMRealizeWidget(panel->frame);
      WMMapSubwidgets(panel->frame);
-@@ -99,6 +101,7 @@
-     SetBoolForKey(WMGetButtonSelected(panel->swi[3]), "UseSaveUnders");
-     SetBoolForKey(WMGetButtonSelected(panel->swi[4]), "DisableBlinking");
+@@ -102,6 +104,7 @@
+     SetBoolForKey(WMGetButtonSelected(panel->swi[4]), "WindozeCycling");
      SetBoolForKey(WMGetButtonSelected(panel->swi[5]), "DontConfirmKill");
+     SetBoolForKey(WMGetButtonSelected(panel->swi[6]), "DisableBlinking");
 +    SetBoolForKey(WMGetButtonSelected(panel->swi[6]), "SingleClickLaunch");
  }
  
  
-diff -Nru WindowMaker-0.62.1/src/WindowMaker.h WindowMaker-0.62.1.new/src/WindowMaker.h
---- WindowMaker-0.62.1/src/WindowMaker.h       Mon Aug  7 23:18:24 2000
-+++ WindowMaker-0.62.1.new/src/WindowMaker.h   Mon Aug  7 23:19:12 2000
-@@ -416,6 +416,9 @@
+diff -Nru WindowMaker-0.63.1/src/WindowMaker.h WindowMaker-0.63.1.new/src/WindowMaker.h
+--- WindowMaker-0.63.1/src/WindowMaker.h       Fri Nov 17 03:10:32 2000
++++ WindowMaker-0.63.1.new/src/WindowMaker.h   Sun Jan  7 23:02:54 2001
+@@ -424,6 +424,9 @@
      /* shading animation */
      signed char shade_speed;
  
@@ -47,9 +47,9 @@ diff -Nru WindowMaker-0.62.1/src/WindowMaker.h WindowMaker-0.62.1.new/src/Window
      int edge_resistance;
      char attract;
  
-diff -Nru WindowMaker-0.62.1/src/appicon.c WindowMaker-0.62.1.new/src/appicon.c
---- WindowMaker-0.62.1/src/appicon.c   Mon Aug  7 23:18:24 2000
-+++ WindowMaker-0.62.1.new/src/appicon.c       Mon Aug  7 23:19:12 2000
+diff -Nru WindowMaker-0.63.1/src/appicon.c WindowMaker-0.63.1.new/src/appicon.c
+--- WindowMaker-0.63.1/src/appicon.c   Wed Nov  1 16:40:16 2000
++++ WindowMaker-0.63.1.new/src/appicon.c       Sun Jan  7 23:02:54 2001
 @@ -717,6 +717,7 @@
      int shad_x = 0, shad_y = 0, docking=0, dockable, collapsed = 0;
      int ix, iy;
@@ -84,10 +84,10 @@ diff -Nru WindowMaker-0.62.1/src/appicon.c WindowMaker-0.62.1.new/src/appicon.c
            break;
        }
      }
-diff -Nru WindowMaker-0.62.1/src/defaults.c WindowMaker-0.62.1.new/src/defaults.c
---- WindowMaker-0.62.1/src/defaults.c  Mon Aug  7 23:18:24 2000
-+++ WindowMaker-0.62.1.new/src/defaults.c      Mon Aug  7 23:20:35 2000
-@@ -530,6 +530,9 @@
+diff -Nru WindowMaker-0.63.1/src/defaults.c WindowMaker-0.63.1.new/src/defaults.c
+--- WindowMaker-0.63.1/src/defaults.c  Sat Jan  6 22:28:02 2001
++++ WindowMaker-0.63.1.new/src/defaults.c      Sun Jan  7 23:02:54 2001
+@@ -547,6 +547,9 @@
      {"DisableBlinking",       "NO",           NULL,
           &wPreferences.dont_blink,    getBool,        NULL
      },
@@ -97,10 +97,10 @@ diff -Nru WindowMaker-0.62.1/src/defaults.c WindowMaker-0.62.1.new/src/defaults.
        /* style options */
      {"MenuStyle",     "normal",               seMenuStyles,
        &wPreferences.menu_style, getEnum,      setMenuStyle
-diff -Nru WindowMaker-0.62.1/src/dock.c WindowMaker-0.62.1.new/src/dock.c
---- WindowMaker-0.62.1/src/dock.c      Mon Aug  7 23:18:24 2000
-+++ WindowMaker-0.62.1.new/src/dock.c  Mon Aug  7 23:19:12 2000
-@@ -3750,7 +3750,7 @@
+diff -Nru WindowMaker-0.63.1/src/dock.c WindowMaker-0.63.1.new/src/dock.c
+--- WindowMaker-0.63.1/src/dock.c      Wed Nov  1 16:40:16 2000
++++ WindowMaker-0.63.1.new/src/dock.c  Sun Jan  7 23:02:54 2001
+@@ -3752,7 +3752,7 @@
  
  
  
@@ -109,7 +109,7 @@ diff -Nru WindowMaker-0.62.1/src/dock.c WindowMaker-0.62.1.new/src/dock.c
  handleIconMove(WDock *dock, WAppIcon *aicon, XEvent *event)
  {
      WScreen *scr = dock->screen_ptr;
-@@ -3765,11 +3765,12 @@
+@@ -3767,11 +3767,12 @@
      int ix = aicon->xindex, iy = aicon->yindex;
      int tmp;
      Pixmap ghost = None;
@@ -123,7 +123,7 @@ diff -Nru WindowMaker-0.62.1/src/dock.c WindowMaker-0.62.1.new/src/dock.c
      if (wPreferences.flags.noupdates)
        return;
  
-@@ -3820,6 +3821,7 @@
+@@ -3822,6 +3823,7 @@
            break;
  
         case MotionNotify:
@@ -131,7 +131,7 @@ diff -Nru WindowMaker-0.62.1/src/dock.c WindowMaker-0.62.1.new/src/dock.c
            if (!grabbed) {
                if (abs(ofs_x-ev.xmotion.x)>=MOVE_THRESHOLD
                    || abs(ofs_y-ev.xmotion.y)>=MOVE_THRESHOLD) {
-@@ -3975,7 +3977,10 @@
+@@ -3977,7 +3979,10 @@
  #ifdef DEBUG
            puts("End icon move");
  #endif
@@ -143,7 +143,7 @@ diff -Nru WindowMaker-0.62.1/src/dock.c WindowMaker-0.62.1.new/src/dock.c
        }
      }
  }
-@@ -4115,7 +4120,9 @@
+@@ -4117,7 +4122,9 @@
              else
                  handleDockMove(dock, aicon, event);
          } else
@@ -154,9 +154,9 @@ diff -Nru WindowMaker-0.62.1/src/dock.c WindowMaker-0.62.1.new/src/dock.c
  
      } else if (event->xbutton.button==Button2 && dock->type==WM_CLIP &&
                 aicon==scr->clip_icon) {
-diff -Nru WindowMaker-0.62.1/src/icon.c WindowMaker-0.62.1.new/src/icon.c
---- WindowMaker-0.62.1/src/icon.c      Mon Aug  7 23:18:24 2000
-+++ WindowMaker-0.62.1.new/src/icon.c  Mon Aug  7 23:19:12 2000
+diff -Nru WindowMaker-0.63.1/src/icon.c WindowMaker-0.63.1.new/src/icon.c
+--- WindowMaker-0.63.1/src/icon.c      Sat Jan  6 22:28:02 2001
++++ WindowMaker-0.63.1.new/src/icon.c  Sun Jan  7 23:02:54 2001
 @@ -874,6 +874,7 @@
      int dx=event->xbutton.x, dy=event->xbutton.y;
      int grabbed=0;
This page took 0.055217 seconds and 4 git commands to generate.