]> git.pld-linux.org Git - packages/VirtualBox.git/commitdiff
- file creation moved to %prep
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 13 Mar 2007 17:15:05 +0000 (17:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    VirtualBox.spec -> 1.15

VirtualBox.spec

index bf76135e43b653b0620e48257eff93f00cfe7e55..c804cd801b825204110d683afdf518ac21cefe50 100644 (file)
@@ -144,6 +144,25 @@ Moduł jądra Linuksa SMP vboxdrv dla VirtualBoksa.
 %patch0 -p0
 %patch1 -p0
 
+cat > VBox.sh <<'EOF'
+#!/bin/sh
+
+if [ ! -c /dev/vboxdrv ]; then
+       echo "Special character device /dev/vboxdrv doesn't exists!"
+       echo "Check your installation and if vboxdrv kernel module is loaded."
+       exit 1
+fi
+
+if [ ! -w /dev/vboxdrv ]; then
+       echo "You don't have write access to /dev/vboxdrv!"
+       echo "Correct this situation or contact with your system administrator."
+       exit 1
+fi
+
+BINFILE=$(basename "$0")
+LD_LIBRARY_PATH=%{_libdir}/VirtualBox %{_libdir}/VirtualBox/$BINFILE ${1:+"$@"}
+EOF
+
 %build
 KDIR="%{_builddir}/%{buildsubdir}/kernel"
 mkdir -p $KDIR
@@ -202,29 +221,9 @@ install -d \
        $RPM_BUILD_ROOT%{_libdir}/VirtualBox \
        $RPM_BUILD_ROOT/etc/rc.d/init.d
 
-cat > VBox.sh <<'EOF'
-#!/bin/sh
-
-if [ ! -c /dev/vboxdrv ]; then
-       echo "Special character device /dev/vboxdrv doesn't exists!"
-       echo "Check your installation and if vboxdrv kernel module is loaded."
-       exit 1
-fi
-
-if [ ! -w /dev/vboxdrv ]; then
-       echo "You don't have write access to /dev/vboxdrv!"
-       echo "Correct this situation or contact with your system administrator."
-       exit 1
-fi
-
-BINFILE=$(basename "$0")
-LD_LIBRARY_PATH=%{_libdir}/VirtualBox %{_libdir}/VirtualBox/$BINFILE ${1:+"$@"}
-EOF
-
-for f in {VBox{BFE,Manage,SDL,SVC,XPCOMIPCD},VirtualBox}
-do
-install out/linux.%{_outdir}/release/bin/$f $RPM_BUILD_ROOT%{_libdir}/VirtualBox/$f
-install VBox.sh $RPM_BUILD_ROOT%{_bindir}/$f
+for f in {VBox{BFE,Manage,SDL,SVC,XPCOMIPCD},VirtualBox}; do
+       install out/linux.%{_outdir}/release/bin/$f $RPM_BUILD_ROOT%{_libdir}/VirtualBox/$f
+       install VBox.sh $RPM_BUILD_ROOT%{_bindir}/$f
 done
 
 install out/linux.%{_outdir}/release/bin/VBox{C,DD,DD2,REM,REMImp,RT,VMM,XML,XPCOM,XPCOMIPCC}.so \
This page took 0.032429 seconds and 4 git commands to generate.