]> git.pld-linux.org Git - packages/Servus.git/blob - Servus.spec
R: Qt5Core-devel in -devel; rel 2
[packages/Servus.git] / Servus.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        C++ network utility library that provides a zeroconf API, URI parsing and UUIDs
6 Summary(pl.UTF-8):      Biblioteka narzędzi sieciowych udostępniająca API zeroconf, analizy URI i UUID
7 Name:           Servus
8 Version:        1.5.2
9 Release:        2
10 License:        LGPL v3
11 Group:          Libraries
12 #Source0Download: https://github.com/HBPVIS/Servus/releases
13 Source0:        https://github.com/HBPVIS/Servus/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  bc6fb62a002fd288fc2c1f12878a533c
15 URL:            https://github.com/HBPVIS/Servus
16 BuildRequires:  Eyescale-CMake >= 2016.04
17 BuildRequires:  Qt5Core-devel >= 5
18 BuildRequires:  Qt5Widgets-devel >= 5
19 BuildRequires:  avahi-devel
20 # unit_test_framework
21 BuildRequires:  boost-devel >= 1.51
22 BuildRequires:  cmake >= 3.1
23 %{?with_apidocs:BuildRequires:  doxygen}
24 BuildRequires:  libstdc++-devel >= 6:4.7
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Servus is a small C++ network utility library that provides a zeroconf
30 API, URI parsing and UUIDs.
31
32 %description -l pl.UTF-8
33 Servus to mała biblioteka C++ narzędzi sieciowych, udostępnikająca API
34 zeroconf, analizy URI i UUID.
35
36 %package devel
37 Summary:        Header files for Servus library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Servus
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       Qt5Core-devel >= 5
42 Requires:       libstdc++-devel >= 6:4.7
43
44 %description devel
45 Header files for Servus library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki Servus.
49
50 %package qt
51 Summary:        Servus Qt library
52 Summary(pl.UTF-8):      Biblioteka Servus Qt
53 Group:          Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description qt
57 Servus Qt library.
58
59 %description qt -l pl.UTF-8
60 Biblioteka Servus Qt.
61
62 %package qt-devel
63 Summary:        Header files for Servus Qt library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Servus Qt
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67 Requires:       %{name}-qt = %{version}-%{release}
68 Requires:       Qt5Core-devel >= 5
69
70 %description qt-devel
71 Header files for Servus Qt library.
72
73 %description qt-devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki Servus Qt.
75
76 %package apidocs
77 Summary:        Servus API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki Servus
79 Group:          Documentation
80 BuildArch:      noarch
81
82 %description apidocs
83 API documentation for Servus library.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki Servus.
87
88 %package browser
89 Summary:        servusBrowser GUI
90 Summary(pl.UTF-8):      Graficzny interfejs servusBrowser
91 Group:          X11/Applications
92 Requires:       %{name}-qt = %{version}-%{release}
93
94 %description browser
95 servusBrowser GUI.
96
97 %description browser -l pl.UTF-8
98 Graficzny interfejs servusBrowser.
99
100 %prep
101 %setup -q
102
103 rmdir CMake/common
104 ln -s %{_datadir}/Eyescale-CMake CMake/common
105
106 %build
107 install -d build
108 cd build
109 %cmake .. \
110         -DBUILDYARD_DISABLED=ON \
111         -DCOMMON_DISABLE_WERROR:BOOL=ON
112 %{__make}
113
114 %if %{with apidocs}
115 doxygen doc/Doxyfile
116 %endif
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} -C build install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # disable completeness check incompatible with split packaging
125 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_datadir}/Servus/CMake/ServusTargets.cmake
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post   qt -p /sbin/ldconfig
134 %postun qt -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt LICENSE.txt README.md doc/Changelog.md
139 %attr(755,root,root) %{_libdir}/libServus.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libServus.so.6
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libServus.so
145 %dir %{_includedir}/servus
146 %{_includedir}/servus/*.h
147 %dir %{_datadir}/Servus
148 %{_datadir}/Servus/CMake
149
150 %files qt
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libServusQt.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libServusQt.so.6
154
155 %files qt-devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libServusQt.so
158 %{_includedir}/servus/qt
159
160 %if %{with apidocs}
161 %files apidocs
162 %defattr(644,root,root,755)
163 %doc build/doc/html/*
164 %endif
165
166 %files browser
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/servusBrowser
This page took 0.121227 seconds and 3 git commands to generate.