]> git.pld-linux.org Git - packages/STLport.git/commitdiff
- fix gcc-4.2/4.3 version detection.
authorPaweł Sikora <pluto@pld-linux.org>
Thu, 6 Mar 2008 20:01:01 +0000 (20:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    STLport-vendor_gcc_detection.patch -> 1.1
    STLport.spec -> 1.93

STLport-vendor_gcc_detection.patch [new file with mode: 0644]
STLport.spec

diff --git a/STLport-vendor_gcc_detection.patch b/STLport-vendor_gcc_detection.patch
new file mode 100644 (file)
index 0000000..33300c9
--- /dev/null
@@ -0,0 +1,17 @@
+this patch fixes gcc version detection for 4.2/4.3:
+
+version strings:
+gcc (GCC) 4.2.3 20080201 (release) (PLD-Linux)
+gcc (PLD-Linux) 4.3.0
+
+--- STLport-5.1.5/build/Makefiles/gmake/gcc.mak.orig   2008-03-06 20:36:20.000000000 +0100
++++ STLport-5.1.5/build/Makefiles/gmake/gcc.mak        2008-03-06 20:44:19.000000000 +0100
+@@ -26,7 +26,7 @@
+ else
+ ifneq ($(OSNAME), windows)
+-CXX_VERSION := $(shell ${CXX} --version | grep GCC | awk '{ print $$3; }')
++CXX_VERSION := $(shell ${CXX} --version | grep PLD | awk '{ print $$3; }')
+ ifeq ($(CXX_VERSION),)
+ # 2.95 report only version
index 367906dd51a8a573e6bbd03b4437a5f0a11bf4f2..aa831e9aeb0131f8fc54ac4dfe820c382a765417 100644 (file)
@@ -11,6 +11,7 @@ Source0:      http://dl.sourceforge.net/stlport/%{name}-%{version}.tar.bz2
 Patch0:                %{name}-endianness.patch
 Patch1:                %{name}-alpha.patch
 Patch2:                %{name}-valarray-copy-constructor.patch
+Patch3:                %{name}-vendor_gcc_detection.patch
 URL:           http://stlport.sourceforge.net/
 BuildRequires: libstdc++-devel >= 6:4.2.0-1
 BuildRequires: sed >= 4.0
@@ -92,6 +93,7 @@ Statyczna wersja diagnostyczna biblioteki STLport.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 sed -i -e 's/= -O2$/= %{rpmcflags}/' build/Makefiles/gmake/gcc.mak
 
This page took 0.034496 seconds and 4 git commands to generate.