]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- updated to 1.2.3
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.3
20 Release:        1
21 License:        LGPL
22 Group:          X11/Libraries
23 Group(de):      X11/Libraries
24 Group(es):      X11/Bibliotecas
25 Group(fr):      X11/Librairies
26 Group(pl):      X11/Biblioteki
27 Group(pt_BR):   X11/Bibliotecas
28 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
29 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
30 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
31 Patch0:         %{name}-byteorder.patch
32 Patch1:         %{name}-fixlibs.patch
33 Patch2:         %{name}-amfix.patch
34 Patch3:         %{name}-lpthread.patch
35 URL:            http://www.libsdl.org/
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{!?_without_esound:BuildRequires:      esound-devel}
39 %{!?_without_arts:BuildRequires:        arts-devel}
40 BuildRequires:  gtk+-devel >= 1.2.1
41 BuildRequires:  XFree86-devel >= 4.0.2
42 BuildRequires:  OpenGL-devel
43 BuildRequires:  perl-modules
44 BuildRequires:  nasm
45 %ifnarch sparc sparc64
46 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
47 %endif
48 %{?_with_svgalib:BuildRequires: svgalib-devel}
49 %{?_with_aalib:BuildRequires:   aalib-devel}
50 %{?_with_ggi:BuildRequires:     libggi-devel}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _prefix         /usr/X11R6
54 %define         _mandir         %{_prefix}/man
55
56 %description
57 SDL (Simple DirectMedia Layer) is a library that allows you portable,
58 low level access to a video framebuffer, audio output, mouse, and
59 keyboard. It can support both windowed and DGA modes of XFree86, and
60 it is designed to be portable - applications linked with SDL can also
61 be built on Win32 and BeOS.
62
63 %description -l pl
64 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
65 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
66 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
67 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
68 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
69
70 %description -l pt_BR
71 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
72 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
73
74 Essa biblioteca é usada por alguns jogos.
75
76 %package devel
77 Summary:        SDL - Header files
78 Summary(pl):    SDL - Pliki nag³ówkowe
79 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
80 Group:          X11/Libraries
81 Group(de):      X11/Libraries
82 Group(es):      X11/Bibliotecas
83 Group(fr):      X11/Librairies
84 Group(pl):      X11/Biblioteki
85 Group(pt_BR):   X11/Bibliotecas
86 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
87 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
88 Requires:       %{name} = %{version}
89 %ifnarch sparc sparc64
90 %{!?_without_alsa:Requires:     alsa-lib-devel}
91 %endif
92 %{!?_without_esound:Requires:   esound-devel}
93 %{!?_without_arts:Requires:     arts-devel}
94
95 %description devel
96 SDL - Header files.
97
98 %description -l pl devel
99 SDL - Pliki nag³ówkowe.
100
101 %description -l pt_BR devel
102 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
103 recursos para o desenvolvimento de aplicativos com SDL.
104
105 %package static
106 Summary:        SDL - static libraries
107 Summary(pl):    SDL - biblioteki statyczne
108 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
109 Group:          X11/Libraries
110 Group(de):      X11/Libraries
111 Group(es):      X11/Bibliotecas
112 Group(fr):      X11/Librairies
113 Group(pl):      X11/Biblioteki
114 Group(pt_BR):   X11/Bibliotecas
115 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
116 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
117 Requires:       %{name}-devel = %{version}
118
119 %description static
120 SDL - static libraries.
121
122 %description -l pl static
123 SDL - biblioteki statyczne.
124
125 %description -l pt_BR static
126 Biblioteca estática para desenvolvimento de aplicações com a SDL.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132 %patch2 -p1
133 %patch3 -p1
134
135 %build
136 rm missing
137 libtoolize --copy --force
138 aclocal
139 autoconf
140 # Another hack
141 cp src/hermes/Makefile.in Makefile.in.ok
142 automake -a -c --foreign
143 cp Makefile.in.ok src/hermes/Makefile.in
144 %configure \
145 %ifnarch sparc sparc64
146         %{!?_without_alsa:--enable-alsa} \
147 %endif
148         --disable-nasm \
149         --enable-pthreads \
150         --enable-pthread-sem \
151         --with-x \
152         --enable-video-x11-vm \
153         --enable-video-x11-dga \
154         --enable-video-x11-mtrr \
155         --enable-video-x11-dgamouse \
156         --enable-video-opengl \
157         %{!?_without_esound:--enable-esd} \
158         %{!?_without_arts:--enable-arts} \
159         %{?_with_svga:--enable-video-svga} \
160         %{?_with_aalib:--enable-video-aalib} \
161         %{?_with_ggi:--enable-video-ggi}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT \
168         m4datadir=%{_aclocaldir}
169
170 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
171
172 gzip -9nf BUGS CREDITS README TODO WhatsNew
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/lib*.so.*.*
183
184 %files devel
185 %defattr(644,root,root,755)
186 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
187 %attr(755,root,root) %{_bindir}/sdl-config
188 %attr(755,root,root) %{_libdir}/lib*.so
189 %attr(755,root,root) %{_libdir}/lib*.la
190 %{_libdir}/libSDLmain.a
191 %{_includedir}/SDL
192 %{_aclocaldir}/*
193 %{_mandir}/man3/*
194
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/lib*.a
This page took 0.048624 seconds and 3 git commands to generate.