]> git.pld-linux.org Git - packages/OpenAL.git/commitdiff
up to 1.21.1 auto/th/OpenAL-1.21.1-1
authorJan Palus <atler@pld-linux.org>
Fri, 5 Feb 2021 12:00:21 +0000 (13:00 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 5 Feb 2021 12:00:21 +0000 (13:00 +0100)
OpenAL-nosse.patch
OpenAL.spec

index f5fe4f69eef5e25ccb1b2001fc293f39eff1c079..97fb3cc435700991130f3600cfdc4ac524a4a980 100644 (file)
      return _mm_cvttsd_si32(_mm_set_sd(d));
  
  #elif ((defined(__GNUC__) || defined(__clang__)) && (defined(__i386__) || defined(__x86_64__)) && \
---- openal-soft-1.20.0/alc/fpu_ctrl.cpp.orig   2019-11-28 09:45:08.000000000 +0100
-+++ openal-soft-1.20.0/alc/fpu_ctrl.cpp        2019-12-04 18:37:09.810067181 +0100
+--- openal-soft-1.20.0/core/fpu_ctrl.cpp.orig  2019-11-28 09:45:08.000000000 +0100
++++ openal-soft-1.20.0/core/fpu_ctrl.cpp       2019-12-04 18:37:09.810067181 +0100
 @@ -209,7 +209,7 @@
- FPUCtl::FPUCtl()
  {
+     if(this->in_mode) return;
 -#if defined(HAVE_SSE_INTRINSICS)
 +#if defined(HAVE_SSE_INTRINSICS) && defined(__SSE_MATH__)
      this->sse_state = _mm_getcsr();
@@ -67,8 +67,8 @@
      for(float &output : dst)
      {
          __m128 r4{_mm_setzero_ps()};
---- openal-soft-1.21.0/alc/uhjfilter.cpp.orig  2020-11-04 11:00:35.000000000 +0100
-+++ openal-soft-1.21.0/alc/uhjfilter.cpp       2020-11-05 06:29:14.128492431 +0100
+--- openal-soft-1.21.0/core/uhjfilter.cpp.orig 2020-11-04 11:00:35.000000000 +0100
++++ openal-soft-1.21.0/core/uhjfilter.cpp      2020-11-05 06:29:14.128492431 +0100
 @@ -3,7 +3,7 @@
  
  #include "uhjfilter.h"
index 95cf4cf7891577e0a160fa7d99bedc879651a8c7..662f761baedb654cbe686f00a11699e7ed8228f5 100644 (file)
 Summary:       Open Audio Library
 Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
-Version:       1.21.0
+Version:       1.21.1
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
-# Source0-md5: 332dc0ead285887a3da5ec6bc725fdcd
+# Source0-md5: a936806ebd8de417b0ffd8cf3f48f456
 Patch0:                %{name}-pc.patch
 Patch1:                %{name}-nosse.patch
 URL:           http://www.openal.org/
This page took 0.030141 seconds and 4 git commands to generate.