]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- updated to 1.13
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support
4 %bcond_without  portaudio       # without PortAudio support
5 %bcond_without  pulseaudio      # without PulseAudio support
6 #
7 Summary:        Open Audio Library
8 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
9 Name:           OpenAL
10 Version:        1.13
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
15 # Source0-md5:  58b7d2809790c70681b825644c5f3614
16 #URL:           http://kcat.strangesoft.net/openal.html
17 URL:            http://www.openal.org/
18 %{?with_alsa:BuildRequires:     alsa-lib-devel}
19 BuildRequires:  cmake
20 %{?with_portaudio:BuildRequires:        portaudio-devel}
21 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 OpenAL, the Open Audio Library, is a joint effort to create an open,
26 vendor-neutral, cross-platform API for interactive, primarily
27 spatialized audio. OpenAL's primary audience are application
28 developers and desktop users that rely on portable standards like
29 OpenGL, for games and other multimedia applications. OpenAL is already
30 supported by a number of hardware vendors and developers.
31
32 %description -l pl.UTF-8
33 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
34 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
35 interfejsu projektowania aplikacji w części obsługi dźwięku.
36 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
37 którzy wybierają przenośne standardy, jak OpenGL, w grach i
38 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
39 dostarczycieli sprzętu i programistów.
40
41 %package devel
42 Summary:        Headers for OpenAL
43 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for OpenAL-based programs.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
52 OpenAL.
53
54 %prep
55 %setup -q -n openal-soft-%{version}
56
57 %build
58 %cmake . \
59         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
60         -DCMAKE_VERBOSE_MAKEFILE=1 \
61         -DLIB_INSTALL_DIR=%{_lib} \
62         %{!?with_alsa:-DALSA=OFF} \
63         %{!?with_portaudio:-DPORTAUDIO=OFF} \
64         %{!?with_pulseaudio:-DPULSEAUDIO=OFF}
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_bindir}/openal-info
83 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libopenal.so
89 %{_includedir}/AL
90 %{_pkgconfigdir}/openal.pc
This page took 0.076008 seconds and 3 git commands to generate.