]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- converted to UTF-8
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  alsa    # without ALSA support
5 %bcond_with     arts    # with aRts support
6 %bcond_without  esd     # without esd support
7 %bcond_without  mmx     # don't use MMX
8 #
9 %ifnarch %{ix86} %{x8664}
10 %undefine       with_mmx
11 %endif
12 %ifarch i386 i486
13 %undefine       with_mmx
14 %endif
15 Summary:        Open Audio Library
16 Summary(pl.UTF-8):   Otwarta Biblioteka Dźwięku
17 Name:           OpenAL
18 Version:        0.0.8
19 Release:        2
20 License:        LGPL
21 Group:          Libraries
22 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
23 # Source0-md5:  641cf53761f35ee979f3e888614797a0
24 URL:            http://www.openal.org/
25 Patch0:         %{name}-alc.h.patch
26 BuildRequires:  SDL-devel
27 %{?with_alsa:BuildRequires:     alsa-lib-devel}
28 %{?with_arts:BuildRequires:     artsc-devel}
29 BuildRequires:  autoconf >= 2.56
30 BuildRequires:  automake
31 %{?with_esd:BuildRequires:      esound-devel}
32 %if %{with mmx}
33 # MMX code triggers ICE in gcc 3.3.x
34 BuildRequires:  gcc >= 5:3.4.0
35 %endif
36 BuildRequires:  libtool
37 BuildRequires:  libvorbis-devel
38 %ifarch %{ix86}
39 %{?with_mmx:BuildRequires:      nasm}
40 %endif
41 BuildRequires:  pkgconfig
42 BuildRequires:  smpeg-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %if %{with mmx}
46 %define         specflags_ia32  -mmmx
47 %else
48 %define         specflags_ia32  -U__MMX__
49 %endif
50
51 %description
52 OpenAL, the Open Audio Library, is a joint effort to create an open,
53 vendor-neutral, cross-platform API for interactive, primarily
54 spatialized audio. OpenAL's primary audience are application
55 developers and desktop users that rely on portable standards like
56 OpenGL, for games and other multimedia applications. OpenAL is already
57 supported by a number of hardware vendors and developers.
58
59 %description -l pl.UTF-8
60 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
61 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
62 interfejsu projektowania aplikacji w części obsługi dźwięku.
63 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
64 którzy wybierają przenośne standardy, jak OpenGL, w grach i
65 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
66 dostarczycieli sprzętu i programistów.
67
68 %package devel
69 Summary:        Headers for OpenAL
70 Summary(pl.UTF-8):   Pliki nagłówkowe do OpenAL
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 Header files for OpenAL-based programs.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
79 OpenAL.
80
81 %package static
82 Summary:        OpenAL static library
83 Summary(pl.UTF-8):   Statyczna biblioteka OpenAL
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 OpenAL static library.
89
90 %description static -l pl.UTF-8
91 Biblioteka OpenAL do konsolidacji statycznej.
92
93 %prep
94 %setup -q -n openal-%{version}
95 %patch0 -p1
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I admin/autotools/m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
105         --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
106         --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
107         --enable-sdl --enable-sdl-dlopen \
108         --enable-capture \
109         --enable-linux \
110         --enable-null \
111 %ifarch amd64 x86_64 athlon i686 i586
112         --enable-optim-generic \
113 %endif
114         --enable-waveout \
115         --enable-vorbis --enable-vorbis-dlopen \
116         --enable-mp3 --enable-mp3-dlopen \
117         --with-gcc="%{__cc}"
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc ChangeLog NOTES TODO
136 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
137
138 %files devel
139 %defattr(644,root,root,755)
140 %doc common/specification/OpenAL1-1Spec.pdf
141 %attr(755,root,root) %{_bindir}/openal-config
142 %attr(755,root,root) %{_libdir}/libopenal.so
143 %{_libdir}/libopenal.la
144 %{_includedir}/AL
145 %{_pkgconfigdir}/openal.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libopenal.a
This page took 0.15872 seconds and 3 git commands to generate.