]> git.pld-linux.org Git - packages/NewsFeed.git/blob - NewsFeed.spec
- standardized
[packages/NewsFeed.git] / NewsFeed.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         lname   %(echo %{name} | tr [:upper:] [:lower:])
3 Summary:        A reader and aggregator for RSS/RDF/Atom feeds in Python/Tk
4 Name:           NewsFeed
5 Version:        2.4
6 Release:        0.1
7 License:        GPL
8 Group:          Applications
9 Source0:        http://home.arcor.de/mdoege/newsfeed/%{name}-%{version}.tar.gz
10 # Source0-md5:  08ac1f889e7f4551a896b59b7a52cf01
11 Source1:        %{lname}.desktop
12 Source2:        %{lname}.png
13 BuildRequires:  rpmbuild(macros) >= 1.231
14 BuildRequires:  rpm-pythonprov
15 Requires:       python-tkinter >= 2.3
16 %pyrequires_eq  python-modules
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 A reader and aggregator for RSS/RDF/Atom feeds in Python/Tk
22
23 %prep
24 %setup -q
25
26 %install
27 rm -rf $RPM_BUILD_ROOT
28 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
29
30 python ./setup.py install \
31         --optimize=2 \
32         --root=$RPM_BUILD_ROOT
33
34 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{lname}.desktop
35 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{lname}.png
36
37 %py_postclean
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc README.html
45 %attr(755,root,root) %{_bindir}/*
46 %{py_sitescriptdir}/*.py[co]
47 %{_desktopdir}/*
48 %{_pixmapsdir}/*
This page took 0.062387 seconds and 4 git commands to generate.