]> git.pld-linux.org Git - packages/NetworkManager-applet.git/blob - NetworkManager-applet.spec
827457f97a157107b637595dd6a7b2ff6758125e
[packages/NetworkManager-applet.git] / NetworkManager-applet.spec
1 #
2 # Conditional build:
3 %bcond_without  appindicator    # application indicators
4 #
5 %define         nm_ver  2:1.8
6 Summary:        Network Manager for GNOME
7 Summary(pl.UTF-8):      Zarządca sieci dla GNOME
8 Name:           NetworkManager-applet
9 Version:        1.36.0
10 Release:        1
11 License:        GPL v2
12 Group:          X11/Applications
13 Source0:        https://download.gnome.org/sources/network-manager-applet/1.36/network-manager-applet-%{version}.tar.xz
14 # Source0-md5:  534f7142f4cfbd81d79eec5e62bc80a8
15 URL:            https://wiki.gnome.org/Projects/NetworkManager
16 BuildRequires:  ModemManager-devel >= 1.0.0
17 BuildRequires:  NetworkManager-devel >= %{nm_ver}
18 BuildRequires:  gcr-devel >= 3.14
19 BuildRequires:  gcr-ui-devel >= 3.14
20 BuildRequires:  gettext-tools >= 0.19.8
21 BuildRequires:  glib2-devel >= 1:2.40
22 BuildRequires:  gobject-introspection-devel >= 0.9.6
23 BuildRequires:  gtk+3-devel >= 3.10
24 BuildRequires:  iso-codes
25 BuildRequires:  jansson-devel >= 2.7
26 %{?with_appindicator:BuildRequires:     libayatana-appindicator-gtk3-devel >= 0.1}
27 %{?with_appindicator:BuildRequires:     libdbusmenu-gtk3-devel >= 16.04.0}
28 BuildRequires:  libnma-devel >= 1.8.27
29 BuildRequires:  libsecret-devel >= 0.18
30 BuildRequires:  libselinux-devel
31 BuildRequires:  meson >= 0.46.0
32 BuildRequires:  ninja >= 1.5
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires(post,postun):  glib2 >= 1:2.40
38 Requires(post,postun):  gtk-update-icon-cache
39 Requires:       NetworkManager >= %{nm_ver}
40 Requires:       glib2 >= 1:2.40
41 Requires:       hicolor-icon-theme
42 Requires:       jansson >= 2.7
43 Requires:       libnma >= 1.8.27
44 Requires:       libsecret >= 0.18
45 Requires:       mobile-broadband-provider-info
46 Requires:       polkit-gnome
47 Suggests:       dbus(org.freedesktop.Notifications)
48 Obsoletes:      NetworkManager-applet-devel < 0.7.0
49 Obsoletes:      gnome-bluetooth-plugin-nma < 1.2.2
50 Conflicts:      libnma-data < 1.10.4
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Network Manager Applet for GNOME.
55
56 %description -l pl.UTF-8
57 Aplet zarządcy sieci dla GNOME.
58
59 %prep
60 %setup -q -n network-manager-applet-%{version}
61
62 %build
63 %meson build \
64         -Dappindicator=%{?with_appindicator:ayatana}%{!?with_appindicator:no}
65
66 %ninja_build -C build
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-vpn-properties
71
72 %ninja_install -C build
73
74 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
75
76 %find_lang %{name} --with-gnome --all-name
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 %update_icon_cache hicolor
83 %glib_compile_schemas
84
85 %postun
86 %update_icon_cache hicolor
87 if [ "$1" = "0" ]; then
88         %glib_compile_schemas
89 fi
90
91 %files -f %{name}.lang
92 %defattr(644,root,root,755)
93 %doc AUTHORS CONTRIBUTING NEWS
94 %attr(755,root,root) %{_bindir}/nm-applet
95 %attr(755,root,root) %{_bindir}/nm-connection-editor
96 %{_datadir}/GConf/gsettings/nm-applet.convert
97 %dir %{_datadir}/gnome-vpn-properties
98 %{_datadir}/metainfo/nm-connection-editor.appdata.xml
99 %{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
100 %{_sysconfdir}/xdg/autostart/nm-applet.desktop
101 %{_desktopdir}/nm-applet.desktop
102 %{_desktopdir}/nm-connection-editor.desktop
103 %{_mandir}/man1/nm-applet.1*
104 %{_mandir}/man1/nm-connection-editor.1*
105 %{_iconsdir}/hicolor/*x*/apps/nm-*.png
106 %{_iconsdir}/hicolor/scalable/apps/nm-*.svg
This page took 0.899161 seconds and 2 git commands to generate.