]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
up to 21.3.0 auto/th/Mesa-21.3.0-1
authorJan Palus <atler@pld-linux.org>
Wed, 17 Nov 2021 23:06:00 +0000 (00:06 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 17 Nov 2021 23:06:00 +0000 (00:06 +0100)
Mesa.spec
zink_x32.patch

index 1da2e2f812ae76b99e36a48100a3d85e5884128f..ac6f654d11d9884e6a7ac98cb3ad935858e9bba1 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       21.2.5
-Release:       3
+Version:       21.3.0
+Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 99938a412df9231870d7ed07837252a2
+# Source0-md5: 3230a374056e951e73c3206de3453211
 Patch0:                zink_x32.patch
 URL:           https://www.mesa3d.org/
 %{?with_opencl_spirv:BuildRequires:    SPIRV-LLVM-Translator-devel >= 8.0.1.3}
@@ -95,7 +95,7 @@ BuildRequires:        libselinux-devel
 BuildRequires: libstdc++-devel >= %{gcc_ver}
 BuildRequires: libunwind-devel
 %{?with_va:BuildRequires:      libva-devel}
-%{?with_va:BuildRequires:      pkgconfig(libva) >= 1.1.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 1.8.0}
 %{?with_vdpau:BuildRequires:   libvdpau-devel >= 1.1}
 BuildRequires: libxcb-devel >= 1.13
 %{?with_gallium:BuildRequires: llvm-devel >= %{llvm_ver}}
@@ -1247,7 +1247,7 @@ Sterowniki VA do Gallium (r600, radeonsi & nouveau).
 Summary:       VA driver for ATI Radeon R600 series adapters
 Summary(pl.UTF-8):     Sterownik VA dla kart ATI Radeon z serii R600
 Group:         Libraries
-Requires:      libva >= 1.6.0
+Requires:      libva >= 1.8.0
 Requires:      zlib >= %{zlib_ver}
 
 %description -n libva-driver-r600
@@ -1260,7 +1260,7 @@ Sterownik VA dla kart ATI Radeon z serii R600.
 Summary:       VA driver for ATI Radeon SI adapters
 Summary(pl.UTF-8):     Sterownik VA dla kart ATI Radeon SI
 Group:         Libraries
-Requires:      libva >= 1.6.0
+Requires:      libva >= 1.8.0
 Requires:      zlib >= %{zlib_ver}
 
 %description -n libva-driver-radeonsi
@@ -1274,7 +1274,7 @@ Islands.
 Summary:       VA driver for NVidia adapters
 Summary(pl.UTF-8):     Sterownik VA dla kart NVidia
 Group:         Libraries
-Requires:      libva >= 1.6.0
+Requires:      libva >= 1.8.0
 Requires:      zlib >= %{zlib_ver}
 
 %description -n libva-driver-nouveau
@@ -1925,6 +1925,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-dcss_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-drm_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ingenic-drm_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/kirin_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mali-dp_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mcde_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mediatek_dri.so
index 1de334dfa4205f26869d279bc5a7a9a6c54e4619..b9c38c5286be590ba4dd4cc17c0ccef2a6abe453 100644 (file)
@@ -1,15 +1,15 @@
---- mesa-mesa-21.1.0/src/gallium/drivers/zink/zink_framebuffer.c.orig  2021-05-05 19:05:43.000000000 +0200
-+++ mesa-mesa-21.1.0/src/gallium/drivers/zink/zink_framebuffer.c       2021-05-08 11:40:04.291968475 +0200
-@@ -64,7 +64,7 @@
+--- mesa-mesa-21.3.0/src/gallium/drivers/zink/zink_framebuffer.c.orig  2021-11-17 21:16:20.000000000 +0100
++++ mesa-mesa-21.3.0/src/gallium/drivers/zink/zink_framebuffer.c       2021-11-17 22:27:05.031355842 +0100
+@@ -37,7 +37,7 @@
                           struct zink_framebuffer *fb)
  {
     hash_table_foreach(&fb->objects, he) {
 -#if defined(_WIN64) || defined(__x86_64__)
 +#if defined(_WIN64) || (defined(__x86_64__) && !defined(__ILP32__))
-       vkDestroyFramebuffer(screen->dev, he->data, NULL);
+       VKSCR(DestroyFramebuffer)(screen->dev, he->data, NULL);
  #else
        VkFramebuffer *ptr = he->data;
-@@ -89,7 +89,7 @@
+@@ -60,7 +60,7 @@
  
     struct hash_entry *he = _mesa_hash_table_search_pre_hashed(&fb->objects, hash, rp);
     if (he) {
        ret = (VkFramebuffer)he->data;
  #else
        VkFramebuffer *ptr = he->data;
-@@ -109,7 +109,7 @@
+@@ -90,7 +90,7 @@
  
-    if (vkCreateFramebuffer(screen->dev, &fci, NULL, &ret) != VK_SUCCESS)
+    if (VKSCR(CreateFramebuffer)(screen->dev, &fci, NULL, &ret) != VK_SUCCESS)
+       return;
+-#if defined(_WIN64) || defined(__x86_64__)
++#if defined(_WIN64) || (defined(__x86_64__) && !defined(__ILP32__))
+    _mesa_hash_table_insert_pre_hashed(&fb->objects, hash, rp, ret);
+ #else
+    VkFramebuffer *ptr = ralloc(fb, VkFramebuffer);
+@@ -207,7 +207,7 @@
+    struct hash_entry *he = _mesa_hash_table_search_pre_hashed(&fb->objects, hash, rp);
+    if (he) {
+-#if defined(_WIN64) || defined(__x86_64__)
++#if defined(_WIN64) || (defined(__x86_64__) && !defined(__ILP32__))
+       ret = (VkFramebuffer)he->data;
+ #else
+       VkFramebuffer *ptr = he->data;
+@@ -229,7 +229,7 @@
+    if (VKSCR(CreateFramebuffer)(screen->dev, &fci, NULL, &ret) != VK_SUCCESS)
        return;
 -#if defined(_WIN64) || defined(__x86_64__)
 +#if defined(_WIN64) || (defined(__x86_64__) && !defined(__ILP32__))
This page took 0.052159 seconds and 4 git commands to generate.