]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- up to 7.6 auto/th/Mesa-7_6-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 29 Sep 2009 07:12:42 +0000 (07:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Mesa-noveau-abi-0.0.15.patch -> 1.2
    Mesa.spec -> 1.221

Mesa-noveau-abi-0.0.15.patch [deleted file]
Mesa.spec

diff --git a/Mesa-noveau-abi-0.0.15.patch b/Mesa-noveau-abi-0.0.15.patch
deleted file mode 100644 (file)
index dafc37e..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-diff -Nur Mesa-7.5.orig/src/gallium/drivers/nv50/nv50_state_validate.c Mesa-7.5/src/gallium/drivers/nv50/nv50_state_validate.c
---- Mesa-7.5.orig/src/gallium/drivers/nv50/nv50_state_validate.c       2009-06-26 20:21:59.000000000 +0200
-+++ Mesa-7.5/src/gallium/drivers/nv50/nv50_state_validate.c    2009-08-06 03:30:12.000000000 +0200
-@@ -260,11 +260,11 @@
-               so = so_new(12, 0);
-               if (!bypass) {
--                      so_method(so, tesla, NV50TCL_VIEWPORT_UNK1(0), 3);
-+                      so_method(so, tesla, NV50TCL_VIEWPORT_TRANSLATE(0), 3);
-                       so_data  (so, fui(nv50->viewport.translate[0]));
-                       so_data  (so, fui(nv50->viewport.translate[1]));
-                       so_data  (so, fui(nv50->viewport.translate[2]));
--                      so_method(so, tesla, NV50TCL_VIEWPORT_UNK0(0), 3);
-+                      so_method(so, tesla, NV50TCL_VIEWPORT_SCALE(0), 3);
-                       so_data  (so, fui(nv50->viewport.scale[0]));
-                       so_data  (so, fui(-nv50->viewport.scale[1]));
-                       so_data  (so, fui(nv50->viewport.scale[2]));
-diff -Nur Mesa-7.5.orig/src/gallium/drivers/nv50/nv50_surface.c Mesa-7.5/src/gallium/drivers/nv50/nv50_surface.c
---- Mesa-7.5.orig/src/gallium/drivers/nv50/nv50_surface.c      2009-06-26 20:21:59.000000000 +0200
-+++ Mesa-7.5/src/gallium/drivers/nv50/nv50_surface.c   2009-08-06 03:30:12.000000000 +0200
-@@ -36,13 +36,13 @@
-       switch (format) {
-       case PIPE_FORMAT_A8R8G8B8_UNORM:
-       case PIPE_FORMAT_Z24S8_UNORM:
--              return NV50_2D_DST_FORMAT_32BPP;
-+              return NV50_2D_DST_FORMAT_A8R8G8B8_UNORM;
-       case PIPE_FORMAT_X8R8G8B8_UNORM:
--              return NV50_2D_DST_FORMAT_24BPP;
-+              return NV50_2D_DST_FORMAT_X8R8G8B8_UNORM;
-       case PIPE_FORMAT_R5G6B5_UNORM:
--              return NV50_2D_DST_FORMAT_16BPP;
-+              return NV50_2D_DST_FORMAT_R5G6B5_UNORM;
-       case PIPE_FORMAT_A8_UNORM:
--              return NV50_2D_DST_FORMAT_8BPP;
-+              return NV50_2D_DST_FORMAT_R8_UNORM;
-       default:
-               return -1;
-       }
-@@ -66,7 +66,7 @@
-       if (format < 0)
-               return 1;
-   
--      if (!bo->tiled) {
-+      if (bo->tile_flags != 0x2800 && bo->tile_flags != 0x7000) {
-               BEGIN_RING(chan, eng2d, mthd, 2);
-               OUT_RING  (chan, format);
-               OUT_RING  (chan, 1);
-diff -Nur Mesa-7.5.orig/src/gallium/drivers/nv50/nv50_transfer.c Mesa-7.5/src/gallium/drivers/nv50/nv50_transfer.c
---- Mesa-7.5.orig/src/gallium/drivers/nv50/nv50_transfer.c     2009-06-26 20:21:59.000000000 +0200
-+++ Mesa-7.5/src/gallium/drivers/nv50/nv50_transfer.c  2009-08-06 03:30:12.000000000 +0200
-@@ -35,7 +35,7 @@
-       WAIT_RING (chan, 14);
--      if (!src_bo->tiled) {
-+      if (src_bo->tile_flags != 0x2800 && src_bo->tile_flags != 0x7000) {
-               BEGIN_RING(chan, m2mf, 0x0200, 1);
-               OUT_RING  (chan, 1);
-               BEGIN_RING(chan, m2mf, 0x0314, 1);
-@@ -51,7 +51,7 @@
-               OUT_RING  (chan, 0);
-       }
--      if (!dst_bo->tiled) {
-+      if (dst_bo->tile_flags != 0x2800 && dst_bo->tile_flags != 0x7000) {
-               BEGIN_RING(chan, m2mf, 0x021c, 1);
-               OUT_RING  (chan, 1);
-               BEGIN_RING(chan, m2mf, 0x0318, 1);
-@@ -77,13 +77,13 @@
-               BEGIN_RING(chan, m2mf, 0x030c, 2);
-               OUT_RELOCl(chan, src_bo, src_offset, src_reloc);
-               OUT_RELOCl(chan, dst_bo, dst_offset, dst_reloc);
--              if (src_bo->tiled) {
-+              if (src_bo->tile_flags == 0x2800 || src_bo->tile_flags == 0x7000) {
-                       BEGIN_RING(chan, m2mf, 0x0218, 1);
-                       OUT_RING  (chan, (dy << 16) | sx);
-               } else {
-                       src_offset += (line_count * src_pitch);
-               }
--              if (dst_bo->tiled) {
-+              if (dst_bo->tile_flags == 0x2800 || dst_bo->tile_flags == 0x7000) {
-                       BEGIN_RING(chan, m2mf, 0x0234, 1);
-                       OUT_RING  (chan, (sy << 16) | dx);
-               } else {
-diff -Nur Mesa-7.5.orig/src/gallium/winsys/drm/nouveau/dri/nouveau_screen.c Mesa-7.5/src/gallium/winsys/drm/nouveau/dri/nouveau_screen.c
---- Mesa-7.5.orig/src/gallium/winsys/drm/nouveau/dri/nouveau_screen.c  2009-06-26 20:21:59.000000000 +0200
-+++ Mesa-7.5/src/gallium/winsys/drm/nouveau/dri/nouveau_screen.c       2009-08-06 03:31:04.000000000 +0200
-@@ -15,7 +15,7 @@
- #include "nouveau_drm.h"
- #include "nouveau_drmif.h"
--#if NOUVEAU_DRM_HEADER_PATCHLEVEL != 12
-+#if NOUVEAU_DRM_HEADER_PATCHLEVEL != 15
- #error nouveau_drm.h version does not match expected version
- #endif
-diff -Nur Mesa-7.5.orig/src/gallium/winsys/drm/nouveau/drm/nouveau_winsys.c Mesa-7.5/src/gallium/winsys/drm/nouveau/drm/nouveau_winsys.c
---- Mesa-7.5.orig/src/gallium/winsys/drm/nouveau/drm/nouveau_winsys.c  2009-06-26 20:21:59.000000000 +0200
-+++ Mesa-7.5/src/gallium/winsys/drm/nouveau/drm/nouveau_winsys.c       2009-08-06 03:30:12.000000000 +0200
-@@ -38,7 +38,7 @@
-       struct nouveau_bo *bo = nouveau_pipe_buffer(buf)->bo;
-       return nouveau_pushbuf_emit_reloc(nvws->channel, ptr, bo,
--                                        data, flags, vor, tor);
-+                                        data, 0, flags, vor, tor);
- }
- static int
-diff -Nur Mesa-7.5.orig/src/gallium/winsys/g3dvl/nouveau/nouveau_screen_vl.c Mesa-7.5/src/gallium/winsys/g3dvl/nouveau/nouveau_screen_vl.c
---- Mesa-7.5.orig/src/gallium/winsys/g3dvl/nouveau/nouveau_screen_vl.c 2009-05-07 17:34:49.000000000 +0200
-+++ Mesa-7.5/src/gallium/winsys/g3dvl/nouveau/nouveau_screen_vl.c      2009-08-06 03:31:23.000000000 +0200
-@@ -4,7 +4,7 @@
- #include <common/nouveau_dri.h>
- #include <common/nouveau_local.h>
--#if NOUVEAU_DRM_HEADER_PATCHLEVEL != 12
-+#if NOUVEAU_DRM_HEADER_PATCHLEVEL != 15
- #error nouveau_drm.h version does not match expected version
- #endif
index d336e59ffbcac2a39bc898a75875eac60d1cc502..ef6a04dd056f1e44b2d2adf0c0a51fb5b3133691 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       7.5.2
+Version:       7.6
 Release:       1%{?with_multigl:.mgl}
 License:       MIT (core), SGI (GLU,libGLw) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 94e47a499f1226803869c2e37a6a8e3a
+# Source0-md5: 8c75f90cd0303cfac9e4b6d54f6759ca
 Source1:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
-# Source1-md5: 4e0f5ccd58afe21eddcd94327d926e86
+# Source1-md5: 0ede7adf217951acd90dbe4551210c07
 Source2:       http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
 # Source2-md5: 6ae05158e678f4594343f32c2ca50515
 Patch0:                %{name}-realclean.patch
-Patch1:                %{name}-noveau-abi-0.0.15.patch
 Patch2:                %{name}-sparc64.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: expat-devel
@@ -614,7 +613,6 @@ Sterownik X.org DRI dla rodziny kart VIA Unichrome.
 %prep
 %setup -q -b1 -a2
 %patch0 -p0
-%patch1 -p1
 %patch2 -p1
 
 # fix demos
@@ -914,7 +912,6 @@ rm -rf $RPM_BUILD_ROOT
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri2.so
 %endif
 
 %files dri-driver-s3virge
This page took 0.051598 seconds and 4 git commands to generate.