]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- up to 8.0 final (includes some changes from DEVEL) auto/th/Mesa-8_0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 10 Feb 2012 12:31:17 +0000 (12:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Mesa-git.patch -> 1.18
    Mesa-selinux.patch -> 1.7
    Mesa.spec -> 1.299

Mesa-git.patch [deleted file]
Mesa-selinux.patch [deleted file]
Mesa.spec

diff --git a/Mesa-git.patch b/Mesa-git.patch
deleted file mode 100644 (file)
index de778cd..0000000
+++ /dev/null
@@ -1,270 +0,0 @@
-diff --git a/docs/news.html b/docs/news.html
-index eea6cd6..70b38c6 100644
---- a/docs/news.html
-+++ b/docs/news.html
-@@ -11,6 +11,13 @@
- <H1>News</H1>
-+<h2>July 31, 2011</h2>
-+
-+<p>
-+<a href="relnotes-7.11.html">Mesa 7.11</a> is released.  This is a new
-+release with many new features.
-+</p>
-+
- <h2>June 13, 2011</h2>
- <p>
-diff --git a/docs/relnotes-7.11.html b/docs/relnotes-7.11.html
-index 79776d3..52033cf 100644
---- a/docs/relnotes-7.11.html
-+++ b/docs/relnotes-7.11.html
-@@ -30,7 +30,12 @@ for DRI hardware acceleration.
- <h2>MD5 checksums</h2>
- <pre>
--tbd
-+fa2c7068503133fb2453244cda11cb2a  MesaLib-7.11.tar.gz
-+ff03aca82d0560009a076a87c888cf13  MesaLib-7.11.tar.bz2
-+ede1ac0976f6f05df586093fc17d63ed  MesaLib-7.11.zip
-+b4fb81a47c5caedaefad49af7702c23d  MesaGLUT-7.11.tar.gz
-+77a9a0bbd7f8bca882aa5709b88cb071  MesaGLUT-7.11.tar.bz2
-+c19ef0c6eb61188c96ed4ccedd70717c  MesaGLUT-7.11.zip
- </pre>
-diff --git a/src/gallium/drivers/i915/i915_state_dynamic.c b/src/gallium/drivers/i915/i915_state_dynamic.c
-index 204cee6..1a21433 100644
---- a/src/gallium/drivers/i915/i915_state_dynamic.c
-+++ b/src/gallium/drivers/i915/i915_state_dynamic.c
-@@ -268,8 +268,8 @@ static void upload_SCISSOR_RECT(struct i915_context *i915)
- {
-    unsigned x1 = i915->scissor.minx;
-    unsigned y1 = i915->scissor.miny;
--   unsigned x2 = i915->scissor.maxx;
--   unsigned y2 = i915->scissor.maxy;
-+   unsigned x2 = i915->scissor.maxx - 1;
-+   unsigned y2 = i915->scissor.maxy - 1;
-    unsigned sc[3];
-    sc[0] = _3DSTATE_SCISSOR_RECT_0_CMD;
-diff --git a/src/gallium/drivers/r300/r300_emit.c b/src/gallium/drivers/r300/r300_emit.c
-index d214af4..09ce470 100644
---- a/src/gallium/drivers/r300/r300_emit.c
-+++ b/src/gallium/drivers/r300/r300_emit.c
-@@ -1237,13 +1237,12 @@ validate:
-         r300->rws->cs_add_reloc(r300->cs, r300_resource(index_buffer)->cs_buf,
-                                 r300_resource(index_buffer)->domain, 0);
--    /* Now do the validation. */
-+    /* Now do the validation (flush is called inside cs_validate on failure). */
-     if (!r300->rws->cs_validate(r300->cs)) {
-         /* Ooops, an infinite loop, give up. */
-         if (flushed)
-             return FALSE;
--        r300_flush(&r300->context, RADEON_FLUSH_ASYNC, NULL);
-         flushed = TRUE;
-         goto validate;
-     }
-diff --git a/src/gallium/winsys/radeon/drm/radeon_drm_cs.c b/src/gallium/winsys/radeon/drm/radeon_drm_cs.c
-index 0139de1..1dcc7e1 100644
---- a/src/gallium/winsys/radeon/drm/radeon_drm_cs.c
-+++ b/src/gallium/winsys/radeon/drm/radeon_drm_cs.c
-@@ -115,6 +115,7 @@ static void radeon_cs_context_cleanup(struct radeon_cs_context *csc)
-     }
-     csc->crelocs = 0;
-+    csc->validated_crelocs = 0;
-     csc->chunks[0].length_dw = 0;
-     csc->chunks[1].length_dw = 0;
-     csc->used_gart = 0;
-@@ -307,9 +308,37 @@ static void radeon_drm_cs_add_reloc(struct radeon_winsys_cs *rcs,
- static boolean radeon_drm_cs_validate(struct radeon_winsys_cs *rcs)
- {
-     struct radeon_drm_cs *cs = radeon_drm_cs(rcs);
-+    boolean status =
-+        cs->csc->used_gart < cs->ws->gart_size * 0.8 &&
-+        cs->csc->used_vram < cs->ws->vram_size * 0.8;
--    return cs->csc->used_gart < cs->ws->gart_size * 0.8 &&
--           cs->csc->used_vram < cs->ws->vram_size * 0.8;
-+    if (status) {
-+        cs->csc->validated_crelocs = cs->csc->crelocs;
-+    } else {
-+        /* Remove lately-added relocations. The validation failed with them
-+         * and the CS is about to be flushed because of that. Keep only
-+         * the already-validated relocations. */
-+        unsigned i;
-+
-+        for (i = cs->csc->validated_crelocs; i < cs->csc->crelocs; i++) {
-+            p_atomic_dec(&cs->csc->relocs_bo[i]->num_cs_references);
-+            radeon_bo_reference(&cs->csc->relocs_bo[i], NULL);
-+        }
-+        cs->csc->crelocs = cs->csc->validated_crelocs;
-+
-+        /* Flush if there are any relocs. Clean up otherwise. */
-+        if (cs->csc->crelocs) {
-+            cs->flush_cs(cs->flush_data, RADEON_FLUSH_ASYNC);
-+        } else {
-+            radeon_cs_context_cleanup(cs->csc);
-+
-+            assert(cs->base.cdw == 0);
-+            if (cs->base.cdw != 0) {
-+                fprintf(stderr, "radeon: Unexpected error in %s.\n", __func__);
-+            }
-+        }
-+    }
-+    return status;
- }
- static void radeon_drm_cs_write_reloc(struct radeon_winsys_cs *rcs,
-diff --git a/src/gallium/winsys/radeon/drm/radeon_drm_cs.h b/src/gallium/winsys/radeon/drm/radeon_drm_cs.h
-index 339beed..fc51f45 100644
---- a/src/gallium/winsys/radeon/drm/radeon_drm_cs.h
-+++ b/src/gallium/winsys/radeon/drm/radeon_drm_cs.h
-@@ -41,6 +41,7 @@ struct radeon_cs_context {
-     /* Relocs. */
-     unsigned                    nrelocs;
-     unsigned                    crelocs;
-+    unsigned                  validated_crelocs;
-     struct radeon_bo            **relocs_bo;
-     struct drm_radeon_cs_reloc  *relocs;
-diff --git a/src/gallium/winsys/radeon/drm/radeon_winsys.h b/src/gallium/winsys/radeon/drm/radeon_winsys.h
-index 3a64e4a..41c26c6 100644
---- a/src/gallium/winsys/radeon/drm/radeon_winsys.h
-+++ b/src/gallium/winsys/radeon/drm/radeon_winsys.h
-@@ -271,7 +271,9 @@ struct radeon_winsys {
-     /**
-      * Return TRUE if there is enough memory in VRAM and GTT for the relocs
--     * added so far.
-+     * added so far. If the validation fails, all the relocations which have
-+     * been added since the last call of cs_validate will be removed and
-+     * the CS will be flushed (provided there are still any relocations).
-      *
-      * \param cs        A command stream to validate.
-      */
-diff --git a/src/glx/drisw_glx.c b/src/glx/drisw_glx.c
-index 07d4955..a57b327 100644
---- a/src/glx/drisw_glx.c
-+++ b/src/glx/drisw_glx.c
-@@ -100,6 +100,13 @@ XCreateDrawable(struct drisw_drawable * pdp,
-                               32,                     /* bitmap_pad */
-                               0);                     /* bytes_per_line */
-+  /**
-+   * swrast does not handle 24-bit depth with 24 bpp, so let X do the
-+   * the conversion for us.
-+   */
-+  if (pdp->ximage->bits_per_pixel == 24)
-+     pdp->ximage->bits_per_pixel = 32;
-+
-    return True;
- }
-diff --git a/src/mesa/drivers/dri/r300/compiler/radeon_dataflow.c b/src/mesa/drivers/dri/r300/compiler/radeon_dataflow.c
-index b0deb75..a8decac 100644
---- a/src/mesa/drivers/dri/r300/compiler/radeon_dataflow.c
-+++ b/src/mesa/drivers/dri/r300/compiler/radeon_dataflow.c
-@@ -687,7 +687,7 @@ static void get_readers_for_single_write(
-       struct rc_instruction * tmp;
-       unsigned int branch_depth = 0;
-       struct rc_instruction * endloop = NULL;
--      unsigned int abort_on_read_at_endloop;
-+      unsigned int abort_on_read_at_endloop = 0;
-       struct get_readers_callback_data * d = userdata;
-       d->ReaderData->Writer = writer;
-diff --git a/src/mesa/drivers/dri/r300/compiler/radeon_optimize.c b/src/mesa/drivers/dri/r300/compiler/radeon_optimize.c
-index ac73608..39dcb21 100644
---- a/src/mesa/drivers/dri/r300/compiler/radeon_optimize.c
-+++ b/src/mesa/drivers/dri/r300/compiler/radeon_optimize.c
-@@ -560,32 +560,30 @@ static int peephole_add_presub_add(
-       struct radeon_compiler * c,
-       struct rc_instruction * inst_add)
- {
--      struct rc_src_register * src0 = NULL;
--      struct rc_src_register * src1 = NULL;
--      unsigned int i;
--
--      if (!is_presub_candidate(c, inst_add))
--              return 0;
-+      unsigned dstmask = inst_add->U.I.DstReg.WriteMask;
-+        unsigned src0_neg = inst_add->U.I.SrcReg[0].Negate & dstmask;
-+        unsigned src1_neg = inst_add->U.I.SrcReg[1].Negate & dstmask;
-       if (inst_add->U.I.SrcReg[0].Swizzle != inst_add->U.I.SrcReg[1].Swizzle)
-               return 0;
--      /* src0 and src1 can't have absolute values only one can be negative and they must be all negative or all positive. */
--      for (i = 0; i < 2; i++) {
--              if (inst_add->U.I.SrcReg[i].Abs)
--                      return 0;
--              if ((inst_add->U.I.SrcReg[i].Negate
--                                      & inst_add->U.I.DstReg.WriteMask) ==
--                                              inst_add->U.I.DstReg.WriteMask) {
--                      src0 = &inst_add->U.I.SrcReg[i];
--              } else if (!src1) {
--                      src1 = &inst_add->U.I.SrcReg[i];
--              } else {
--                      src0 = &inst_add->U.I.SrcReg[i];
--              }
--      }
-+      /* src0 and src1 can't have absolute values */
-+      if (inst_add->U.I.SrcReg[0].Abs || inst_add->U.I.SrcReg[1].Abs)
-+              return 0;
-+
-+      /* presub_replace_add() assumes only one is negative */
-+      if (inst_add->U.I.SrcReg[0].Negate && inst_add->U.I.SrcReg[1].Negate)
-+              return 0;
-+
-+        /* if src0 is negative, at least all bits of dstmask have to be set */
-+        if (inst_add->U.I.SrcReg[0].Negate && src0_neg != dstmask)
-+              return 0;
--      if (!src1)
-+        /* if src1 is negative, at least all bits of dstmask have to be set */
-+        if (inst_add->U.I.SrcReg[1].Negate && src1_neg != dstmask)
-+              return 0;
-+
-+      if (!is_presub_candidate(c, inst_add))
-               return 0;
-       if (presub_helper(c, inst_add, RC_PRESUB_ADD, presub_replace_add)) {
-@@ -618,7 +616,7 @@ static void presub_replace_inv(
-  * of the add instruction must have the constatnt 1 swizzle.  This function
-  * does not check const registers to see if their value is 1.0, so it should
-  * be called after the constant_folding optimization.
-- * @return 
-+ * @return
-  *    0 if the ADD instruction is still part of the program.
-  *    1 if the ADD instruction is no longer part of the program.
-  */
-diff --git a/src/mesa/vbo/vbo_exec_array.c b/src/mesa/vbo/vbo_exec_array.c
-index 7959337..5903ae23 100644
---- a/src/mesa/vbo/vbo_exec_array.c
-+++ b/src/mesa/vbo/vbo_exec_array.c
-@@ -909,11 +909,10 @@ vbo_exec_DrawRangeElementsBaseVertex(GLenum mode,
-       if (0)
-          _mesa_print_arrays(ctx);
--#ifdef DEBUG
-       /* 'end' was out of bounds, but now let's check the actual array
-        * indexes to see if any of them are out of bounds.
-        */
--      {
-+      if (0) {
-          GLuint max = _mesa_max_buffer_index(ctx, count, type, indices,
-                                              ctx->Array.ElementArrayBufferObj);
-          if (max >= ctx->Array.ArrayObj->_MaxElement) {
-@@ -934,7 +933,6 @@ vbo_exec_DrawRangeElementsBaseVertex(GLenum mode,
-           * upper bound wrong.
-           */
-       }
--#endif
-       /* Set 'end' to the max possible legal value */
-       assert(ctx->Array.ArrayObj->_MaxElement >= 1);
diff --git a/Mesa-selinux.patch b/Mesa-selinux.patch
deleted file mode 100644 (file)
index c04b0c9..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- Mesa-7.11/configure.ac~    2011-07-12 12:57:43.000000000 +0200
-+++ Mesa-7.11/configure.ac     2011-07-18 19:40:58.701272226 +0200
-@@ -908,7 +908,7 @@
- AC_SUBST([GLESv2_LIB_DEPS])
- AC_SUBST([GLESv2_PC_LIB_PRIV])
--GLAPI_LIB_DEPS="-lpthread"
-+GLAPI_LIB_DEPS="-lpthread $SELINUX_LIBS"
- AC_SUBST([GLAPI_LIB_DEPS])
---- Mesa-7.11/configure.ac~    2011-08-01 13:49:24.000000000 +0200
-+++ Mesa-7.11/configure.ac     2011-08-01 13:50:55.554153435 +0200
-@@ -893,7 +893,7 @@
-     fi
-     # need DRM libs, -lpthread, etc.
--    GL_LIB_DEPS="$GL_LIB_DEPS $LIBDRM_LIBS -lm -lpthread $DLOPEN_LIBS"
-+    GL_LIB_DEPS="$GL_LIB_DEPS $LIBDRM_LIBS -lm -lpthread $DLOPEN_LIBS $SELINUX_LIBS"
-     GL_PC_LIB_PRIV="-lm -lpthread $DLOPEN_LIBS"
-     GLESv1_CM_LIB_DEPS="$LIBDRM_LIBS -lm -lpthread $DLOPEN_LIBS"
-     GLESv1_CM_PC_LIB_PRIV="-lm -lpthread $DLOPEN_LIBS"
index 83539c73df4e068480b1dc62b01d9bab493de631..31c273058d21a3f57513f6325bb78944c7642adc 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 %bcond_without egl     # build egl
 %bcond_without gallium # don't build gallium
 %bcond_with    gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
-%bcond_without gallium_radeon  # gallium radeon driver
 %bcond_without gallium_nouveau # gallium nouveau driver
-%bcond_without motif   # build static libGLw without Motif interface
 %bcond_without osmesa  # don't build osmesa
+%bcond_without gbm     # with Graphics Buffer Manager
 %bcond_with    static_libs     # static libraries
 #
 # minimal supported xserver version
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver       7.1.0
 #
-%define                libdrm_ver      2.4.25
+%define                libdrm_ver      2.4.30
 %define                dri2proto_ver   2.6
 %define                glproto_ver     1.4.11
 #
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       7.11.2
-Release:       3
-License:       MIT (core), SGI (GLU,libGLw) and others - see license.html file
+Version:       8.0
+Release:       1
+License:       MIT (core), SGI (GLU) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 0837c52698fe3252369c3fdb5195afcc
+# Source0-md5: 1a5668fe72651a670611164cefc703b2
 Patch0:                %{name}-realclean.patch
-Patch1:                %{name}-git.patch
-Patch2:                %{name}-selinux.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -49,9 +46,8 @@ BuildRequires:        libselinux-devel
 BuildRequires: libstdc++-devel >= 5:3.3.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:1.4d
-# for Gallium R300
+BuildRequires: libvdpau-devel
 BuildRequires: llvm-devel >= 2.9
-%{?with_motif:BuildRequires:   motif-devel}
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig(talloc) >= 2.0.1
@@ -63,6 +59,7 @@ BuildRequires:        sed >= 4.0
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXt-devel
+BuildRequires: xorg-lib-libXvMC-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
@@ -80,12 +77,14 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %if %{without gallium}
 %undefine      with_gallium_intel
-%undefine      with_gallium_nouveau
-%undefine      with_gallium_radeon
+%endif
+
+%if %{without egl}
+%undefine      with_gbm
 %endif
 
 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
-%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.*
+%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.* libvdpau_nouveau.so.1.*
 
 %description
 Mesa is a 3-D graphics library with an API which is very similar to
@@ -331,52 +330,6 @@ Static SGI libGLU library.
 %description libGLU-static -l pl.UTF-8
 Statyczna biblioteka SGI libGLU.
 
-%package libGLw
-Summary:       SGI OpenGL Xt widgets library
-Summary(pl.UTF-8):     Biblioteka SGI widgetów Xt dla OpenGL-a
-License:       SGI MIT-like
-Group:         Libraries
-# loose dependency on libGL.so.1 to use with other libGL binaries
-Requires:      OpenGL >= 1.1
-Provides:      OpenGL-GLw
-
-%description libGLw
-SGI OpenGL Xt widgets library.
-
-%description libGLw -l pl.UTF-8
-Biblioteka SGI widgetów Xt dla OpenGL-a.
-
-%package libGLw-devel
-Summary:       Header files for SGI libGLw library
-Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki SGI libGLw
-License:       SGI MIT-like
-Group:         Development/Libraries
-Requires:      %{name}-libGLw = %{version}-%{release}
-Requires:      OpenGL-devel >= 1.2
-Requires:      xorg-lib-libX11-devel
-Requires:      xorg-lib-libXt-devel
-Provides:      OpenGL-GLw-devel
-
-%description libGLw-devel
-Header files for SGI libGLw library.
-
-%description libGLw-devel -l pl.UTF-8
-Pliki nagłówkowe biblioteki SGI libGLw.
-
-%package libGLw-static
-Summary:       Static SGI libGLw library
-Summary(pl.UTF-8):     Statyczna biblioteka SGI libGLw
-License:       SGI MIT-like
-Group:         Development/Libraries
-Requires:      %{name}-libGLw-devel = %{version}-%{release}
-Provides:      OpenGL-GLw-static
-
-%description libGLw-static
-Static SGI libGLw library.
-
-%description libGLw-static -l pl.UTF-8
-Statyczna biblioteka SGI libGLw.
-
 %package libOSMesa
 Summary:       OSMesa (off-screen renderer) library
 Summary(pl.UTF-8):     Biblioteka OSMesa (renderująca bitmapy w pamięci)
@@ -438,10 +391,10 @@ Mesa implements OpenVG 1.1.
 %description libOpenVG -l pl.UTF-8
 Ten pakiet zawiera implementację Mesa standardu OpenVG -
 wieloplatfomowego API zapewniającego niskopoziomowy interfejs
-akceleracji sprzętowej dla bibliotek grafiki wektorowej, takiej
-jak Flash czy SVG. Specyfikację OpenVG można znaleźć na stronie
-Khronos Group: <http://www.khronos.org/openvg/>. Mesa zawiera
-implementację OpenVG w wersji 1.1.
+akceleracji sprzętowej dla bibliotek grafiki wektorowej, takiej jak
+Flash czy SVG. Specyfikację OpenVG można znaleźć na stronie Khronos
+Group: <http://www.khronos.org/openvg/>. Mesa zawiera implementację
+OpenVG w wersji 1.1.
 
 %package libOpenVG-devel
 Summary:       Header file for Mesa OpenVG library
@@ -458,20 +411,18 @@ Header file for Mesa OpenVG library.
 %description libOpenVG-devel -l pl.UTF-8
 Plik nagłówkowy biblioteki Mesa OpenVG.
 
-%package dri-driver-ati-mach64
-Summary:       X.org DRI driver for ATI Mach64 card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI Mach64
+%package libXvMC
+Summary:       XvMC implementations
+Summary(pl.UTF-8):     Implementacje API XvMC
 License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-mach64
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
+Group:         Libraries
+# doesn't require base
 
-%description dri-driver-ati-mach64
-X.org DRI driver for ATI Mach64 card family.
+%description libXvMC
+libXvMC implementations.
 
-%description dri-driver-ati-mach64 -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart ATI Mach64.
+%description libXvMC -l pl.UTF-8
+Implementacje API libXvMC.
 
 %package dri-driver-ati-radeon-R100
 Summary:       X.org DRI driver for ATI R100 card family
@@ -537,22 +488,6 @@ X.org DRI driver for ATI R600 card family.
 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
 Sterownik X.org DRI dla rodziny kart ATI R600.
 
-%package dri-driver-ati-rage128
-Summary:       X.org DRI driver for ATI Rage128 card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI Rage128
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-r128
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-Obsoletes:     X11-driver-r128-dri < 1:7.0.0
-
-%description dri-driver-ati-rage128
-X.org DRI driver for ATI Rage128 card family.
-
-%description dri-driver-ati-rage128 -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart ATI Rage128.
-
 %package dri-driver-ffb
 Summary:       X.org DRI driver for Sun FFB card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Sun FFB
@@ -584,22 +519,6 @@ X.org DRI driver for GLINT/Permedia card family.
 %description dri-driver-glint -l pl.UTF-8
 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
 
-%package dri-driver-intel-i810
-Summary:       X.org DRI driver for Intel i810 card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i810
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-intel
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-Obsoletes:     X11-driver-i810-dri < 1:7.0.0
-
-%description dri-driver-intel-i810
-X.org DRI driver for Intel i810 card family.
-
-%description dri-driver-intel-i810 -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart Intel i810.
-
 %package dri-driver-intel-i915
 Summary:       X.org DRI driver for Intel i915 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i915
@@ -634,22 +553,6 @@ X.org DRI driver for Intel i965 card family.
 %description dri-driver-intel-i965 -l pl.UTF-8
 Sterownik X.org DRI dla rodziny kart Intel i965.
 
-%package dri-driver-matrox
-Summary:       X.org DRI driver for Matrox G card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Matrox G
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-mga
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-Obsoletes:     X11-driver-mga-dri < 1:7.0.0
-
-%description dri-driver-matrox
-X.org DRI drivers for Matrox G card family.
-
-%description dri-driver-matrox -l pl.UTF-8
-Sterowniki X.org DRI dla rodziny kart Matrox G.
-
 %package dri-driver-nouveau
 Summary:       X.org DRI driver for NVIDIA card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart NVIDIA
@@ -665,37 +568,6 @@ X.org DRI drivers for NVIDIA card family.
 %description dri-driver-nouveau -l pl.UTF-8
 Sterowniki X.org DRI dla rodziny kart NVIDIA.
 
-%package dri-driver-savage
-Summary:       X.org DRI driver for S3 Savage card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart S3 Savage
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-savage
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-
-%description dri-driver-savage
-X.org DRI driver for S3 Savage card family.
-
-%description dri-driver-savage -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart S3 Savage.
-
-%package dri-driver-sis
-Summary:       X.org DRI driver for SiS card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart SiS
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-sis
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-Obsoletes:     X11-driver-sis-dri < 1:7.0.0
-
-%description dri-driver-sis
-X.org DRI driver for SiS card family.
-
-%description dri-driver-sis -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart SiS.
-
 %package dri-driver-swrast
 Summary:       X.org DRI software rasterizer driver
 Summary(pl.UTF-8):     Sterownik X.org DRI obsługujący rysowanie programowe
@@ -710,40 +582,6 @@ X.org DRI software rasterizer driver.
 %description dri-driver-swrast -l pl.UTF-8
 Sterownik X.org DRI obsługujący rysowanie programowe.
 
-%package dri-driver-tdfx
-Summary:       X.org DRI driver for 3DFX Voodoo card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
-License:       MIT
-Group:         X11/Libraries
-Requires:      Glide3-DRI
-Requires:      xorg-driver-video-tdfx
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-Obsoletes:     X11-driver-tdfx-dri < 1:7.0.0
-
-%description dri-driver-tdfx
-X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
-and Velocity 100/200).
-
-%description dri-driver-tdfx -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
-Banshee i Velocity 100/200).
-
-%package dri-driver-via-unichrome
-Summary:       X.org DRI driver for VIA Unichrome card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart VIA Unichrome
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-openchrome
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-
-%description dri-driver-via-unichrome
-X.org DRI driver for VIA Unichrome card family.
-
-%description dri-driver-via-unichrome -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart VIA Unichrome.
-
 %package dri-driver-vmwgfx
 Summary:       X.org DRI driver for VMware
 Summary(pl.UTF-8):     Sterownik X.org DRI dla VMware
@@ -758,34 +596,37 @@ X.org DRI driver for VMWare.
 %description dri-driver-vmwgfx -l pl.UTF-8
 Sterownik X.org DRI dla VMware.
 
+%package -n libvdpau-driver-mesa
+Summary:       Mesa driver for the vdpau API
+Summary(pl.UTF-8):     Sterownik Mesa dla API vdpau
+License:       MIT
+Group:         X11/Libraries
+
+%description -n libvdpau-driver-mesa
+Mesa driver for the vdpau API.
+
+%description -n libvdpau-driver-mesa -l pl.UTF-8
+Sterownik Mesa dla API vdpau.
+
 # llvm build broken
 %define                filterout_ld    -Wl,--as-needed
 
 %prep
 %setup -q
 %patch0 -p0
-#%patch1 -p1
-%patch2 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 
-dri_drivers="i810 mach64 mga r128 r200 radeon \
-%if %{without gallium_radeon}
-r300 r600 \
-%endif
-savage \
+dri_drivers="r200 radeon \
 %if %{without gallium_intel}
 i915 i965 \
 %endif
 %ifarch sparc sparcv9 sparc64
 ffb \
 %endif
-%ifarch %{ix86} %{x8664}
-sis \
-%endif
-swrast tdfx unichrome"
+swrast"
 
 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
 
@@ -794,10 +635,8 @@ gallium_drivers="svga swrast \
 i915 \
 i965 \
 %endif
-%if %{with gallium_radeon}
 r300 \
 r600 \
-%endif
 %if %{with gallium_nouveau}
 nouveau \
 %endif
@@ -806,11 +645,11 @@ nouveau \
 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 
 common_flags="\
+       --enable-shared \
        --enable-glx-tls \
        --enable-pic \
        --enable-selinux \
        %{?with_static_libs:--enable-static} \
-       --disable-glut \
 "
 
 osmesa_common_flags="\
@@ -830,6 +669,8 @@ cp -p src/mesa/osmesa.pc osmesa8
 %endif
 
 %configure $common_flags \
+       --enable-shared-glapi \
+       %{__enable gbm} \
 %if %{with egl}
        --enable-egl \
        --enable-gles1 \
@@ -837,7 +678,11 @@ cp -p src/mesa/osmesa.pc osmesa8
 %endif
 %if %{with gallium}
        --enable-openvg \
-       --enable-gallium-egl \
+       --enable-gallium-llvm \
+       %{__enable egl gallium-egl} \
+       %{__enable gbm gallium-gbm} \
+       --enable-vdpau \
+       --enable-xvmc \
        --with-gallium-drivers=${gallium_drivers} \
 %else
        --disable-gallium \
@@ -861,12 +706,7 @@ cp -p osmesa8/osmesa.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
 %endif
 
 # strip out undesirable headers
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{glfbdev,mesa_wgl,vms_x_fix,wglext,wmesa}.h
-
-%if %{with gallium}
-# use gallium swrastg as swrast
-mv $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri/swrastg_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri/swrast_dri.so
-%endif
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{vms_x_fix,wglext,wmesa}.h
 
 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
 # set up via /etc/ld.so.conf.d/*.conf will be preferred over this
@@ -887,15 +727,15 @@ rm -rf $RPM_BUILD_ROOT
 %post  libGLU -p /sbin/ldconfig
 %postun        libGLU -p /sbin/ldconfig
 
-%post  libGLw -p /sbin/ldconfig
-%postun        libGLw -p /sbin/ldconfig
-
 %post  libOSMesa -p /sbin/ldconfig
 %postun        libOSMesa -p /sbin/ldconfig
 
 %post  libOpenVG -p /sbin/ldconfig
 %postun        libOpenVG -p /sbin/ldconfig
 
+%post  libXvMC -p /sbin/ldconfig
+%postun        libXvMC -p /sbin/ldconfig
+
 %if %{with egl}
 %files libEGL
 %defattr(644,root,root,755)
@@ -903,15 +743,28 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
+%if %{with gbm}
+%dir %{_libdir}/gbm
+%attr(755,root,root) %{_libdir}/libgbm.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
+%endif
 %if %{with gallium}
 %dir %{_libdir}/egl
 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
-%attr(755,root,root) %{_libdir}/egl/st_GL.so
+%attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
+%attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
+%if %{with gbm}
+%attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
+%attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
+%if %{with gallium_nouveau}
+%attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
+%endif
 %if %{with gallium_intel}
 %attr(755,root,root) %{_libdir}/egl/pipe_i915.so
 %attr(755,root,root) %{_libdir}/egl/pipe_i965.so
 %endif
 %endif
+%endif
 
 %files libEGL-devel
 %defattr(644,root,root,755)
@@ -920,10 +773,16 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_includedir}/EGL
 %{_includedir}/EGL/egl.h
 %{_includedir}/EGL/eglext.h
+%{_includedir}/EGL/eglmesaext.h
 %{_includedir}/EGL/eglplatform.h
 %dir %{_includedir}/KHR
 %{_includedir}/KHR/khrplatform.h
 %{_pkgconfigdir}/egl.pc
+%if %{with gbm}
+%attr(755,root,root) %{_libdir}/libgbm.so
+%{_includedir}/gbm.h
+%{_pkgconfigdir}/gbm.pc
+%endif
 
 %if %{with static_libs}
 %files libEGL-static
@@ -934,7 +793,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libGL
 %defattr(644,root,root,755)
-%doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
+%doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
 %attr(755,root,root) %{_libdir}/libGL.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
 # symlink for binary apps which fail to conform Linux OpenGL ABI
@@ -996,31 +855,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libGLU.a
 %endif
 
-%files libGLw
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libGLw.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
-
-%files libGLw-devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libGLw.so
-%{_includedir}/GL/GLwDrawA.h
-%{_includedir}/GL/GLwDrawAP.h
-%{_includedir}/GL/GLwMDrawA.h
-%{_includedir}/GL/GLwMDrawAP.h
-%{_pkgconfigdir}/glw.pc
-
-%if %{with static_libs}
-%files libGLw-static
-%defattr(644,root,root,755)
-%{_libdir}/libGLw.a
-%endif
-
 %if %{with osmesa}
 %files libOSMesa
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.7
+%attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.8
 
 %files libOSMesa-devel
 %defattr(644,root,root,755)
@@ -1048,9 +887,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/vg.pc
 %endif
 
-%files dri-driver-ati-mach64
+%files libXvMC
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
+%attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
+%attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
+%attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
+%attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
+%attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
+%attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
+%attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
+%attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
 
 %files dri-driver-ati-radeon-R100
 %defattr(644,root,root,755)
@@ -1068,10 +914,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
 
-%files dri-driver-ati-rage128
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
-
 # sunffb (sparc only)
 %ifarch sparc sparcv9 sparc64
 %files dri-driver-ffb
@@ -1086,10 +928,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
 %endif
 
-%files dri-driver-intel-i810
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
-
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
@@ -1101,40 +939,34 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
 %endif
 
-%files dri-driver-matrox
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
-
 %if %{with gallium_nouveau}
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
 %endif
 
-%files dri-driver-savage
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
-
-%ifarch %{ix86} %{x8664}
-%files dri-driver-sis
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
-%endif
-
 %files dri-driver-swrast
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
 
-%files dri-driver-tdfx
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
-
-%files dri-driver-via-unichrome
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
-
 %if %{with gallium}
 %files dri-driver-vmwgfx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
 %endif
+
+%files -n libvdpau-driver-mesa
+%defattr(644,root,root,755)
+# there is no ldconfig here
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1.0
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
This page took 0.077219 seconds and 4 git commands to generate.