]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- rel 2 auto/th/Mesa-7_11-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 1 Aug 2011 07:17:01 +0000 (07:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Mesa-git.patch -> 1.16
    Mesa.spec -> 1.280

Mesa-git.patch
Mesa.spec

index c813d2a778c08a9bef0c21bdf7e5222d113afe42..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,205 +0,0 @@
-diff --git a/docs/news.html b/docs/news.html
-index 72d38ee..ce0cd0c 100644
---- a/docs/news.html
-+++ b/docs/news.html
-@@ -11,6 +11,19 @@
- <H1>News</H1>
-+<h2>January 7, 2011</h2>
-+
-+<p>
-+<a href="relnotes-7.10.html">Mesa 7.10</a> (final) is released.  This is a new
-+development release.
-+</p>
-+
-+<p>
-+Also, <a href="relnotes-7.9.1.html">Mesa 7.9.1</a> (final) is released.
-+This is a bug fix release.
-+</p>
-+
-+
- <h2>October 4, 2010</h2>
- <p>
-diff --git a/docs/relnotes-7.10.html b/docs/relnotes-7.10.html
-index 2abbc4a..3f4f229 100644
---- a/docs/relnotes-7.10.html
-+++ b/docs/relnotes-7.10.html
-@@ -1,8 +1,10 @@
- <HTML>
-+<head>
- <TITLE>Mesa Release Notes</TITLE>
--
--<head><link rel="stylesheet" type="text/css" href="mesa.css"></head>
-+<link rel="stylesheet" type="text/css" href="mesa.css">
-+<meta http-equiv="content-type" content="text/html; charset=utf-8" />
-+</head>
- <BODY>
-@@ -28,7 +30,12 @@ for DRI hardware acceleration.
- <h2>MD5 checksums</h2>
- <pre>
--tbd
-+0a70c15c135561824bdcae92bf232e43  MesaLib-7.10.tar.gz
-+33fb94eccc02cbb4d8d1365615e38e46  MesaLib-7.10.tar.bz2
-+5cafdc0eda0f9bf370b95c98df3338fa  MesaLib-7.10.zip
-+bc644be551ed585fc4f66c16b64a91c9  MesaGLUT-7.10.tar.gz
-+5c2677a155672352d62b177e4f0f92e8  MesaGLUT-7.10.tar.bz2
-+2ce5001f74496d1ba719ef74d910a5cf  MesaGLUT-7.10.zip
- </pre>
-diff --git a/docs/relnotes-7.9.1.html b/docs/relnotes-7.9.1.html
-index a46eb16..bef4ef1 100644
---- a/docs/relnotes-7.9.1.html
-+++ b/docs/relnotes-7.9.1.html
-@@ -1,8 +1,10 @@
- <HTML>
-+<head>
- <TITLE>Mesa Release Notes</TITLE>
--
--<head><link rel="stylesheet" type="text/css" href="mesa.css"></head>
-+<link rel="stylesheet" type="text/css" href="mesa.css">
-+<meta http-equiv="content-type" content="text/html; charset=utf-8" />
-+</head>
- <BODY>
-diff --git a/docs/relnotes.html b/docs/relnotes.html
-index 4487af9..036d3f8 100644
---- a/docs/relnotes.html
-+++ b/docs/relnotes.html
-@@ -13,6 +13,8 @@ The release notes summarize what's new or changed in each Mesa release.
- </p>
- <UL>
-+<LI><A HREF="relnotes-7.10.html">7.10 release notes</A>
-+<LI><A HREF="relnotes-7.9.1html">7.9.1 release notes</A>
- <LI><A HREF="relnotes-7.9.html">7.9 release notes</A>
- <LI><A HREF="relnotes-7.8.3.html">7.8.3 release notes</A>
- <LI><A HREF="relnotes-7.8.2.html">7.8.2 release notes</A>
-diff --git a/src/gallium/auxiliary/draw/draw_pt_vsplit_tmp.h b/src/gallium/auxiliary/draw/draw_pt_vsplit_tmp.h
-index 3f66f96..75dba8c 100644
---- a/src/gallium/auxiliary/draw/draw_pt_vsplit_tmp.h
-+++ b/src/gallium/auxiliary/draw/draw_pt_vsplit_tmp.h
-@@ -258,9 +258,10 @@ vsplit_segment_fan_linear(struct vsplit_frontend *vsplit, unsigned flags,
-    boolean use_spoken = ((flags & DRAW_SPLIT_BEFORE) != 0);
-    unsigned nr = 0, i;
--   assert(icount + !!use_spoken <= vsplit->segment_size);
-+   assert(icount <= vsplit->segment_size);
-    if (use_spoken) {
-+      /* replace istart by i0 */
-       vsplit->fetch_elts[nr++] = i0;
-       for (i = 1 ; i < icount; i++)
-          vsplit->fetch_elts[nr++] = istart + i;
-diff --git a/src/mesa/drivers/dri/r600/r700_assembler.c b/src/mesa/drivers/dri/r600/r700_assembler.c
-index bee9c3b..024853c 100644
---- a/src/mesa/drivers/dri/r600/r700_assembler.c
-+++ b/src/mesa/drivers/dri/r600/r700_assembler.c
-@@ -481,6 +481,8 @@ unsigned int EG_GetNumOperands(GLuint opcode, GLuint nIsOp3)
-     case EG_OP2_INST_FLT_TO_INT:
-     case EG_OP2_INST_SIN:
-     case EG_OP2_INST_COS:
-+    case EG_OP2_INST_FLT_TO_INT_FLOOR:
-+    case EG_OP2_INST_MOVA_INT:
-         return 1;
-         
-     default: radeon_error(
-@@ -3297,23 +3299,76 @@ GLboolean assemble_ARL(r700_AssemblerBase *pAsm)
-         return GL_FALSE;
-     }
--    pAsm->D.dst.opcode = SQ_OP2_INST_MOVA_FLOOR;
--    setaddrmode_PVSDST(&(pAsm->D.dst), ADDR_ABSOLUTE);
--    pAsm->D.dst.rtype = DST_REG_TEMPORARY;
--    pAsm->D.dst.reg = 0;
--    pAsm->D.dst.writex = 0;
--    pAsm->D.dst.writey = 0;
--    pAsm->D.dst.writez = 0;
--    pAsm->D.dst.writew = 0;
--
--    if( GL_FALSE == assemble_src(pAsm, 0, -1) )
-+    if(8 == pAsm->unAsic)
-     {
--        return GL_FALSE;
--    }
-+        /* Evergreen */
--    if( GL_FALSE == next_ins(pAsm) )
-+        /* Float to Signed Integer Using FLOOR */
-+        pAsm->D.dst.opcode = EG_OP2_INST_FLT_TO_INT_FLOOR;
-+        setaddrmode_PVSDST(&(pAsm->D.dst), ADDR_ABSOLUTE);
-+        pAsm->D.dst.rtype = DST_REG_TEMPORARY;
-+        pAsm->D.dst.reg = 0;
-+        pAsm->D.dst.writex = 0;
-+        pAsm->D.dst.writey = 0;
-+        pAsm->D.dst.writez = 0;
-+        pAsm->D.dst.writew = 0;
-+
-+        if( GL_FALSE == assemble_src(pAsm, 0, -1) )
-+        {
-+            return GL_FALSE;
-+        }
-+
-+        if( GL_FALSE == next_ins(pAsm) )
-+        {
-+            return GL_FALSE;
-+        }
-+
-+        /* Copy Signed Integer To Integer in AR and GPR */
-+        pAsm->D.dst.opcode = EG_OP2_INST_MOVA_INT;
-+        setaddrmode_PVSDST(&(pAsm->D.dst), ADDR_ABSOLUTE);
-+        pAsm->D.dst.rtype = DST_REG_TEMPORARY;
-+        pAsm->D.dst.reg = 0;
-+        pAsm->D.dst.writex = 0;
-+        pAsm->D.dst.writey = 0;
-+        pAsm->D.dst.writez = 0;
-+        pAsm->D.dst.writew = 0;
-+
-+        if( GL_FALSE == assemble_src(pAsm, 0, -1) )
-+        {
-+            return GL_FALSE;
-+        }
-+
-+        if( GL_FALSE == next_ins(pAsm) )
-+        {
-+            return GL_FALSE;
-+        }
-+    }
-+    else
-     {
--        return GL_FALSE;
-+        /* r6xx/r7xx */
-+
-+        /* Truncate floating-point to the nearest integer
-+           in the range [-256, +255], and copy to AR and
-+           to a GPR.
-+        */
-+        pAsm->D.dst.opcode = SQ_OP2_INST_MOVA_FLOOR;
-+        setaddrmode_PVSDST(&(pAsm->D.dst), ADDR_ABSOLUTE);
-+        pAsm->D.dst.rtype = DST_REG_TEMPORARY;
-+        pAsm->D.dst.reg = 0;
-+        pAsm->D.dst.writex = 0;
-+        pAsm->D.dst.writey = 0;
-+        pAsm->D.dst.writez = 0;
-+        pAsm->D.dst.writew = 0;
-+
-+        if( GL_FALSE == assemble_src(pAsm, 0, -1) )
-+        {
-+            return GL_FALSE;
-+        }
-+
-+        if( GL_FALSE == next_ins(pAsm) )
-+        {
-+            return GL_FALSE;
-+        }
-     }
-     return GL_TRUE;
index c018974588aef1a0e6e705fe759f20a932bb5ed9..fc817cf404057b771cfd28c8a7a40a3f83ea652a 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -29,7 +29,7 @@ Summary:      Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
 Version:       7.11
-Release:       1%{?with_multigl:.mgl}
+Release:       2%{?with_multigl:.mgl}
 License:       MIT (core), SGI (GLU,libGLw) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
This page took 0.036686 seconds and 4 git commands to generate.