]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- added tgsi_dump patch (fixes conflict with fortify printf redirect in glibc)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Jan 2010 10:55:43 +0000 (10:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Mesa-tgsi_dump.patch -> 1.1
    Mesa.spec -> 1.233

Mesa-tgsi_dump.patch [new file with mode: 0644]
Mesa.spec

diff --git a/Mesa-tgsi_dump.patch b/Mesa-tgsi_dump.patch
new file mode 100644 (file)
index 0000000..4ddf96c
--- /dev/null
@@ -0,0 +1,86 @@
+--- Mesa-7.7/src/gallium/auxiliary/tgsi/tgsi_dump.c.orig       2009-12-22 03:26:02.000000000 +0100
++++ Mesa-7.7/src/gallium/auxiliary/tgsi/tgsi_dump.c    2010-01-10 09:40:23.298610151 +0100
+@@ -47,7 +47,7 @@
+    
+    uint indentation;
+-   void (*printf)(struct dump_ctx *ctx, const char *format, ...);
++   void (*dump_printf)(struct dump_ctx *ctx, const char *format, ...);
+ };
+ static void 
+@@ -68,19 +68,19 @@
+    uint enum_count )
+ {
+    if (e >= enum_count)
+-      ctx->printf( ctx, "%u", e );
++      ctx->dump_printf( ctx, "%u", e );
+    else
+-      ctx->printf( ctx, "%s", enums[e] );
++      ctx->dump_printf( ctx, "%s", enums[e] );
+ }
+-#define EOL()           ctx->printf( ctx, "\n" )
+-#define TXT(S)          ctx->printf( ctx, "%s", S )
+-#define CHR(C)          ctx->printf( ctx, "%c", C )
+-#define UIX(I)          ctx->printf( ctx, "0x%x", I )
+-#define UID(I)          ctx->printf( ctx, "%u", I )
+-#define INSTID(I)          ctx->printf( ctx, "% 3u", I )
+-#define SID(I)          ctx->printf( ctx, "%d", I )
+-#define FLT(F)          ctx->printf( ctx, "%10.4f", F )
++#define EOL()           ctx->dump_printf( ctx, "\n" )
++#define TXT(S)          ctx->dump_printf( ctx, "%s", S )
++#define CHR(C)          ctx->dump_printf( ctx, "%c", C )
++#define UIX(I)          ctx->dump_printf( ctx, "0x%x", I )
++#define UID(I)          ctx->dump_printf( ctx, "%u", I )
++#define INSTID(I)          ctx->dump_printf( ctx, "% 3u", I )
++#define SID(I)          ctx->dump_printf( ctx, "%d", I )
++#define FLT(F)          ctx->dump_printf( ctx, "%10.4f", F )
+ #define ENM(E,ENUMS)    dump_enum( ctx, E, ENUMS, sizeof( ENUMS ) / sizeof( *ENUMS ) )
+ static const char *processor_type_names[] =
+@@ -278,7 +278,7 @@
+ {
+    struct dump_ctx ctx;
+-   ctx.printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_printf;
+    iter_declaration( &ctx.iter, (struct tgsi_full_declaration *)decl );
+ }
+@@ -323,7 +323,7 @@
+ {
+    struct dump_ctx ctx;
+-   ctx.printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_printf;
+    iter_immediate( &ctx.iter, (struct tgsi_full_immediate *)imm );
+ }
+@@ -491,7 +491,7 @@
+    ctx.instno = instno;
+    ctx.indent = 0;
+-   ctx.printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_printf;
+    ctx.indentation = 0;
+    iter_instruction( &ctx.iter, (struct tgsi_full_instruction *)inst );
+@@ -525,7 +525,7 @@
+    ctx.instno = 0;
+    ctx.indent = 0;
+-   ctx.printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_printf;
+    ctx.indentation = 0;
+    tgsi_iterate_shader( tokens, &ctx.iter );
+@@ -579,7 +579,7 @@
+    ctx.base.instno = 0;
+    ctx.base.indent = 0;
+-   ctx.base.printf = &str_dump_ctx_printf;
++   ctx.base.dump_printf = &str_dump_ctx_printf;
+    ctx.base.indentation = 0;
+    ctx.str = str;
index de6571816a5329f6c1160923fbdf0532fa77acbe..2b2b69321752c035ad9d9a4471b3ea1759a487ff 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -35,6 +35,7 @@ Source1:      ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.t
 Source2:       http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
 # Source2-md5: 6ae05158e678f4594343f32c2ca50515
 Patch0:                %{name}-realclean.patch
+Patch1:                %{name}-tgsi_dump.patch
 URL:           http://www.mesa3d.org/
 %{?with_demos:BuildRequires:   OpenGL-glut-devel >= 3.8}
 BuildRequires: autoconf
@@ -620,6 +621,7 @@ Sterownik X.org DRI dla VMware.
 %prep
 %setup -q -b1 -a2
 %patch0 -p0
+%patch1 -p1
 
 # fix demos
 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
This page took 0.049065 seconds and 4 git commands to generate.