]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 8.0.1
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - consider:
4 #   --enable-shared-glapi (for libGL; required if the same app uses GL and GLES)
5 #   --enable-shared-dricore
6 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
7 # - resurrect static if it's useful
8 #
9 # Conditional build:
10 %bcond_without  egl     # build egl
11 %bcond_without  gallium # don't build gallium
12 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
13 %bcond_without  gallium_nouveau # gallium nouveau driver
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_without  gbm     # with Graphics Buffer Manager
16 %bcond_with     static_libs     # static libraries
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.30
26 %define         dri2proto_ver   2.6
27 %define         glproto_ver     1.4.11
28 #
29 Summary:        Free OpenGL implementation
30 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
31 Name:           Mesa
32 Version:        8.0.1
33 Release:        1
34 License:        MIT (core), SGI (GLU) and others - see license.html file
35 Group:          X11/Libraries
36 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
37 # Source0-md5:  24eeebf66971809d8f40775a379b36c9
38 Patch0:         %{name}-realclean.patch
39 URL:            http://www.mesa3d.org/
40 BuildRequires:  autoconf >= 2.59
41 BuildRequires:  automake
42 BuildRequires:  expat-devel
43 BuildRequires:  gcc >= 5:3.3
44 BuildRequires:  libdrm-devel >= %{libdrm_ver}
45 BuildRequires:  libselinux-devel
46 BuildRequires:  libstdc++-devel >= 5:3.3.0
47 BuildRequires:  libtalloc-devel >= 2:2.0.1
48 BuildRequires:  libtool >= 2:1.4d
49 BuildRequires:  libvdpau-devel
50 BuildRequires:  llvm-devel >= 2.9
51 BuildRequires:  pixman-devel
52 BuildRequires:  pkgconfig
53 BuildRequires:  pkgconfig(talloc) >= 2.0.1
54 BuildRequires:  python
55 BuildRequires:  python-libxml2
56 BuildRequires:  python-modules
57 BuildRequires:  rpmbuild(macros) >= 1.470
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  xorg-lib-libXdamage-devel
60 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
61 BuildRequires:  xorg-lib-libXt-devel
62 BuildRequires:  xorg-lib-libXvMC-devel
63 BuildRequires:  xorg-lib-libXxf86vm-devel
64 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
65 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
66 BuildRequires:  xorg-util-makedepend
67 BuildRequires:  xorg-xserver-server-devel
68 %if %{with egl}
69 BuildRequires:  libxcb-devel
70 BuildRequires:  udev-devel >= 150
71 %endif
72 %if %{with gallium}
73 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
74 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
75 %endif
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %if %{without gallium}
79 %undefine       with_gallium_intel
80 %endif
81
82 %if %{without egl}
83 %undefine       with_gbm
84 %endif
85
86 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
87 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.* libvdpau_nouveau.so.1.*
88
89 %description
90 Mesa is a 3-D graphics library with an API which is very similar to
91 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
92 syntax or state machine, it is being used with authorization from
93 Silicon Graphics, Inc. However, the author does not possess an OpenGL
94 license from SGI, and makes no claim that Mesa is in any way a
95 compatible replacement for OpenGL or associated with SGI.
96
97 %description -l pl.UTF-8
98 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
99 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
100 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
101 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
102 OpenGL ani powiązana z SGI.
103
104 %package libEGL
105 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
106 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
107 License:        MIT
108 Group:          Libraries
109 # glx driver in libEGL dlopens libGL.so
110 Requires:       OpenGL >= 1.2
111 Requires:       libdrm >= %{libdrm_ver}
112 %if %{with gallium}
113 # for egl_gallium.so
114 Requires:       Mesa-libOpenVG = %{version}-%{release}
115 Requires:       udev-libs >= 150
116 %endif
117 Provides:       EGL = 1.4
118
119 %description libEGL
120 This package contains shared libEGL - Mesa implementation of EGL
121 Native Platform Graphics Interface as specified by Khronos Group:
122 <http://www.khronos.org/egl/>.
123
124 %description libEGL -l pl.UTF-8
125 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
126 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
127 graficznego platformy natywnej) wg specyfikacji Khronos Group:
128 <http://www.khronos.org/egl/>.
129
130 %package libEGL-devel
131 Summary:        Header files for Mesa implementation of EGL library
132 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
133 License:        MIT
134 Group:          Development/Libraries
135 Requires:       %{name}-libEGL = %{version}-%{release}
136 Requires:       libdrm-devel >= %{libdrm_ver}
137 Requires:       xorg-lib-libX11-devel
138 Requires:       xorg-lib-libXdamage-devel
139 Requires:       xorg-lib-libXext-devel
140 Requires:       xorg-lib-libXfixes-devel
141 Requires:       xorg-lib-libXxf86vm-devel
142 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
143 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
144 Provides:       EGL-devel = 1.4
145
146 %description libEGL-devel
147 Header files for Mesa implementation of EGL library.
148
149 %description libEGL-devel -l pl.UTF-8
150 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
151
152 %package libEGL-static
153 Summary:        Static Mesa EGL library
154 Summary(pl.UTF-8):      Statyczna biblioteka Mesa EGL
155 License:        MIT
156 Group:          Development/Libraries
157 Requires:       %{name}-libEGL-devel = %{version}-%{release}
158 Provides:       EGL-static = 1.4
159
160 %description libEGL-static
161 Static Mesa EGL library.
162
163 %description libEGL-static -l pl.UTF-8
164 Statyczna biblioteka Mesa EGL.
165
166 %package libGL
167 Summary:        Free Mesa3D implementation of libGL OpenGL library
168 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
169 License:        MIT
170 Group:          X11/Libraries
171 Requires:       libdrm >= %{libdrm_ver}
172 Provides:       OpenGL = 2.1
173 Provides:       OpenGL-GLX = 1.4
174 Obsoletes:      Mesa
175 Obsoletes:      Mesa-dri
176 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
177 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
178
179 %description libGL
180 Mesa is a 3-D graphics library with an API which is very similar to
181 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
182 syntax or state machine, it is being used with authorization from
183 Silicon Graphics, Inc. However, the author does not possess an OpenGL
184 license from SGI, and makes no claim that Mesa is in any way a
185 compatible replacement for OpenGL or associated with SGI.
186
187 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
188 specifications. It uses DRI for rendering.
189
190 %description libGL -l pl.UTF-8
191 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
192 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
193 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
194 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
195 OpenGL ani powiązana z SGI.
196
197 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
198 GLX 1.4. Używa DRI do renderowania.
199
200 %package libGL-devel
201 Summary:        Header files for Mesa3D libGL library
202 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
203 License:        MIT
204 Group:          X11/Development/Libraries
205 # loose dependency on libGL to use with other libGL binaries
206 Requires:       OpenGL >= 1.5
207 Requires:       libdrm-devel >= %{libdrm_ver}
208 Requires:       xorg-lib-libX11-devel
209 Requires:       xorg-lib-libXdamage-devel
210 Requires:       xorg-lib-libXext-devel
211 Requires:       xorg-lib-libXxf86vm-devel
212 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
213 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
214 Suggests:       OpenGL-doc-man
215 Provides:       OpenGL-GLX-devel = 1.4
216 Provides:       OpenGL-devel = 2.1
217 Obsoletes:      Mesa-devel
218 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
219 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
220 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
221 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
222
223 %description libGL-devel
224 Header files for Mesa3D libGL library.
225
226 %description libGL-devel -l pl.UTF-8
227 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
228
229 %package libGL-static
230 Summary:        Static Mesa3D libGL library
231 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
232 License:        MIT
233 Group:          X11/Development/Libraries
234 Requires:       %{name}-libGL-devel = %{version}-%{release}
235 Provides:       OpenGL-static = 2.1
236 Obsoletes:      Mesa-static
237 Obsoletes:      X11-OpenGL-static < 1:7.0.0
238 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
239
240 %description libGL-static
241 Static Mesa3D libGL library. It uses software renderer.
242
243 %description libGL-static -l pl.UTF-8
244 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
245 renderingu.
246
247 %package libGLES
248 Summary:        Mesa implementation of GLES (OpenGL ES) libraries
249 Summary(pl.UTF-8):      Implementacja Mesa bibliotek GLES (OpenGL ES)
250 Group:          Libraries
251 # only for libglapi.so.0
252 Requires:       %{name}-libEGL = %{version}-%{release}
253
254 %description libGLES
255 This package contains shared libraries of Mesa implementation of GLES
256 (OpenGL ES) - cross-platform API for full-function 2D and 3D graphics
257 on embedded systems. OpenGL ES specification can be found on Khronos
258 Group site: <http://www.khronos.org/opengles/>. Mesa implements OpenGL
259 ES 1.1 and 2.0.
260
261 %description libGLES -l pl.UTF-8
262 Ten pakiet zawiera biblioteki współdzielone implementacji Mesa
263 standardu GLES (OpenGL ES) - wieloplatformowego API do w pełni
264 funkcjonalnej grafiki 2D i 3D na systemach wbudowanych. Specyfikację
265 OpenGL ES można znaleźć na stronie Khronos Group:
266 <http://www.khronos.org/opengles/>. Mesa zawiera implementacją OpenGL
267 ES 1.1 i 2.0.
268
269 %package libGLES-devel
270 Summary:        Header files for Mesa GLES libraries
271 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Mesa GLES
272 Group:          Development/Libraries
273 # EGL for libglapi.so, <KHR/khrplatform.h> always required, <EGL/egl.h> for <GLES/egl.h>
274 Requires:       %{name}-libEGL-devel = %{version}-%{release}
275 Requires:       %{name}-libGLES = %{version}-%{release}
276
277 %description libGLES-devel
278 Header files for Mesa GLES libraries.
279
280 %description libGLES-devel -l pl.UTF-8
281 Pliki nagłówkowe bibliotek Mesa GLES.
282
283 %package libGLU
284 Summary:        SGI implementation of libGLU OpenGL library
285 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
286 License:        SGI Free Software License B v2.0 (MIT-like)
287 Group:          Libraries
288 # loose dependency on libGL.so.1 to use with other libGL binaries
289 Requires:       OpenGL >= 1.2
290 Provides:       OpenGL-GLU = 1.3
291 Obsoletes:      Mesa-devel
292 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
293 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
294
295 %description libGLU
296 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
297 1.3 specifications.
298
299 %description libGLU -l pl.UTF-8
300 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
301 specyfikację OpenGL GLU 1.3.
302
303 %package libGLU-devel
304 Summary:        Header files for SGI libGLU library
305 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
306 License:        SGI Free Software License B v2.0 (MIT-like)
307 Group:          Development/Libraries
308 Requires:       %{name}-libGLU = %{version}-%{release}
309 Requires:       OpenGL-devel >= 1.2
310 Requires:       libstdc++-devel
311 Provides:       OpenGL-GLU-devel = 1.3
312
313 %description libGLU-devel
314 Header files for SGI libGLU library.
315
316 %description libGLU-devel -l pl.UTF-8
317 Pliki nagłówkowe biblioteki SGI libGLU.
318
319 %package libGLU-static
320 Summary:        Static SGI libGLU library
321 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
322 License:        SGI Free Software License B v2.0 (MIT-like)
323 Group:          Development/Libraries
324 Requires:       %{name}-libGLU-devel = %{version}-%{release}
325 Provides:       OpenGL-GLU-static = 1.3
326
327 %description libGLU-static
328 Static SGI libGLU library.
329
330 %description libGLU-static -l pl.UTF-8
331 Statyczna biblioteka SGI libGLU.
332
333 %package libOSMesa
334 Summary:        OSMesa (off-screen renderer) library
335 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
336 License:        MIT
337 Group:          Libraries
338 # doesn't require base
339
340 %description libOSMesa
341 OSMesa (off-screen renderer) library.
342
343 %description libOSMesa -l pl.UTF-8
344 Biblioteka OSMesa (renderująca bitmapy w pamięci).
345
346 %package libOSMesa-devel
347 Summary:        Header file for OSMesa (off-screen renderer) library
348 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
349 License:        MIT
350 Group:          Development/Libraries
351 Requires:       %{name}-libOSMesa = %{version}-%{release}
352 # for <GL/gl.h> only
353 Requires:       OpenGL-devel
354 Requires:       libselinux-devel
355
356 %description libOSMesa-devel
357 Header file for OSMesa (off-screen renderer) library.
358
359 %description libOSMesa-devel -l pl.UTF-8
360 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
361
362 %package libOSMesa-static
363 Summary:        Static OSMesa (off-screen renderer) library
364 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
365 License:        MIT
366 Group:          Development/Libraries
367 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
368 # this static build of OSMesa needs static non-dri Mesa implementation
369 Requires:       %{name}-libGL-static = %{version}-%{release}
370
371 %description libOSMesa-static
372 Static OSMesa (off-screen renderer) library.
373
374 %description libOSMesa-static -l pl.UTF-8
375 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
376
377 %package libOpenVG
378 Summary:        Mesa implementation of OpenVG (Vector Graphics Accelleration) API
379 Summary(pl.UTF-8):      Implementacja Mesa API OpenVG (akceleracji grafiki wektorowej)
380 License:        MIT
381 Group:          Libraries
382 # doesn't require base
383
384 %description libOpenVG
385 This package contains Mesa implementation of OpenVG - cross-platform
386 API that provides a low-level hardware acceleration interface for
387 vector graphics libraries such as Flash and SVG. OpenVG specification
388 can be found on Khronos Group site: <http://www.khronos.org/openvg/>.
389 Mesa implements OpenVG 1.1.
390
391 %description libOpenVG -l pl.UTF-8
392 Ten pakiet zawiera implementację Mesa standardu OpenVG -
393 wieloplatfomowego API zapewniającego niskopoziomowy interfejs
394 akceleracji sprzętowej dla bibliotek grafiki wektorowej, takiej jak
395 Flash czy SVG. Specyfikację OpenVG można znaleźć na stronie Khronos
396 Group: <http://www.khronos.org/openvg/>. Mesa zawiera implementację
397 OpenVG w wersji 1.1.
398
399 %package libOpenVG-devel
400 Summary:        Header file for Mesa OpenVG library
401 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Mesa OpenVG
402 License:        MIT
403 Group:          Development/Libraries
404 # EGL headers for <KHR/khrplatform.h>
405 Requires:       %{name}-libEGL-devel = %{version}-%{release}
406 Requires:       %{name}-libOpenVG = %{version}-%{release}
407
408 %description libOpenVG-devel
409 Header file for Mesa OpenVG library.
410
411 %description libOpenVG-devel -l pl.UTF-8
412 Plik nagłówkowy biblioteki Mesa OpenVG.
413
414 %package libXvMC
415 Summary:        XvMC implementations
416 Summary(pl.UTF-8):      Implementacje API XvMC
417 License:        MIT
418 Group:          Libraries
419 # doesn't require base
420
421 %description libXvMC
422 libXvMC implementations.
423
424 %description libXvMC -l pl.UTF-8
425 Implementacje API libXvMC.
426
427 %package dri-driver-ati-radeon-R100
428 Summary:        X.org DRI driver for ATI R100 card family
429 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
430 License:        MIT
431 Group:          X11/Libraries
432 Requires:       xorg-driver-video-ati
433 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
434 Requires:       xorg-xserver-server >= %{xserver_ver}
435 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
436
437 %description dri-driver-ati-radeon-R100
438 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
439
440 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
441 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
442
443 %package dri-driver-ati-radeon-R200
444 Summary:        X.org DRI driver for ATI R200 card family
445 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
446 License:        MIT
447 Group:          X11/Libraries
448 Requires:       xorg-driver-video-ati
449 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
450 Requires:       xorg-xserver-server >= %{xserver_ver}
451 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
452
453 %description dri-driver-ati-radeon-R200
454 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
455
456 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
457 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
458
459 %package dri-driver-ati-radeon-R300
460 Summary:        X.org DRI driver for ATI R300 card family
461 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
462 License:        MIT
463 Group:          X11/Libraries
464 Requires:       xorg-driver-video-ati
465 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
466 Requires:       xorg-xserver-server >= %{xserver_ver}
467 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
468
469 %description dri-driver-ati-radeon-R300
470 X.org DRI driver for ATI R300 card family.
471
472 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
473 Sterownik X.org DRI dla rodziny kart ATI R300.
474
475 %package dri-driver-ati-radeon-R600
476 Summary:        X.org DRI driver for ATI R600 card family
477 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
478 License:        MIT
479 Group:          X11/Libraries
480 Requires:       radeon-ucode
481 Requires:       xorg-driver-video-ati
482 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
483 Requires:       xorg-xserver-server >= %{xserver_ver}
484
485 %description dri-driver-ati-radeon-R600
486 X.org DRI driver for ATI R600 card family.
487
488 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
489 Sterownik X.org DRI dla rodziny kart ATI R600.
490
491 %package dri-driver-ffb
492 Summary:        X.org DRI driver for Sun FFB card family
493 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
494 License:        MIT
495 Group:          X11/Libraries
496 Requires:       xorg-driver-video-sunffb
497 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
498 Requires:       xorg-xserver-server >= %{xserver_ver}
499
500 %description dri-driver-ffb
501 X.org DRI driver for SUN Creator3D and Elite3D card family.
502
503 %description dri-driver-ffb -l pl.UTF-8
504 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
505
506 %package dri-driver-glint
507 Summary:        X.org DRI driver for GLINT/Permedia card family
508 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
509 License:        MIT
510 Group:          X11/Libraries
511 Requires:       xorg-driver-video-glint
512 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
513 Requires:       xorg-xserver-server >= %{xserver_ver}
514 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
515
516 %description dri-driver-glint
517 X.org DRI driver for GLINT/Permedia card family.
518
519 %description dri-driver-glint -l pl.UTF-8
520 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
521
522 %package dri-driver-intel-i915
523 Summary:        X.org DRI driver for Intel i915 card family
524 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
525 License:        MIT
526 Group:          X11/Libraries
527 Requires:       xorg-driver-video-intel
528 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
529 Requires:       xorg-xserver-server >= %{xserver_ver}
530 Obsoletes:      Mesa-dri-driver-intel-i830
531 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
532
533 %description dri-driver-intel-i915
534 X.org DRI driver for Intel i915 card family.
535
536 %description dri-driver-intel-i915 -l pl.UTF-8
537 Sterownik X.org DRI dla rodziny kart Intel i915.
538
539 %package dri-driver-intel-i965
540 Summary:        X.org DRI driver for Intel i965 card family
541 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
542 License:        MIT
543 Group:          X11/Libraries
544 Requires:       xorg-driver-video-intel
545 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
546 Requires:       xorg-xserver-server >= %{xserver_ver}
547 Obsoletes:      Mesa-dri-driver-intel-i830
548 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
549
550 %description dri-driver-intel-i965
551 X.org DRI driver for Intel i965 card family.
552
553 %description dri-driver-intel-i965 -l pl.UTF-8
554 Sterownik X.org DRI dla rodziny kart Intel i965.
555
556 %package dri-driver-nouveau
557 Summary:        X.org DRI driver for NVIDIA card family
558 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
559 License:        MIT
560 Group:          X11/Libraries
561 Requires:       xorg-driver-video-nouveau
562 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
563 Requires:       xorg-xserver-server >= %{xserver_ver}
564
565 %description dri-driver-nouveau
566 X.org DRI drivers for NVIDIA card family.
567
568 %description dri-driver-nouveau -l pl.UTF-8
569 Sterowniki X.org DRI dla rodziny kart NVIDIA.
570
571 %package dri-driver-swrast
572 Summary:        X.org DRI software rasterizer driver
573 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
574 License:        MIT
575 Group:          X11/Libraries
576 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
577 Requires:       xorg-xserver-server >= %{xserver_ver}
578
579 %description dri-driver-swrast
580 X.org DRI software rasterizer driver.
581
582 %description dri-driver-swrast -l pl.UTF-8
583 Sterownik X.org DRI obsługujący rysowanie programowe.
584
585 %package dri-driver-vmwgfx
586 Summary:        X.org DRI driver for VMware
587 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
588 License:        MIT
589 Group:          X11/Libraries
590 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
591 Requires:       xorg-xserver-server >= %{xserver_ver}
592
593 %description dri-driver-vmwgfx
594 X.org DRI driver for VMWare.
595
596 %description dri-driver-vmwgfx -l pl.UTF-8
597 Sterownik X.org DRI dla VMware.
598
599 %package -n libvdpau-driver-mesa
600 Summary:        Mesa driver for the vdpau API
601 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
602 License:        MIT
603 Group:          X11/Libraries
604
605 %description -n libvdpau-driver-mesa
606 Mesa driver for the vdpau API.
607
608 %description -n libvdpau-driver-mesa -l pl.UTF-8
609 Sterownik Mesa dla API vdpau.
610
611 # llvm build broken
612 %define         filterout_ld    -Wl,--as-needed
613
614 %prep
615 %setup -q
616 %patch0 -p0
617
618 %build
619 %{__aclocal}
620 %{__autoconf}
621
622 dri_drivers="r200 radeon \
623 %if %{without gallium_intel}
624 i915 i965 \
625 %endif
626 %ifarch sparc sparcv9 sparc64
627 ffb \
628 %endif
629 swrast"
630
631 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
632
633 gallium_drivers="svga swrast \
634 %if %{with gallium_intel}
635 i915 \
636 i965 \
637 %endif
638 r300 \
639 r600 \
640 %if %{with gallium_nouveau}
641 nouveau \
642 %endif
643 "
644
645 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
646
647 common_flags="\
648         --enable-shared \
649         --enable-glx-tls \
650         --enable-pic \
651         --enable-selinux \
652         %{?with_static_libs:--enable-static} \
653 "
654
655 osmesa_common_flags="\
656         --with-driver=osmesa \
657         --disable-asm \
658         --disable-egl \
659         --disable-glu"
660
661 %if %{with osmesa}
662 %configure $common_flags $osmesa_common_flags \
663         --with-osmesa-bits=8
664 %{__make}
665 %{__make} -C src/mesa osmesa.pc
666 mv %{_lib} osmesa8
667 cp -p src/mesa/osmesa.pc osmesa8
668 %{__make} clean
669 %endif
670
671 %configure $common_flags \
672         --enable-shared-glapi \
673         %{__enable gbm} \
674 %if %{with egl}
675         --enable-egl \
676         --enable-gles1 \
677         --enable-gles2 \
678 %endif
679 %if %{with gallium}
680         --enable-openvg \
681         --enable-gallium-llvm \
682         %{__enable egl gallium-egl} \
683         %{__enable gbm gallium-gbm} \
684         --enable-vdpau \
685         --enable-xvmc \
686         --with-gallium-drivers=${gallium_drivers} \
687 %else
688         --disable-gallium \
689 %endif
690         --with-driver=dri \
691         --with-dri-drivers=${dri_drivers} \
692         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
693
694 %{__make}
695
696 %install
697 rm -rf $RPM_BUILD_ROOT
698
699 # libs without drivers
700 %{__make} install \
701         DESTDIR=$RPM_BUILD_ROOT
702
703 %if %{with osmesa}
704 cp -p osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
705 cp -p osmesa8/osmesa.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
706 %endif
707
708 # strip out undesirable headers
709 %{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{vms_x_fix,wglext,wmesa}.h
710
711 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
712 # set up via /etc/ld.so.conf.d/*.conf will be preferred over this
713 strip -R .note.ABI-tag $RPM_BUILD_ROOT%{_libdir}/libGL.so.*.*
714
715 %clean
716 rm -rf $RPM_BUILD_ROOT
717
718 %post   libEGL -p /sbin/ldconfig
719 %postun libEGL -p /sbin/ldconfig
720
721 %post   libGL -p /sbin/ldconfig
722 %postun libGL -p /sbin/ldconfig
723
724 %post   libGLES -p /sbin/ldconfig
725 %postun libGLES -p /sbin/ldconfig
726
727 %post   libGLU -p /sbin/ldconfig
728 %postun libGLU -p /sbin/ldconfig
729
730 %post   libOSMesa -p /sbin/ldconfig
731 %postun libOSMesa -p /sbin/ldconfig
732
733 %post   libOpenVG -p /sbin/ldconfig
734 %postun libOpenVG -p /sbin/ldconfig
735
736 %post   libXvMC -p /sbin/ldconfig
737 %postun libXvMC -p /sbin/ldconfig
738
739 %if %{with egl}
740 %files libEGL
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
744 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
746 %if %{with gbm}
747 %dir %{_libdir}/gbm
748 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
750 %endif
751 %if %{with gallium}
752 %dir %{_libdir}/egl
753 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
754 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
755 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
756 %if %{with gbm}
757 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
758 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
759 %if %{with gallium_nouveau}
760 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
761 %endif
762 %if %{with gallium_intel}
763 %attr(755,root,root) %{_libdir}/egl/pipe_i915.so
764 %attr(755,root,root) %{_libdir}/egl/pipe_i965.so
765 %endif
766 %endif
767 %endif
768
769 %files libEGL-devel
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libEGL.so
772 %attr(755,root,root) %{_libdir}/libglapi.so
773 %dir %{_includedir}/EGL
774 %{_includedir}/EGL/egl.h
775 %{_includedir}/EGL/eglext.h
776 %{_includedir}/EGL/eglmesaext.h
777 %{_includedir}/EGL/eglplatform.h
778 %dir %{_includedir}/KHR
779 %{_includedir}/KHR/khrplatform.h
780 %{_pkgconfigdir}/egl.pc
781 %if %{with gbm}
782 %attr(755,root,root) %{_libdir}/libgbm.so
783 %{_includedir}/gbm.h
784 %{_pkgconfigdir}/gbm.pc
785 %endif
786
787 %if %{with static_libs}
788 %files libEGL-static
789 %defattr(644,root,root,755)
790 %{_libdir}/libEGL.a
791 %endif
792 %endif
793
794 %files libGL
795 %defattr(644,root,root,755)
796 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
797 %attr(755,root,root) %{_libdir}/libGL.so.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
799 # symlink for binary apps which fail to conform Linux OpenGL ABI
800 # (and dlopen libGL.so instead of libGL.so.1; the same does Mesa libEGL)
801 %attr(755,root,root) %{_libdir}/libGL.so
802
803 %files libGL-devel
804 %defattr(644,root,root,755)
805 %doc docs/*.spec
806 %dir %{_includedir}/GL
807 %{_includedir}/GL/gl.h
808 %{_includedir}/GL/glext.h
809 %{_includedir}/GL/gl_mangle.h
810 %{_includedir}/GL/glx.h
811 %{_includedir}/GL/glxext.h
812 %{_includedir}/GL/glx_mangle.h
813 %dir %{_includedir}/GL/internal
814 %{_includedir}/GL/internal/dri_interface.h
815 %{_pkgconfigdir}/dri.pc
816 %{_pkgconfigdir}/gl.pc
817
818 %if %{with static_libs}
819 %files libGL-static
820 %defattr(644,root,root,755)
821 %{_libdir}/libGL.a
822 %endif
823
824 %files libGLES
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so.*.*.*
827 %attr(755,root,root) %ghost %{_libdir}/libGLESv1_CM.so.1
828 %attr(755,root,root) %{_libdir}/libGLESv2.so.*.*
829 %attr(755,root,root) %ghost %{_libdir}/libGLESv2.so.2
830
831 %files libGLES-devel
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so
834 %attr(755,root,root) %{_libdir}/libGLESv2.so
835 %{_includedir}/GLES
836 %{_includedir}/GLES2
837 %{_pkgconfigdir}/glesv1_cm.pc
838 %{_pkgconfigdir}/glesv2.pc
839
840 %files libGLU
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
843 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
844
845 %files libGLU-devel
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_libdir}/libGLU.so
848 %{_includedir}/GL/glu.h
849 %{_includedir}/GL/glu_mangle.h
850 %{_pkgconfigdir}/glu.pc
851
852 %if %{with static_libs}
853 %files libGLU-static
854 %defattr(644,root,root,755)
855 %{_libdir}/libGLU.a
856 %endif
857
858 %if %{with osmesa}
859 %files libOSMesa
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
862 %attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.8
863
864 %files libOSMesa-devel
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/libOSMesa.so
867 %{_includedir}/GL/osmesa.h
868 %{_pkgconfigdir}/osmesa.pc
869
870 %if %{with static_libs}
871 %files libOSMesa-static
872 %defattr(644,root,root,755)
873 %{_libdir}/libOSMesa.a
874 %endif
875 %endif
876
877 %if %{with gallium}
878 %files libOpenVG
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/libOpenVG.so.*.*.*
881 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
882
883 %files libOpenVG-devel
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/libOpenVG.so
886 %{_includedir}/VG
887 %{_pkgconfigdir}/vg.pc
888 %endif
889
890 %files libXvMC
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
893 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
894 %attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
895 %attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
896 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
897 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
898 %attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
899 %attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
900
901 %files dri-driver-ati-radeon-R100
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
904
905 %files dri-driver-ati-radeon-R200
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
908
909 %files dri-driver-ati-radeon-R300
910 %defattr(644,root,root,755)
911 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
912
913 %files dri-driver-ati-radeon-R600
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
916
917 # sunffb (sparc only)
918 %ifarch sparc sparcv9 sparc64
919 %files dri-driver-ffb
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
922 %endif
923
924 # glint (requires update)
925 %if 0
926 %files dri-driver-glint
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
929 %endif
930
931 %files dri-driver-intel-i915
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
934
935 %files dri-driver-intel-i965
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
938 %if %{with gallium_intel}
939 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
940 %endif
941
942 %if %{with gallium_nouveau}
943 %files dri-driver-nouveau
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
946 %endif
947
948 %files dri-driver-swrast
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
951
952 %if %{with gallium}
953 %files dri-driver-vmwgfx
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
956 %endif
957
958 %files -n libvdpau-driver-mesa
959 %defattr(644,root,root,755)
960 # there is no ldconfig here
961 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
962 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
963 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
964 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
965 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
966 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
967 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
968 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
969 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
970 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1.0
971 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1
972 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
This page took 0.159863 seconds and 4 git commands to generate.