]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- rel 3; disable nouveau
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_with     gallium_nouveau # doesn't build due to libdrm API changes (fixed in Mesa 7.8)
13 %bcond_without  motif   # build static libGLw without Motif interface
14 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
15 %bcond_without  osmesa  # don't build osmesa
16 %bcond_with     static
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.18
26 %define         dri2proto_ver   1.99.3
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.7
32 Release:        3%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  e3fa64a1508bc23dd9de9dd2cea7cfb1
37 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
38 # Source1-md5:  6fd616b27b9826d0faa23e08e05d9435
39 Patch0:         %{name}-realclean.patch
40 Patch1:         %{name}-tgsi_dump.patch
41 URL:            http://www.mesa3d.org/
42 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  expat-devel
46 %{?with_demos:BuildRequires:    glew-devel}
47 BuildRequires:  libdrm-devel >= %{libdrm_ver}
48 BuildRequires:  libselinux-devel
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtool >= 2:1.4d
51 %{?with_motif:BuildRequires:    motif-devel}
52 BuildRequires:  pkgconfig
53 BuildRequires:  python
54 BuildRequires:  rpmbuild(macros) >= 1.470
55 BuildRequires:  sed >= 4.0
56 BuildRequires:  xorg-lib-libXdamage-devel
57 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
58 BuildRequires:  xorg-lib-libXt-devel
59 BuildRequires:  xorg-lib-libXxf86vm-devel
60 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
61 BuildRequires:  xorg-proto-glproto-devel
62 BuildRequires:  xorg-proto-printproto-devel
63 BuildRequires:  xorg-util-makedepend
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %if %{without gallium}
67 %undefine       with_gallium_intel
68 %endif
69
70 %description
71 Mesa is a 3-D graphics library with an API which is very similar to
72 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
73 syntax or state machine, it is being used with authorization from
74 Silicon Graphics, Inc. However, the author does not possess an OpenGL
75 license from SGI, and makes no claim that Mesa is in any way a
76 compatible replacement for OpenGL or associated with SGI.
77
78 %description -l pl.UTF-8
79 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
80 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
81 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
82 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
83 OpenGL ani powiązana z SGI.
84
85 %package libGL
86 Summary:        Free Mesa3D implementation of libGL OpenGL library
87 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
88 License:        MIT
89 Group:          X11/Libraries
90 Requires:       libdrm >= %{libdrm_ver}
91 Provides:       OpenGL = 2.1
92 # reports version 1.3, but supports glXGetProcAddress() from 1.4
93 Provides:       OpenGL-GLX = 1.4
94 Obsoletes:      Mesa
95 Obsoletes:      Mesa-dri
96 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
97 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
98
99 %description libGL
100 Mesa is a 3-D graphics library with an API which is very similar to
101 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
102 syntax or state machine, it is being used with authorization from
103 Silicon Graphics, Inc. However, the author does not possess an OpenGL
104 license from SGI, and makes no claim that Mesa is in any way a
105 compatible replacement for OpenGL or associated with SGI.
106
107 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
108 specifications. It uses DRI for rendering.
109
110 %description libGL -l pl.UTF-8
111 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
112 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
113 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
114 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
115 OpenGL ani powiązana z SGI.
116
117 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
118 GLX 1.4. Używa DRI do renderowania.
119
120 %package libGL-devel
121 Summary:        Header files for Mesa3D libGL library
122 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
123 License:        MIT
124 Group:          X11/Development/Libraries
125 # loose dependency on libGL to use with other libGL binaries
126 Requires:       OpenGL >= 1.5
127 Requires:       libdrm-devel >= %{libdrm_ver}
128 Requires:       xorg-lib-libX11-devel
129 Requires:       xorg-lib-libXdamage-devel
130 Requires:       xorg-lib-libXext-devel
131 Requires:       xorg-lib-libXxf86vm-devel
132 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
133 Suggests:       OpenGL-doc-man
134 Provides:       OpenGL-GLX-devel = 1.4
135 Provides:       OpenGL-devel = 2.1
136 Obsoletes:      Mesa-devel
137 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
138 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
139 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
140 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
141
142 %description libGL-devel
143 Header files for Mesa3D libGL library.
144
145 %description libGL-devel -l pl.UTF-8
146 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
147
148 %package libGL-static
149 Summary:        Static Mesa3D libGL library
150 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
151 License:        MIT
152 Group:          X11/Development/Libraries
153 Requires:       %{name}-libGL-devel = %{version}-%{release}
154 Provides:       OpenGL-static = 2.1
155 Obsoletes:      Mesa-static
156 Obsoletes:      X11-OpenGL-static < 1:7.0.0
157 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
158
159 %description libGL-static
160 Static Mesa3D libGL library. It uses software renderer.
161
162 %description libGL-static -l pl.UTF-8
163 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
164 renderingu.
165
166 %package libGLU
167 Summary:        SGI implementation of libGLU OpenGL library
168 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
169 License:        SGI Free Software License B v2.0 (MIT-like)
170 Group:          Libraries
171 # loose dependency on libGL.so.1 to use with other libGL binaries
172 Requires:       OpenGL >= 1.2
173 Provides:       OpenGL-GLU = 1.3
174 Obsoletes:      Mesa-devel
175 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
176 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
177
178 %description libGLU
179 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
180 1.3 specifications.
181
182 %description libGLU -l pl.UTF-8
183 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
184 specyfikację OpenGL GLU 1.3.
185
186 %package libGLU-devel
187 Summary:        Header files for SGI libGLU library
188 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
189 License:        SGI Free Software License B v2.0 (MIT-like)
190 Group:          Development/Libraries
191 Requires:       %{name}-libGLU = %{version}-%{release}
192 Requires:       OpenGL-devel >= 1.2
193 Requires:       libstdc++-devel
194 Provides:       OpenGL-GLU-devel = 1.3
195
196 %description libGLU-devel
197 Header files for SGI libGLU library.
198
199 %description libGLU-devel -l pl.UTF-8
200 Pliki nagłówkowe biblioteki SGI libGLU.
201
202 %package libGLU-static
203 Summary:        Static SGI libGLU library
204 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
205 License:        SGI Free Software License B v2.0 (MIT-like)
206 Group:          Development/Libraries
207 Requires:       %{name}-libGLU-devel = %{version}-%{release}
208 Provides:       OpenGL-GLU-static = 1.3
209
210 %description libGLU-static
211 Static SGI libGLU library.
212
213 %description libGLU-static -l pl.UTF-8
214 Statyczna biblioteka SGI libGLU.
215
216 %package libGLw
217 Summary:        SGI OpenGL Xt widgets library
218 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
219 License:        SGI MIT-like
220 Group:          Libraries
221 # loose dependency on libGL.so.1 to use with other libGL binaries
222 Requires:       OpenGL >= 1.1
223 Provides:       OpenGL-GLw
224
225 %description libGLw
226 SGI OpenGL Xt widgets library.
227
228 %description libGLU -l pl.UTF-8
229 Biblioteka SGI widgetów Xt dla OpenGL-a.
230
231 %package libGLw-devel
232 Summary:        Header files for SGI libGLw library
233 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
234 License:        SGI MIT-like
235 Group:          Development/Libraries
236 Requires:       %{name}-libGLw = %{version}-%{release}
237 Requires:       OpenGL-devel >= 1.2
238 Provides:       OpenGL-GLw-devel
239
240 %description libGLw-devel
241 Header files for SGI libGLw library.
242
243 %description libGLw-devel -l pl.UTF-8
244 Pliki nagłówkowe biblioteki SGI libGLw.
245
246 %package libGLw-static
247 Summary:        Static SGI libGLw library
248 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
249 License:        SGI MIT-like
250 Group:          Development/Libraries
251 Requires:       %{name}-libGLw-devel = %{version}-%{release}
252 Provides:       OpenGL-GLw-static
253
254 %description libGLw-static
255 Static SGI libGLw library.
256
257 %description libGLw-static -l pl.UTF-8
258 Statyczna biblioteka SGI libGLw.
259
260 %package libOSMesa
261 Summary:        OSMesa (off-screen renderer) library
262 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
263 License:        MIT
264 Group:          Libraries
265 # doesn't require base
266
267 %description libOSMesa
268 OSMesa (off-screen renderer) library.
269
270 %description libOSMesa -l pl.UTF-8
271 Biblioteka OSMesa (renderująca bitmapy w pamięci).
272
273 %package libOSMesa-devel
274 Summary:        Header file for OSMesa (off-screen renderer) library
275 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
276 License:        MIT
277 Group:          Development/Libraries
278 Requires:       %{name}-libOSMesa = %{version}-%{release}
279 # for <GL/gl.h> only
280 Requires:       OpenGL-devel
281
282 %description libOSMesa-devel
283 Header file for OSMesa (off-screen renderer) library.
284
285 %description libOSMesa-devel -l pl.UTF-8
286 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
287
288 %package libOSMesa-static
289 Summary:        Static OSMesa (off-screen renderer) library
290 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
291 License:        MIT
292 Group:          Development/Libraries
293 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
294 # this static build of OSMesa needs static non-dri Mesa implementation
295 Requires:       %{name}-libGL-static = %{version}-%{release}
296
297 %description libOSMesa-static
298 Static OSMesa (off-screen renderer) library.
299
300 %description libOSMesa-static -l pl.UTF-8
301 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
302
303 %package utils
304 Summary:        OpenGL utilities from Mesa3D
305 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
306 License:        MIT
307 Group:          X11/Applications/Graphics
308 # loose deps on libGL/libGLU
309
310 %description utils
311 OpenGL utilities from Mesa3D: glxgears and glxinfo.
312
313 %description utils -l pl.UTF-8
314 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
315
316 %package demos
317 Summary:        Mesa Demos source code
318 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
319 License:        various (MIT, SGI, GPL - see copyright notes in sources)
320 Group:          Development/Libraries
321 Requires:       OpenGL-devel
322
323 %description demos
324 Demonstration programs for the Mesa libraries in source code form.
325
326 %description demos -l pl.UTF-8
327 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
328
329 %package dri-driver-ati-mach64
330 Summary:        X.org DRI driver for ATI Mach64 card family
331 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
332 License:        MIT
333 Group:          X11/Libraries
334 Requires:       xorg-driver-video-mach64
335 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
336 Requires:       xorg-xserver-server >= %{xserver_ver}
337
338 %description dri-driver-ati-mach64
339 X.org DRI driver for ATI Mach64 card family.
340
341 %description dri-driver-ati-mach64 -l pl.UTF-8
342 Sterownik X.org DRI dla rodziny kart ATI Mach64.
343
344 %package dri-driver-ati-radeon-R100
345 Summary:        X.org DRI driver for ATI R100 card family
346 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
347 License:        MIT
348 Group:          X11/Libraries
349 Requires:       xorg-driver-video-ati
350 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
351 Requires:       xorg-xserver-server >= %{xserver_ver}
352 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
353
354 %description dri-driver-ati-radeon-R100
355 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
356
357 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
358 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
359
360 %package dri-driver-ati-radeon-R200
361 Summary:        X.org DRI driver for ATI R200 card family
362 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
363 License:        MIT
364 Group:          X11/Libraries
365 Requires:       xorg-driver-video-ati
366 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
367 Requires:       xorg-xserver-server >= %{xserver_ver}
368 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
369
370 %description dri-driver-ati-radeon-R200
371 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
372
373 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
374 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
375
376 %package dri-driver-ati-radeon-R300
377 Summary:        X.org DRI driver for ATI R300 card family
378 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
379 License:        MIT
380 Group:          X11/Libraries
381 Requires:       xorg-driver-video-ati
382 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
383 Requires:       xorg-xserver-server >= %{xserver_ver}
384 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
385
386 %description dri-driver-ati-radeon-R300
387 X.org DRI driver for ATI R300 card family.
388
389 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
390 Sterownik X.org DRI dla rodziny kart ATI R300.
391
392 %package dri-driver-ati-radeon-R600
393 Summary:        X.org DRI driver for ATI R600 card family
394 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
395 License:        MIT
396 Group:          X11/Libraries
397 Requires:       radeon-ucode
398 Requires:       xorg-driver-video-ati
399 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
400 Requires:       xorg-xserver-server >= %{xserver_ver}
401
402 %description dri-driver-ati-radeon-R600
403 X.org DRI driver for ATI R600 card family.
404
405 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
406 Sterownik X.org DRI dla rodziny kart ATI R600.
407
408 %package dri-driver-ati-rage128
409 Summary:        X.org DRI driver for ATI Rage128 card family
410 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
411 License:        MIT
412 Group:          X11/Libraries
413 Requires:       xorg-driver-video-r128
414 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
415 Requires:       xorg-xserver-server >= %{xserver_ver}
416 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
417
418 %description dri-driver-ati-rage128
419 X.org DRI driver for ATI Rage128 card family.
420
421 %description dri-driver-ati-rage128 -l pl.UTF-8
422 Sterownik X.org DRI dla rodziny kart ATI Rage128.
423
424 %package dri-driver-ffb
425 Summary:        X.org DRI driver for Sun FFB card family
426 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
427 License:        MIT
428 Group:          X11/Libraries
429 Requires:       xorg-driver-video-sunffb
430 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
431 Requires:       xorg-xserver-server >= %{xserver_ver}
432
433 %description dri-driver-ffb
434 X.org DRI driver for SUN Creator3D and Elite3D card family.
435
436 %description dri-driver-ffb -l pl.UTF-8
437 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
438
439 %package dri-driver-glint
440 Summary:        X.org DRI driver for GLINT/Permedia card family
441 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
442 License:        MIT
443 Group:          X11/Libraries
444 Requires:       xorg-driver-video-glint
445 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
446 Requires:       xorg-xserver-server >= %{xserver_ver}
447 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
448
449 %description dri-driver-glint
450 X.org DRI driver for GLINT/Permedia card family.
451
452 %description dri-driver-glint -l pl.UTF-8
453 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
454
455 %package dri-driver-intel-i810
456 Summary:        X.org DRI driver for Intel i810 card family
457 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
458 License:        MIT
459 Group:          X11/Libraries
460 Requires:       xorg-driver-video-intel
461 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
462 Requires:       xorg-xserver-server >= %{xserver_ver}
463 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
464
465 %description dri-driver-intel-i810
466 X.org DRI driver for Intel i810 card family.
467
468 %description dri-driver-intel-i810 -l pl.UTF-8
469 Sterownik X.org DRI dla rodziny kart Intel i810.
470
471 %package dri-driver-intel-i915
472 Summary:        X.org DRI driver for Intel i915 card family
473 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
474 License:        MIT
475 Group:          X11/Libraries
476 Requires:       xorg-driver-video-intel
477 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
478 Requires:       xorg-xserver-server >= %{xserver_ver}
479 Obsoletes:      Mesa-dri-driver-intel-i830
480 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
481
482 %description dri-driver-intel-i915
483 X.org DRI driver for Intel i915 card family.
484
485 %description dri-driver-intel-i915 -l pl.UTF-8
486 Sterownik X.org DRI dla rodziny kart Intel i915.
487
488 %package dri-driver-intel-i965
489 Summary:        X.org DRI driver for Intel i965 card family
490 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
491 License:        MIT
492 Group:          X11/Libraries
493 Requires:       xorg-driver-video-intel
494 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
495 Requires:       xorg-xserver-server >= %{xserver_ver}
496 Obsoletes:      Mesa-dri-driver-intel-i830
497 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
498
499 %description dri-driver-intel-i965
500 X.org DRI driver for Intel i965 card family.
501
502 %description dri-driver-intel-i965 -l pl.UTF-8
503 Sterownik X.org DRI dla rodziny kart Intel i965.
504
505 %package dri-driver-matrox
506 Summary:        X.org DRI driver for Matrox G card family
507 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
508 License:        MIT
509 Group:          X11/Libraries
510 Requires:       xorg-driver-video-mga
511 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
512 Requires:       xorg-xserver-server >= %{xserver_ver}
513 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
514
515 %description dri-driver-matrox
516 X.org DRI drivers for Matrox G card family.
517
518 %description dri-driver-matrox -l pl.UTF-8
519 Sterowniki X.org DRI dla rodziny kart Matrox G.
520
521 %package dri-driver-nouveau
522 Summary:        X.org DRI driver for NVIDIA card family
523 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
524 License:        MIT
525 Group:          X11/Libraries
526 Requires:       xorg-driver-video-nouveau
527 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
528 Requires:       xorg-xserver-server >= %{xserver_ver}
529
530 %description dri-driver-nouveau
531 X.org DRI drivers for NVIDIA card family.
532
533 %description dri-driver-nouveau -l pl.UTF-8
534 Sterowniki X.org DRI dla rodziny kart NVIDIA.
535
536 %package dri-driver-savage
537 Summary:        X.org DRI driver for S3 Savage card family
538 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
539 License:        MIT
540 Group:          X11/Libraries
541 Requires:       xorg-driver-video-savage
542 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
543 Requires:       xorg-xserver-server >= %{xserver_ver}
544
545 %description dri-driver-savage
546 X.org DRI driver for S3 Savage card family.
547
548 %description dri-driver-savage -l pl.UTF-8
549 Sterownik X.org DRI dla rodziny kart S3 Savage.
550
551 %package dri-driver-sis
552 Summary:        X.org DRI driver for SiS card family
553 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
554 License:        MIT
555 Group:          X11/Libraries
556 Requires:       xorg-driver-video-sis
557 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
558 Requires:       xorg-xserver-server >= %{xserver_ver}
559 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
560
561 %description dri-driver-sis
562 X.org DRI driver for SiS card family.
563
564 %description dri-driver-sis -l pl.UTF-8
565 Sterownik X.org DRI dla rodziny kart SiS.
566
567 %package dri-driver-swrast
568 Summary:        X.org DRI software rasterizer driver
569 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
570 License:        MIT
571 Group:          X11/Libraries
572 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
573 Requires:       xorg-xserver-server >= %{xserver_ver}
574
575 %description dri-driver-swrast
576 X.org DRI software rasterizer driver.
577
578 %description dri-driver-swrast -l pl.UTF-8
579 Sterownik X.org DRI obsługujący rysowanie programowe.
580
581 %package dri-driver-tdfx
582 Summary:        X.org DRI driver for 3DFX Voodoo card family
583 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
584 License:        MIT
585 Group:          X11/Libraries
586 Requires:       Glide3-DRI
587 Requires:       xorg-driver-video-tdfx
588 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
589 Requires:       xorg-xserver-server >= %{xserver_ver}
590 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
591
592 %description dri-driver-tdfx
593 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
594 and Velocity 100/200).
595
596 %description dri-driver-tdfx -l pl.UTF-8
597 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
598 Banshee i Velocity 100/200).
599
600 %package dri-driver-via-unichrome
601 Summary:        X.org DRI driver for VIA Unichrome card family
602 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
603 License:        MIT
604 Group:          X11/Libraries
605 Requires:       xorg-driver-video-openchrome
606 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
607 Requires:       xorg-xserver-server >= %{xserver_ver}
608
609 %description dri-driver-via-unichrome
610 X.org DRI driver for VIA Unichrome card family.
611
612 %description dri-driver-via-unichrome -l pl.UTF-8
613 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
614
615 %package dri-driver-vmwgfx
616 Summary:        X.org DRI driver for VMware
617 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
618 License:        MIT
619 Group:          X11/Libraries
620 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
621 Requires:       xorg-xserver-server >= %{xserver_ver}
622
623 %description dri-driver-vmwgfx
624 X.org DRI driver for VMWare.
625
626 %description dri-driver-vmwgfx -l pl.UTF-8
627 Sterownik X.org DRI dla VMware.
628
629 %prep
630 %setup -q -b1
631 %patch0 -p0
632 %patch1 -p1
633
634 # fix demos
635 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
636
637 %build
638 %{__aclocal}
639 %{__autoconf}
640
641 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
642 %if %{without gallium_intel}
643 i915 \
644 %endif
645 %ifarch sparc sparcv9 sparc64
646 ffb \
647 %endif
648 %ifarch %{ix86} %{x8664}
649 sis \
650 %endif
651 swrast tdfx unichrome"
652
653 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
654
655 common_flags="\
656         --enable-shared \
657         --enable-selinux \
658         --enable-pic \
659         --enable-glx-tls \
660         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
661         --with%{!?with_demos:out}-demos"
662
663 %if %{with osmesa}
664 # osmesa variants
665 %configure $common_flags \
666         --with-driver=osmesa \
667         --disable-asm \
668         --with-osmesa-bits=8
669 %{__make} \
670         SRC_DIRS=mesa
671 mv %{_lib} osmesa8
672 %{__make} clean
673
674 %configure $common_flags \
675         --with-driver=osmesa \
676         --disable-asm \
677         --with-osmesa-bits=16
678 %{__make} \
679         SRC_DIRS=mesa
680 mv %{_lib} osmesa16
681 %{__make} clean
682
683 %configure $common_flags \
684         --with-driver=osmesa \
685         --disable-asm \
686         --with-osmesa-bits=32
687 %{__make} \
688         SRC_DIRS=mesa
689 mv %{_lib} osmesa32
690 %{__make} clean
691 %endif
692
693 %configure $common_flags \
694         --enable-glu \
695         --enable-glw \
696         --disable-glut \
697 %if %{with gallium}
698         --enable-gallium \
699         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
700         --enable-gallium-svga \
701         --%{?with_gallium_nouveau:en}%{!?with_gallium_nouveau:dis}able-gallium-nouveau \
702         --with-state-trackers=dri \
703 %else
704         --disable-gallium \
705 %endif
706         --with-driver=dri \
707         --with-dri-drivers=${dri_drivers} \
708         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
709
710 %{__make}
711 %{__make} -C progs/xdemos glxgears glxinfo
712 %if %{with demos}
713 %{__make} -C progs/demos
714 %endif
715
716 %install
717 rm -rf $RPM_BUILD_ROOT
718
719 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
720
721 # libs without drivers
722 %{__make} install \
723         DESTDIR=$RPM_BUILD_ROOT
724
725 %if %{with osmesa}
726 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
727 %endif
728
729 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
730 # work on copy to keep -bi --short-circuit working
731 rm -rf progs-clean
732 install -d progs-clean
733 for l in demos glsl osdemos redbook samples xdemos ; do
734         cp -a progs/$l progs-clean/$l
735         %{__make} -C progs-clean/$l clean
736         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
737 done
738 rm -rf progs-clean
739 for l in util images ; do
740         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
741 done
742 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
743
744 # strip out undesirable headers
745 olddir=$(pwd)
746 cd $RPM_BUILD_ROOT%{_includedir}/GL
747 rm [a-fh-np-wyz]*.h gg*.h glf*.h
748 cd $RPM_BUILD_ROOT%{_libdir}
749 cd $olddir
750
751 %if %{with multigl}
752 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
753
754 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
755 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
756
757 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
758 %endif
759
760 %clean
761 rm -rf $RPM_BUILD_ROOT
762
763 %post   libGL -p /sbin/ldconfig
764 %postun libGL -p /sbin/ldconfig
765
766 %post   libGLU -p /sbin/ldconfig
767 %postun libGLU -p /sbin/ldconfig
768
769 %post   libGLw -p /sbin/ldconfig
770 %postun libGLw -p /sbin/ldconfig
771
772 %files libGL
773 %defattr(644,root,root,755)
774 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
775 %if %{with multigl}
776 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
777 %dir %{_libdir}/Mesa
778 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
779 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
780 %else
781 %attr(755,root,root) %{_libdir}/libGL.so.*.*
782 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
783 # symlink for binary apps which fail to conform Linux OpenGL ABI
784 # (and dlopen libGL.so instead of libGL.so.1)
785 %attr(755,root,root) %{_libdir}/libGL.so
786 %endif
787
788 %files libGL-devel
789 %defattr(644,root,root,755)
790 %doc docs/*.spec
791 %if %{with multigl}
792 %attr(755,root,root) %{_libdir}/libGL.so
793 %endif
794 %dir %{_includedir}/GL
795 %{_includedir}/GL/gl.h
796 %{_includedir}/GL/glext.h
797 %{_includedir}/GL/gl_mangle.h
798 %{_includedir}/GL/glx.h
799 %{_includedir}/GL/glxext.h
800 %{_includedir}/GL/glx_mangle.h
801 %dir %{_includedir}/GL/internal
802 %{_includedir}/GL/internal/dri_interface.h
803 %{_pkgconfigdir}/dri.pc
804 %{_pkgconfigdir}/gl.pc
805
806 %if %{with static}
807 %files libGL-static
808 %defattr(644,root,root,755)
809 %{_libdir}/libGL.a
810 %endif
811
812 %files libGLU
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
815 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
816
817 %files libGLU-devel
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libGLU.so
820 %{_includedir}/GL/glu.h
821 %{_includedir}/GL/glu_mangle.h
822 %{_pkgconfigdir}/glu.pc
823
824 %if %{with static}
825 %files libGLU-static
826 %defattr(644,root,root,755)
827 %{_libdir}/libGLU.a
828 %endif
829
830 %files libGLw
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
833 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
834
835 %files libGLw-devel
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libGLw.so
838 %{_includedir}/GL/GLwDrawA.h
839 %{_includedir}/GL/GLwDrawAP.h
840 %{_includedir}/GL/GLwMDrawA.h
841 %{_includedir}/GL/GLwMDrawAP.h
842 %{_pkgconfigdir}/glw.pc
843
844 %if %{with static}
845 %files libGLw-static
846 %defattr(644,root,root,755)
847 %{_libdir}/libGLw.a
848 %endif
849
850 %if %{with osmesa}
851 %files libOSMesa
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
854 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
855
856 %files libOSMesa-devel
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/libOSMesa*.so
859 %{_includedir}/GL/osmesa.h
860
861 %if %{with static}
862 %files libOSMesa-static
863 %defattr(644,root,root,755)
864 %{_libdir}/libOSMesa*.a
865 %endif
866 %endif
867
868 %files utils
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_bindir}/glxgears
871 %attr(755,root,root) %{_bindir}/glxinfo
872
873 %files dri-driver-ati-mach64
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
876
877 %files dri-driver-ati-radeon-R100
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
880
881 %files dri-driver-ati-radeon-R200
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
884
885 %files dri-driver-ati-radeon-R300
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
888
889 %files dri-driver-ati-radeon-R600
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
892
893 %files dri-driver-ati-rage128
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
896
897 # sunffb (sparc only)
898 %ifarch sparc sparcv9 sparc64
899 %files dri-driver-ffb
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
902 %endif
903
904 # glint (requires update)
905 %if 0
906 %files dri-driver-glint
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
909 %endif
910
911 %files dri-driver-intel-i810
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
914
915 %files dri-driver-intel-i915
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
918
919 %files dri-driver-intel-i965
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
922
923 %files dri-driver-matrox
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
926
927 %if %{with gallium}
928 %if %{with gallium_nouveau}
929 %files dri-driver-nouveau
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
932 %endif
933 %endif
934
935 %files dri-driver-savage
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
938
939 %ifarch %{ix86} %{x8664}
940 %files dri-driver-sis
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
943 %endif
944
945 %files dri-driver-swrast
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
948
949 %files dri-driver-tdfx
950 %defattr(644,root,root,755)
951 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
952
953 %files dri-driver-via-unichrome
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
956
957 %if %{with gallium}
958 %files dri-driver-vmwgfx
959 %defattr(644,root,root,755)
960 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
961 %endif
962
963 %if %{with demos}
964 %files demos
965 %defattr(644,root,root,755)
966 %{_examplesdir}/%{name}-%{version}
967 %endif
This page took 0.105716 seconds and 4 git commands to generate.