]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- updated for 6.2
[packages/Mesa.git] / Mesa.spec
1 #
2 # Conditional build:
3 %bcond_with     glide   # with GLIDE (broken now)
4 %bcond_with     xlibs   # use xlibs deps
5 #
6 Summary:        Free OpenGL implementation
7 Summary(pl):    Bezp³atna implementacja standardu OpenGL
8 Name:           Mesa
9 Version:        6.1
10 Release:        1
11 License:        MIT (core), LGPL (MesaGLU), SGI (GLU,libGLw) and others - see COPYRIGHT file
12 Group:          X11/Libraries
13 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
14 # Source0-md5:  5de1f53ec0709f60fc68fdfed57351f3
15 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
16 # Source1-md5:  89bfe0f6c69b39fd0ebd9fff481a4e9b
17 Patch0:         %{name}-opt.patch
18 URL:            http://www.mesa3d.org/
19 %ifarch %{ix86} alpha
20 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
21 %{?with_glide:Requires: Glide3-DRI}
22 %endif
23 %if %{with xlibs}
24 BuildRequires:  libXmu-devel
25 BuildRequires:  libXp-devel
26 %else
27 BuildRequires:  XFree86-devel
28 %endif
29 BuildRequires:  autoconf >= 2.50
30 BuildRequires:  automake
31 BuildRequires:  libtool >= 2:1.4d
32 BuildRequires:  motif-devel
33 BuildRequires:  perl-devel
34 Provides:       OpenGL = 1.5
35 Provides:       OpenGL-GLU = 1.3
36 # reports version 1.3, but supports glXGetProcAddress() from 1.4
37 Provides:       OpenGL-GLX = 1.4
38 Obsoletes:      XFree86-OpenGL-libGL
39 Obsoletes:      XFree86-OpenGL-libs
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # avoid XFree86-OpenGL* dependency
43 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
45
46 %define         _sysconfdir     /etc/X11
47
48 %description
49 Mesa is a 3-D graphics library with an API which is very similar to
50 that of OpenGL*. To the extent that Mesa utilizes the OpenGL command
51 syntax or state machine, it is being used with authorization from
52 Silicon Graphics, Inc. However, the author makes no claim that Mesa is
53 in any way a compatible replacement for OpenGL or associated with
54 Silicon Graphics, Inc. Those who want a licensed implementation of
55 OpenGL should contact a licensed vendor. This software is distributed
56 under the terms of the GNU Library General Public License, see the
57 LICENSE file for details.
58
59 - OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
60
61 %description -l pl
62 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standardu
63 OpenGL(*).
64
65 - OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics,
66   Inc.
67
68 %package devel
69 Summary:        Development environment for Mesa
70 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 %if %{with xlibs}
74 Requires:       libX11-devel
75 Requires:       libXp-devel
76 %else
77 Requires:       XFree86-devel
78 %endif
79 Provides:       OpenGL-devel = 1.5
80 Provides:       OpenGL-GLU-devel = 1.3
81 Provides:       OpenGL-GLX-devel = 1.4
82 Obsoletes:      XFree86-OpenGL-devel
83 Obsoletes:      XFree86-OpenGL-devel-base
84
85 %description devel
86 Header files and documentation needed for development.
87
88 %description devel -l pl
89 Pliki nag³ówkowe i dokumentacja do Mesy.
90
91 %package static
92 Summary:        Mesa static libraries
93 Summary(pl):    Biblioteki statyczne Mesy
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Provides:       OpenGL-static = 1.5
97 Provides:       OpenGL-GLU-static = 1.3
98 Obsoletes:      XFree86-OpenGL-static
99
100 %description static
101 The static version of the Mesa libraries.
102
103 %description static -l pl
104 Biblioteki statyczne Mesy.
105
106 %package demos
107 Summary:        Mesa Demos
108 Summary(pl):    Demonstracje mo¿liwo¶ci bibliotek Mesa
109 Group:          Development/Libraries
110 Requires:       OpenGL-devel
111
112 %description demos
113 Demonstration programs for the Mesa libraries.
114
115 %description demos -l pl
116 Programy demonstracyjne dla bibliotek Mesa.
117
118 %prep
119 %setup -q -n Mesa-%{version} -b 1
120 %patch0 -p1
121
122 # fix demos
123 %{__perl} -pi -e "s,\.\./images/,%{_examplesdir}/Mesa/images/,g" progs/demos/*
124
125 %build
126 %ifarch %{ix86}
127 targ=linux-x86
128 %else
129 targ=linux
130 %endif
131
132 %{__make} ${targ}-static \
133         CC="%{__cc}" \
134         CXX="%{__cxx}" \
135         OPT="%{rpmcflags}" \
136         XLIB_DIR=/usr/X11R6/%{_lib} \
137         GLW_SOURCES="GLwDrawA.c GLwMDrawA.c"
138 mv -f lib lib-static
139 %{__make} clean
140 %{__make} ${targ} \
141         CC="%{__cc}" \
142         CXX="%{__cxx}" \
143         OPT="%{rpmcflags}" \
144         XLIB_DIR=/usr/X11R6/%{_lib}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/GL,%{_mandir}/man3,%{_examplesdir}/Mesa}
149
150 cp -df lib-static/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
151 cp -df lib/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
152 cp -rf include/GL/{gl*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
153 rm -f $RPM_BUILD_ROOT%{_includedir}/GL/glut*
154
155 for l in demos redbook samples xdemos ; do
156         %{__make} -C progs/$l clean
157 done
158 for l in demos redbook samples util xdemos images ; do
159         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/Mesa/$l
160 done
161 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/Mesa/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
172 %attr(755,root,root) %{_libdir}/libGL.so.*.*
173 %attr(755,root,root) %{_libdir}/libGL.so
174 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
175 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
176
177 %files devel
178 %defattr(644,root,root,755)
179 %doc docs/*.spec
180 %attr(755,root,root) %{_libdir}/libGLU.so
181 %attr(755,root,root) %{_libdir}/libOSMesa.so
182 %{_libdir}/libGLw.a
183 %dir %{_includedir}/GL
184 %{_includedir}/GL/GLwDrawA.h
185 %{_includedir}/GL/GLwDrawAP.h
186 %{_includedir}/GL/GLwMDrawA.h
187 %{_includedir}/GL/GLwMDrawAP.h
188 %{_includedir}/GL/gl.h
189 %{_includedir}/GL/glext.h
190 %{_includedir}/GL/gl_mangle.h
191 %{_includedir}/GL/glu.h
192 %{_includedir}/GL/glu_mangle.h
193 %{_includedir}/GL/glx.h
194 %{_includedir}/GL/glxext.h
195 %{_includedir}/GL/glx_mangle.h
196 %{_includedir}/GL/osmesa.h
197 %{_includedir}/GL/xmesa.h
198 %{_includedir}/GL/xmesa_x.h
199 %{_includedir}/GL/xmesa_xf86.h
200
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/libGL.a
204 %{_libdir}/libGLU.a
205 %{_libdir}/libOSMesa.a
206
207 %files demos
208 %defattr(644,root,root,755)
209 %{_examplesdir}/Mesa
This page took 0.086633 seconds and 4 git commands to generate.