]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- moved from DEVEL; 7.4 on MESA_7_4
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - what's libEGL?
6 #
7 # Conditional build:
8 %bcond_without  motif   # build static libGLw without Motif interface
9 %bcond_without  gallium
10 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
11 %bcond_with     static
12 #
13 # minimal supported xserver version
14 %define         xserver_ver     1.5.0
15 # glapi version (glapi tables in dri drivers and libglx must be in sync);
16 # set to current Mesa version on ABI break, when xserver tables get regenerated
17 # (until they start to be somehow versioned themselves)
18 %define         glapi_ver       7.1.0
19 #
20 Summary:        Free OpenGL implementation
21 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
22 Name:           Mesa
23 Version:        7.5
24 Release:        1%{?with_multigl:.mgl}
25 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
26 Group:          X11/Libraries
27 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
28 # Source0-md5:  459f332551f6ebb86f384d21dd15e1f0
29 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
30 # Source1-md5:  398ee8801814a00e47f6c2314e3dfddc
31 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
32 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
33 Patch0:         %{name}-realclean.patch
34 URL:            http://www.mesa3d.org/
35 BuildRequires:  expat-devel
36 BuildRequires:  libdrm-devel >= 2.4.5
37 BuildRequires:  libselinux-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.4d
40 %{?with_motif:BuildRequires:    motif-devel}
41 BuildRequires:  rpmbuild(macros) >= 1.470
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  xorg-lib-libXdamage-devel
44 BuildRequires:  xorg-lib-libXt-devel
45 BuildRequires:  xorg-lib-libXxf86vm-devel
46 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
47 BuildRequires:  xorg-proto-glproto-devel
48 BuildRequires:  xorg-proto-printproto-devel
49 BuildRequires:  xorg-util-makedepend
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Mesa is a 3-D graphics library with an API which is very similar to
54 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
55 syntax or state machine, it is being used with authorization from
56 Silicon Graphics, Inc. However, the author does not possess an OpenGL
57 license from SGI, and makes no claim that Mesa is in any way a
58 compatible replacement for OpenGL or associated with SGI.
59
60 %description -l pl.UTF-8
61 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
62 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
63 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
64 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
65 OpenGL ani powiązana z SGI.
66
67 %package libGL
68 Summary:        Free Mesa3D implementation of libGL OpenGL library
69 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
70 License:        MIT
71 Group:          X11/Libraries
72 Requires:       libdrm >= 2.4.5
73 Provides:       OpenGL = 2.1
74 # reports version 1.3, but supports glXGetProcAddress() from 1.4
75 Provides:       OpenGL-GLX = 1.4
76 Obsoletes:      Mesa
77 Obsoletes:      Mesa-dri
78 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
79 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
80
81 %description libGL
82 Mesa is a 3-D graphics library with an API which is very similar to
83 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
84 syntax or state machine, it is being used with authorization from
85 Silicon Graphics, Inc. However, the author does not possess an OpenGL
86 license from SGI, and makes no claim that Mesa is in any way a
87 compatible replacement for OpenGL or associated with SGI.
88
89 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
90 specifications. It uses DRI for rendering.
91
92 %description libGL -l pl.UTF-8
93 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
94 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
95 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
96 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
97 OpenGL ani powiązana z SGI.
98
99 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
100 GLX 1.4. Używa DRI do renderowania.
101
102 %package libGL-devel
103 Summary:        Header files for Mesa3D libGL library
104 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
105 License:        MIT
106 Group:          X11/Development/Libraries
107 # loose dependency on libGL to use with other libGL binaries
108 Requires:       OpenGL >= 1.5
109 Requires:       xorg-lib-libX11-devel
110 Provides:       OpenGL-devel = 2.1
111 Provides:       OpenGL-GLX-devel = 1.4
112 Obsoletes:      Mesa-devel
113 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
114 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
115 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
116 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
117
118 %description libGL-devel
119 Header files for Mesa3D libGL library.
120
121 %description libGL-devel -l pl.UTF-8
122 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
123
124 %package libGL-static
125 Summary:        Static Mesa3D libGL library
126 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
127 License:        MIT
128 Group:          X11/Development/Libraries
129 Requires:       %{name}-libGL-devel = %{version}-%{release}
130 Provides:       OpenGL-static = 2.1
131 Obsoletes:      Mesa-static
132 Obsoletes:      X11-OpenGL-static < 1:7.0.0
133 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
134
135 %description libGL-static
136 Static Mesa3D libGL library. It uses software renderer.
137
138 %description libGL-static -l pl.UTF-8
139 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
140 renderingu.
141
142 %package libGLU
143 Summary:        SGI implementation of libGLU OpenGL library
144 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
145 License:        SGI Free Software License B v2.0 (MIT-like)
146 Group:          Libraries
147 # loose dependency on libGL.so.1 to use with other libGL binaries
148 Requires:       OpenGL >= 1.2
149 Provides:       OpenGL-GLU = 1.3
150 Obsoletes:      Mesa-devel
151 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
152 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
153
154 %description libGLU
155 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
156 1.3 specifications.
157
158 %description libGLU -l pl.UTF-8
159 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
160 specyfikację OpenGL GLU 1.3.
161
162 %package libGLU-devel
163 Summary:        Header files for SGI libGLU library
164 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
165 License:        SGI Free Software License B v2.0 (MIT-like)
166 Group:          Development/Libraries
167 Requires:       %{name}-libGLU = %{version}-%{release}
168 Requires:       OpenGL-devel >= 1.2
169 Requires:       libstdc++-devel
170 Provides:       OpenGL-GLU-devel = 1.3
171
172 %description libGLU-devel
173 Header files for SGI libGLU library.
174
175 %description libGLU-devel -l pl.UTF-8
176 Pliki nagłówkowe biblioteki SGI libGLU.
177
178 %package libGLU-static
179 Summary:        Static SGI libGLU library
180 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
181 License:        SGI Free Software License B v2.0 (MIT-like)
182 Group:          Development/Libraries
183 Requires:       %{name}-libGLU-devel = %{version}-%{release}
184 Provides:       OpenGL-GLU-static = 1.3
185
186 %description libGLU-static
187 Static SGI libGLU library.
188
189 %description libGLU-static -l pl.UTF-8
190 Statyczna biblioteka SGI libGLU.
191
192 %package libGLw
193 Summary:        SGI OpenGL Xt widgets library
194 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
195 License:        SGI MIT-like
196 Group:          Libraries
197 # loose dependency on libGL.so.1 to use with other libGL binaries
198 Requires:       OpenGL >= 1.1
199 Provides:       OpenGL-GLw
200
201 %description libGLw
202 SGI OpenGL Xt widgets library.
203
204 %description libGLU -l pl.UTF-8
205 Biblioteka SGI widgetów Xt dla OpenGL-a.
206
207 %package libGLw-devel
208 Summary:        Header files for SGI libGLw library
209 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
210 License:        SGI MIT-like
211 Group:          Development/Libraries
212 Requires:       %{name}-libGLw = %{version}-%{release}
213 Requires:       OpenGL-devel >= 1.2
214 Provides:       OpenGL-GLw-devel
215
216 %description libGLw-devel
217 Header files for SGI libGLw library.
218
219 %description libGLw-devel -l pl.UTF-8
220 Pliki nagłówkowe biblioteki SGI libGLw.
221
222 %package libGLw-static
223 Summary:        Static SGI libGLw library
224 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
225 License:        SGI MIT-like
226 Group:          Development/Libraries
227 Requires:       %{name}-libGLw-devel = %{version}-%{release}
228 Provides:       OpenGL-GLw-static
229
230 %description libGLw-static
231 Static SGI libGLw library.
232
233 %description libGLw-static -l pl.UTF-8
234 Statyczna biblioteka SGI libGLw.
235
236 %package libOSMesa
237 Summary:        OSMesa (off-screen renderer) library
238 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
239 License:        MIT
240 Group:          Libraries
241 # doesn't require base
242
243 %description libOSMesa
244 OSMesa (off-screen renderer) library.
245
246 %description libOSMesa -l pl.UTF-8
247 Biblioteka OSMesa (renderująca bitmapy w pamięci).
248
249 %package libOSMesa-devel
250 Summary:        Header file for OSMesa (off-screen renderer) library
251 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
252 License:        MIT
253 Group:          Development/Libraries
254 Requires:       %{name}-libOSMesa = %{version}-%{release}
255 # for <GL/gl.h> only
256 Requires:       OpenGL-devel
257
258 %description libOSMesa-devel
259 Header file for OSMesa (off-screen renderer) library.
260
261 %description libOSMesa-devel -l pl.UTF-8
262 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
263
264 %package libOSMesa-static
265 Summary:        Static OSMesa (off-screen renderer) library
266 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
267 License:        MIT
268 Group:          Development/Libraries
269 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
270 # this static build of OSMesa needs static non-dri Mesa implementation
271 Requires:       %{name}-libGL-static = %{version}-%{release}
272
273 %description libOSMesa-static
274 Static OSMesa (off-screen renderer) library.
275
276 %description libOSMesa-static -l pl.UTF-8
277 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
278
279 %package utils
280 Summary:        OpenGL utilities from Mesa3D
281 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
282 License:        MIT
283 Group:          X11/Applications/Graphics
284 # loose deps on libGL/libGLU
285
286 %description utils
287 OpenGL utilities from Mesa3D: glxgears and glxinfo.
288
289 %description utils -l pl.UTF-8
290 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
291
292 %package demos
293 Summary:        Mesa Demos source code
294 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
295 License:        various (MIT, SGI, GPL - see copyright notes in sources)
296 Group:          Development/Libraries
297 Requires:       OpenGL-devel
298
299 %description demos
300 Demonstration programs for the Mesa libraries in source code form.
301
302 %description demos -l pl.UTF-8
303 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
304
305 %package dri-driver-ati-mach64
306 Summary:        X.org DRI driver for ATI Mach64 card family
307 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
308 License:        MIT
309 Group:          X11/Libraries
310 Requires:       xorg-driver-video-mach64
311 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
312 Requires:       xorg-xserver-server >= %{xserver_ver}
313
314 %description dri-driver-ati-mach64
315 X.org DRI driver for ATI Mach64 card family.
316
317 %description dri-driver-ati-mach64 -l pl.UTF-8
318 Sterownik X.org DRI dla rodziny kart ATI Mach64.
319
320 %package dri-driver-ati-radeon-R100
321 Summary:        X.org DRI driver for ATI R100 card family
322 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
323 License:        MIT
324 Group:          X11/Libraries
325 Requires:       xorg-driver-video-ati
326 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
327 Requires:       xorg-xserver-server >= %{xserver_ver}
328 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
329
330 %description dri-driver-ati-radeon-R100
331 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
332
333 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
334 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
335
336 %package dri-driver-ati-radeon-R200
337 Summary:        X.org DRI driver for ATI R200 card family
338 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
339 License:        MIT
340 Group:          X11/Libraries
341 Requires:       xorg-driver-video-ati
342 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
343 Requires:       xorg-xserver-server >= %{xserver_ver}
344 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
345
346 %description dri-driver-ati-radeon-R200
347 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
348
349 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
350 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
351
352 %package dri-driver-ati-radeon-R300
353 Summary:        X.org DRI driver for ATI R300 card family
354 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
355 License:        MIT
356 Group:          X11/Libraries
357 Requires:       xorg-driver-video-ati
358 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
359 Requires:       xorg-xserver-server >= %{xserver_ver}
360 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
361
362 %description dri-driver-ati-radeon-R300
363 X.org DRI driver for ATI R300 card family.
364
365 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
366 Sterownik X.org DRI dla rodziny kart ATI R300.
367
368 %package dri-driver-ati-rage128
369 Summary:        X.org DRI driver for ATI Rage128 card family
370 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
371 License:        MIT
372 Group:          X11/Libraries
373 Requires:       xorg-driver-video-r128
374 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
375 Requires:       xorg-xserver-server >= %{xserver_ver}
376 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
377
378 %description dri-driver-ati-rage128
379 X.org DRI driver for ATI Rage128 card family.
380
381 %description dri-driver-ati-rage128 -l pl.UTF-8
382 Sterownik X.org DRI dla rodziny kart ATI Rage128.
383
384 %package dri-driver-ffb
385 Summary:        X.org DRI driver for Sun FFB card family
386 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
387 License:        MIT
388 Group:          X11/Libraries
389 Requires:       xorg-driver-video-sunffb
390 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
391 Requires:       xorg-xserver-server >= %{xserver_ver}
392
393 %description dri-driver-ffb
394 X.org DRI driver for SUN Creator3D and Elite3D card family.
395
396 %description dri-driver-ffb -l pl.UTF-8
397 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
398
399 %package dri-driver-glint
400 Summary:        X.org DRI driver for GLINT/Permedia card family
401 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
402 License:        MIT
403 Group:          X11/Libraries
404 Requires:       xorg-driver-video-glint
405 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
406 Requires:       xorg-xserver-server >= %{xserver_ver}
407 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
408
409 %description dri-driver-glint
410 X.org DRI driver for GLINT/Permedia card family.
411
412 %description dri-driver-glint -l pl.UTF-8
413 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
414
415 %package dri-driver-intel-i810
416 Summary:        X.org DRI driver for Intel i810 card family
417 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
418 License:        MIT
419 Group:          X11/Libraries
420 Requires:       xorg-driver-video-intel
421 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
422 Requires:       xorg-xserver-server >= %{xserver_ver}
423 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
424
425 %description dri-driver-intel-i810
426 X.org DRI driver for Intel i810 card family.
427
428 %description dri-driver-intel-i810 -l pl.UTF-8
429 Sterownik X.org DRI dla rodziny kart Intel i810.
430
431 %package dri-driver-intel-i915
432 Summary:        X.org DRI driver for Intel i915 card family
433 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
434 License:        MIT
435 Group:          X11/Libraries
436 Requires:       xorg-driver-video-intel
437 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
438 Requires:       xorg-xserver-server >= %{xserver_ver}
439 Obsoletes:      Mesa-dri-driver-intel-i830
440 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
441
442 %description dri-driver-intel-i915
443 X.org DRI driver for Intel i915 card family.
444
445 %description dri-driver-intel-i915 -l pl.UTF-8
446 Sterownik X.org DRI dla rodziny kart Intel i915.
447
448 %package dri-driver-intel-i965
449 Summary:        X.org DRI driver for Intel i965 card family
450 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
451 License:        MIT
452 Group:          X11/Libraries
453 Requires:       xorg-driver-video-intel
454 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
455 Requires:       xorg-xserver-server >= %{xserver_ver}
456 Obsoletes:      Mesa-dri-driver-intel-i830
457 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
458
459 %description dri-driver-intel-i965
460 X.org DRI driver for Intel i965 card family.
461
462 %description dri-driver-intel-i965 -l pl.UTF-8
463 Sterownik X.org DRI dla rodziny kart Intel i965.
464
465 %package dri-driver-matrox
466 Summary:        X.org DRI driver for Matrox G card family
467 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
468 License:        MIT
469 Group:          X11/Libraries
470 Requires:       xorg-driver-video-mga
471 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
472 Requires:       xorg-xserver-server >= %{xserver_ver}
473 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
474
475 %description dri-driver-matrox
476 X.org DRI drivers for Matrox G card family.
477
478 %description dri-driver-matrox -l pl.UTF-8
479 Sterowniki X.org DRI dla rodziny kart Matrox G.
480
481 %package dri-driver-s3virge
482 Summary:        X.org DRI driver for S3 Virge card family
483 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
484 License:        MIT
485 Group:          X11/Libraries
486 Requires:       xorg-driver-video-s3virge
487 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
488 Requires:       xorg-xserver-server >= %{xserver_ver}
489
490 %description dri-driver-s3virge
491 X.org DRI driver for S3 Virge card family.
492
493 %description dri-driver-s3virge -l pl.UTF-8
494 Sterownik X.org DRI dla rodziny kart S3 Virge.
495
496 %package dri-driver-savage
497 Summary:        X.org DRI driver for S3 Savage card family
498 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
499 License:        MIT
500 Group:          X11/Libraries
501 Requires:       xorg-driver-video-savage
502 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
503 Requires:       xorg-xserver-server >= %{xserver_ver}
504
505 %description dri-driver-savage
506 X.org DRI driver for S3 Savage card family.
507
508 %description dri-driver-savage -l pl.UTF-8
509 Sterownik X.org DRI dla rodziny kart S3 Savage.
510
511 %package dri-driver-sis
512 Summary:        X.org DRI driver for SiS card family
513 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
514 License:        MIT
515 Group:          X11/Libraries
516 Requires:       xorg-driver-video-sis
517 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
518 Requires:       xorg-xserver-server >= %{xserver_ver}
519 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
520
521 %description dri-driver-sis
522 X.org DRI driver for SiS card family.
523
524 %description dri-driver-sis -l pl.UTF-8
525 Sterownik X.org DRI dla rodziny kart SiS.
526
527 %package dri-driver-swrast
528 Summary:        X.org DRI software rasterizer driver
529 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
530 License:        MIT
531 Group:          X11/Libraries
532 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
533 Requires:       xorg-xserver-server >= %{xserver_ver}
534
535 %description dri-driver-swrast
536 X.org DRI software rasterizer driver.
537
538 %description dri-driver-swrast -l pl.UTF-8
539 Sterownik X.org DRI obsługujący rysowanie programowe.
540
541 %package dri-driver-tdfx
542 Summary:        X.org DRI driver for 3DFX Voodoo card family
543 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
544 License:        MIT
545 Group:          X11/Libraries
546 Requires:       Glide3-DRI
547 Requires:       xorg-driver-video-tdfx
548 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
549 Requires:       xorg-xserver-server >= %{xserver_ver}
550 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
551
552 %description dri-driver-tdfx
553 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
554 and Velocity 100/200).
555
556 %description dri-driver-tdfx -l pl.UTF-8
557 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
558 Banshee i Velocity 100/200).
559
560 %package dri-driver-trident
561 Summary:        X.org DRI driver for Trident card family
562 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
563 License:        MIT
564 Group:          X11/Libraries
565 Requires:       xorg-driver-video-trident
566 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
567 Requires:       xorg-xserver-server >= %{xserver_ver}
568
569 %description dri-driver-trident
570 X.org DRI drivers for Trident card family.
571
572 %description dri-driver-trident -l pl.UTF-8
573 Sterowniki X.org DRI dla rodziny kart Trident.
574
575 %package dri-driver-via-unichrome
576 Summary:        X.org DRI driver for VIA Unichrome card family
577 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
578 License:        MIT
579 Group:          X11/Libraries
580 Requires:       xorg-driver-video-openchrome
581 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
582 Requires:       xorg-xserver-server >= %{xserver_ver}
583
584 %description dri-driver-via-unichrome
585 X.org DRI driver for VIA Unichrome card family.
586
587 %description dri-driver-via-unichrome -l pl.UTF-8
588 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
589
590 %prep
591 %setup -q -b1 -a2
592 %patch0 -p0
593
594 # fix demos
595 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
596
597 %build
598 [ ! -f configure ] && ./autogen.sh
599
600 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
601 %if %{without gallium}
602 i915 \
603 %endif
604 %ifarch sparc sparcv9 sparc64
605 ffb \
606 %endif
607 %ifarch %{ix86} %{x8664}
608 sis \
609 %endif
610 swrast tdfx unichrome"
611
612 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
613
614 common_flags="\
615         --enable-shared \
616         --enable-selinux \
617         --enable-pic"
618
619 # osmesa variants
620 %configure $common_flags \
621         --with-driver=osmesa \
622         --disable-asm \
623         --with-osmesa-bits=8
624 %{__make} \
625         SRC_DIRS=mesa
626 mv %{_lib} osmesa8
627 %{__make} clean
628
629 %configure $common_flags \
630         --with-driver=osmesa \
631         --disable-asm \
632         --with-osmesa-bits=16
633 %{__make} \
634         SRC_DIRS=mesa
635 mv %{_lib} osmesa16
636 %{__make} clean
637
638 %configure $common_flags \
639         --with-driver=osmesa \
640         --disable-asm \
641         --with-osmesa-bits=32
642 %{__make} \
643         SRC_DIRS=mesa
644 mv %{_lib} osmesa32
645 %{__make} clean
646
647 %configure $common_flags \
648         --enable-glu \
649         --enable-glw \
650         --disable-glut \
651         --%{?with_gallium:en}%{!?with_gallium:dis}able-gallium \
652         --with-driver=dri \
653         --with-dri-drivers=${dri_drivers} \
654         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
655
656 %{__make}
657 %{__make} -C progs/xdemos glxgears glxinfo
658 %{__make} -C progs/demos
659
660 cd gl-manpages-*
661 %configure
662 %{__make}
663
664 %install
665 rm -rf $RPM_BUILD_ROOT
666
667 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
668
669 # libs without drivers
670 %{__make} install \
671         DESTDIR=$RPM_BUILD_ROOT
672
673 cd gl-manpages-*
674 %{__make} install \
675         DESTDIR=$RPM_BUILD_ROOT
676 cd ..
677
678 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
679
680 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
681 # work on copy to keep -bi --short-circuit working
682 rm -rf progs-clean
683 install -d progs-clean
684 for l in demos glsl osdemos redbook samples xdemos ; do
685         cp -a progs/$l progs-clean/$l
686         %{__make} -C progs-clean/$l clean
687         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
688 done
689 rm -rf progs-clean
690 for l in util images ; do
691         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
692 done
693 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
694
695 # strip out undesirable headers
696 olddir=$(pwd)
697 cd $RPM_BUILD_ROOT%{_includedir}/GL 
698 rm [a-fh-np-wyz]*.h gg*.h glf*.h
699 cd $RPM_BUILD_ROOT%{_libdir}
700 %if %{without gallium}
701 rm libEGL*
702 %endif
703 cd $olddir
704
705 %if %{with multigl}
706 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
707
708 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
709 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
710
711 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
712 %endif
713
714 %clean
715 rm -rf $RPM_BUILD_ROOT
716
717 %post   libGL -p /sbin/ldconfig
718 %postun libGL -p /sbin/ldconfig
719
720 %post   libGLU -p /sbin/ldconfig
721 %postun libGLU -p /sbin/ldconfig
722
723 %post   libGLw -p /sbin/ldconfig
724 %postun libGLw -p /sbin/ldconfig
725
726 %files libGL
727 %defattr(644,root,root,755)
728 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
729 %if %{with multigl}
730 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
731 %dir %{_libdir}/Mesa
732 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
733 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
734 %else
735 %attr(755,root,root) %{_libdir}/libGL.so.*.*
736 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
738 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
739 # symlink for binary apps which fail to conform Linux OpenGL ABI
740 # (and dlopen libGL.so instead of libGL.so.1)
741 %attr(755,root,root) %{_libdir}/libGL.so
742 %attr(755,root,root) %{_libdir}/libEGL.so
743 %endif
744
745 %files libGL-devel
746 %defattr(644,root,root,755)
747 %doc docs/*.spec
748 %if %{with multigl}
749 %attr(755,root,root) %{_libdir}/libGL.so
750 %endif
751 %dir %{_includedir}/GL
752 %{_includedir}/GL/gl.h
753 %{_includedir}/GL/glext.h
754 %{_includedir}/GL/gl_mangle.h
755 %{_includedir}/GL/glx.h
756 %{_includedir}/GL/glxext.h
757 %{_includedir}/GL/glx_mangle.h
758 %dir %{_includedir}/GL/internal
759 %{_includedir}/GL/internal/dri_interface.h
760 %{_pkgconfigdir}/dri.pc
761 %{_pkgconfigdir}/gl.pc
762 %{_datadir}/man/man3/gl[^uX]*.3gl*
763 %{_datadir}/man/man3/glX*.3gl*
764
765 %if %{with static}
766 %files libGL-static
767 %defattr(644,root,root,755)
768 %{_libdir}/libGL.a
769 %endif
770
771 %files libGLU
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
774 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
775
776 %files libGLU-devel
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libGLU.so
779 %{_includedir}/GL/glu.h
780 %{_includedir}/GL/glu_mangle.h
781 %{_pkgconfigdir}/glu.pc
782 %{_datadir}/man/man3/glu*.3gl*
783
784 %if %{with static}
785 %files libGLU-static
786 %defattr(644,root,root,755)
787 %{_libdir}/libGLU.a
788 %endif
789
790 %files libGLw
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
793 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
794
795 %files libGLw-devel
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libGLw.so
798 %{_includedir}/GL/GLwDrawA.h
799 %{_includedir}/GL/GLwDrawAP.h
800 %{_includedir}/GL/GLwMDrawA.h
801 %{_includedir}/GL/GLwMDrawAP.h
802 %{_pkgconfigdir}/glw.pc
803
804 %if %{with static}
805 %files libGLw-static
806 %defattr(644,root,root,755)
807 %{_libdir}/libGLw.a
808 %endif
809
810 %files libOSMesa
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
814
815 %files libOSMesa-devel
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libOSMesa*.so
818 %{_includedir}/GL/osmesa.h
819
820 %if %{with static}
821 %files libOSMesa-static
822 %defattr(644,root,root,755)
823 %{_libdir}/libOSMesa*.a
824 %endif
825
826 %files utils
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_bindir}/glxgears
829 %attr(755,root,root) %{_bindir}/glxinfo
830
831 %files dri-driver-ati-mach64
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
834
835 %files dri-driver-ati-radeon-R100
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
838
839 %files dri-driver-ati-radeon-R200
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
842
843 %files dri-driver-ati-radeon-R300
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
846
847 %files dri-driver-ati-rage128
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
850
851 # sunffb (sparc only)
852 %ifarch sparc sparcv9 sparc64
853 %files dri-driver-ffb
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
856 %endif
857
858 # glint (requires update)
859 %if 0
860 %files dri-driver-glint
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
863 %endif
864
865 %files dri-driver-intel-i810
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
868
869 %files dri-driver-intel-i915
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_libdir}/xorg/modules/dri/EGL_i915.so
872
873 %files dri-driver-intel-i965
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
876
877 %files dri-driver-matrox
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
880
881 %files dri-driver-s3virge
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
884
885 %files dri-driver-savage
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
888
889 %ifarch %{ix86} %{x8664}
890 %files dri-driver-sis
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
893 %endif
894
895 %files dri-driver-swrast
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
898
899 %files dri-driver-tdfx
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
902
903 %files dri-driver-trident
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
906
907 %files dri-driver-via-unichrome
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
910
911 %files demos
912 %defattr(644,root,root,755)
913 %{_examplesdir}/%{name}-%{version}
This page took 0.099916 seconds and 4 git commands to generate.