]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- BR: OpenGL-glut-devel >= 3.8 (demos requires glut.h from freeglut)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 Summary:        Free OpenGL implementation
25 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
26 Name:           Mesa
27 Version:        7.6
28 Release:        2%{?with_multigl:.mgl}
29 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
30 Group:          X11/Libraries
31 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
32 # Source0-md5:  8c75f90cd0303cfac9e4b6d54f6759ca
33 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
34 # Source1-md5:  0ede7adf217951acd90dbe4551210c07
35 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
36 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-sparc64.patch
39 Patch2:         %{name}-git.patch
40 URL:            http://www.mesa3d.org/
41 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
42 BuildRequires:  expat-devel
43 %{?with_demos:BuildRequires:    glew-devel}
44 BuildRequires:  libdrm-devel >= 2.4.12-3
45 BuildRequires:  libselinux-devel
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool >= 2:1.4d
48 %{?with_motif:BuildRequires:    motif-devel}
49 BuildRequires:  rpmbuild(macros) >= 1.470
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  xorg-lib-libXdamage-devel
52 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
53 BuildRequires:  xorg-lib-libXt-devel
54 BuildRequires:  xorg-lib-libXxf86vm-devel
55 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
56 BuildRequires:  xorg-proto-glproto-devel
57 BuildRequires:  xorg-proto-printproto-devel
58 BuildRequires:  xorg-util-makedepend
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %if %{without gallium}
62 %undefine       with_gallium_intel
63 %endif
64
65 %description
66 Mesa is a 3-D graphics library with an API which is very similar to
67 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
68 syntax or state machine, it is being used with authorization from
69 Silicon Graphics, Inc. However, the author does not possess an OpenGL
70 license from SGI, and makes no claim that Mesa is in any way a
71 compatible replacement for OpenGL or associated with SGI.
72
73 %description -l pl.UTF-8
74 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
75 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
76 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
77 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
78 OpenGL ani powiązana z SGI.
79
80 %package libGL
81 Summary:        Free Mesa3D implementation of libGL OpenGL library
82 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
83 License:        MIT
84 Group:          X11/Libraries
85 Requires:       libdrm >= 2.4.5
86 Provides:       OpenGL = 2.1
87 # reports version 1.3, but supports glXGetProcAddress() from 1.4
88 Provides:       OpenGL-GLX = 1.4
89 Obsoletes:      Mesa
90 Obsoletes:      Mesa-dri
91 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
92 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
93
94 %description libGL
95 Mesa is a 3-D graphics library with an API which is very similar to
96 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
97 syntax or state machine, it is being used with authorization from
98 Silicon Graphics, Inc. However, the author does not possess an OpenGL
99 license from SGI, and makes no claim that Mesa is in any way a
100 compatible replacement for OpenGL or associated with SGI.
101
102 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
103 specifications. It uses DRI for rendering.
104
105 %description libGL -l pl.UTF-8
106 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
107 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
108 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
109 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
110 OpenGL ani powiązana z SGI.
111
112 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
113 GLX 1.4. Używa DRI do renderowania.
114
115 %package libGL-devel
116 Summary:        Header files for Mesa3D libGL library
117 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
118 License:        MIT
119 Group:          X11/Development/Libraries
120 # loose dependency on libGL to use with other libGL binaries
121 Requires:       OpenGL >= 1.5
122 Requires:       xorg-lib-libX11-devel
123 Provides:       OpenGL-GLX-devel = 1.4
124 Provides:       OpenGL-devel = 2.1
125 Obsoletes:      Mesa-devel
126 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
127 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
128 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
129 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
130
131 %description libGL-devel
132 Header files for Mesa3D libGL library.
133
134 %description libGL-devel -l pl.UTF-8
135 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
136
137 %package libGL-static
138 Summary:        Static Mesa3D libGL library
139 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
140 License:        MIT
141 Group:          X11/Development/Libraries
142 Requires:       %{name}-libGL-devel = %{version}-%{release}
143 Provides:       OpenGL-static = 2.1
144 Obsoletes:      Mesa-static
145 Obsoletes:      X11-OpenGL-static < 1:7.0.0
146 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
147
148 %description libGL-static
149 Static Mesa3D libGL library. It uses software renderer.
150
151 %description libGL-static -l pl.UTF-8
152 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
153 renderingu.
154
155 %package libGLU
156 Summary:        SGI implementation of libGLU OpenGL library
157 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
158 License:        SGI Free Software License B v2.0 (MIT-like)
159 Group:          Libraries
160 # loose dependency on libGL.so.1 to use with other libGL binaries
161 Requires:       OpenGL >= 1.2
162 Provides:       OpenGL-GLU = 1.3
163 Obsoletes:      Mesa-devel
164 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
165 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
166
167 %description libGLU
168 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
169 1.3 specifications.
170
171 %description libGLU -l pl.UTF-8
172 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
173 specyfikację OpenGL GLU 1.3.
174
175 %package libGLU-devel
176 Summary:        Header files for SGI libGLU library
177 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
178 License:        SGI Free Software License B v2.0 (MIT-like)
179 Group:          Development/Libraries
180 Requires:       %{name}-libGLU = %{version}-%{release}
181 Requires:       OpenGL-devel >= 1.2
182 Requires:       libstdc++-devel
183 Provides:       OpenGL-GLU-devel = 1.3
184
185 %description libGLU-devel
186 Header files for SGI libGLU library.
187
188 %description libGLU-devel -l pl.UTF-8
189 Pliki nagłówkowe biblioteki SGI libGLU.
190
191 %package libGLU-static
192 Summary:        Static SGI libGLU library
193 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
194 License:        SGI Free Software License B v2.0 (MIT-like)
195 Group:          Development/Libraries
196 Requires:       %{name}-libGLU-devel = %{version}-%{release}
197 Provides:       OpenGL-GLU-static = 1.3
198
199 %description libGLU-static
200 Static SGI libGLU library.
201
202 %description libGLU-static -l pl.UTF-8
203 Statyczna biblioteka SGI libGLU.
204
205 %package libGLw
206 Summary:        SGI OpenGL Xt widgets library
207 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
208 License:        SGI MIT-like
209 Group:          Libraries
210 # loose dependency on libGL.so.1 to use with other libGL binaries
211 Requires:       OpenGL >= 1.1
212 Provides:       OpenGL-GLw
213
214 %description libGLw
215 SGI OpenGL Xt widgets library.
216
217 %description libGLU -l pl.UTF-8
218 Biblioteka SGI widgetów Xt dla OpenGL-a.
219
220 %package libGLw-devel
221 Summary:        Header files for SGI libGLw library
222 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
223 License:        SGI MIT-like
224 Group:          Development/Libraries
225 Requires:       %{name}-libGLw = %{version}-%{release}
226 Requires:       OpenGL-devel >= 1.2
227 Provides:       OpenGL-GLw-devel
228
229 %description libGLw-devel
230 Header files for SGI libGLw library.
231
232 %description libGLw-devel -l pl.UTF-8
233 Pliki nagłówkowe biblioteki SGI libGLw.
234
235 %package libGLw-static
236 Summary:        Static SGI libGLw library
237 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
238 License:        SGI MIT-like
239 Group:          Development/Libraries
240 Requires:       %{name}-libGLw-devel = %{version}-%{release}
241 Provides:       OpenGL-GLw-static
242
243 %description libGLw-static
244 Static SGI libGLw library.
245
246 %description libGLw-static -l pl.UTF-8
247 Statyczna biblioteka SGI libGLw.
248
249 %package libOSMesa
250 Summary:        OSMesa (off-screen renderer) library
251 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
252 License:        MIT
253 Group:          Libraries
254 # doesn't require base
255
256 %description libOSMesa
257 OSMesa (off-screen renderer) library.
258
259 %description libOSMesa -l pl.UTF-8
260 Biblioteka OSMesa (renderująca bitmapy w pamięci).
261
262 %package libOSMesa-devel
263 Summary:        Header file for OSMesa (off-screen renderer) library
264 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
265 License:        MIT
266 Group:          Development/Libraries
267 Requires:       %{name}-libOSMesa = %{version}-%{release}
268 # for <GL/gl.h> only
269 Requires:       OpenGL-devel
270
271 %description libOSMesa-devel
272 Header file for OSMesa (off-screen renderer) library.
273
274 %description libOSMesa-devel -l pl.UTF-8
275 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
276
277 %package libOSMesa-static
278 Summary:        Static OSMesa (off-screen renderer) library
279 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
280 License:        MIT
281 Group:          Development/Libraries
282 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
283 # this static build of OSMesa needs static non-dri Mesa implementation
284 Requires:       %{name}-libGL-static = %{version}-%{release}
285
286 %description libOSMesa-static
287 Static OSMesa (off-screen renderer) library.
288
289 %description libOSMesa-static -l pl.UTF-8
290 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
291
292 %package utils
293 Summary:        OpenGL utilities from Mesa3D
294 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
295 License:        MIT
296 Group:          X11/Applications/Graphics
297 # loose deps on libGL/libGLU
298
299 %description utils
300 OpenGL utilities from Mesa3D: glxgears and glxinfo.
301
302 %description utils -l pl.UTF-8
303 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
304
305 %package demos
306 Summary:        Mesa Demos source code
307 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
308 License:        various (MIT, SGI, GPL - see copyright notes in sources)
309 Group:          Development/Libraries
310 Requires:       OpenGL-devel
311
312 %description demos
313 Demonstration programs for the Mesa libraries in source code form.
314
315 %description demos -l pl.UTF-8
316 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
317
318 %package dri-driver-ati-mach64
319 Summary:        X.org DRI driver for ATI Mach64 card family
320 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
321 License:        MIT
322 Group:          X11/Libraries
323 Requires:       xorg-driver-video-mach64
324 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
325 Requires:       xorg-xserver-server >= %{xserver_ver}
326
327 %description dri-driver-ati-mach64
328 X.org DRI driver for ATI Mach64 card family.
329
330 %description dri-driver-ati-mach64 -l pl.UTF-8
331 Sterownik X.org DRI dla rodziny kart ATI Mach64.
332
333 %package dri-driver-ati-radeon-R100
334 Summary:        X.org DRI driver for ATI R100 card family
335 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
336 License:        MIT
337 Group:          X11/Libraries
338 Requires:       xorg-driver-video-ati
339 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
340 Requires:       xorg-xserver-server >= %{xserver_ver}
341 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
342
343 %description dri-driver-ati-radeon-R100
344 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
345
346 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
347 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
348
349 %package dri-driver-ati-radeon-R200
350 Summary:        X.org DRI driver for ATI R200 card family
351 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
352 License:        MIT
353 Group:          X11/Libraries
354 Requires:       xorg-driver-video-ati
355 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
356 Requires:       xorg-xserver-server >= %{xserver_ver}
357 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
358
359 %description dri-driver-ati-radeon-R200
360 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
361
362 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
363 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
364
365 %package dri-driver-ati-radeon-R300
366 Summary:        X.org DRI driver for ATI R300 card family
367 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
368 License:        MIT
369 Group:          X11/Libraries
370 Requires:       xorg-driver-video-ati
371 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
372 Requires:       xorg-xserver-server >= %{xserver_ver}
373 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
374
375 %description dri-driver-ati-radeon-R300
376 X.org DRI driver for ATI R300 card family.
377
378 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
379 Sterownik X.org DRI dla rodziny kart ATI R300.
380
381 %package dri-driver-ati-rage128
382 Summary:        X.org DRI driver for ATI Rage128 card family
383 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
384 License:        MIT
385 Group:          X11/Libraries
386 Requires:       xorg-driver-video-r128
387 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
388 Requires:       xorg-xserver-server >= %{xserver_ver}
389 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
390
391 %description dri-driver-ati-rage128
392 X.org DRI driver for ATI Rage128 card family.
393
394 %description dri-driver-ati-rage128 -l pl.UTF-8
395 Sterownik X.org DRI dla rodziny kart ATI Rage128.
396
397 %package dri-driver-ffb
398 Summary:        X.org DRI driver for Sun FFB card family
399 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
400 License:        MIT
401 Group:          X11/Libraries
402 Requires:       xorg-driver-video-sunffb
403 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
404 Requires:       xorg-xserver-server >= %{xserver_ver}
405
406 %description dri-driver-ffb
407 X.org DRI driver for SUN Creator3D and Elite3D card family.
408
409 %description dri-driver-ffb -l pl.UTF-8
410 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
411
412 %package dri-driver-glint
413 Summary:        X.org DRI driver for GLINT/Permedia card family
414 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
415 License:        MIT
416 Group:          X11/Libraries
417 Requires:       xorg-driver-video-glint
418 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
419 Requires:       xorg-xserver-server >= %{xserver_ver}
420 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
421
422 %description dri-driver-glint
423 X.org DRI driver for GLINT/Permedia card family.
424
425 %description dri-driver-glint -l pl.UTF-8
426 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
427
428 %package dri-driver-intel-i810
429 Summary:        X.org DRI driver for Intel i810 card family
430 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
431 License:        MIT
432 Group:          X11/Libraries
433 Requires:       xorg-driver-video-intel
434 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
435 Requires:       xorg-xserver-server >= %{xserver_ver}
436 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
437
438 %description dri-driver-intel-i810
439 X.org DRI driver for Intel i810 card family.
440
441 %description dri-driver-intel-i810 -l pl.UTF-8
442 Sterownik X.org DRI dla rodziny kart Intel i810.
443
444 %package dri-driver-intel-i915
445 Summary:        X.org DRI driver for Intel i915 card family
446 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
447 License:        MIT
448 Group:          X11/Libraries
449 Requires:       xorg-driver-video-intel
450 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
451 Requires:       xorg-xserver-server >= %{xserver_ver}
452 Obsoletes:      Mesa-dri-driver-intel-i830
453 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
454
455 %description dri-driver-intel-i915
456 X.org DRI driver for Intel i915 card family.
457
458 %description dri-driver-intel-i915 -l pl.UTF-8
459 Sterownik X.org DRI dla rodziny kart Intel i915.
460
461 %package dri-driver-intel-i965
462 Summary:        X.org DRI driver for Intel i965 card family
463 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
464 License:        MIT
465 Group:          X11/Libraries
466 Requires:       xorg-driver-video-intel
467 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
468 Requires:       xorg-xserver-server >= %{xserver_ver}
469 Obsoletes:      Mesa-dri-driver-intel-i830
470 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
471
472 %description dri-driver-intel-i965
473 X.org DRI driver for Intel i965 card family.
474
475 %description dri-driver-intel-i965 -l pl.UTF-8
476 Sterownik X.org DRI dla rodziny kart Intel i965.
477
478 %package dri-driver-matrox
479 Summary:        X.org DRI driver for Matrox G card family
480 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
481 License:        MIT
482 Group:          X11/Libraries
483 Requires:       xorg-driver-video-mga
484 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
485 Requires:       xorg-xserver-server >= %{xserver_ver}
486 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
487
488 %description dri-driver-matrox
489 X.org DRI drivers for Matrox G card family.
490
491 %description dri-driver-matrox -l pl.UTF-8
492 Sterowniki X.org DRI dla rodziny kart Matrox G.
493
494 %package dri-driver-nouveau
495 Summary:        X.org DRI driver for NVIDIA card family
496 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
497 License:        MIT
498 Group:          X11/Libraries
499 Requires:       xorg-driver-video-nouveau
500 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
501 Requires:       xorg-xserver-server >= %{xserver_ver}
502
503 %description dri-driver-nouveau
504 X.org DRI drivers for NVIDIA card family.
505
506 %description dri-driver-nouveau -l pl.UTF-8
507 Sterowniki X.org DRI dla rodziny kart NVIDIA.
508
509 %package dri-driver-s3virge
510 Summary:        X.org DRI driver for S3 Virge card family
511 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
512 License:        MIT
513 Group:          X11/Libraries
514 Requires:       xorg-driver-video-s3virge
515 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
516 Requires:       xorg-xserver-server >= %{xserver_ver}
517
518 %description dri-driver-s3virge
519 X.org DRI driver for S3 Virge card family.
520
521 %description dri-driver-s3virge -l pl.UTF-8
522 Sterownik X.org DRI dla rodziny kart S3 Virge.
523
524 %package dri-driver-savage
525 Summary:        X.org DRI driver for S3 Savage card family
526 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
527 License:        MIT
528 Group:          X11/Libraries
529 Requires:       xorg-driver-video-savage
530 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
531 Requires:       xorg-xserver-server >= %{xserver_ver}
532
533 %description dri-driver-savage
534 X.org DRI driver for S3 Savage card family.
535
536 %description dri-driver-savage -l pl.UTF-8
537 Sterownik X.org DRI dla rodziny kart S3 Savage.
538
539 %package dri-driver-sis
540 Summary:        X.org DRI driver for SiS card family
541 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
542 License:        MIT
543 Group:          X11/Libraries
544 Requires:       xorg-driver-video-sis
545 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
546 Requires:       xorg-xserver-server >= %{xserver_ver}
547 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
548
549 %description dri-driver-sis
550 X.org DRI driver for SiS card family.
551
552 %description dri-driver-sis -l pl.UTF-8
553 Sterownik X.org DRI dla rodziny kart SiS.
554
555 %package dri-driver-swrast
556 Summary:        X.org DRI software rasterizer driver
557 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
558 License:        MIT
559 Group:          X11/Libraries
560 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
561 Requires:       xorg-xserver-server >= %{xserver_ver}
562
563 %description dri-driver-swrast
564 X.org DRI software rasterizer driver.
565
566 %description dri-driver-swrast -l pl.UTF-8
567 Sterownik X.org DRI obsługujący rysowanie programowe.
568
569 %package dri-driver-tdfx
570 Summary:        X.org DRI driver for 3DFX Voodoo card family
571 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
572 License:        MIT
573 Group:          X11/Libraries
574 Requires:       Glide3-DRI
575 Requires:       xorg-driver-video-tdfx
576 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
577 Requires:       xorg-xserver-server >= %{xserver_ver}
578 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
579
580 %description dri-driver-tdfx
581 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
582 and Velocity 100/200).
583
584 %description dri-driver-tdfx -l pl.UTF-8
585 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
586 Banshee i Velocity 100/200).
587
588 %package dri-driver-trident
589 Summary:        X.org DRI driver for Trident card family
590 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
591 License:        MIT
592 Group:          X11/Libraries
593 Requires:       xorg-driver-video-trident
594 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
595 Requires:       xorg-xserver-server >= %{xserver_ver}
596
597 %description dri-driver-trident
598 X.org DRI drivers for Trident card family.
599
600 %description dri-driver-trident -l pl.UTF-8
601 Sterowniki X.org DRI dla rodziny kart Trident.
602
603 %package dri-driver-via-unichrome
604 Summary:        X.org DRI driver for VIA Unichrome card family
605 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
606 License:        MIT
607 Group:          X11/Libraries
608 Requires:       xorg-driver-video-openchrome
609 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
610 Requires:       xorg-xserver-server >= %{xserver_ver}
611
612 %description dri-driver-via-unichrome
613 X.org DRI driver for VIA Unichrome card family.
614
615 %description dri-driver-via-unichrome -l pl.UTF-8
616 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
617
618 %prep
619 %setup -q -b1 -a2
620 %patch0 -p0
621 %patch1 -p1
622 %patch2 -p1
623
624 # fix demos
625 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
626
627 %build
628 [ ! -f configure ] && ./autogen.sh
629
630 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
631 %if %{without gallium_intel}
632 i915 \
633 %endif
634 %ifarch sparc sparcv9 sparc64
635 ffb \
636 %endif
637 %ifarch %{ix86} %{x8664}
638 sis \
639 %endif
640 swrast tdfx unichrome"
641
642 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
643
644 common_flags="\
645         --enable-shared \
646         --enable-selinux \
647         --enable-pic \
648         --enable-glx-tls \
649         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
650         --with%{!?with_demos:out}-demos"
651
652 %if %{with osmesa}
653 # osmesa variants
654 %configure $common_flags \
655         --with-driver=osmesa \
656         --disable-asm \
657         --with-osmesa-bits=8
658 %{__make} \
659         SRC_DIRS=mesa
660 mv %{_lib} osmesa8
661 %{__make} clean
662
663 %configure $common_flags \
664         --with-driver=osmesa \
665         --disable-asm \
666         --with-osmesa-bits=16
667 %{__make} \
668         SRC_DIRS=mesa
669 mv %{_lib} osmesa16
670 %{__make} clean
671
672 %configure $common_flags \
673         --with-driver=osmesa \
674         --disable-asm \
675         --with-osmesa-bits=32
676 %{__make} \
677         SRC_DIRS=mesa
678 mv %{_lib} osmesa32
679 %{__make} clean
680 %endif
681
682 %configure $common_flags \
683         --enable-glu \
684         --enable-glw \
685         --disable-glut \
686 %if %{with gallium}
687         --enable-gallium \
688         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
689         --enable-gallium-nouveau \
690         --with-state-trackers=dri \
691 %else
692         --disable-gallium \
693 %endif
694         --with-driver=dri \
695         --with-dri-drivers=${dri_drivers} \
696         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
697
698 %{__make}
699 %{__make} -C progs/xdemos glxgears glxinfo
700 %if %{with demos}
701 %{__make} -C progs/demos
702 %endif
703
704 cd gl-manpages-*
705 %configure
706 %{__make}
707
708 %install
709 rm -rf $RPM_BUILD_ROOT
710
711 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
712
713 # libs without drivers
714 %{__make} install \
715         DESTDIR=$RPM_BUILD_ROOT
716
717 cd gl-manpages-*
718 %{__make} install \
719         DESTDIR=$RPM_BUILD_ROOT
720 cd ..
721
722 %if %{with osmesa}
723 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
724 %endif
725
726 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
727 # work on copy to keep -bi --short-circuit working
728 rm -rf progs-clean
729 install -d progs-clean
730 for l in demos glsl osdemos redbook samples xdemos ; do
731         cp -a progs/$l progs-clean/$l
732         %{__make} -C progs-clean/$l clean
733         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
734 done
735 rm -rf progs-clean
736 for l in util images ; do
737         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
738 done
739 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
740
741 # strip out undesirable headers
742 olddir=$(pwd)
743 cd $RPM_BUILD_ROOT%{_includedir}/GL
744 rm [a-fh-np-wyz]*.h gg*.h glf*.h
745 cd $RPM_BUILD_ROOT%{_libdir}
746 cd $olddir
747
748 %if %{with multigl}
749 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
750
751 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
752 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
753
754 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
755 %endif
756
757 %clean
758 rm -rf $RPM_BUILD_ROOT
759
760 %post   libGL -p /sbin/ldconfig
761 %postun libGL -p /sbin/ldconfig
762
763 %post   libGLU -p /sbin/ldconfig
764 %postun libGLU -p /sbin/ldconfig
765
766 %post   libGLw -p /sbin/ldconfig
767 %postun libGLw -p /sbin/ldconfig
768
769 %files libGL
770 %defattr(644,root,root,755)
771 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
772 %if %{with multigl}
773 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
774 %dir %{_libdir}/Mesa
775 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
776 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
777 %else
778 %attr(755,root,root) %{_libdir}/libGL.so.*.*
779 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
780 # symlink for binary apps which fail to conform Linux OpenGL ABI
781 # (and dlopen libGL.so instead of libGL.so.1)
782 %attr(755,root,root) %{_libdir}/libGL.so
783 %endif
784
785 %files libGL-devel
786 %defattr(644,root,root,755)
787 %doc docs/*.spec
788 %if %{with multigl}
789 %attr(755,root,root) %{_libdir}/libGL.so
790 %endif
791 %dir %{_includedir}/GL
792 %{_includedir}/GL/gl.h
793 %{_includedir}/GL/glext.h
794 %{_includedir}/GL/gl_mangle.h
795 %{_includedir}/GL/glx.h
796 %{_includedir}/GL/glxext.h
797 %{_includedir}/GL/glx_mangle.h
798 %dir %{_includedir}/GL/internal
799 %{_includedir}/GL/internal/dri_interface.h
800 %{_pkgconfigdir}/dri.pc
801 %{_pkgconfigdir}/gl.pc
802 %{_mandir}/man3/gl[^uX]*.3gl*
803 %{_mandir}/man3/glX*.3gl*
804
805 %if %{with static}
806 %files libGL-static
807 %defattr(644,root,root,755)
808 %{_libdir}/libGL.a
809 %endif
810
811 %files libGLU
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
814 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
815
816 %files libGLU-devel
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libGLU.so
819 %{_includedir}/GL/glu.h
820 %{_includedir}/GL/glu_mangle.h
821 %{_pkgconfigdir}/glu.pc
822 %{_mandir}/man3/glu*.3gl*
823
824 %if %{with static}
825 %files libGLU-static
826 %defattr(644,root,root,755)
827 %{_libdir}/libGLU.a
828 %endif
829
830 %files libGLw
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
833 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
834
835 %files libGLw-devel
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libGLw.so
838 %{_includedir}/GL/GLwDrawA.h
839 %{_includedir}/GL/GLwDrawAP.h
840 %{_includedir}/GL/GLwMDrawA.h
841 %{_includedir}/GL/GLwMDrawAP.h
842 %{_pkgconfigdir}/glw.pc
843
844 %if %{with static}
845 %files libGLw-static
846 %defattr(644,root,root,755)
847 %{_libdir}/libGLw.a
848 %endif
849
850 %if %{with osmesa}
851 %files libOSMesa
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
854 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
855
856 %files libOSMesa-devel
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/libOSMesa*.so
859 %{_includedir}/GL/osmesa.h
860
861 %if %{with static}
862 %files libOSMesa-static
863 %defattr(644,root,root,755)
864 %{_libdir}/libOSMesa*.a
865 %endif
866 %endif
867
868 %files utils
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_bindir}/glxgears
871 %attr(755,root,root) %{_bindir}/glxinfo
872
873 %files dri-driver-ati-mach64
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
876
877 %files dri-driver-ati-radeon-R100
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
880
881 %files dri-driver-ati-radeon-R200
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
884
885 %files dri-driver-ati-radeon-R300
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
888
889 %files dri-driver-ati-rage128
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
892
893 # sunffb (sparc only)
894 %ifarch sparc sparcv9 sparc64
895 %files dri-driver-ffb
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
898 %endif
899
900 # glint (requires update)
901 %if 0
902 %files dri-driver-glint
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
905 %endif
906
907 %files dri-driver-intel-i810
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
910
911 %files dri-driver-intel-i915
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
914
915 %files dri-driver-intel-i965
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
918
919 %files dri-driver-matrox
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
922
923 %if %{with gallium}
924 %files dri-driver-nouveau
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
927 %endif
928
929 %files dri-driver-s3virge
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
932
933 %files dri-driver-savage
934 %defattr(644,root,root,755)
935 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
936
937 %ifarch %{ix86} %{x8664}
938 %files dri-driver-sis
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
941 %endif
942
943 %files dri-driver-swrast
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
946
947 %files dri-driver-tdfx
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
950
951 %files dri-driver-trident
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
954
955 %files dri-driver-via-unichrome
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
958
959 %if %{with demos}
960 %files demos
961 %defattr(644,root,root,755)
962 %{_examplesdir}/%{name}-%{version}
963 %endif
This page took 0.12352 seconds and 4 git commands to generate.