]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- rel 1
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 #
5 # Conditional build:
6 %bcond_without  motif   # build static libGLw without Motif interface
7 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
8 %bcond_with     ttm     # enable TTM API
9 #
10 # minimal supported xserver version
11 %define         xserver_ver     1.5.0
12 # glapi version (glapi tables in dri drivers and libglx must be in sync);
13 # set to current Mesa version on ABI break, when xserver tables get regenerated
14 # (until they start to be somehow versioned themselves)
15 %define         glapi_ver       7.1.0
16 Summary:        Free OpenGL implementation
17 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
18 Name:           Mesa
19 Version:        7.2
20 Release:        1%{?with_multigl:.mgl}
21 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
22 Group:          X11/Libraries
23 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
24 # Source0-md5:  04d379292e023df0b0266825cb0dbde5
25 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
26 # Source1-md5:  22e03dc4038cd63f32c21eb60994892b
27 Patch0:         %{name}-realclean.patch
28 Patch1:         %{name}-dri_mm.patch
29 URL:            http://www.mesa3d.org/
30 BuildRequires:  expat-devel
31 BuildRequires:  libdrm-devel >= 2.3.1
32 %{?with_ttm:BuildRequires:      libdrm-devel >= 2.4.0}
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool >= 2:1.4d
35 %{?with_motif:BuildRequires:    motif-devel}
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  xorg-lib-libXdamage-devel
38 BuildRequires:  xorg-lib-libXt-devel
39 BuildRequires:  xorg-lib-libXxf86vm-devel
40 BuildRequires:  xorg-proto-dri2proto-devel
41 BuildRequires:  xorg-proto-glproto-devel
42 BuildRequires:  xorg-proto-printproto-devel
43 BuildRequires:  xorg-util-makedepend
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Mesa is a 3-D graphics library with an API which is very similar to
48 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
49 syntax or state machine, it is being used with authorization from
50 Silicon Graphics, Inc. However, the author does not possess an OpenGL
51 license from SGI, and makes no claim that Mesa is in any way a
52 compatible replacement for OpenGL or associated with SGI.
53
54 %description -l pl.UTF-8
55 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
56 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
57 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
58 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
59 OpenGL ani powiązana z SGI.
60
61 %package libGL
62 Summary:        Free Mesa3D implementation of libGL OpenGL library
63 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
64 License:        MIT
65 Group:          X11/Libraries
66 Requires:       libdrm >= 2.2.0
67 Provides:       OpenGL = 2.1
68 # reports version 1.3, but supports glXGetProcAddress() from 1.4
69 Provides:       OpenGL-GLX = 1.4
70 Obsoletes:      Mesa
71 Obsoletes:      Mesa-dri
72 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
73 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
74
75 %description libGL
76 Mesa is a 3-D graphics library with an API which is very similar to
77 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
78 syntax or state machine, it is being used with authorization from
79 Silicon Graphics, Inc. However, the author does not possess an OpenGL
80 license from SGI, and makes no claim that Mesa is in any way a
81 compatible replacement for OpenGL or associated with SGI.
82
83 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
84 specifications. It uses DRI for rendering.
85
86 %description libGL -l pl.UTF-8
87 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
88 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
89 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
90 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
91 OpenGL ani powiązana z SGI.
92
93 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
94 GLX 1.4. Używa DRI do renderowania.
95
96 %package libGL-devel
97 Summary:        Header files for Mesa3D libGL library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
99 License:        MIT
100 Group:          X11/Development/Libraries
101 # loose dependency on libGL to use with other libGL binaries
102 Requires:       OpenGL >= 1.5
103 Requires:       xorg-lib-libX11-devel
104 Provides:       OpenGL-devel = 2.1
105 Provides:       OpenGL-GLX-devel = 1.4
106 Obsoletes:      Mesa-devel
107 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
108 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
109 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
110 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
111
112 %description libGL-devel
113 Header files for Mesa3D libGL library.
114
115 %description libGL-devel -l pl.UTF-8
116 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
117
118 %package libGL-static
119 Summary:        Static Mesa3D libGL library
120 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
121 License:        MIT
122 Group:          X11/Development/Libraries
123 Requires:       %{name}-libGL-devel = %{version}-%{release}
124 Provides:       OpenGL-static = 2.1
125 Obsoletes:      Mesa-static
126 Obsoletes:      X11-OpenGL-static < 1:7.0.0
127 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
128
129 %description libGL-static
130 Static Mesa3D libGL library. It uses software renderer.
131
132 %description libGL-static -l pl.UTF-8
133 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
134 renderingu.
135
136 %package libGLU
137 Summary:        SGI implementation of libGLU OpenGL library
138 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
139 License:        SGI Free Software License B v2.0 (MIT-like)
140 Group:          Libraries
141 # loose dependency on libGL.so.1 to use with other libGL binaries
142 Requires:       OpenGL >= 1.2
143 Provides:       OpenGL-GLU = 1.3
144 Obsoletes:      Mesa-devel
145 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
146 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
147
148 %description libGLU
149 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
150 1.3 specifications.
151
152 %description libGLU -l pl.UTF-8
153 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
154 specyfikację OpenGL GLU 1.3.
155
156 %package libGLU-devel
157 Summary:        Header files for SGI libGLU library
158 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
159 License:        SGI Free Software License B v2.0 (MIT-like)
160 Group:          Development/Libraries
161 Requires:       %{name}-libGLU = %{version}-%{release}
162 Requires:       OpenGL-devel >= 1.2
163 Requires:       libstdc++-devel
164 Provides:       OpenGL-GLU-devel = 1.3
165
166 %description libGLU-devel
167 Header files for SGI libGLU library.
168
169 %description libGLU-devel -l pl.UTF-8
170 Pliki nagłówkowe biblioteki SGI libGLU.
171
172 %package libGLU-static
173 Summary:        Static SGI libGLU library
174 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
175 License:        SGI Free Software License B v2.0 (MIT-like)
176 Group:          Development/Libraries
177 Requires:       %{name}-libGLU-devel = %{version}-%{release}
178 Provides:       OpenGL-GLU-static = 1.3
179
180 %description libGLU-static
181 Static SGI libGLU library.
182
183 %description libGLU-static -l pl.UTF-8
184 Statyczna biblioteka SGI libGLU.
185
186 %package libGLw
187 Summary:        SGI OpenGL Xt widgets library
188 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
189 License:        SGI MIT-like
190 Group:          Libraries
191 # loose dependency on libGL.so.1 to use with other libGL binaries
192 Requires:       OpenGL >= 1.1
193 Provides:       OpenGL-GLw
194
195 %description libGLw
196 SGI OpenGL Xt widgets library.
197
198 %description libGLU -l pl.UTF-8
199 Biblioteka SGI widgetów Xt dla OpenGL-a.
200
201 %package libGLw-devel
202 Summary:        Header files for SGI libGLw library
203 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
204 License:        SGI MIT-like
205 Group:          Development/Libraries
206 Requires:       %{name}-libGLw = %{version}-%{release}
207 Requires:       OpenGL-devel >= 1.2
208 Provides:       OpenGL-GLw-devel
209
210 %description libGLw-devel
211 Header files for SGI libGLw library.
212
213 %description libGLw-devel -l pl.UTF-8
214 Pliki nagłówkowe biblioteki SGI libGLw.
215
216 %package libGLw-static
217 Summary:        Static SGI libGLw library
218 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
219 License:        SGI MIT-like
220 Group:          Development/Libraries
221 Requires:       %{name}-libGLw-devel = %{version}-%{release}
222 Provides:       OpenGL-GLw-static
223
224 %description libGLw-static
225 Static SGI libGLw library.
226
227 %description libGLw-static -l pl.UTF-8
228 Statyczna biblioteka SGI libGLw.
229
230 %package libOSMesa
231 Summary:        OSMesa (off-screen renderer) library
232 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
233 License:        MIT
234 Group:          Libraries
235 # doesn't require base
236
237 %description libOSMesa
238 OSMesa (off-screen renderer) library.
239
240 %description libOSMesa -l pl.UTF-8
241 Biblioteka OSMesa (renderująca bitmapy w pamięci).
242
243 %package libOSMesa-devel
244 Summary:        Header file for OSMesa (off-screen renderer) library
245 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
246 License:        MIT
247 Group:          Development/Libraries
248 Requires:       %{name}-libOSMesa = %{version}-%{release}
249 # for <GL/gl.h> only
250 Requires:       OpenGL-devel
251
252 %description libOSMesa-devel
253 Header file for OSMesa (off-screen renderer) library.
254
255 %description libOSMesa-devel -l pl.UTF-8
256 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
257
258 %package libOSMesa-static
259 Summary:        Static OSMesa (off-screen renderer) library
260 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
261 License:        MIT
262 Group:          Development/Libraries
263 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
264 # this static build of OSMesa needs static non-dri Mesa implementation
265 Requires:       %{name}-libGL-static = %{version}-%{release}
266
267 %description libOSMesa-static
268 Static OSMesa (off-screen renderer) library.
269
270 %description libOSMesa-static -l pl.UTF-8
271 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
272
273 %package utils
274 Summary:        OpenGL utilities from Mesa3D
275 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
276 License:        MIT
277 Group:          X11/Applications/Graphics
278 # loose deps on libGL/libGLU
279
280 %description utils
281 OpenGL utilities from Mesa3D: glxgears and glxinfo.
282
283 %description utils -l pl.UTF-8
284 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
285
286 %package demos
287 Summary:        Mesa Demos source code
288 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
289 License:        various (MIT, SGI, GPL - see copyright notes in sources)
290 Group:          Development/Libraries
291 Requires:       OpenGL-devel
292
293 %description demos
294 Demonstration programs for the Mesa libraries in source code form.
295
296 %description demos -l pl.UTF-8
297 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
298
299 %package dri-driver-ati-mach64
300 Summary:        X.org DRI driver for ATI Mach64 card family
301 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
302 License:        MIT
303 Group:          X11/Libraries
304 Requires:       xorg-driver-video-mach64
305 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
306 Requires:       xorg-xserver-server >= %{xserver_ver}
307
308 %description dri-driver-ati-mach64
309 X.org DRI driver for ATI Mach64 card family.
310
311 %description dri-driver-ati-mach64 -l pl.UTF-8
312 Sterownik X.org DRI dla rodziny kart ATI Mach64.
313
314 %package dri-driver-ati-radeon-R100
315 Summary:        X.org DRI driver for ATI R100 card family
316 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
317 License:        MIT
318 Group:          X11/Libraries
319 Requires:       xorg-driver-video-ati
320 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
321 Requires:       xorg-xserver-server >= %{xserver_ver}
322 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
323
324 %description dri-driver-ati-radeon-R100
325 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
326
327 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
328 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
329
330 %package dri-driver-ati-radeon-R200
331 Summary:        X.org DRI driver for ATI R200 card family
332 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
333 License:        MIT
334 Group:          X11/Libraries
335 Requires:       xorg-driver-video-ati
336 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
337 Requires:       xorg-xserver-server >= %{xserver_ver}
338 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
339
340 %description dri-driver-ati-radeon-R200
341 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
342
343 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
344 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
345
346 %package dri-driver-ati-radeon-R300
347 Summary:        X.org DRI driver for ATI R300 card family
348 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
349 License:        MIT
350 Group:          X11/Libraries
351 Requires:       xorg-driver-video-ati
352 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
353 Requires:       xorg-xserver-server >= %{xserver_ver}
354 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
355
356 %description dri-driver-ati-radeon-R300
357 X.org DRI driver for ATI R300 card family.
358
359 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
360 Sterownik X.org DRI dla rodziny kart ATI R300.
361
362 %package dri-driver-ati-rage128
363 Summary:        X.org DRI driver for ATI Rage128 card family
364 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
365 License:        MIT
366 Group:          X11/Libraries
367 Requires:       xorg-driver-video-r128
368 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
369 Requires:       xorg-xserver-server >= %{xserver_ver}
370 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
371
372 %description dri-driver-ati-rage128
373 X.org DRI driver for ATI Rage128 card family.
374
375 %description dri-driver-ati-rage128 -l pl.UTF-8
376 Sterownik X.org DRI dla rodziny kart ATI Rage128.
377
378 %package dri-driver-ffb
379 Summary:        X.org DRI driver for Sun FFB card family
380 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
381 License:        MIT
382 Group:          X11/Libraries
383 Requires:       xorg-driver-video-sunffb
384 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
385 Requires:       xorg-xserver-server >= %{xserver_ver}
386
387 %description dri-driver-ffb
388 X.org DRI driver for SUN Creator3D and Elite3D card family.
389
390 %description dri-driver-ffb -l pl.UTF-8
391 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
392
393 %package dri-driver-glint
394 Summary:        X.org DRI driver for GLINT/Permedia card family
395 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
396 License:        MIT
397 Group:          X11/Libraries
398 Requires:       xorg-driver-video-glint
399 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
400 Requires:       xorg-xserver-server >= %{xserver_ver}
401 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
402
403 %description dri-driver-glint
404 X.org DRI driver for GLINT/Permedia card family.
405
406 %description dri-driver-glint -l pl.UTF-8
407 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
408
409 %package dri-driver-intel-i810
410 Summary:        X.org DRI driver for Intel i810 card family
411 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
412 License:        MIT
413 Group:          X11/Libraries
414 Requires:       xorg-driver-video-intel
415 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
416 Requires:       xorg-xserver-server >= %{xserver_ver}
417 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
418
419 %description dri-driver-intel-i810
420 X.org DRI driver for Intel i810 card family.
421
422 %description dri-driver-intel-i810 -l pl.UTF-8
423 Sterownik X.org DRI dla rodziny kart Intel i810.
424
425 %package dri-driver-intel-i915
426 Summary:        X.org DRI driver for Intel i915 card family
427 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
428 License:        MIT
429 Group:          X11/Libraries
430 Requires:       xorg-driver-video-intel
431 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
432 Requires:       xorg-xserver-server >= %{xserver_ver}
433 Obsoletes:      Mesa-dri-driver-intel-i830
434 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
435
436 %description dri-driver-intel-i915
437 X.org DRI driver for Intel i915 card family.
438
439 %description dri-driver-intel-i915 -l pl.UTF-8
440 Sterownik X.org DRI dla rodziny kart Intel i915.
441
442 %package dri-driver-intel-i965
443 Summary:        X.org DRI driver for Intel i965 card family
444 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
445 License:        MIT
446 Group:          X11/Libraries
447 Requires:       xorg-driver-video-intel
448 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
449 Requires:       xorg-xserver-server >= %{xserver_ver}
450 Obsoletes:      Mesa-dri-driver-intel-i830
451 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
452
453 %description dri-driver-intel-i965
454 X.org DRI driver for Intel i965 card family.
455
456 %description dri-driver-intel-i965 -l pl.UTF-8
457 Sterownik X.org DRI dla rodziny kart Intel i965.
458
459 %package dri-driver-matrox
460 Summary:        X.org DRI driver for Matrox G card family
461 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
462 License:        MIT
463 Group:          X11/Libraries
464 Requires:       xorg-driver-video-mga
465 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
466 Requires:       xorg-xserver-server >= %{xserver_ver}
467 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
468
469 %description dri-driver-matrox
470 X.org DRI drivers for Matrox G card family.
471
472 %description dri-driver-matrox -l pl.UTF-8
473 Sterowniki X.org DRI dla rodziny kart Matrox G.
474
475 %package dri-driver-s3virge
476 Summary:        X.org DRI driver for S3 Virge card family
477 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
478 License:        MIT
479 Group:          X11/Libraries
480 Requires:       xorg-driver-video-s3virge
481 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
482 Requires:       xorg-xserver-server >= %{xserver_ver}
483
484 %description dri-driver-s3virge
485 X.org DRI driver for S3 Virge card family.
486
487 %description dri-driver-s3virge -l pl.UTF-8
488 Sterownik X.org DRI dla rodziny kart S3 Virge.
489
490 %package dri-driver-savage
491 Summary:        X.org DRI driver for S3 Savage card family
492 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
493 License:        MIT
494 Group:          X11/Libraries
495 Requires:       xorg-driver-video-savage
496 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
497 Requires:       xorg-xserver-server >= %{xserver_ver}
498
499 %description dri-driver-savage
500 X.org DRI driver for S3 Savage card family.
501
502 %description dri-driver-savage -l pl.UTF-8
503 Sterownik X.org DRI dla rodziny kart S3 Savage.
504
505 %package dri-driver-sis
506 Summary:        X.org DRI driver for SiS card family
507 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
508 License:        MIT
509 Group:          X11/Libraries
510 Requires:       xorg-driver-video-sis
511 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
512 Requires:       xorg-xserver-server >= %{xserver_ver}
513 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
514
515 %description dri-driver-sis
516 X.org DRI driver for SiS card family.
517
518 %description dri-driver-sis -l pl.UTF-8
519 Sterownik X.org DRI dla rodziny kart SiS.
520
521 %package dri-driver-swrast
522 Summary:        X.org DRI software rasterizer driver
523 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
524 License:        MIT
525 Group:          X11/Libraries
526 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
527 Requires:       xorg-xserver-server >= %{xserver_ver}
528
529 %description dri-driver-swrast
530 X.org DRI software rasterizer driver.
531
532 %description dri-driver-swrast -l pl.UTF-8
533 Sterownik X.org DRI obsługujący rysowanie programowe.
534
535 %package dri-driver-tdfx
536 Summary:        X.org DRI driver for 3DFX Voodoo card family
537 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
538 License:        MIT
539 Group:          X11/Libraries
540 Requires:       Glide3-DRI
541 Requires:       xorg-driver-video-tdfx
542 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
543 Requires:       xorg-xserver-server >= %{xserver_ver}
544 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
545
546 %description dri-driver-tdfx
547 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
548 and Velocity 100/200).
549
550 %description dri-driver-tdfx -l pl.UTF-8
551 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
552 Banshee i Velocity 100/200).
553
554 %package dri-driver-trident
555 Summary:        X.org DRI driver for Trident card family
556 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
557 License:        MIT
558 Group:          X11/Libraries
559 Requires:       xorg-driver-video-trident
560 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
561 Requires:       xorg-xserver-server >= %{xserver_ver}
562
563 %description dri-driver-trident
564 X.org DRI drivers for Trident card family.
565
566 %description dri-driver-trident -l pl.UTF-8
567 Sterowniki X.org DRI dla rodziny kart Trident.
568
569 %package dri-driver-via-unichrome
570 Summary:        X.org DRI driver for VIA Unichrome card family
571 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
572 License:        MIT
573 Group:          X11/Libraries
574 Requires:       xorg-driver-video-via
575 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
576 Requires:       xorg-xserver-server >= %{xserver_ver}
577
578 %description dri-driver-via-unichrome
579 X.org DRI driver for VIA Unichrome card family.
580
581 %description dri-driver-via-unichrome -l pl.UTF-8
582 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
583
584 %prep
585 %setup -q -b1
586 %patch0 -p0
587 %patch1 -p1
588
589 # fix demos
590 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
591
592 # s3v, sis, trident missing there - don't override list from linux-dri
593 sed -i -e '/^DRI_DIRS/d' configs/linux-dri-x86-64
594
595 # add swrast driver
596 sed -i -e 's/ i810 / swrast i810 /' configs/linux-dri
597
598 %ifnarch sparc sparcv9 sparc64
599 # for sunffb driver - useful on sparc only
600 sed -i -e 's/ ffb\>//' configs/linux-dri
601 %endif
602
603 %ifnarch %{ix86} %{x8664}
604 # sis needs write-memory barrier
605 sed -i -e 's/ sis / /' configs/linux-dri
606 %endif
607
608 %build
609 # use $lib, not %{_lib} as Mesa uses lib64 only for *-x86-64* targets
610 %ifarch %{x8664}
611 targ=-x86-64
612 lib=lib64
613 %else
614 lib=lib
615 %ifarch %{ix86}
616 targ=-x86
617 %else
618 targ=""
619 %endif
620 %endif
621
622 # required for -bc --short-circuit
623 %{__make} realclean
624 # as above - existing directory makes mv move into instead of rename
625 rm -rf lib-{dri,osmesa,static}
626
627 %{__make} linux${targ}-static \
628         CC="%{__cc}" \
629         CXX="%{__cxx}" \
630         OPT_FLAGS="%{rpmcppflags} %{rpmcflags} -fno-strict-aliasing" \
631         XLIB_DIR=%{_libdir} \
632         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
633         SRC_DIRS="mesa glu glw" \
634         PROGRAM_DIRS=
635 mv -f ${lib} lib-static
636 %{__make} realclean
637
638 %{__make} linux-osmesa \
639         CC="%{__cc}" \
640         CXX="%{__cxx}" \
641         CFLAGS="%{rpmcppflags} %{rpmcflags} -fno-strict-aliasing -fPIC" \
642         XLIB_DIR=%{_libdir} \
643         SRC_DIRS="mesa" \
644         PROGRAM_DIRS=
645 mv -f lib lib-osmesa
646 %{__make} realclean
647
648 %{__make} linux-dri${targ} \
649         CC="%{__cc}" \
650         CXX="%{__cxx}" \
651         MKDEP=makedepend \
652         OPT_FLAGS="%{rpmcppflags} %{rpmcflags} -fno-strict-aliasing %{?with_ttm:-DTTM_API}" \
653         XLIB_DIR=%{_libdir} \
654         DRI_DRIVER_SEARCH_DIR=%{_libdir}/xorg/modules/dri \
655         SRC_DIRS="glx/x11 mesa glu glw" \
656         PROGRAM_DIRS=
657
658 %{__make} -C progs/xdemos \
659         CC="%{__cc}" \
660         CXX="%{__cxx}" \
661         OPT_FLAGS="%{rpmcppflags} %{rpmcflags}" \
662         XLIB_DIR=%{_libdir} \
663         PROGS="glxgears" \
664         APP_LIB_DEPS="-L../../${lib} -lGL"
665
666 %{__make} -C progs/xdemos \
667         CC="%{__cc}" \
668         CXX="%{__cxx}" \
669         OPT_FLAGS="%{rpmcppflags} %{rpmcflags}" \
670         XLIB_DIR=%{_libdir} \
671         PROGS="glxinfo" \
672         APP_LIB_DEPS="-L../../${lib} -lGL -lGLU"
673
674 mv -f ${lib} lib-dri
675
676 for d in mesa glu glw ; do
677         %{__make} -C src/$d `basename src/$d/*.pc.in .in` \
678                 INSTALL_DIR=%{_prefix} \
679                 LIB_DIR=%{_lib}
680 done
681
682 %install
683 rm -rf $RPM_BUILD_ROOT
684 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL/internal,%{_pkgconfigdir},%{_examplesdir}/%{name}-%{version}}
685 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
686
687 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
688 cp -df lib-osmesa/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
689 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
690 cp -rf include/GL/{gl[!f]*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
691 cp -rf include/GL/internal/dri_interface.h $RPM_BUILD_ROOT%{_includedir}/GL/internal
692 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
693
694 install src/mesa/gl.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
695 install src/glu/glu.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
696 install src/glw/glw.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
697
698 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
699 # work on copy to keep -bi --short-circuit working
700 rm -rf progs-clean
701 install -d progs-clean
702 for l in demos glsl osdemos redbook samples xdemos ; do
703         cp -a progs/$l progs-clean/$l
704         %{__make} -C progs-clean/$l clean
705         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
706 done
707 rm -rf progs-clean
708 for l in util images ; do
709         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
710 done
711 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
712
713 %if %{with multigl}
714 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
715
716 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
717 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
718
719 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
720 %endif
721
722 %clean
723 rm -rf $RPM_BUILD_ROOT
724
725 %post   libGL -p /sbin/ldconfig
726 %postun libGL -p /sbin/ldconfig
727
728 %post   libGLU -p /sbin/ldconfig
729 %postun libGLU -p /sbin/ldconfig
730
731 %post   libGLw -p /sbin/ldconfig
732 %postun libGLw -p /sbin/ldconfig
733
734 %files libGL
735 %defattr(644,root,root,755)
736 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
737 %if %{with multigl}
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
739 %dir %{_libdir}/Mesa
740 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
741 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
742 %else
743 %attr(755,root,root) %{_libdir}/libGL.so.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
745 # symlink for binary apps which fail to conform Linux OpenGL ABI
746 # (and dlopen libGL.so instead of libGL.so.1)
747 %attr(755,root,root) %{_libdir}/libGL.so
748 %endif
749
750 %files libGL-devel
751 %defattr(644,root,root,755)
752 %doc docs/*.spec
753 %if %{with multigl}
754 %attr(755,root,root) %{_libdir}/libGL.so
755 %endif
756 %dir %{_includedir}/GL
757 %{_includedir}/GL/gl.h
758 %{_includedir}/GL/glext.h
759 %{_includedir}/GL/gl_mangle.h
760 %{_includedir}/GL/glx.h
761 %{_includedir}/GL/glxext.h
762 %{_includedir}/GL/glx_mangle.h
763 %dir %{_includedir}/GL/internal
764 %{_includedir}/GL/internal/dri_interface.h
765 %{_pkgconfigdir}/gl.pc
766
767 %files libGL-static
768 %defattr(644,root,root,755)
769 %{_libdir}/libGL.a
770 # x11 (non-dri) Mesa API
771 %{_includedir}/GL/xmesa.h
772 %{_includedir}/GL/xmesa_x.h
773 %{_includedir}/GL/xmesa_xf86.h
774
775 %files libGLU
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
778 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
779
780 %files libGLU-devel
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_libdir}/libGLU.so
783 %{_includedir}/GL/glu.h
784 %{_includedir}/GL/glu_mangle.h
785 %{_pkgconfigdir}/glu.pc
786
787 %files libGLU-static
788 %defattr(644,root,root,755)
789 %{_libdir}/libGLU.a
790
791 %files libGLw
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
794 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
795
796 %files libGLw-devel
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{_libdir}/libGLw.so
799 %{_includedir}/GL/GLwDrawA.h
800 %{_includedir}/GL/GLwDrawAP.h
801 %{_includedir}/GL/GLwMDrawA.h
802 %{_includedir}/GL/GLwMDrawAP.h
803 %{_pkgconfigdir}/glw.pc
804
805 %files libGLw-static
806 %defattr(644,root,root,755)
807 %{_libdir}/libGLw.a
808
809 %files libOSMesa
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
812 %attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.[0-9]
813
814 %files libOSMesa-devel
815 %defattr(644,root,root,755)
816 %attr(755,root,root) %{_libdir}/libOSMesa.so
817 %{_includedir}/GL/osmesa.h
818
819 %files libOSMesa-static
820 %defattr(644,root,root,755)
821 %{_libdir}/libOSMesa.a
822
823 %files utils
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_bindir}/glxgears
826 %attr(755,root,root) %{_bindir}/glxinfo
827
828 %files dri-driver-ati-mach64
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
831
832 %files dri-driver-ati-radeon-R100
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
835
836 %files dri-driver-ati-radeon-R200
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
839
840 %files dri-driver-ati-radeon-R300
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
843
844 %files dri-driver-ati-rage128
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
847
848 # sunffb (sparc only)
849 %ifarch sparc sparcv9 sparc64
850 %files dri-driver-ffb
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
853 %endif
854
855 # glint (requires update)
856 %if 0
857 %files dri-driver-glint
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
860 %endif
861
862 %files dri-driver-intel-i810
863 %defattr(644,root,root,755)
864 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
865
866 %files dri-driver-intel-i915
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
869
870 %files dri-driver-intel-i965
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
873
874 %files dri-driver-matrox
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
877
878 %files dri-driver-s3virge
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
881
882 %files dri-driver-savage
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
885
886 %ifarch %{ix86} %{x8664}
887 %files dri-driver-sis
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
890 %endif
891
892 %files dri-driver-swrast
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
895
896 %files dri-driver-tdfx
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
899
900 %files dri-driver-trident
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
903
904 %files dri-driver-via-unichrome
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
907
908 %files demos
909 %defattr(644,root,root,755)
910 %{_examplesdir}/%{name}-%{version}
This page took 0.135794 seconds and 4 git commands to generate.