]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- updated to 6.4.1 (bugfixes)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 #
5 # Conditional build:
6 %bcond_with     glide   # with GLIDE (broken now)
7 %bcond_without  motif   # build static libGLw without Motif interface
8 #
9 Summary:        Free OpenGL implementation
10 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
11 Name:           Mesa
12 Version:        6.4.1
13 Release:        1
14 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
17 # Source0-md5:  ea148c828ec6f645526451db1b8556f1
18 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
19 # Source1-md5:  99df1fdcb98d391666b476ca6f1dda8a
20 URL:            http://www.mesa3d.org/
21 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
22 BuildRequires:  expat-devel
23 BuildRequires:  libdrm-devel >= 1.0.4-1.20051022
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.4d
26 %{?with_motif:BuildRequires:    motif-devel}
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  xorg-lib-libXt-devel
29 BuildRequires:  xorg-lib-libXxf86vm-devel
30 BuildRequires:  xorg-proto-glproto-devel
31 BuildRequires:  xorg-util-makedepend
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # avoid XFree86-OpenGL* dependency
35 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
37
38 %define         _sysconfdir     /etc/X11
39
40 %description
41 Mesa is a 3-D graphics library with an API which is very similar to
42 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
43 syntax or state machine, it is being used with authorization from
44 Silicon Graphics, Inc. However, the author does not possess an OpenGL
45 license from SGI, and makes no claim that Mesa is in any way a
46 compatible replacement for OpenGL or associated with SGI.
47
48 %description -l pl
49 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
50 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
51 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
52 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
53 OpenGL ani powi±zana z SGI.
54
55 %package libGL
56 Summary:        Free Mesa3D implementation of libGL OpenGL library
57 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
58 License:        MIT
59 Group:          X11/Libraries
60 %{?with_glide:Requires: Glide3-DRI}
61 Provides:       OpenGL = 1.5
62 # reports version 1.3, but supports glXGetProcAddress() from 1.4
63 Provides:       OpenGL-GLX = 1.4
64 Obsoletes:      Mesa
65 Obsoletes:      XFree86-OpenGL-libGL
66
67 %description libGL
68 Mesa is a 3-D graphics library with an API which is very similar to
69 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
70 syntax or state machine, it is being used with authorization from
71 Silicon Graphics, Inc. However, the author does not possess an OpenGL
72 license from SGI, and makes no claim that Mesa is in any way a
73 compatible replacement for OpenGL or associated with SGI.
74
75 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
76 specifications. It uses DRI for rendering.
77
78 %description libGL -l pl
79 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
80 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
81 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
82 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
83 OpenGL ani powi±zana z SGI.
84
85 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
86 GLX 1.4. U¿ywa DRI do renderowania.
87
88 %package libGL-devel
89 Summary:        Header files for Mesa3D libGL library
90 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
91 License:        MIT
92 Group:          X11/Development/Libraries
93 # loose dependency on libGL to use with other libGL binaries
94 Requires:       OpenGL >= 1.5
95 Requires:       xorg-lib-libX11-devel
96 Provides:       OpenGL-devel = 1.5
97 Provides:       OpenGL-GLX-devel = 1.4
98 Obsoletes:      Mesa-devel
99 Obsoletes:      XFree86-OpenGL-devel
100 Obsoletes:      XFree86-OpenGL-devel-base
101
102 %description libGL-devel
103 Header files for Mesa3D libGL library.
104
105 %description libGL-devel -l pl
106 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
107
108 %package libGL-static
109 Summary:        Static Mesa3D libGL library
110 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
111 License:        MIT
112 Group:          X11/Development/Libraries
113 Requires:       %{name}-libGL-devel = %{version}-%{release}
114 Provides:       OpenGL-static = 1.5
115 Obsoletes:      Mesa-static
116
117 %description libGL-static
118 Static Mesa3D libGL library. It uses software renderer.
119
120 %description libGL-static -l pl
121 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
122 renderingu.
123
124 %package libGLU
125 Summary:        SGI implementation of libGLU OpenGL library
126 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
127 License:        SGI Free Software License B v1.1
128 Group:          Libraries
129 # loose dependency on libGL.so.1 to use with other libGL binaries
130 Requires:       OpenGL >= 1.2
131 Provides:       OpenGL-GLU = 1.3
132 Obsoletes:      Mesa-devel
133 Obsoletes:      XFree86-OpenGL-libs
134
135 %description libGLU
136 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
137 1.3 specifications.
138
139 %description libGLU -l pl
140 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
141 specyfikacjê OpenGL GLU 1.3.
142
143 %package libGLU-devel
144 Summary:        Header files for SGI libGLU library
145 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
146 License:        SGI Free Software License B v1.1
147 Group:          Development/Libraries
148 Requires:       %{name}-libGLU = %{version}-%{release}
149 Requires:       OpenGL-devel >= 1.2
150 Requires:       libstdc++-devel
151 Provides:       OpenGL-GLU-devel = 1.3
152
153 %description libGLU-devel
154 Header files for SGI libGLU library.
155
156 %description libGLU-devel -l pl
157 Pliki nag³ówkowe biblioteki SGI libGLU.
158
159 %package libGLU-static
160 Summary:        Static SGI libGLU library
161 Summary(pl):    Statyczna biblioteka SGI libGLU
162 License:        SGI Free Software License B v1.1
163 Group:          Development/Libraries
164 Requires:       %{name}-libGLU-devel = %{version}-%{release}
165 Provides:       OpenGL-GLU-static = 1.3
166
167 %description libGLU-static
168 Static SGI libGLU library.
169
170 %description libGLU-static -l pl
171 Statyczna biblioteka SGI libGLU.
172
173 %package libGLw
174 Summary:        SGI OpenGL Xt widgets library
175 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
176 License:        SGI MIT-like
177 Group:          Libraries
178 # loose dependency on libGL.so.1 to use with other libGL binaries
179 Requires:       OpenGL >= 1.1
180 Provides:       OpenGL-GLw
181
182 %description libGLw
183 SGI OpenGL Xt widgets library.
184
185 %description libGLU -l pl
186 Biblioteka SGI widgetów Xt dla OpenGL-a.
187
188 %package libGLw-devel
189 Summary:        Header files for SGI libGLw library
190 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
191 License:        SGI Free Software License B v1.1
192 Group:          Development/Libraries
193 Requires:       %{name}-libGLw = %{version}-%{release}
194 Requires:       OpenGL-devel >= 1.2
195 Provides:       OpenGL-GLw-devel
196
197 %description libGLw-devel
198 Header files for SGI libGLw library.
199
200 %description libGLw-devel -l pl
201 Pliki nag³ówkowe biblioteki SGI libGLw.
202
203 %package libGLw-static
204 Summary:        Static SGI libGLw library
205 Summary(pl):    Statyczna biblioteka SGI libGLw
206 License:        SGI Free Software License B v1.1
207 Group:          Development/Libraries
208 Requires:       %{name}-libGLw-devel = %{version}-%{release}
209 Provides:       OpenGL-GLw-static
210
211 %description libGLw-static
212 Static SGI libGLw library.
213
214 %description libGLw-static -l pl
215 Statyczna biblioteka SGI libGLw.
216
217 %package utils
218 Summary:        OpenGL utilities from Mesa3D
219 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
220 Group:          X11/Applications/Graphisc
221 # loose deps on libGL/libGLU
222
223 %description utils
224 OpenGL utilities from Mesa3D: glxgears and glxinfo.
225
226 %description utils -l pl
227 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
228
229 %package demos
230 Summary:        Mesa Demos
231 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
232 Group:          Development/Libraries
233 Requires:       OpenGL-devel
234
235 %description demos
236 Demonstration programs for the Mesa libraries.
237
238 %description demos -l pl
239 Programy demonstracyjne dla bibliotek Mesa.
240
241 %package dri
242 Summary:        X.org DRI drivers
243 Summary(pl):    Sterowniki DRI dla X.org
244 Group:          Development/Libraries
245 Requires:       xorg-xserver-server
246
247 %description dri
248 X.org DRI drivers.
249
250 %description dri -l pl
251 Sterowniki DRI dla X.org.
252
253 #%package dri-driver-ffb ...
254
255 %prep
256 %setup -q -n Mesa-%{version} -b 1
257
258 # fix demos
259 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
260
261 %ifnarch sparc sparcv9 sparc64
262 # for sunffb driver - useful on sparc only
263 sed -i -e 's/ ffb$//' configs/linux-dri
264 %endif
265
266 %build
267 %ifarch %{ix86}
268 targ=-x86
269 %else
270 targ=""
271 %endif
272
273 %{__make} linux${targ}-static \
274         CC="%{__cc}" \
275         CXX="%{__cxx}" \
276         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
277         XLIB_DIR=%{_libdir} \
278         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
279         SRC_DIRS="mesa glu glw" \
280         PROGRAM_DIRS=
281 mv -f lib lib-static
282 %{__make} clean
283
284 %{__make} linux-dri${targ} \
285         CC="%{__cc}" \
286         CXX="%{__cxx}" \
287         MKDEP=makedepend \
288         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
289         XLIB_DIR=%{_libdir} \
290         SRC_DIRS="glx/x11 mesa glu glw" \
291         PROGRAM_DIRS=
292
293 %{__make} -C progs/xdemos \
294         CC="%{__cc}" \
295         CXX="%{__cxx}" \
296         OPT_FLAGS="%{rpmcflags}" \
297         XLIB_DIR=%{_libdir} \
298         PROGS="glxgears" \
299         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL"
300
301 %{__make} -C progs/xdemos \
302         CC="%{__cc}" \
303         CXX="%{__cxx}" \
304         OPT_FLAGS="%{rpmcflags}" \
305         XLIB_DIR=%{_libdir} \
306         PROGS="glxinfo" \
307         APP_LIB_DEPS="-L\$(LIB_DIR) -lGLU -lGL"
308
309 mv -f lib lib-dri
310 %{__make} clean \
311         MKDEP=makedepend
312
313 %{__make} linux${targ} \
314         CC="%{__cc}" \
315         CXX="%{__cxx}" \
316         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
317         XLIB_DIR=%{_libdir} \
318         SRC_DIRS="mesa" \
319         PROGRAM_DIRS=
320
321 %install
322 rm -rf $RPM_BUILD_ROOT
323 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
324 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
325
326 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
327 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
328 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
329 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
330 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
331
332 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
333 for l in demos redbook samples xdemos ; do
334         %{__make} -C progs/$l clean
335 done
336 for l in demos redbook samples util xdemos images ; do
337         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
338 done
339 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
340
341 %clean
342 rm -rf $RPM_BUILD_ROOT
343
344 %post   libGL -p /sbin/ldconfig
345 %postun libGL -p /sbin/ldconfig
346
347 %post   libGLU -p /sbin/ldconfig
348 %postun libGLU -p /sbin/ldconfig
349
350 %post   libGLw -p /sbin/ldconfig
351 %postun libGLw -p /sbin/ldconfig
352
353 %files libGL
354 %defattr(644,root,root,755)
355 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
356 %attr(755,root,root) %{_libdir}/libGL.so.*.*
357 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
358 # symlink for binary apps which fail to conform Linux OpenGL ABI
359 # (and dlopen libGL.so instead of libGL.so.1)
360 %attr(755,root,root) %{_libdir}/libGL.so
361
362 %files libGL-devel
363 %defattr(644,root,root,755)
364 %doc docs/*.spec
365 %attr(755,root,root) %{_libdir}/libOSMesa.so
366 %dir %{_includedir}/GL
367 %{_includedir}/GL/gl.h
368 %{_includedir}/GL/glext.h
369 %{_includedir}/GL/gl_mangle.h
370 %{_includedir}/GL/glx.h
371 %{_includedir}/GL/glxext.h
372 %{_includedir}/GL/glx_mangle.h
373 %{_includedir}/GL/osmesa.h
374 %{_includedir}/GL/xmesa.h
375 %{_includedir}/GL/xmesa_x.h
376 %{_includedir}/GL/xmesa_xf86.h
377
378 %files libGL-static
379 %defattr(644,root,root,755)
380 %{_libdir}/libGL.a
381 %{_libdir}/libOSMesa.a
382
383 %files libGLU
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
386
387 %files libGLU-devel
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_libdir}/libGLU.so
390 %{_includedir}/GL/glu.h
391 %{_includedir}/GL/glu_mangle.h
392
393 %files libGLU-static
394 %defattr(644,root,root,755)
395 %{_libdir}/libGLU.a
396
397 %files libGLw
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
400
401 %files libGLw-devel
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{_libdir}/libGLw.so
404 %{_includedir}/GL/GLwDrawA.h
405 %{_includedir}/GL/GLwDrawAP.h
406 %{_includedir}/GL/GLwMDrawA.h
407 %{_includedir}/GL/GLwMDrawAP.h
408
409 %files libGLw-static
410 %defattr(644,root,root,755)
411 %{_libdir}/libGLw.a
412
413 %files utils
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_bindir}/glxgears
416 %attr(755,root,root) %{_bindir}/glxinfo
417
418 %files dri
419 %defattr(644,root,root,755)
420 %dir %{_libdir}/xorg/modules/dri
421 # XXX: split
422 %ifarch sparc sparcv9 sparc64
423 # sunffb (sparc only)
424 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
425 %endif
426 # i810
427 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
428 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
429 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
430 # ati
431 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
432 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
433 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
434 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
435 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
436 # glint (requires update)
437 #%attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
438 # mga
439 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
440 # s3virge (but driver not ready?)
441 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
442 # savage
443 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
444 # sis
445 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
446 # tdfx
447 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
448 # trident
449 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
450 # via
451 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
452
453 %files demos
454 %defattr(644,root,root,755)
455 %{_examplesdir}/%{name}-%{version}
This page took 0.089459 seconds and 3 git commands to generate.