]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- updated dri2proto version
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos           # don't build demos
9 %bcond_with     egl             # don't build egl
10 %bcond_without  gallium         # don't build gallium
11 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_with     gallium_nouveau # gallium nouveau driver
13 %bcond_without  motif           # build static libGLw without Motif interface
14 %bcond_with     multigl         # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
15 %bcond_without  osmesa          # don't build osmesa
16 %bcond_with     static          # build static libraries
17 #
18 # minimal supported xserver version
19 %if %{with gallium}
20 %define         xserver_ver     1.6.0
21 %else
22 %define         xserver_ver     1.5.0
23 %endif
24
25 # glapi version (glapi tables in dri drivers and libglx must be in sync);
26 # set to current Mesa version on ABI break, when xserver tables get regenerated
27 # (until they start to be somehow versioned themselves)
28 %define         glapi_ver       7.1.0
29 #
30 %define         libdrm_ver      2.4.19
31 %define         dri2proto_ver   2.1
32 %define         glproto_ver     1.4.11
33 #
34 Summary:        Free OpenGL implementation
35 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
36 Name:           Mesa
37 Version:        7.8.2
38 Release:        1%{?with_multigl:.mgl}
39 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
40 Group:          X11/Libraries
41 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
42 # Source0-md5:  6be2d343a0089bfd395ce02aaf8adb57
43 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
44 # Source1-md5:  757d9e2e06f48b1a52848be9b0307ced
45 Patch0:         %{name}-realclean.patch
46 Patch1:         %{name}-tgsi_dump.patch
47 URL:            http://www.mesa3d.org/
48 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  expat-devel
52 #%%{?with_demos:BuildRequires:  glew-devel}
53 BuildRequires:  libdrm-devel >= %{libdrm_ver}
54 BuildRequires:  libselinux-devel
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  libtool >= 2:1.4d
57 %{?with_motif:BuildRequires:    motif-devel}
58 BuildRequires:  pixman-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  python
61 BuildRequires:  python-modules
62 BuildRequires:  rpmbuild(macros) >= 1.470
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  xorg-lib-libXdamage-devel
65 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
66 BuildRequires:  xorg-lib-libXt-devel
67 BuildRequires:  xorg-lib-libXxf86vm-devel
68 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
69 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
70 BuildRequires:  xorg-util-makedepend
71 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %if %{without gallium}
75 %undefine       with_gallium_intel
76 %endif
77
78 %description
79 Mesa is a 3-D graphics library with an API which is very similar to
80 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
81 syntax or state machine, it is being used with authorization from
82 Silicon Graphics, Inc. However, the author does not possess an OpenGL
83 license from SGI, and makes no claim that Mesa is in any way a
84 compatible replacement for OpenGL or associated with SGI.
85
86 %description -l pl.UTF-8
87 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
88 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
89 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
90 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
91 OpenGL ani powiązana z SGI.
92
93 %package libGL
94 Summary:        Free Mesa3D implementation of libGL OpenGL library
95 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
96 License:        MIT
97 Group:          X11/Libraries
98 Requires:       libdrm >= %{libdrm_ver}
99 Provides:       OpenGL = 2.1
100 # reports version 1.3, but supports glXGetProcAddress() from 1.4
101 Provides:       OpenGL-GLX = 1.4
102 Obsoletes:      Mesa
103 Obsoletes:      Mesa-dri
104 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
105 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
106
107 %description libGL
108 Mesa is a 3-D graphics library with an API which is very similar to
109 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
110 syntax or state machine, it is being used with authorization from
111 Silicon Graphics, Inc. However, the author does not possess an OpenGL
112 license from SGI, and makes no claim that Mesa is in any way a
113 compatible replacement for OpenGL or associated with SGI.
114
115 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
116 specifications. It uses DRI for rendering.
117
118 %description libGL -l pl.UTF-8
119 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
120 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
121 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
122 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
123 OpenGL ani powiązana z SGI.
124
125 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
126 GLX 1.4. Używa DRI do renderowania.
127
128 %package libGL-devel
129 Summary:        Header files for Mesa3D libGL library
130 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
131 License:        MIT
132 Group:          X11/Development/Libraries
133 # loose dependency on libGL to use with other libGL binaries
134 Requires:       OpenGL >= 1.5
135 Requires:       libdrm-devel >= %{libdrm_ver}
136 Requires:       xorg-lib-libX11-devel
137 Requires:       xorg-lib-libXdamage-devel
138 Requires:       xorg-lib-libXext-devel
139 Requires:       xorg-lib-libXxf86vm-devel
140 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
141 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
142 Suggests:       OpenGL-doc-man
143 Provides:       OpenGL-GLX-devel = 1.4
144 Provides:       OpenGL-devel = 2.1
145 Obsoletes:      Mesa-devel
146 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
147 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
148 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
149 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
150
151 %description libGL-devel
152 Header files for Mesa3D libGL library.
153
154 %description libGL-devel -l pl.UTF-8
155 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
156
157 %package libGL-static
158 Summary:        Static Mesa3D libGL library
159 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
160 License:        MIT
161 Group:          X11/Development/Libraries
162 Requires:       %{name}-libGL-devel = %{version}-%{release}
163 Provides:       OpenGL-static = 2.1
164 Obsoletes:      Mesa-static
165 Obsoletes:      X11-OpenGL-static < 1:7.0.0
166 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
167
168 %description libGL-static
169 Static Mesa3D libGL library. It uses software renderer.
170
171 %description libGL-static -l pl.UTF-8
172 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
173 renderingu.
174
175 %package libGLU
176 Summary:        SGI implementation of libGLU OpenGL library
177 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
178 License:        SGI Free Software License B v2.0 (MIT-like)
179 Group:          Libraries
180 # loose dependency on libGL.so.1 to use with other libGL binaries
181 Requires:       OpenGL >= 1.2
182 Provides:       OpenGL-GLU = 1.3
183 Obsoletes:      Mesa-devel
184 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
185 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
186
187 %description libGLU
188 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
189 1.3 specifications.
190
191 %description libGLU -l pl.UTF-8
192 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
193 specyfikację OpenGL GLU 1.3.
194
195 %package libGLU-devel
196 Summary:        Header files for SGI libGLU library
197 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
198 License:        SGI Free Software License B v2.0 (MIT-like)
199 Group:          Development/Libraries
200 Requires:       %{name}-libGLU = %{version}-%{release}
201 Requires:       OpenGL-devel >= 1.2
202 Requires:       libstdc++-devel
203 Provides:       OpenGL-GLU-devel = 1.3
204
205 %description libGLU-devel
206 Header files for SGI libGLU library.
207
208 %description libGLU-devel -l pl.UTF-8
209 Pliki nagłówkowe biblioteki SGI libGLU.
210
211 %package libGLU-static
212 Summary:        Static SGI libGLU library
213 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
214 License:        SGI Free Software License B v2.0 (MIT-like)
215 Group:          Development/Libraries
216 Requires:       %{name}-libGLU-devel = %{version}-%{release}
217 Provides:       OpenGL-GLU-static = 1.3
218
219 %description libGLU-static
220 Static SGI libGLU library.
221
222 %description libGLU-static -l pl.UTF-8
223 Statyczna biblioteka SGI libGLU.
224
225 %package libGLw
226 Summary:        SGI OpenGL Xt widgets library
227 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
228 License:        SGI MIT-like
229 Group:          Libraries
230 # loose dependency on libGL.so.1 to use with other libGL binaries
231 Requires:       OpenGL >= 1.1
232 Provides:       OpenGL-GLw
233
234 %description libGLw
235 SGI OpenGL Xt widgets library.
236
237 %description libGLU -l pl.UTF-8
238 Biblioteka SGI widgetów Xt dla OpenGL-a.
239
240 %package libGLw-devel
241 Summary:        Header files for SGI libGLw library
242 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
243 License:        SGI MIT-like
244 Group:          Development/Libraries
245 Requires:       %{name}-libGLw = %{version}-%{release}
246 Requires:       OpenGL-devel >= 1.2
247 Provides:       OpenGL-GLw-devel
248
249 %description libGLw-devel
250 Header files for SGI libGLw library.
251
252 %description libGLw-devel -l pl.UTF-8
253 Pliki nagłówkowe biblioteki SGI libGLw.
254
255 %package libGLw-static
256 Summary:        Static SGI libGLw library
257 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
258 License:        SGI MIT-like
259 Group:          Development/Libraries
260 Requires:       %{name}-libGLw-devel = %{version}-%{release}
261 Provides:       OpenGL-GLw-static
262
263 %description libGLw-static
264 Static SGI libGLw library.
265
266 %description libGLw-static -l pl.UTF-8
267 Statyczna biblioteka SGI libGLw.
268
269 %package libOSMesa
270 Summary:        OSMesa (off-screen renderer) library
271 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
272 License:        MIT
273 Group:          Libraries
274 # doesn't require base
275
276 %description libOSMesa
277 OSMesa (off-screen renderer) library.
278
279 %description libOSMesa -l pl.UTF-8
280 Biblioteka OSMesa (renderująca bitmapy w pamięci).
281
282 %package libOSMesa-devel
283 Summary:        Header file for OSMesa (off-screen renderer) library
284 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
285 License:        MIT
286 Group:          Development/Libraries
287 Requires:       %{name}-libOSMesa = %{version}-%{release}
288 # for <GL/gl.h> only
289 Requires:       OpenGL-devel
290
291 %description libOSMesa-devel
292 Header file for OSMesa (off-screen renderer) library.
293
294 %description libOSMesa-devel -l pl.UTF-8
295 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
296
297 %package libOSMesa-static
298 Summary:        Static OSMesa (off-screen renderer) library
299 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
300 License:        MIT
301 Group:          Development/Libraries
302 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
303 # this static build of OSMesa needs static non-dri Mesa implementation
304 Requires:       %{name}-libGL-static = %{version}-%{release}
305
306 %description libOSMesa-static
307 Static OSMesa (off-screen renderer) library.
308
309 %description libOSMesa-static -l pl.UTF-8
310 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
311
312 %package utils
313 Summary:        OpenGL utilities from Mesa3D
314 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
315 License:        MIT
316 Group:          X11/Applications/Graphics
317 # loose deps on libGL/libGLU
318
319 %description utils
320 OpenGL utilities from Mesa3D: glxgears and glxinfo.
321
322 %description utils -l pl.UTF-8
323 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
324
325 %package demos
326 Summary:        Mesa Demos source code
327 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
328 License:        various (MIT, SGI, GPL - see copyright notes in sources)
329 Group:          Development/Libraries
330 Requires:       OpenGL-devel
331
332 %description demos
333 Demonstration programs for the Mesa libraries in source code form.
334
335 %description demos -l pl.UTF-8
336 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
337
338 %package dri-driver-ati-mach64
339 Summary:        X.org DRI driver for ATI Mach64 card family
340 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
341 License:        MIT
342 Group:          X11/Libraries
343 Requires:       xorg-driver-video-mach64
344 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
345 Requires:       xorg-xserver-server >= %{xserver_ver}
346
347 %description dri-driver-ati-mach64
348 X.org DRI driver for ATI Mach64 card family.
349
350 %description dri-driver-ati-mach64 -l pl.UTF-8
351 Sterownik X.org DRI dla rodziny kart ATI Mach64.
352
353 %package dri-driver-ati-radeon-R100
354 Summary:        X.org DRI driver for ATI R100 card family
355 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
356 License:        MIT
357 Group:          X11/Libraries
358 Requires:       xorg-driver-video-ati
359 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
360 Requires:       xorg-xserver-server >= %{xserver_ver}
361 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
362
363 %description dri-driver-ati-radeon-R100
364 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
365
366 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
367 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
368
369 %package dri-driver-ati-radeon-R200
370 Summary:        X.org DRI driver for ATI R200 card family
371 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
372 License:        MIT
373 Group:          X11/Libraries
374 Requires:       xorg-driver-video-ati
375 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
376 Requires:       xorg-xserver-server >= %{xserver_ver}
377 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
378
379 %description dri-driver-ati-radeon-R200
380 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
381
382 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
383 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
384
385 %package dri-driver-ati-radeon-R300
386 Summary:        X.org DRI driver for ATI R300 card family
387 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
388 License:        MIT
389 Group:          X11/Libraries
390 Requires:       xorg-driver-video-ati
391 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
392 Requires:       xorg-xserver-server >= %{xserver_ver}
393 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
394
395 %description dri-driver-ati-radeon-R300
396 X.org DRI driver for ATI R300 card family.
397
398 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
399 Sterownik X.org DRI dla rodziny kart ATI R300.
400
401 %package dri-driver-ati-radeon-R600
402 Summary:        X.org DRI driver for ATI R600 card family
403 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
404 License:        MIT
405 Group:          X11/Libraries
406 Requires:       radeon-ucode
407 Requires:       xorg-driver-video-ati
408 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
409 Requires:       xorg-xserver-server >= %{xserver_ver}
410
411 %description dri-driver-ati-radeon-R600
412 X.org DRI driver for ATI R600 card family.
413
414 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
415 Sterownik X.org DRI dla rodziny kart ATI R600.
416
417 %package dri-driver-ati-rage128
418 Summary:        X.org DRI driver for ATI Rage128 card family
419 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
420 License:        MIT
421 Group:          X11/Libraries
422 Requires:       xorg-driver-video-r128
423 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
424 Requires:       xorg-xserver-server >= %{xserver_ver}
425 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
426
427 %description dri-driver-ati-rage128
428 X.org DRI driver for ATI Rage128 card family.
429
430 %description dri-driver-ati-rage128 -l pl.UTF-8
431 Sterownik X.org DRI dla rodziny kart ATI Rage128.
432
433 %package dri-driver-ffb
434 Summary:        X.org DRI driver for Sun FFB card family
435 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
436 License:        MIT
437 Group:          X11/Libraries
438 Requires:       xorg-driver-video-sunffb
439 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
440 Requires:       xorg-xserver-server >= %{xserver_ver}
441
442 %description dri-driver-ffb
443 X.org DRI driver for SUN Creator3D and Elite3D card family.
444
445 %description dri-driver-ffb -l pl.UTF-8
446 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
447
448 %package dri-driver-glint
449 Summary:        X.org DRI driver for GLINT/Permedia card family
450 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
451 License:        MIT
452 Group:          X11/Libraries
453 Requires:       xorg-driver-video-glint
454 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
455 Requires:       xorg-xserver-server >= %{xserver_ver}
456 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
457
458 %description dri-driver-glint
459 X.org DRI driver for GLINT/Permedia card family.
460
461 %description dri-driver-glint -l pl.UTF-8
462 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
463
464 %package dri-driver-intel-i810
465 Summary:        X.org DRI driver for Intel i810 card family
466 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
467 License:        MIT
468 Group:          X11/Libraries
469 Requires:       xorg-driver-video-intel
470 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
471 Requires:       xorg-xserver-server >= %{xserver_ver}
472 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
473
474 %description dri-driver-intel-i810
475 X.org DRI driver for Intel i810 card family.
476
477 %description dri-driver-intel-i810 -l pl.UTF-8
478 Sterownik X.org DRI dla rodziny kart Intel i810.
479
480 %package dri-driver-intel-i915
481 Summary:        X.org DRI driver for Intel i915 card family
482 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
483 License:        MIT
484 Group:          X11/Libraries
485 Requires:       xorg-driver-video-intel
486 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
487 Requires:       xorg-xserver-server >= %{xserver_ver}
488 Obsoletes:      Mesa-dri-driver-intel-i830
489 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
490
491 %description dri-driver-intel-i915
492 X.org DRI driver for Intel i915 card family.
493
494 %description dri-driver-intel-i915 -l pl.UTF-8
495 Sterownik X.org DRI dla rodziny kart Intel i915.
496
497 %package dri-driver-intel-i965
498 Summary:        X.org DRI driver for Intel i965 card family
499 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
500 License:        MIT
501 Group:          X11/Libraries
502 Requires:       xorg-driver-video-intel
503 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
504 Requires:       xorg-xserver-server >= %{xserver_ver}
505 Obsoletes:      Mesa-dri-driver-intel-i830
506 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
507
508 %description dri-driver-intel-i965
509 X.org DRI driver for Intel i965 card family.
510
511 %description dri-driver-intel-i965 -l pl.UTF-8
512 Sterownik X.org DRI dla rodziny kart Intel i965.
513
514 %package dri-driver-matrox
515 Summary:        X.org DRI driver for Matrox G card family
516 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
517 License:        MIT
518 Group:          X11/Libraries
519 Requires:       xorg-driver-video-mga
520 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
521 Requires:       xorg-xserver-server >= %{xserver_ver}
522 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
523
524 %description dri-driver-matrox
525 X.org DRI drivers for Matrox G card family.
526
527 %description dri-driver-matrox -l pl.UTF-8
528 Sterowniki X.org DRI dla rodziny kart Matrox G.
529
530 %package dri-driver-nouveau
531 Summary:        X.org DRI driver for NVIDIA card family
532 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
533 License:        MIT
534 Group:          X11/Libraries
535 Requires:       xorg-driver-video-nouveau
536 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
537 Requires:       xorg-xserver-server >= %{xserver_ver}
538
539 %description dri-driver-nouveau
540 X.org DRI drivers for NVIDIA card family.
541
542 %description dri-driver-nouveau -l pl.UTF-8
543 Sterowniki X.org DRI dla rodziny kart NVIDIA.
544
545 %package dri-driver-savage
546 Summary:        X.org DRI driver for S3 Savage card family
547 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
548 License:        MIT
549 Group:          X11/Libraries
550 Requires:       xorg-driver-video-savage
551 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
552 Requires:       xorg-xserver-server >= %{xserver_ver}
553
554 %description dri-driver-savage
555 X.org DRI driver for S3 Savage card family.
556
557 %description dri-driver-savage -l pl.UTF-8
558 Sterownik X.org DRI dla rodziny kart S3 Savage.
559
560 %package dri-driver-sis
561 Summary:        X.org DRI driver for SiS card family
562 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
563 License:        MIT
564 Group:          X11/Libraries
565 Requires:       xorg-driver-video-sis
566 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
567 Requires:       xorg-xserver-server >= %{xserver_ver}
568 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
569
570 %description dri-driver-sis
571 X.org DRI driver for SiS card family.
572
573 %description dri-driver-sis -l pl.UTF-8
574 Sterownik X.org DRI dla rodziny kart SiS.
575
576 %package dri-driver-swrast
577 Summary:        X.org DRI software rasterizer driver
578 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
579 License:        MIT
580 Group:          X11/Libraries
581 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
582 Requires:       xorg-xserver-server >= %{xserver_ver}
583
584 %description dri-driver-swrast
585 X.org DRI software rasterizer driver.
586
587 %description dri-driver-swrast -l pl.UTF-8
588 Sterownik X.org DRI obsługujący rysowanie programowe.
589
590 %package dri-driver-tdfx
591 Summary:        X.org DRI driver for 3DFX Voodoo card family
592 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
593 License:        MIT
594 Group:          X11/Libraries
595 Requires:       Glide3-DRI
596 Requires:       xorg-driver-video-tdfx
597 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
598 Requires:       xorg-xserver-server >= %{xserver_ver}
599 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
600
601 %description dri-driver-tdfx
602 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
603 and Velocity 100/200).
604
605 %description dri-driver-tdfx -l pl.UTF-8
606 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
607 Banshee i Velocity 100/200).
608
609 %package dri-driver-via-unichrome
610 Summary:        X.org DRI driver for VIA Unichrome card family
611 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
612 License:        MIT
613 Group:          X11/Libraries
614 Requires:       xorg-driver-video-openchrome
615 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
616 Requires:       xorg-xserver-server >= %{xserver_ver}
617
618 %description dri-driver-via-unichrome
619 X.org DRI driver for VIA Unichrome card family.
620
621 %description dri-driver-via-unichrome -l pl.UTF-8
622 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
623
624 %package dri-driver-vmwgfx
625 Summary:        X.org DRI driver for VMware
626 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
627 License:        MIT
628 Group:          X11/Libraries
629 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
630 Requires:       xorg-xserver-server >= %{xserver_ver}
631
632 %description dri-driver-vmwgfx
633 X.org DRI driver for VMWare.
634
635 %description dri-driver-vmwgfx -l pl.UTF-8
636 Sterownik X.org DRI dla VMware.
637
638 %prep
639 %setup -q -b1
640 %patch0 -p0
641 %patch1 -p1
642
643 # fix demos
644 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
645
646 %build
647 autoreconf --install
648 #%{__aclocal}
649 #%{__autoconf}
650
651 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
652 %if %{without gallium_intel}
653 i915 \
654 %endif
655 %ifarch sparc sparcv9 sparc64
656 ffb \
657 %endif
658 %ifarch %{ix86} %{x8664}
659 sis \
660 %endif
661 swrast tdfx unichrome"
662
663 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
664
665 common_flags="\
666         --enable-shared \
667         --enable-selinux \
668         --enable-pic \
669         --enable-glx-tls \
670         --disable-glut \
671         --disable-os-mesa \
672         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
673         --with%{!?with_demos:out}-demos"
674
675 osmesa_common_flags="\
676         --with-driver=osmesa \
677         --disable-asm \
678         --disable-glu"
679
680 %if %{with osmesa}
681 # osmesa variants
682 %configure $common_flags $osmesa_common_flags \
683         --with-osmesa-bits=8
684 %{__make}
685 mv %{_lib} osmesa8
686 %{__make} clean
687
688 %configure $common_flags $osmesa_common_flags \
689         --with-osmesa-bits=16
690 %{__make}
691 mv %{_lib} osmesa16
692 %{__make} clean
693
694 %configure $common_flags $osmesa_common_flags \
695         --with-osmesa-bits=32
696 %{__make}
697 mv %{_lib} osmesa32
698 %{__make} clean
699 %endif
700
701 %configure $common_flags \
702 %if %{with gallium}
703         --enable-gallium \
704         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
705         --enable-gallium-svga \
706 %{?with_gallium_nouveau:--enable-gallium-nouveau} \
707         --with-state-trackers=dri,xorg,glx \
708 %else
709         --disable-gallium \
710 %endif
711         --with-driver=dri \
712         --with-dri-drivers=${dri_drivers} \
713         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
714
715 %{__make}
716 %{__make} -C progs/xdemos glxgears glxinfo
717 %if %{with demos}
718 %{__make} -C progs/demos
719 %endif
720
721 %install
722 rm -rf $RPM_BUILD_ROOT
723
724 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
725
726 # libs without drivers
727 %{__make} install \
728         DESTDIR=$RPM_BUILD_ROOT
729
730 %if %{with osmesa}
731 rm -f osmesa*/libGLEW.*
732 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
733 %endif
734
735 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
736 # work on copy to keep -bi --short-circuit working
737 rm -rf progs-clean
738 install -d progs-clean
739 for l in demos glsl osdemos redbook samples xdemos ; do
740         cp -a progs/$l progs-clean/$l
741         %{__make} -C progs-clean/$l clean
742         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
743 done
744 rm -rf progs-clean
745 for l in util images ; do
746         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
747 done
748 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
749
750 # strip out undesirable headers
751 olddir=$(pwd)
752 cd $RPM_BUILD_ROOT%{_includedir}/GL
753 rm [a-fh-np-wyz]*.h glf*.h
754 cd $RPM_BUILD_ROOT%{_libdir}
755 cd $olddir
756
757 %if %{with multigl}
758 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
759
760 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
761 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
762
763 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
764 %endif
765
766 %clean
767 rm -rf $RPM_BUILD_ROOT
768
769 %post   libGL -p /sbin/ldconfig
770 %postun libGL -p /sbin/ldconfig
771
772 %post   libGLU -p /sbin/ldconfig
773 %postun libGLU -p /sbin/ldconfig
774
775 %post   libGLw -p /sbin/ldconfig
776 %postun libGLw -p /sbin/ldconfig
777
778 %files libGL
779 %defattr(644,root,root,755)
780 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
781 %if %{with multigl}
782 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
783 %dir %{_libdir}/Mesa
784 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
785 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
786 %else
787 %attr(755,root,root) %{_libdir}/libGL.so.*.*
788 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
789 # symlink for binary apps which fail to conform Linux OpenGL ABI
790 # (and dlopen libGL.so instead of libGL.so.1)
791 %attr(755,root,root) %{_libdir}/libGL.so
792 %endif
793
794 %files libGL-devel
795 %defattr(644,root,root,755)
796 %doc docs/*.spec
797 %if %{with multigl}
798 %attr(755,root,root) %{_libdir}/libGL.so
799 %endif
800 %dir %{_includedir}/GL
801 %{_includedir}/GL/gl.h
802 %{_includedir}/GL/glext.h
803 %{_includedir}/GL/gl_mangle.h
804 %{_includedir}/GL/glx.h
805 %{_includedir}/GL/glxext.h
806 %{_includedir}/GL/glx_mangle.h
807 %dir %{_includedir}/GL/internal
808 %{_includedir}/GL/internal/dri_interface.h
809 %{_pkgconfigdir}/dri.pc
810 %{_pkgconfigdir}/gl.pc
811
812 %if %{with static}
813 %files libGL-static
814 %defattr(644,root,root,755)
815 %{_libdir}/libGL.a
816 %endif
817
818 %files libGLU
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
821 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
822
823 %files libGLU-devel
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libGLU.so
826 %{_includedir}/GL/glu.h
827 %{_includedir}/GL/glu_mangle.h
828 %{_pkgconfigdir}/glu.pc
829
830 %if %{with static}
831 %files libGLU-static
832 %defattr(644,root,root,755)
833 %{_libdir}/libGLU.a
834 %endif
835
836 %files libGLw
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
839 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
840
841 %files libGLw-devel
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_libdir}/libGLw.so
844 %{_includedir}/GL/GLwDrawA.h
845 %{_includedir}/GL/GLwDrawAP.h
846 %{_includedir}/GL/GLwMDrawA.h
847 %{_includedir}/GL/GLwMDrawAP.h
848 %{_pkgconfigdir}/glw.pc
849
850 %if %{with static}
851 %files libGLw-static
852 %defattr(644,root,root,755)
853 %{_libdir}/libGLw.a
854 %endif
855
856 %if %{with osmesa}
857 %files libOSMesa
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
860 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
861
862 %files libOSMesa-devel
863 %defattr(644,root,root,755)
864 %attr(755,root,root) %{_libdir}/libOSMesa*.so
865 %{_includedir}/GL/osmesa.h
866
867 %if %{with static}
868 %files libOSMesa-static
869 %defattr(644,root,root,755)
870 %{_libdir}/libOSMesa*.a
871 %endif
872 %endif
873
874 %files utils
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_bindir}/glxgears
877 %attr(755,root,root) %{_bindir}/glxinfo
878
879 %files dri-driver-ati-mach64
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
882
883 %files dri-driver-ati-radeon-R100
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
886
887 %files dri-driver-ati-radeon-R200
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
890
891 %files dri-driver-ati-radeon-R300
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
894
895 %files dri-driver-ati-radeon-R600
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
898
899 %files dri-driver-ati-rage128
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
902
903 # sunffb (sparc only)
904 %ifarch sparc sparcv9 sparc64
905 %files dri-driver-ffb
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
908 %endif
909
910 # glint (requires update)
911 %if 0
912 %files dri-driver-glint
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
915 %endif
916
917 %files dri-driver-intel-i810
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
920
921 %files dri-driver-intel-i915
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
924
925 %files dri-driver-intel-i965
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
928
929 %files dri-driver-matrox
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
932
933 %if %{with gallium}
934 %if %{with gallium_nouveau}
935 %files dri-driver-nouveau
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
938 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
939 %endif
940 %endif
941
942 %files dri-driver-savage
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
945
946 %ifarch %{ix86} %{x8664}
947 %files dri-driver-sis
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
950 %endif
951
952 %files dri-driver-swrast
953 %defattr(644,root,root,755)
954 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
955
956 %files dri-driver-tdfx
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
959
960 %files dri-driver-via-unichrome
961 %defattr(644,root,root,755)
962 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
963
964 %if %{with gallium}
965 %files dri-driver-vmwgfx
966 %defattr(644,root,root,755)
967 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
968 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
969 %endif
970
971 %if %{with demos}
972 %files demos
973 %defattr(644,root,root,755)
974 %{_examplesdir}/%{name}-%{version}
975 %endif
This page took 0.705169 seconds and 3 git commands to generate.