]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- Release: 5
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.0
5 Release:        5
6 Copyright:      GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Lib-%{version}.tar.gz
10 Source1:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Demos-%{version}.tar.gz
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildRoot:      /tmp/%{name}-%{version}-root
14
15 %description
16 Mesa is a 3-D graphics library with an API which is very similar to that
17 of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
18 or state machine, it is being used with authorization from Silicon Graphics,
19 Inc.  However, the author makes no claim that Mesa is in any way a
20 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
21 Those who want a licensed implementation of OpenGL should contact a licensed
22 vendor.  This software is distributed under the terms of the GNU Library
23 General Public License, see the LICENSE file for details.
24
25 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
26
27 %description -l pl
28 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
29 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
30
31 %package devel
32 Summary:        Development environment for Mesa
33 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
34 Group:          Development/Libraries
35 Group(pl):      Programowanie/Biblioteki
36 Requires:       %{name} = %{version}
37
38 %description devel
39 Header files and documentation needed for development.
40
41 %description -l pl devel
42 Pliki nag³owkowe i dokumentacja do Mesy.
43
44 %package static
45 Summary:        Mesa static libraries
46 Summary(pl):    Biblioteki satyczne Mesy
47 Group:          Development/Libraries
48 Group(pl):      Programowanie/Biblioteki
49 Requires:       %{name}-devel = %{version}
50
51 %description static
52 The static version of the Mesa libraries
53
54 %description -l pl static
55 Biblioteki satyczne Mesy.
56
57 %package glut
58 Summary:        GLUT library for Mesa
59 Summary(pl):    Biblioteka GLUT dla Mesy
60 Group:          X11/Libraries
61 Group(pl):      X11/Biblioteki
62 Requires:       %{name} = %{version}
63 Obsoletes:      glut
64
65 %description glut
66 The GLUT library.
67
68 %description -l pl glut
69 Biblioteka GLUT
70
71 %package glut-devel
72 Summary:        GLUT Development environment for Mesa
73 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
74 Group:          Development/Libraries
75 Group(pl):      Programowanie/Biblioteki
76 Requires:       %{name} = %{version}
77 Obsoletes:      glut-devel
78
79 %description glut-devel
80 Header files needed for development aplications using GLUT library.
81
82 %description -l pl glut-devel
83 Pliki nag³owkowe do biblioteki GLUT.
84
85 %package glut-static
86 Summary:        GLUT static libraries
87 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
88 Group:          Development/Libraries
89 Group(pl):      Programowanie/Biblioteki
90 Requires:       %{name}-glut-devel = %{version}
91 Obsoletes:      glut-devel
92
93 %description glut-static
94 The static version of the GLUT library.
95
96 %description -l pl glut-static
97 Biblioteki statyczne GLUT.
98
99 %package demos
100 Summary:        Mesa Demos
101 Summary(pl):    Demonstrace mo¿liwo¶ci biblioteki MESA.
102 Group:          Development/Libraries
103 Group(pl):      Programowanie/Biblioteki
104 Requires:       %{name} = %{version}
105
106 %description demos
107 Demonstration programs for the Mesa libraries.
108
109 %description -l pl demos
110 Programy demonstracyjne dla biblioteki Mesa.
111
112 %prep
113 %setup -q -n Mesa-%{version} -b 1
114 %patch -p1
115
116 %build
117 %ifarch alpha
118 make LIBS_ONLY=YES linux-alpha
119 make clean
120 make linux-alpha-elf
121 %endif
122
123 %ifarch ppc
124 make linux-ppc
125 %endif
126
127 %ifarch i386
128 make clean
129 make LIBS_ONLY=YES linux-386
130 make clean
131 make linux-386-elf
132 %endif
133
134 %ifarch sparc sparc64
135 make  linux-elf
136 %endif
137
138 (cd widgets-mesa; CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
139 ./configure \
140         --prefix=/usr/X11R6/
141 make)
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT/usr/X11R6/{lib/Mesa,include,man/man3}
146
147 cp -dpr lib include $RPM_BUILD_ROOT/usr/X11R6
148 cp -dpr book demos xdemos samples util $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
149 install Make-config $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
150
151 (cd widgets-mesa; make prefix=$RPM_BUILD_ROOT/usr/X11R6 install )
152
153 install */lib*.a $RPM_BUILD_ROOT/usr/X11R6/lib
154
155 strip $RPM_BUILD_ROOT/usr/X11R6/lib/{lib*so.*.*,Mesa/*/*} ||
156
157 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man3/* \
158         FUTURE IAFA-PACKAGE LICENSE README* RELNOTES VERSIONS
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %post   -p /sbin/ldconfig glut
164 %postun -p /sbin/ldconfig glut
165
166 %clean
167 rm -fr $RPM_BUILD_ROOT
168
169 %files
170 %defattr(644,root,root,755)
171
172 %ifnarch ppc
173 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so.*.*
174 %else
175 /usr/X11R6/lib/libMesa*.a
176 %endif
177
178 %files glut
179 %defattr(644,root,root,755)
180 %ifnarch ppc
181 %attr(755,root,root) /usr/X11R6/lib/libglut.so.*
182 %else
183 /usr/X11R6/lib/libglut.a
184 %endif
185
186 %files glut-devel
187 %defattr(644,root,root,755)
188 /usr/X11R6/include/GL/glut.h
189 %ifnarch ppc
190 %attr(755,root,root) /usr/X11R6/lib/libglut.so
191 %endif
192
193 %ifnarch ppc
194 %files glut-static
195 %attr(644,root,root) /usr/X11R6/lib/libglut.a
196 %endif
197
198 %files devel
199 %defattr(644,root,root,755)
200 %doc {FUTURE,IAFA-PACKAGE,LICENSE,RELNOTES,VERSIONS,README}.gz
201 %doc README.{3DFX,GGI,MGL,QUAKE,VIRGE,X11}.gz
202
203 %ifnarch ppc
204 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so
205 %endif
206
207 %dir /usr/X11R6/lib/Mesa
208 /usr/X11R6/lib/Mesa/Make-config
209 /usr/X11R6/lib/Mesa/util
210
211 %dir /usr/X11R6/include/GL
212 /usr/X11R6/include/GL/GL*.h
213 /usr/X11R6/include/GL/Mesa*.h
214 /usr/X11R6/include/GL/*mesa.h
215 /usr/X11R6/include/GL/*mangle.h
216 /usr/X11R6/include/GL/gl.h
217 /usr/X11R6/include/GL/glu.h
218 /usr/X11R6/include/GL/glx.h
219 /usr/X11R6/man/man3/*
220
221 %ifnarch ppc
222 %files static
223 %endif
224 %attr(644,root,root) /usr/X11R6/lib/libMesa*.a
225
226 %files demos
227 %defattr(644,root,root,755)
228 %dir /usr/X11R6/lib/Mesa/book
229 %dir /usr/X11R6/lib/Mesa/demos
230 %dir /usr/X11R6/lib/Mesa/samples
231 %dir /usr/X11R6/lib/Mesa/xdemos
232
233 %attr(-,root,root)/usr/X11R6/lib/Mesa/book/*
234 %attr(-,root,root)/usr/X11R6/lib/Mesa/demos/*
235 %attr(-,root,root)/usr/X11R6/lib/Mesa/samples/*
236 %attr(-,root,root)/usr/X11R6/lib/Mesa/xdemos/*
237
238 %changelog
239 * Mon Mar  8 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
240   [3.0-4]
241 - updated URL to http://www.mesa3d.org/,
242 - %doc moved to devel,
243 - added static subpackages,
244 - removed some README files,
245 - removed man group from man pages.
246
247 * Tue Feb  9 1999 Micha³ Kuratczyk <kurkens@polbox.com>
248   [3.0-3d]
249 - added gzipping documentation
250 - simplification in %files
251 - fixed pl translations
252
253 * Sat Jan 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
254   [3.0-2d]
255 - added LDFLAGS="-s" to ./configure enviroment,
256 - fixed permission on lib*so* files (must be 755),
257 - removed RPM_OPT_FLAGS="$RPM_OPT_FLAGS" make parameters
258   (this is redundant).
259
260 * Sat Jan 23 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
261 - gzipped man page.
262
263 * Thu Jan 12 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
264 - fixing library location.
265
266 * Thu Oct  1 1998 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
267   [3.0-1]
268 - fixing access permision.
269
270 * Wed May  5 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
271 - removed declarate %%{version}, %%{name}, %%{release} macros because
272   all are predefined,
273 - removed check $RPM_BUILD_ROOT in %clean and %install,
274 - added "Requires: Mesa = %%{version}" for all subpackages (for
275   keeping corectly dependences),
276 - in Mesa-glut* packages changed "Conflict:" to "Obsoletes:",
277 - added striping shared libs and demos,
278 - added modification in %build wihch allow build Mesa on sparc[64]
279   architecture,
280 - all utils and demos instaled in /usr/lib/Mesa,
281 - added %defattr macros in %files (on rebuild require rpm >= 2.4.99),
282 - added -q %setup parameter.
283
284 * Thu Feb 12 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
285 - updated to final version 2.6
286
287 * Thu Feb 05 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
288 - Fixed thinko in misc patch
289 - build against glibc
290
291 * Sat Jan 31 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
292 - updated to version 2.6beta5
293 - added widget-mesa to the things to be build.
294
295 * Mon Jan 26 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
296 - updated to version 2.6beta4
297
298 * Sun Dec 14 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
299 - updated to version 2.6beta1
300
301 * Sat Dec 13 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
302 - Moved GLUT into a separate subpackage and added an Obsoletes tag to this
303   subpackage
304 - Moved lib*.so to the devel package, they are only needed for development,
305   not for a runtime environment.
306
307 * Sat Nov 29 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
308 - added patches from ftp://iris.ssec.wisc.edu/pub/Mesa/patches_to_2.5
309 - BuildRoot'ed
310 - Prefix'ed
311 - added static versions of the libraries. (PPC version seems not to have
312   support for shared versions of the library)
313 - moved static versions of the library and the includes to the new subpackage
314   'devel'
315 - targets other than linux-x86 still untested.
316 - added Conflitcs tag
317 - added %postun
318 - added patch for RPM_OPT_FLAGS support
319
320 * Fri Nov 21 1997 Karsten Weiss <karsten@addx.au.s.shuttle.de>
321 - Upgraded to Mesa 2.5
322 - Multiarch destinations (untested).
323 - Included GLUT.
324 - Removed some of the READMEs for other platforms from the binary RPM.
This page took 0.082839 seconds and 3 git commands to generate.