]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
0e471ab1b1a9f2446c751693cb6ce1c2ec162293
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static  # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.23
25 %define         dri2proto_ver   2.1
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.10.1
32 Release:        1%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  efe8da4d80c2a5d32a800770b8ce5dfa
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-selinux.patch
39 Patch2:         %{name}-git.patch
40 URL:            http://www.mesa3d.org/
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake
43 BuildRequires:  expat-devel
44 BuildRequires:  libdrm-devel >= %{libdrm_ver}
45 BuildRequires:  libselinux-devel
46 BuildRequires:  libstdc++-devel >= 5:3.3.0
47 BuildRequires:  libtalloc-devel >= 2:2.0.1
48 BuildRequires:  libtool >= 2:1.4d
49 %{?with_motif:BuildRequires:    motif-devel}
50 BuildRequires:  pixman-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  python
53 BuildRequires:  python-modules
54 BuildRequires:  rpmbuild(macros) >= 1.470
55 BuildRequires:  sed >= 4.0
56 BuildRequires:  xorg-lib-libXdamage-devel
57 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
58 BuildRequires:  xorg-lib-libXt-devel
59 BuildRequires:  xorg-lib-libXxf86vm-devel
60 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
61 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
62 BuildRequires:  xorg-util-makedepend
63 BuildRequires:  xorg-xserver-server-devel
64 %if %{with egl}
65 BuildRequires:  libxcb-devel
66 BuildRequires:  udev-devel >= 150
67 %endif
68 %if %{with gallium}
69 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
70 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
71 %endif
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %if %{without gallium}
75 %undefine       with_gallium_intel
76 %undefine       with_gallium_radeon
77 %endif
78
79 %description
80 Mesa is a 3-D graphics library with an API which is very similar to
81 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
82 syntax or state machine, it is being used with authorization from
83 Silicon Graphics, Inc. However, the author does not possess an OpenGL
84 license from SGI, and makes no claim that Mesa is in any way a
85 compatible replacement for OpenGL or associated with SGI.
86
87 %description -l pl.UTF-8
88 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
89 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
90 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
91 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
92 OpenGL ani powiązana z SGI.
93
94 %package libEGL
95 Summary:        SGI implementation of libEGL OpenGL library
96 Summary(pl.UTF-8):      Implementacja SGI biblioteki libEGL ze standardu OpenGL
97 License:        SGI Free Software License B v2.0 (MIT-like)
98 Group:          Libraries
99 Requires:       OpenGL >= 1.2
100 Requires:       udev-libs >= 150
101 Provides:       OpenGL-EGL = 1.0
102
103 %description libEGL
104 SGI implementation of libEGL OpenGL library.
105
106 %description libEGL -l pl.UTF-8
107 Implementacja SGI biblioteki libEGL ze standardu OpenGL.
108
109 %package libEGL-devel
110 Summary:        Header files for SGI libEGL library
111 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libEGL
112 License:        SGI Free Software License B v2.0 (MIT-like)
113 Group:          Development/Libraries
114 Requires:       %{name}-libEGL = %{version}-%{release}
115 Requires:       OpenGL-devel >= 1.2
116 Requires:       libstdc++-devel
117 Provides:       OpenGL-EGL-devel = 1.0
118
119 %description libEGL-devel
120 Header files for SGI libEGL library.
121
122 %description libEGL-devel -l pl.UTF-8
123 Pliki nagłówkowe biblioteki SGI libEGL.
124
125 %package libEGL-static
126 Summary:        Static SGI libEGL library
127 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
128 License:        SGI Free Software License B v2.0 (MIT-like)
129 Group:          Development/Libraries
130 Requires:       %{name}-libEGL-devel = %{version}-%{release}
131 Provides:       OpenGL-EGL-static = 1.0
132
133 %description libEGL-static
134 Static SGI libEGL library.
135
136 %description libEGL-static -l pl.UTF-8
137 Statyczna biblioteka SGI libEGL.
138
139 %package libGL
140 Summary:        Free Mesa3D implementation of libGL OpenGL library
141 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
142 License:        MIT
143 Group:          X11/Libraries
144 Requires:       libdrm >= %{libdrm_ver}
145 Provides:       OpenGL = 2.1
146 # reports version 1.3, but supports glXGetProcAddress() from 1.4
147 Provides:       OpenGL-GLX = 1.4
148 Obsoletes:      Mesa
149 Obsoletes:      Mesa-dri
150 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
151 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
152
153 %description libGL
154 Mesa is a 3-D graphics library with an API which is very similar to
155 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
156 syntax or state machine, it is being used with authorization from
157 Silicon Graphics, Inc. However, the author does not possess an OpenGL
158 license from SGI, and makes no claim that Mesa is in any way a
159 compatible replacement for OpenGL or associated with SGI.
160
161 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
162 specifications. It uses DRI for rendering.
163
164 %description libGL -l pl.UTF-8
165 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
166 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
167 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
168 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
169 OpenGL ani powiązana z SGI.
170
171 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
172 GLX 1.4. Używa DRI do renderowania.
173
174 %package libGL-devel
175 Summary:        Header files for Mesa3D libGL library
176 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
177 License:        MIT
178 Group:          X11/Development/Libraries
179 # loose dependency on libGL to use with other libGL binaries
180 Requires:       OpenGL >= 1.5
181 Requires:       libdrm-devel >= %{libdrm_ver}
182 Requires:       xorg-lib-libX11-devel
183 Requires:       xorg-lib-libXdamage-devel
184 Requires:       xorg-lib-libXext-devel
185 Requires:       xorg-lib-libXxf86vm-devel
186 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
187 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
188 Suggests:       OpenGL-doc-man
189 Provides:       OpenGL-GLX-devel = 1.4
190 Provides:       OpenGL-devel = 2.1
191 Obsoletes:      Mesa-devel
192 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
193 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
194 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
195 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
196
197 %description libGL-devel
198 Header files for Mesa3D libGL library.
199
200 %description libGL-devel -l pl.UTF-8
201 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
202
203 %package libGL-static
204 Summary:        Static Mesa3D libGL library
205 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
206 License:        MIT
207 Group:          X11/Development/Libraries
208 Requires:       %{name}-libGL-devel = %{version}-%{release}
209 Provides:       OpenGL-static = 2.1
210 Obsoletes:      Mesa-static
211 Obsoletes:      X11-OpenGL-static < 1:7.0.0
212 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
213
214 %description libGL-static
215 Static Mesa3D libGL library. It uses software renderer.
216
217 %description libGL-static -l pl.UTF-8
218 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
219 renderingu.
220
221 %package libGLU
222 Summary:        SGI implementation of libGLU OpenGL library
223 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
224 License:        SGI Free Software License B v2.0 (MIT-like)
225 Group:          Libraries
226 # loose dependency on libGL.so.1 to use with other libGL binaries
227 Requires:       OpenGL >= 1.2
228 Provides:       OpenGL-GLU = 1.3
229 Obsoletes:      Mesa-devel
230 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
231 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
232
233 %description libGLU
234 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
235 1.3 specifications.
236
237 %description libGLU -l pl.UTF-8
238 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
239 specyfikację OpenGL GLU 1.3.
240
241 %package libGLU-devel
242 Summary:        Header files for SGI libGLU library
243 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
244 License:        SGI Free Software License B v2.0 (MIT-like)
245 Group:          Development/Libraries
246 Requires:       %{name}-libGLU = %{version}-%{release}
247 Requires:       OpenGL-devel >= 1.2
248 Requires:       libstdc++-devel
249 Provides:       OpenGL-GLU-devel = 1.3
250
251 %description libGLU-devel
252 Header files for SGI libGLU library.
253
254 %description libGLU-devel -l pl.UTF-8
255 Pliki nagłówkowe biblioteki SGI libGLU.
256
257 %package libGLU-static
258 Summary:        Static SGI libGLU library
259 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
260 License:        SGI Free Software License B v2.0 (MIT-like)
261 Group:          Development/Libraries
262 Requires:       %{name}-libGLU-devel = %{version}-%{release}
263 Provides:       OpenGL-GLU-static = 1.3
264
265 %description libGLU-static
266 Static SGI libGLU library.
267
268 %description libGLU-static -l pl.UTF-8
269 Statyczna biblioteka SGI libGLU.
270
271 %package libGLw
272 Summary:        SGI OpenGL Xt widgets library
273 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
274 License:        SGI MIT-like
275 Group:          Libraries
276 # loose dependency on libGL.so.1 to use with other libGL binaries
277 Requires:       OpenGL >= 1.1
278 Provides:       OpenGL-GLw
279
280 %description libGLw
281 SGI OpenGL Xt widgets library.
282
283 %description libGLw -l pl.UTF-8
284 Biblioteka SGI widgetów Xt dla OpenGL-a.
285
286 %package libGLw-devel
287 Summary:        Header files for SGI libGLw library
288 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
289 License:        SGI MIT-like
290 Group:          Development/Libraries
291 Requires:       %{name}-libGLw = %{version}-%{release}
292 Requires:       OpenGL-devel >= 1.2
293 Provides:       OpenGL-GLw-devel
294
295 %description libGLw-devel
296 Header files for SGI libGLw library.
297
298 %description libGLw-devel -l pl.UTF-8
299 Pliki nagłówkowe biblioteki SGI libGLw.
300
301 %package libGLw-static
302 Summary:        Static SGI libGLw library
303 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
304 License:        SGI MIT-like
305 Group:          Development/Libraries
306 Requires:       %{name}-libGLw-devel = %{version}-%{release}
307 Provides:       OpenGL-GLw-static
308
309 %description libGLw-static
310 Static SGI libGLw library.
311
312 %description libGLw-static -l pl.UTF-8
313 Statyczna biblioteka SGI libGLw.
314
315 %package libOSMesa
316 Summary:        OSMesa (off-screen renderer) library
317 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
318 License:        MIT
319 Group:          Libraries
320 # doesn't require base
321
322 %description libOSMesa
323 OSMesa (off-screen renderer) library.
324
325 %description libOSMesa -l pl.UTF-8
326 Biblioteka OSMesa (renderująca bitmapy w pamięci).
327
328 %package libOSMesa-devel
329 Summary:        Header file for OSMesa (off-screen renderer) library
330 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
331 License:        MIT
332 Group:          Development/Libraries
333 Requires:       %{name}-libOSMesa = %{version}-%{release}
334 # for <GL/gl.h> only
335 Requires:       OpenGL-devel
336
337 %description libOSMesa-devel
338 Header file for OSMesa (off-screen renderer) library.
339
340 %description libOSMesa-devel -l pl.UTF-8
341 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
342
343 %package libOSMesa-static
344 Summary:        Static OSMesa (off-screen renderer) library
345 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
346 License:        MIT
347 Group:          Development/Libraries
348 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
349 # this static build of OSMesa needs static non-dri Mesa implementation
350 Requires:       %{name}-libGL-static = %{version}-%{release}
351
352 %description libOSMesa-static
353 Static OSMesa (off-screen renderer) library.
354
355 %description libOSMesa-static -l pl.UTF-8
356 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
357
358 %package utils
359 Summary:        OpenGL utilities from Mesa3D
360 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
361 License:        MIT
362 Group:          X11/Applications/Graphics
363 # loose deps on libGL/libGLU
364
365 %description utils
366 OpenGL utilities from Mesa3D: glxgears and glxinfo.
367
368 %description utils -l pl.UTF-8
369 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
370
371 %package dri-driver-ati-mach64
372 Summary:        X.org DRI driver for ATI Mach64 card family
373 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
374 License:        MIT
375 Group:          X11/Libraries
376 Requires:       xorg-driver-video-mach64
377 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
378 Requires:       xorg-xserver-server >= %{xserver_ver}
379
380 %description dri-driver-ati-mach64
381 X.org DRI driver for ATI Mach64 card family.
382
383 %description dri-driver-ati-mach64 -l pl.UTF-8
384 Sterownik X.org DRI dla rodziny kart ATI Mach64.
385
386 %package dri-driver-ati-radeon-R100
387 Summary:        X.org DRI driver for ATI R100 card family
388 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
389 License:        MIT
390 Group:          X11/Libraries
391 Requires:       xorg-driver-video-ati
392 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
393 Requires:       xorg-xserver-server >= %{xserver_ver}
394 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
395
396 %description dri-driver-ati-radeon-R100
397 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
398
399 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
400 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
401
402 %package dri-driver-ati-radeon-R200
403 Summary:        X.org DRI driver for ATI R200 card family
404 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
405 License:        MIT
406 Group:          X11/Libraries
407 Requires:       xorg-driver-video-ati
408 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
409 Requires:       xorg-xserver-server >= %{xserver_ver}
410 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
411
412 %description dri-driver-ati-radeon-R200
413 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
414
415 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
416 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
417
418 %package dri-driver-ati-radeon-R300
419 Summary:        X.org DRI driver for ATI R300 card family
420 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
421 License:        MIT
422 Group:          X11/Libraries
423 Requires:       xorg-driver-video-ati
424 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
425 Requires:       xorg-xserver-server >= %{xserver_ver}
426 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
427
428 %description dri-driver-ati-radeon-R300
429 X.org DRI driver for ATI R300 card family.
430
431 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
432 Sterownik X.org DRI dla rodziny kart ATI R300.
433
434 %package dri-driver-ati-radeon-R600
435 Summary:        X.org DRI driver for ATI R600 card family
436 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
437 License:        MIT
438 Group:          X11/Libraries
439 Requires:       radeon-ucode
440 Requires:       xorg-driver-video-ati
441 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
442 Requires:       xorg-xserver-server >= %{xserver_ver}
443
444 %description dri-driver-ati-radeon-R600
445 X.org DRI driver for ATI R600 card family.
446
447 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
448 Sterownik X.org DRI dla rodziny kart ATI R600.
449
450 %package dri-driver-ati-rage128
451 Summary:        X.org DRI driver for ATI Rage128 card family
452 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
453 License:        MIT
454 Group:          X11/Libraries
455 Requires:       xorg-driver-video-r128
456 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
457 Requires:       xorg-xserver-server >= %{xserver_ver}
458 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
459
460 %description dri-driver-ati-rage128
461 X.org DRI driver for ATI Rage128 card family.
462
463 %description dri-driver-ati-rage128 -l pl.UTF-8
464 Sterownik X.org DRI dla rodziny kart ATI Rage128.
465
466 %package dri-driver-ffb
467 Summary:        X.org DRI driver for Sun FFB card family
468 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
469 License:        MIT
470 Group:          X11/Libraries
471 Requires:       xorg-driver-video-sunffb
472 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
473 Requires:       xorg-xserver-server >= %{xserver_ver}
474
475 %description dri-driver-ffb
476 X.org DRI driver for SUN Creator3D and Elite3D card family.
477
478 %description dri-driver-ffb -l pl.UTF-8
479 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
480
481 %package dri-driver-glint
482 Summary:        X.org DRI driver for GLINT/Permedia card family
483 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
484 License:        MIT
485 Group:          X11/Libraries
486 Requires:       xorg-driver-video-glint
487 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
488 Requires:       xorg-xserver-server >= %{xserver_ver}
489 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
490
491 %description dri-driver-glint
492 X.org DRI driver for GLINT/Permedia card family.
493
494 %description dri-driver-glint -l pl.UTF-8
495 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
496
497 %package dri-driver-intel-i810
498 Summary:        X.org DRI driver for Intel i810 card family
499 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
500 License:        MIT
501 Group:          X11/Libraries
502 Requires:       xorg-driver-video-intel
503 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
504 Requires:       xorg-xserver-server >= %{xserver_ver}
505 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
506
507 %description dri-driver-intel-i810
508 X.org DRI driver for Intel i810 card family.
509
510 %description dri-driver-intel-i810 -l pl.UTF-8
511 Sterownik X.org DRI dla rodziny kart Intel i810.
512
513 %package dri-driver-intel-i915
514 Summary:        X.org DRI driver for Intel i915 card family
515 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
516 License:        MIT
517 Group:          X11/Libraries
518 Requires:       xorg-driver-video-intel
519 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
520 Requires:       xorg-xserver-server >= %{xserver_ver}
521 Obsoletes:      Mesa-dri-driver-intel-i830
522 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
523
524 %description dri-driver-intel-i915
525 X.org DRI driver for Intel i915 card family.
526
527 %description dri-driver-intel-i915 -l pl.UTF-8
528 Sterownik X.org DRI dla rodziny kart Intel i915.
529
530 %package dri-driver-intel-i965
531 Summary:        X.org DRI driver for Intel i965 card family
532 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
533 License:        MIT
534 Group:          X11/Libraries
535 Requires:       xorg-driver-video-intel
536 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
537 Requires:       xorg-xserver-server >= %{xserver_ver}
538 Obsoletes:      Mesa-dri-driver-intel-i830
539 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
540
541 %description dri-driver-intel-i965
542 X.org DRI driver for Intel i965 card family.
543
544 %description dri-driver-intel-i965 -l pl.UTF-8
545 Sterownik X.org DRI dla rodziny kart Intel i965.
546
547 %package dri-driver-matrox
548 Summary:        X.org DRI driver for Matrox G card family
549 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
550 License:        MIT
551 Group:          X11/Libraries
552 Requires:       xorg-driver-video-mga
553 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
554 Requires:       xorg-xserver-server >= %{xserver_ver}
555 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
556
557 %description dri-driver-matrox
558 X.org DRI drivers for Matrox G card family.
559
560 %description dri-driver-matrox -l pl.UTF-8
561 Sterowniki X.org DRI dla rodziny kart Matrox G.
562
563 %package dri-driver-nouveau
564 Summary:        X.org DRI driver for NVIDIA card family
565 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
566 License:        MIT
567 Group:          X11/Libraries
568 Requires:       xorg-driver-video-nouveau
569 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
570 Requires:       xorg-xserver-server >= %{xserver_ver}
571
572 %description dri-driver-nouveau
573 X.org DRI drivers for NVIDIA card family.
574
575 %description dri-driver-nouveau -l pl.UTF-8
576 Sterowniki X.org DRI dla rodziny kart NVIDIA.
577
578 %package dri-driver-savage
579 Summary:        X.org DRI driver for S3 Savage card family
580 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
581 License:        MIT
582 Group:          X11/Libraries
583 Requires:       xorg-driver-video-savage
584 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
585 Requires:       xorg-xserver-server >= %{xserver_ver}
586
587 %description dri-driver-savage
588 X.org DRI driver for S3 Savage card family.
589
590 %description dri-driver-savage -l pl.UTF-8
591 Sterownik X.org DRI dla rodziny kart S3 Savage.
592
593 %package dri-driver-sis
594 Summary:        X.org DRI driver for SiS card family
595 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
596 License:        MIT
597 Group:          X11/Libraries
598 Requires:       xorg-driver-video-sis
599 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
600 Requires:       xorg-xserver-server >= %{xserver_ver}
601 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
602
603 %description dri-driver-sis
604 X.org DRI driver for SiS card family.
605
606 %description dri-driver-sis -l pl.UTF-8
607 Sterownik X.org DRI dla rodziny kart SiS.
608
609 %package dri-driver-swrast
610 Summary:        X.org DRI software rasterizer driver
611 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
612 License:        MIT
613 Group:          X11/Libraries
614 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
615 Requires:       xorg-xserver-server >= %{xserver_ver}
616
617 %description dri-driver-swrast
618 X.org DRI software rasterizer driver.
619
620 %description dri-driver-swrast -l pl.UTF-8
621 Sterownik X.org DRI obsługujący rysowanie programowe.
622
623 %package dri-driver-tdfx
624 Summary:        X.org DRI driver for 3DFX Voodoo card family
625 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
626 License:        MIT
627 Group:          X11/Libraries
628 Requires:       Glide3-DRI
629 Requires:       xorg-driver-video-tdfx
630 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
631 Requires:       xorg-xserver-server >= %{xserver_ver}
632 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
633
634 %description dri-driver-tdfx
635 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
636 and Velocity 100/200).
637
638 %description dri-driver-tdfx -l pl.UTF-8
639 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
640 Banshee i Velocity 100/200).
641
642 %package dri-driver-via-unichrome
643 Summary:        X.org DRI driver for VIA Unichrome card family
644 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
645 License:        MIT
646 Group:          X11/Libraries
647 Requires:       xorg-driver-video-openchrome
648 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
649 Requires:       xorg-xserver-server >= %{xserver_ver}
650
651 %description dri-driver-via-unichrome
652 X.org DRI driver for VIA Unichrome card family.
653
654 %description dri-driver-via-unichrome -l pl.UTF-8
655 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
656
657 %package dri-driver-vmwgfx
658 Summary:        X.org DRI driver for VMware
659 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
660 License:        MIT
661 Group:          X11/Libraries
662 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
663 Requires:       xorg-xserver-server >= %{xserver_ver}
664
665 %description dri-driver-vmwgfx
666 X.org DRI driver for VMWare.
667
668 %description dri-driver-vmwgfx -l pl.UTF-8
669 Sterownik X.org DRI dla VMware.
670
671 %prep
672 %setup -q
673 %patch0 -p0
674 %patch1 -p1
675 #patch2 -p1
676
677 %build
678 %{__aclocal}
679 %{__autoconf}
680
681 dri_drivers="i810 i965 mach64 mga r128 \
682 %if %{without gallium_radeon}
683 r200 r300 r600 radeon \
684 %endif
685 savage \
686 %if %{without gallium_intel}
687 i915 \
688 %endif
689 %ifarch sparc sparcv9 sparc64
690 ffb \
691 %endif
692 %ifarch %{ix86} %{x8664}
693 sis \
694 %endif
695 swrast tdfx unichrome"
696
697 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
698
699 common_flags="\
700         --enable-shared \
701         --enable-selinux \
702         --enable-pic \
703         --enable-glx-tls \
704         --disable-glut \
705         --disable-os-mesa \
706         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
707
708 osmesa_common_flags="\
709         --with-driver=osmesa \
710         --disable-asm \
711         --disable-glu"
712
713 %if %{with osmesa}
714 # osmesa variants
715 %configure $common_flags $osmesa_common_flags \
716         --with-osmesa-bits=8
717 %{__make}
718 mv %{_lib} osmesa8
719 %{__make} clean
720
721 %configure $common_flags $osmesa_common_flags \
722         --with-osmesa-bits=16
723 %{__make}
724 mv %{_lib} osmesa16
725 %{__make} clean
726
727 %configure $common_flags $osmesa_common_flags \
728         --with-osmesa-bits=32
729 %{__make}
730 mv %{_lib} osmesa32
731 %{__make} clean
732 %endif
733
734 %configure $common_flags \
735 %if %{with gallium}
736         --enable-gallium \
737         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
738         --%{?with_gallium_radeon:en}%{!?with_gallium_radeon:dis}able-gallium-radeon \
739         --enable-gallium-svga \
740         %{?with_gallium_nouveau:--enable-gallium-nouveau} \
741         --with-state-trackers=dri,glx \
742 %else
743         --disable-gallium \
744 %endif
745         --with-driver=dri \
746         --with-dri-drivers=${dri_drivers} \
747         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
748
749 %{__make}
750
751 %install
752 rm -rf $RPM_BUILD_ROOT
753
754 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
755
756 # libs without drivers
757 %{__make} install \
758         DESTDIR=$RPM_BUILD_ROOT
759
760 %if %{with osmesa}
761 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
762 %endif
763
764 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
765
766 # strip out undesirable headers
767 olddir=$(pwd)
768 cd $RPM_BUILD_ROOT%{_includedir}/GL
769 rm [a-fh-np-wyz]*.h glf*.h
770 cd $RPM_BUILD_ROOT%{_libdir}
771 cd $olddir
772
773 %if %{with multigl}
774 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
775
776 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
777 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
778
779 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
780 %endif
781
782 %clean
783 rm -rf $RPM_BUILD_ROOT
784
785 %post   libEGL -p /sbin/ldconfig
786 %postun libEGL -p /sbin/ldconfig
787
788 %post   libGL -p /sbin/ldconfig
789 %postun libGL -p /sbin/ldconfig
790
791 %post   libGLU -p /sbin/ldconfig
792 %postun libGLU -p /sbin/ldconfig
793
794 %post   libGLw -p /sbin/ldconfig
795 %postun libGLw -p /sbin/ldconfig
796
797 %if %{with egl}
798 %files libEGL
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
801 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
802 %dir %{_libdir}/egl
803 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
804 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
805
806 %files libEGL-devel
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libEGL.so
809 %dir %{_includedir}/EGL
810 %{_includedir}/EGL/egl.h
811 %{_includedir}/EGL/eglext.h
812 %{_includedir}/EGL/eglplatform.h
813 %dir %{_includedir}/KHR
814 %{_includedir}/KHR/khrplatform.h
815 %{_pkgconfigdir}/egl.pc
816
817 %if %{with static}
818 %files libEGL-static
819 %defattr(644,root,root,755)
820 %{_libdir}/libEGL.a
821 %endif
822 %endif
823
824 %files libGL
825 %defattr(644,root,root,755)
826 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
827 %if %{with multigl}
828 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
829 %dir %{_libdir}/Mesa
830 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
831 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
832 %else
833 %attr(755,root,root) %{_libdir}/libGL.so.*.*
834 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
835 # symlink for binary apps which fail to conform Linux OpenGL ABI
836 # (and dlopen libGL.so instead of libGL.so.1)
837 %attr(755,root,root) %{_libdir}/libGL.so
838 %endif
839
840 %files libGL-devel
841 %defattr(644,root,root,755)
842 %doc docs/*.spec
843 %if %{with multigl}
844 %attr(755,root,root) %{_libdir}/libGL.so
845 %endif
846 %dir %{_includedir}/GL
847 %{_includedir}/GL/gl.h
848 %{_includedir}/GL/glext.h
849 %{_includedir}/GL/gl_mangle.h
850 %{_includedir}/GL/glx.h
851 %{_includedir}/GL/glxext.h
852 %{_includedir}/GL/glx_mangle.h
853 %dir %{_includedir}/GL/internal
854 %{_includedir}/GL/internal/dri_interface.h
855 %{_pkgconfigdir}/dri.pc
856 %{_pkgconfigdir}/gl.pc
857
858 %if %{with static}
859 %files libGL-static
860 %defattr(644,root,root,755)
861 %{_libdir}/libGL.a
862 %endif
863
864 %files libGLU
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
867 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
868
869 %files libGLU-devel
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_libdir}/libGLU.so
872 %{_includedir}/GL/glu.h
873 %{_includedir}/GL/glu_mangle.h
874 %{_pkgconfigdir}/glu.pc
875
876 %if %{with static}
877 %files libGLU-static
878 %defattr(644,root,root,755)
879 %{_libdir}/libGLU.a
880 %endif
881
882 %files libGLw
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
885 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
886
887 %files libGLw-devel
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/libGLw.so
890 %{_includedir}/GL/GLwDrawA.h
891 %{_includedir}/GL/GLwDrawAP.h
892 %{_includedir}/GL/GLwMDrawA.h
893 %{_includedir}/GL/GLwMDrawAP.h
894 %{_pkgconfigdir}/glw.pc
895
896 %if %{with static}
897 %files libGLw-static
898 %defattr(644,root,root,755)
899 %{_libdir}/libGLw.a
900 %endif
901
902 %if %{with osmesa}
903 %files libOSMesa
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
906 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
907
908 %files libOSMesa-devel
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/libOSMesa*.so
911 %{_includedir}/GL/osmesa.h
912
913 %if %{with static}
914 %files libOSMesa-static
915 %defattr(644,root,root,755)
916 %{_libdir}/libOSMesa*.a
917 %endif
918 %endif
919
920 %files dri-driver-ati-mach64
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
923
924 %files dri-driver-ati-radeon-R100
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
927
928 %files dri-driver-ati-radeon-R200
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
931
932 %files dri-driver-ati-radeon-R300
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
935
936 %files dri-driver-ati-radeon-R600
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
939
940 %files dri-driver-ati-rage128
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
943
944 # sunffb (sparc only)
945 %ifarch sparc sparcv9 sparc64
946 %files dri-driver-ffb
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
949 %endif
950
951 # glint (requires update)
952 %if 0
953 %files dri-driver-glint
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
956 %endif
957
958 %files dri-driver-intel-i810
959 %defattr(644,root,root,755)
960 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
961
962 %files dri-driver-intel-i915
963 %defattr(644,root,root,755)
964 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
965
966 %files dri-driver-intel-i965
967 %defattr(644,root,root,755)
968 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
969
970 %files dri-driver-matrox
971 %defattr(644,root,root,755)
972 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
973
974 %if %{with gallium}
975 %if %{with gallium_nouveau}
976 %files dri-driver-nouveau
977 %defattr(644,root,root,755)
978 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
979 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
980 %endif
981 %endif
982
983 %files dri-driver-savage
984 %defattr(644,root,root,755)
985 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
986
987 %ifarch %{ix86} %{x8664}
988 %files dri-driver-sis
989 %defattr(644,root,root,755)
990 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
991 %endif
992
993 %files dri-driver-swrast
994 %defattr(644,root,root,755)
995 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
996 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
997
998 %files dri-driver-tdfx
999 %defattr(644,root,root,755)
1000 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
1001
1002 %files dri-driver-via-unichrome
1003 %defattr(644,root,root,755)
1004 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
1005
1006 %if %{with gallium}
1007 %files dri-driver-vmwgfx
1008 %defattr(644,root,root,755)
1009 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
1010 %endif
This page took 0.116732 seconds and 3 git commands to generate.