]> git.pld-linux.org Git - packages/Lunchbox.git/blob - Lunchbox.spec
- new
[packages/Lunchbox.git] / Lunchbox.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     mpi             # MPI support
5 %bcond_with     skv             # SKV (Scalable Key-Value Store) support
6 #
7 Summary:        Lunchbox - C++ library for multi-threading programming
8 Summary(pl.UTF-8):      Lunchbox - biblioteka C++ do programowania wielowątkowego
9 Name:           Lunchbox
10 Version:        1.10.0
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  3e01c3a2ddeeb7b3682e88092831d5a5
16 Source1:        https://github.com/Eyescale/CMake/archive/139ce7d/Eyescale-CMake-139ce7d.tar.gz
17 # Source1-md5:  4a6abcd9e0fc417528a8ca68a97e65eb
18 URL:            http://pogl.wordpress.com/category/lunchbox/
19 BuildRequires:  avahi-devel
20 BuildRequires:  boost-devel >= 1.41.0
21 BuildRequires:  cmake >= 2.8
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  gcc-c++ >= 6:4.2
24 BuildRequires:  hwloc-devel >= 1.3
25 BuildRequires:  leveldb-devel
26 BuildRequires:  libgomp-devel
27 BuildRequires:  libjpeg-turbo-devel >= 1.2.1
28 BuildRequires:  libstdc++-devel
29 %{?with_mpi:BuildRequires:      mpi-devel}
30 BuildRequires:  pkgconfig
31 %{?with_skv:BuildRequires:      skv-devel}
32 Requires:       hwloc-libs >= 1.3
33 Requires:       libjpeg-turbo >= 1.2.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
38 formerly known as eq::base or co::base, the foundation for the
39 Equalizer parallel rendering framework and the Collage network
40 library. It is intended for all application developers creating
41 high-performance multi-threaded programs.
42
43 %description -l pl.UTF-8
44 Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
45 była znana jako eq::base lub co::base - podstawa szkieletu do
46 renderowania wielowątkowego Equalizer lub biblioteki sieciowej
47 Collage. Biblioteka jest przeznaczona dla wszystkich programistów
48 tworzących wysoko wydajne, wielowątkowe aplikacje.
49
50 %package devel
51 Summary:        Header files for Lunchbox library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lunchbox
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       boost-devel >= 1.41.0
56 Requires:       libgomp-devel
57 Requires:       libstdc++-devel
58
59 %description devel
60 Header files for Lunchbox library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Lunchbox.
64
65 %package apidocs
66 Summary:        Lunchbox API documentation
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki Lunchbox
68 Group:          Documentation
69
70 %description apidocs
71 API documentation for Lunchbox library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki Lunchbox.
75
76 %prep
77 %setup -q -a1
78
79 %{__mv} CMake-* CMake/common
80 %{__rm} .gitexternals
81
82 %build
83 install -d build
84 cd build
85 %cmake .. \
86         -DBUILDYARD_DISABLED=ON \
87         %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
88         %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
89 %{__make}
90
91 %if %{with apidocs}
92 doxygen doc/Doxyfile
93 %endif
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/RelNotes.md
112 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.3
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libLunchbox.so
118 %{_includedir}/lunchbox
119 %{_pkgconfigdir}/Lunchbox.pc
120 %dir %{_datadir}/Lunchbox
121 %{_datadir}/Lunchbox/CMake
122
123 %if %{with apidocs}
124 %files apidocs
125 %defattr(644,root,root,755)
126 %doc build/doc/html/*
127 %endif
This page took 0.129649 seconds and 3 git commands to generate.