]> git.pld-linux.org Git - packages/JXplorer.git/blob - JXplorer.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/JXplorer.git] / JXplorer.spec
1 # NOTE:
2 # - it builds with any JDK, but it runs on java-sun only. It's not able to
3 #   connect to LDAP on icedtea6
4 Summary:        LDAP browser
5 Summary(pl.UTF-8):      Przeglądarka LDAP
6 Name:           JXplorer
7 Version:        3.2
8 Release:        4
9 License:        Computer Associates Open Source Software License
10 Group:          Applications/Databases/Interfaces
11 Source0:        http://dl.sourceforge.net/jxplorer/JXv%{version}deploy.tar.bz2
12 # Source0-md5:  5cd9766391995736164b17a30354d72e
13 Source1:        http://dl.sourceforge.net/jxplorer/JXv%{version}src.tar.bz2
14 # Source1-md5:  7773a4de17a935db2aaaf3984772fcb1
15 Source2:        %{name}.sh
16 Source3:        %{name}.jxconfig.txt
17 Source4:        %{name}.desktop
18 Patch0:         %{name}-NoInstallAnywhere.patch
19 URL:            http://www.jxplorer.org/
20 BuildRequires:  ant
21 BuildRequires:  icoutils
22 BuildRequires:  jar
23 BuildRequires:  jdk
24 BuildRequires:  jpackage-utils
25 BuildRequires:  rpm-javaprov
26 BuildRequires:  rpmbuild(macros) >= 1.553
27 BuildRequires:  sed >= 4.0
28 BuildConflicts: java-gcj-compat-devel
29 Requires:       java-help
30 Requires:       java-junit
31 Requires:       java-sun-jre-base-X11
32 Requires:       jpackage-utils
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 JXplorer is a standards compliant general purpose LDAP browser that
38 can be used to read and search any LDAP directory, or any X.500
39 directory with an LDAP interface. It is available for immediate free
40 download under a standard OSI-style open source licence.
41
42 %description -l pl.UTF-8
43 JXplorer jest zgodną ze standardami przeglądarką LDAP ogólnego
44 przeznaczenia. Programu tego można używać do przeglądania i
45 modyfikowania dowolnego katalogu LDAP, lub dowolnego katalogu zgodnego
46 z X.500 posiadającego interfejs LDAP.
47
48 %prep
49 %setup -q -b 1 -n jxplorer
50
51 %undos build.xml
52
53 icotool -x -o jxplorer.png jxplorer.ico
54
55 %patch0 -p0
56
57 install %{SOURCE2} jxplorer.sh
58 install %{SOURCE3} jxconfig.txt
59 %{__sed} -i -e 's~@DATADIR@~%{_datadir}/%{name}~g' jxconfig.txt jxplorer.sh
60 %{__sed} -i -e 's~@JVMDIR@~%{_jvmdir}~g' jxplorer.sh
61
62 %build
63 export JAVA_HOME="%{java_home}"
64
65 export LC_ALL=en_US # source code not US-ASCII
66
67 %ant clean
68 %ant
69 %ant jar
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT%{_bindir}
74 install jxplorer.sh $RPM_BUILD_ROOT%{_bindir}/jxplorer
75
76 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
77 install jxplorer.jar $RPM_BUILD_ROOT%{_javadir}/jxplorer-%{version}.jar
78 ln -s jxplorer-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/jxplorer.jar
79
80 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/{htmldocs,icons,images,language,security,conftemplate}
81 install htmldocs/* $RPM_BUILD_ROOT%{_datadir}/%{name}/htmldocs
82 install icons/* $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
83 install images/* $RPM_BUILD_ROOT%{_datadir}/%{name}/images
84 install language/* $RPM_BUILD_ROOT%{_datadir}/%{name}/language
85 install security/* $RPM_BUILD_ROOT%{_datadir}/%{name}/security
86 install connections.txt $RPM_BUILD_ROOT%{_datadir}/%{name}/conftemplate
87
88 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/{country,images,inetOrgPerson,locality,newPilotPerson,organization,organizationalPerson,organizationalUnit,person,schema}
89 install templates/country/*              $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/country
90 install templates/images/*               $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/images
91 install templates/inetOrgPerson/*        $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/inetOrgPerson
92 install templates/locality/*             $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/locality
93 install templates/newPilotPerson/*       $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/newPilotPerson
94 install templates/organization/*         $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/organization
95 install templates/organizationalPerson/* $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/organizationalPerson
96 install templates/organizationalUnit/*   $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/organizationalUnit
97 install templates/person/*               $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/person
98 install templates/schema/*               $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/schema
99 install templates/*.*                    $RPM_BUILD_ROOT%{_datadir}/%{name}/templates
100
101 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
102 install log4j.xml $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/log4j.xml
103 install jxconfig.txt $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/jxconfig.txt
104 install connections.txt $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/connections.txt
105
106 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
107 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/jxplorer.desktop
108 install jxplorer.png $RPM_BUILD_ROOT%{_pixmapsdir}/jxplorer.png
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc RELEASE.TXT example.ldif licence.txt
116 %attr(755,root,root) %{_bindir}/jxplorer
117 %{_javadir}/jxplorer.jar
118 %{_javadir}/jxplorer-%{version}.jar
119 %{_datadir}/%{name}
120 %{_pixmapsdir}/jxplorer.png
121 %{_desktopdir}/jxplorer.desktop
122 %dir %{_sysconfdir}/%{name}
123 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/connections.txt
124 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/log4j.xml
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/jxconfig.txt
This page took 0.068 seconds and 3 git commands to generate.