]> git.pld-linux.org Git - packages/DirectFB-extra.git/commitdiff
- added acfix patch, disabled imlib2 plugin (requires older DirectFB API)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 6 Nov 2002 23:49:19 +0000 (23:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    DirectFB-extra-acfix.patch -> 1.1
    DirectFB-extra.spec -> 1.2

DirectFB-extra-acfix.patch [new file with mode: 0644]
DirectFB-extra.spec

diff --git a/DirectFB-extra-acfix.patch b/DirectFB-extra-acfix.patch
new file mode 100644 (file)
index 0000000..b362197
--- /dev/null
@@ -0,0 +1,51 @@
+--- DirectFB-extra-0.9.9/configure.in.orig     Thu Jan 10 19:49:32 2002
++++ DirectFB-extra-0.9.9/configure.in  Wed Nov  6 23:40:30 2002
+@@ -114,6 +114,8 @@
+ #
+ # OpenQuicktime check
+ #
++AC_ARG_ENABLE(openquicktime, [  --disable-openquicktime     disable openquicktime plugin [default=yes]],, enable_openquicktime=yes)
++if test "x$enable_openquicktime" = xyes ; then
+ AC_CHECK_LIB(openquicktime, quicktime_open, openquicktime="yes", openquicktime="no")
+ if test "x$openquicktime" = xyes; then
+   OPENQUICKTIME_LIBS="-lopenquicktime"
+@@ -127,7 +129,9 @@
+ fi 
+ AC_SUBST(OPENQUICKTIME_LIBS)
+-
++else
++      openquicktime=no
++fi
+ AM_CONDITIONAL(OPENQUICKTIME, test "x$openquicktime" = xyes)
+@@ -135,6 +139,8 @@
+ # Imlib2 check
+ #
++AC_ARG_ENABLE(imlib2, [  --disable-imlib2     disable imlib2 plugin [default=yes]],, enable_imlib2=yes)
++if test "x$enable_imlib2" = xyes ; then
+ AC_PATH_PROG(IMLIB2_CONFIG, imlib2-config, no)
+ if test "x$IMLIB2_CONFIG" = xno; then
+   AC_MSG_WARN([*** Imlib2 library not found, building without Imlib2 support ***])
+@@ -147,7 +153,9 @@
+ AC_SUBST(IMLIB2_LIBS)
+ AC_SUBST(IMLIB2_INCLUDES)
+-
++else
++      imlib2=no
++fi
+ AM_CONDITIONAL(IMLIB2, test "x$imlib2" = xyes)
+@@ -161,7 +169,7 @@
+ AM_CONDITIONAL(ENABLE_DEBUG, test "x$enable_debug" = xyes)
+-if test x$cflags_set != xset ; then
++if test "x$cflags_set" != "xset" ; then
+   DFB_CFLAGS="$DFB_CFLAGS $CFLAGS"
+ fi
index 9ed8fb42895f1500fc5e334360e57879fc34f47f..b8c719e59ac0a6146b482da07665bf55af7c0a9f 100644 (file)
@@ -6,13 +6,14 @@ Release:      1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://www.directfb.org/download/DirectFB-extra/%{name}-%{version}.tar.gz
+Patch0:                %{name}-acfix.patch
 URL:           http://www.directfb.org/
 BuildRequires: DirectFB-devel >= %{version}
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: imlib2-devel
+#BuildRequires:        imlib2-devel
 BuildRequires: openquicktime-devel
-BuildRequires: pkgconfig
+BuildRequires: pkgconfig >= 0.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dfbdir          %(pkg-config --variable=moduledir directfb-internal)
@@ -56,13 +57,15 @@ OpenQuicktime.
 
 %prep
 %setup -q
+%patch -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       --disable-imlib2
 
 %{__make} MODULEDIR=%{dfbdir}
 
@@ -76,10 +79,10 @@ rm -rf $RPM_BUILD_ROOT
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -n DirectFB-image-imlib2
-%defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README
-%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_imlib2.??
+#%files -n DirectFB-image-imlib2
+#%defattr(644,root,root,755)
+#%doc AUTHORS ChangeLog README
+#%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_imlib2.??
 
 %files -n DirectFB-video-openquicktime
 %defattr(644,root,root,755)
This page took 0.074769 seconds and 4 git commands to generate.