]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
2769349f471e184f4ef357d427e29276667c232b
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl):    Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        0.9.15
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/DirectFB/%{name}-%{version}.tar.gz
9 # Source0-md5:  32f194907e5d36dbafabbe5becdfbdcd
10 URL:            http://www.directfb.org/
11 BuildRequires:  DirectFB-devel >= %{version}
12 BuildRequires:  autoconf
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  pkgconfig
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
19 advantage is that the 'thiz' doesn't need to be passed as the first
20 argument of every interface function. Another feature is the usage of
21 exceptions. It's annoying having these error checking stuff with
22 growing deinitialization stacks. Most functions are 'void'. As soon as
23 a DirectFB function returns an error a DFBException is thrown.
24                 
25 %description -l pl
26 DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
27 u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
28 jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
29 wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym stosem
30 deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
31 zwraca b³±d, rzucany jest wyj±tek DFBException.
32
33 %package devel
34 Summary:        DFB++ header files
35 Summary(pl):    Pliki nag³ówkowe DFB++
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}
38
39 %description devel
40 Header files for DFB++ library.
41
42 %description devel -l pl
43 Pliki nag³ówkowe biblioteki DFB++.
44
45 %package static
46 Summary:        DFB++ static library
47 Summary(pl):    Statyczna biblioteka DFB++
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}
50
51 %description static
52 DFB++ static library.
53
54 %description static -l pl
55 Statyczna biblioteka DFB++.
56
57 %prep
58 %setup -q
59
60 %build
61 %{__autoconf}
62 %configure \
63         --enable-static
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install DESTDIR=$RPM_BUILD_ROOT
70
71 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS ChangeLog README
83 %attr(755,root,root) %{_libdir}/lib*.so.*.*
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/lib*.so
88 %{_libdir}/lib*.la
89 %attr(755,root,root) %{_bindir}/dfb++-config
90 %{_includedir}/dfb++
91 %{_pkgconfigdir}/*.pc
92 %{_examplesdir}/%{name}-%{version}
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/lib*.a
This page took 0.040835 seconds and 2 git commands to generate.