]> git.pld-linux.org Git - packages/CoinUtils.git/blob - CoinUtils.spec
- unconditional noarch subpackages
[packages/CoinUtils.git] / CoinUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        COIN-OR Utilities library
7 Summary(pl.UTF-8):      Biblioteka narzędziowa COIN-OR Utilities
8 Name:           CoinUtils
9 Version:        2.9.17
10 Release:        4
11 License:        Eclipse Public License v1.0
12 Group:          Libraries
13 Source0:        http://www.coin-or.org/download/source/CoinUtils/%{name}-%{version}.tgz
14 # Source0-md5:  e91ff822dc535055968094d88bcaabce
15 Patch0:         %{name}-format.patch
16 Patch1:         %{name}-destdir.patch
17 URL:            https://projects.coin-or.org/CoinUtils
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  blas-devel
21 BuildRequires:  bzip2-devel
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  lapack-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.5
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 CoinUtils (Coin-or Utilities) is an open-source collection of classes
31 and functions that are generally useful to more than one COIN-OR
32 project. These utilities include:
33  - Vector classes
34  - Matrix classes
35  - MPS file reading
36  - Comparing floating point numbers with a tolerance
37
38 %description -l pl.UTF-8
39 CoinUtils (Coin-or Utilities) to mający otwarte źródła zbiór klas i
40 funkcji ogólnie przydatnych dla więcej niż jednego projektu COIN-OR.
41 Narzędzia Coin-or zawirają:
42  - klasy wektorów
43  - klasy macierzy
44  - odczyt plików MPS
45  - porównywanie liczb zmiennoprzecinkowych z określoną dokładnością
46
47 %package devel
48 Summary:        Header files for CoinUtils library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CoinUtils
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       blas-devel
53 Requires:       bzip2-devel
54 Requires:       lapack-devel
55 Requires:       libstdc++-devel
56 Requires:       zlib-devel
57
58 %description devel
59 Header files for CoinUtils library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki CoinUtils.
63
64 %package static
65 Summary:        Static CoinUtils library
66 Summary(pl.UTF-8):      Statyczna biblioteka CoinUtils
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static CoinUtils library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka CoinUtils.
75
76 %package apidocs
77 Summary:        CoinUtils API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki CoinUtils
79 Group:          Documentation
80 BuildArch:      noarch
81
82 %description apidocs
83 API documentation for CoinUtils library.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki CoinUtils.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 ln -s ../BuildTools CoinUtils/BuildTools
94
95 %build
96 cd CoinUtils
97 %{__libtoolize}
98 %{__aclocal} -I BuildTools
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 cd ..
103 %configure \
104         PKG_CONFIG_PATH="%{_pkgconfigdir}" \
105         --enable-dependency-linking \
106         %{?with_static_libs:--enable-static}
107 %{__make}
108
109 %if %{with apidocs}
110 %{__make} doxydoc
111 %endif
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 # obsoleted by pkg-config
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoinUtils.la
121 # packages as %doc
122 %{__rm} $RPM_BUILD_ROOT%{_datadir}/coin/doc/CoinUtils/{AUTHORS,LICENSE,README}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc CoinUtils/{AUTHORS,LICENSE,README}
133 %attr(755,root,root) %{_libdir}/libCoinUtils.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libCoinUtils.so.3
135 %dir %{_datadir}/coin
136 %{_datadir}/coin/Data
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libCoinUtils.so
141 %dir %{_includedir}/coin
142 %{_includedir}/coin/CoinUtilsConfig.h
143 %{_includedir}/coin/Coin_C_defines.h
144 %{_includedir}/coin/Coin*.hpp
145 %{_pkgconfigdir}/coindatasample.pc
146 %{_pkgconfigdir}/coinutils.pc
147 %dir %{_datadir}/coin/doc
148 %dir %{_datadir}/coin/doc/CoinUtils
149 %{_datadir}/coin/doc/CoinUtils/coinutils_addlibs.txt
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libCoinUtils.a
155 %endif
156
157 %if %{with apidocs}
158 %files apidocs
159 %defattr(644,root,root,755)
160 %doc doxydoc/html/*
161 %endif
This page took 0.097989 seconds and 4 git commands to generate.