]> git.pld-linux.org Git - packages/Backbone.git/blob - Backbone.spec
- builds cleanly with -Werror
[packages/Backbone.git] / Backbone.spec
1 %define cvs     20050327
2 Summary:        GNUstep backbone apps, including Preferences
3 Summary(pl):    Szkieletowe aplikacje GNUstepa, w tym Preferences
4 Name:           Backbone
5 Version:        1.2.99
6 Release:        0.%{cvs}.2
7 License:        GPL
8 Group:          X11/Applications
9 Source0:        %{name}-%{cvs}.tar.gz
10 # Source0-md5:  7e599ad7c8acadc81b682602e2906175
11 Patch0:         %{name}-buildinplace.patch
12 Patch1:         %{name}-installprefix.patch
13 Patch2:         %{name}-pass-arguments.patch
14 URL:            http://www.nongnu.org/backbone/
15 BuildRequires:  gnustep-gui-devel
16 Obsoletes:      Preferences
17 Obsoletes:      Terminal
18 Obsoletes:      TextEdit
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _prefix         /usr/%{_lib}/GNUstep
22
23 %define         libcombo        gnu-gnu-gnu
24 %define         gsos            linux-gnu
25 %ifarch %{ix86}
26 %define         gscpu           ix86
27 %else
28 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
29 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
30 %endif
31
32 %description
33 GNUstep Backbone applications, including Preferences.
34
35 %description -l pl
36 Szkieletowe aplikacje GNUstepa, w tym Preferences (edytor ustawieñ).
37
38 %package devel
39 Summary:        Header files for Backbone frameworks
40 Summary(pl):    Pliki nag³ówkowe dla bibliotek Backbone
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       gnustep-gui-devel
44 Obsoletes:      Preferences-devel
45
46 %description devel
47 Header files for Backbone frameworks.
48
49 %description devel -l pl
50 Pliki nag³ówkowe dla bibliotek Backbone.
51
52 %prep
53 %setup -q -n System
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57
58 %build
59 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
60 %{__make} \
61         OPTFLAG="%{rpmcflags}" \
62         messages=yes
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
67
68 %{__make} install \
69         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT \
70         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %dir %{_prefix}/System/Applications/*.app
81 %dir %{_prefix}/System/Applications/*.app/Resources
82 %{_prefix}/System/Applications/*.app/Resources/*.desktop
83 %{_prefix}/System/Applications/*.app/Resources/*.plist
84 %{_prefix}/System/Applications/*.app/Resources/*.tiff
85 %{_prefix}/System/Applications/*.app/Resources/*.txt
86 %{_prefix}/System/Applications/*.app/Resources/*.svcs
87 %{_prefix}/System/Applications/*.app/Resources/English.lproj
88 %lang(fr) %{_prefix}/System/Applications/*.app/Resources/French.lproj
89 %lang(de) %{_prefix}/System/Applications/*.app/Resources/German.lproj
90 %lang(hu) %{_prefix}/System/Applications/*.app/Resources/Hungarian.lproj
91 %lang(nb) %{_prefix}/System/Applications/*.app/Resources/Norwegian.lproj
92 %lang(ru) %{_prefix}/System/Applications/*.app/Resources/Russian.lproj
93 %lang(es) %{_prefix}/System/Applications/*.app/Resources/Spanish.lproj
94 %lang(se) %{_prefix}/System/Applications/*.app/Resources/Swedish.lproj
95 %lang(tr) %{_prefix}/System/Applications/*.app/Resources/Turkish.lproj
96 %dir %{_prefix}/System/Applications/*.app/%{gscpu}
97 %dir %{_prefix}/System/Applications/*.app/%{gscpu}/%{gsos}
98 %dir %{_prefix}/System/Applications/*.app/%{gscpu}/%{gsos}/%{libcombo}
99 %attr(755,root,root) %{_prefix}/System/Applications/Preferences.app/Preferences
100 %attr(755,root,root) %{_prefix}/System/Applications/Preferences.app/%{gscpu}/%{gsos}/%{libcombo}/Preferences
101 %attr(755,root,root) %{_prefix}/System/Applications/Terminal.app/Terminal
102 %attr(755,root,root) %{_prefix}/System/Applications/Terminal.app/%{gscpu}/%{gsos}/%{libcombo}/Terminal
103 %attr(755,root,root) %{_prefix}/System/Applications/TextEdit.app/TextEdit
104 %attr(755,root,root) %{_prefix}/System/Applications/TextEdit.app/%{gscpu}/%{gsos}/%{libcombo}/TextEdit
105 %{_prefix}/System/Applications/*.app/%{gscpu}/%{gsos}/%{libcombo}/*.openapp
106 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
107
108 %dir %{_prefix}/System/Library/Frameworks/*.framework
109 %{_prefix}/System/Library/Frameworks/*.framework/Resources
110 %dir %{_prefix}/System/Library/Frameworks/*.framework/Versions
111 %dir %{_prefix}/System/Library/Frameworks/*.framework/Versions/*
112 %{_prefix}/System/Library/Frameworks/*.framework/Versions/1.1.0/Resources
113 %attr(755,root,root) %{_prefix}/System/Library/Frameworks/*.framework/Versions/1.1.0/%{gscpu}
114
115 %attr(755,root,root) %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
116
117 %dir %{_prefix}/System/Library/Preferences
118 %dir %{_prefix}/System/Library/Preferences/*.prefs
119 %{_prefix}/System/Library/Preferences/*.prefs/Resources
120 %attr(755,root,root) %{_prefix}/System/Library/Preferences/*.prefs/%{gscpu}
121  
122 %files devel
123 %defattr(644,root,root,755)
124 %{_prefix}/System/Library/Frameworks/*.framework/Headers
125 %{_prefix}/System/Library/Frameworks/*.framework/Versions/1.1.0/Headers
126 %{_prefix}/System/Library/Headers/%{libcombo}/*
127
128 %attr(755,root,root) %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
This page took 0.095682 seconds and 3 git commands to generate.