]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
b321c771aeeb88ea4d354081f23daa1adae99d40
[packages/Atlas-C++.git] / Atlas-C++.spec
1 Summary:        C++ reference implementation of the Atlas protocol
2 Summary(pl):    Implementacja protoko³u Atlas
3 Name:           Atlas-C++
4 Version:        0.4.6
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/%{name}-%{version}.tar.bz2
9 # Source0-md5:  5ef0a12001d3924baa2742171af31ed3
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libtool
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
18 communications layer designed to be used in the WorldForge MMORPG
19 gaming system. This library is suitable for linking to either clients
20 xor servers.
21
22 %description -l pl
23 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
24 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
25 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
26
27 %package devel
28 Summary:        Header files for Atlas-C++ development
29 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}
32 Requires:       libstdc++-devel
33
34 %description devel
35 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
36 communications layer designed to be used in the WorldForge MMORPG
37 gaming system. This library is suitable for linking to either clients
38 or servers.
39
40 This package contains the header files needed to develop programs that
41 use these Atlas-C++
42
43 %description devel -l pl
44 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
45 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
46 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
47
48 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
49 u¿ywaj±cych bibliotek Atlas-C++.
50
51 %package static
52 Summary:        Static libraries for Atlas-C++ development
53 Summary(pl):    Statyczne biblioteki Atlas-C++
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}
56
57 %description static
58 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
59 communications layer designed to be used in the WorldForge MMORPG
60 gaming system. This library is suitable for linking to either clients
61 or servers.
62
63 This package contains the static Atlas-C++ libraries.
64
65 %description static -l pl
66 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
67 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
68 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
69
70 Pakiet zawiera statyczne biblioteki Atlas-C++.
71
72 %prep
73 %setup -q
74
75 %build
76 rm -f missing
77 %{__aclocal}
78 %{__autoheader}
79 %{__libtoolize}
80 %{__automake}
81 %{__autoconf}
82 %configure \
83         --enable-static
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS ChangeLog NEWS README
101 %attr(755,root,root) %{_libdir}/lib*.so.*.*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/atlas-config
106 %{_includedir}/Atlas*
107 %{_libdir}/lib*.la
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %{_aclocaldir}/atlas.m4
110 %{_pkgconfigdir}/atlascpp*.pc
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.a
This page took 0.028103 seconds and 2 git commands to generate.