]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
60ec7b716f0939a43ac93e6cee00608a901585fd
[packages/Atlas-C++.git] / Atlas-C++.spec
1 Summary:        C++ reference implementation of the Atlas protocol
2 Summary(pl):    Implementacja protoko³u Atlas
3 Name:           Atlas-C++
4 Version:        0.4.6
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://ftp.worldforge.org/pub/worldforge/libs/Atlas-C++/%{name}-%{version}.tar.bz2
9 # Source0-md5:  5ef0a12001d3924baa2742171af31ed3
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  libtool >= 2:1.5
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
18 communications layer designed to be used in the WorldForge MMORPG
19 gaming system. This library is suitable for linking to either clients
20 xor servers.
21
22 %description -l pl
23 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
24 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
25 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
26
27 %package devel
28 Summary:        Header files for Atlas-C++ development
29 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       libstdc++-devel
33
34 %description devel
35 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
36 communications layer designed to be used in the WorldForge MMORPG
37 gaming system. This library is suitable for linking to either clients
38 or servers.
39
40 This package contains the header files needed to develop programs that
41 use these Atlas-C++
42
43 %description devel -l pl
44 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
45 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
46 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
47
48 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
49 u¿ywaj±cych bibliotek Atlas-C++.
50
51 %package static
52 Summary:        Static libraries for Atlas-C++ development
53 Summary(pl):    Statyczne biblioteki Atlas-C++
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
59 communications layer designed to be used in the WorldForge MMORPG
60 gaming system. This library is suitable for linking to either clients
61 or servers.
62
63 This package contains the static Atlas-C++ libraries.
64
65 %description static -l pl
66 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
67 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
68 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
69
70 Pakiet zawiera statyczne biblioteki Atlas-C++.
71
72 %prep
73 %setup -q
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoheader}
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --enable-static
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS ChangeLog NEWS README
100 %attr(755,root,root) %{_libdir}/lib*.so.*.*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_bindir}/atlas-config
105 %attr(755,root,root) %{_libdir}/lib*.so
106 %{_libdir}/lib*.la
107 %{_includedir}/Atlas*
108 %{_aclocaldir}/atlas.m4
109 %{_pkgconfigdir}/atlascpp*.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/lib*.a
This page took 0.048721 seconds and 2 git commands to generate.