]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- added link patch
[packages/Atlas-C++.git] / Atlas-C++.spec
1 # TODO:
2 # add tutorial subpackage
3 Summary:        C++ reference implementation of the Atlas protocol
4 Summary(pl):    Implementacja protoko³u Atlas
5 Name:           Atlas-C++
6 Version:        0.6.0rc2
7 Release:        0.2
8 License:        LGPL
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/worldforge/%{name}-%{version}.tar.bz2
11 # Source0-md5:  4b1d3094f17bb01a9460278897dc17cd
12 Patch0:         %{name}-link.patch
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  bzip2-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
23 communications layer designed to be used in the WorldForge MMORPG
24 gaming system. This library is suitable for linking to either clients
25 or servers.
26
27 %description -l pl
28 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
29 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
30 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
31
32 %package devel
33 Summary:        Header files for Atlas-C++ development
34 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38 # libAtlasFilters additionally R: bzip2-devel,zlib-devel
39
40 %description devel
41 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
42 communications layer designed to be used in the WorldForge MMORPG
43 gaming system. This library is suitable for linking to either clients
44 or servers.
45
46 This package contains the header files needed to develop programs that
47 use these Atlas-C++
48
49 %description devel -l pl
50 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
51 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
52 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
53
54 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
55 u¿ywaj±cych bibliotek Atlas-C++.
56
57 %package static
58 Summary:        Static libraries for Atlas-C++ development
59 Summary(pl):    Statyczne biblioteki Atlas-C++
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
65 communications layer designed to be used in the WorldForge MMORPG
66 gaming system. This library is suitable for linking to either clients
67 or servers.
68
69 This package contains the static Atlas-C++ libraries.
70
71 %description static -l pl
72 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
73 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
74 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
75
76 Pakiet zawiera statyczne biblioteki Atlas-C++.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoheader}
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --enable-static
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog NEWS README
107 %attr(755,root,root) %{_bindir}/atlas_convert
108 %attr(755,root,root) %{_libdir}/libAtlas*.so.*.*.*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/libAtlas*.so
113 %{_libdir}/libAtlas*.la
114 %{_includedir}/Atlas*
115 %{_pkgconfigdir}/atlascpp*.pc
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libAtlas*.a
This page took 0.052389 seconds and 3 git commands to generate.