]> git.pld-linux.org Git - packages/AMD.git/blob - AMD.spec
- fix SuiteSparse BRs
[packages/AMD.git] / AMD.spec
1 Summary:        AMD: Approximate Minimum Degree
2 Summary(pl.UTF-8):      AMD - przybliżony algorytm minimalnego stopnia
3 Name:           AMD
4 Version:        2.4.0
5 Release:        4
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/amd/%{name}-%{version}.tar.gz
9 # Source0-md5:  5044de774a2f7804d09ac0d5134d6884
10 Patch0:         amd-ufconfig.patch
11 Patch1:         amd-shared.patch
12 Patch2:         amd-externc.patch
13 URL:            http://www.cise.ufl.edu/research/sparse/amd/
14 BuildRequires:  SuiteSparse_config-devel >= 4.3.0
15 BuildRequires:  gcc-fortran
16 BuildRequires:  libtool >= 2:1.5
17 Requires:       SuiteSparse_config-libs >= 4.3.0
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 AMD is a set of routines for ordering a sparse matrix prior to
22 Cholesky factorization (or for LU factorization with diagonal
23 pivoting). There are versions in both C and Fortran. A MATLAB
24 interface is provided. Note that this software has nothing to do with
25 AMD the company.
26
27 %description -l pl.UTF-8
28 AMD to zbiór procedur do porządkowania macierzy rzadkich przed
29 rozkładem Cholesky'ego (lub do rozkładu LU z obrotami diagonalnymi).
30 Istnieją wersje zarówno w C, jak i Fortranie. Dostępny jest interfejs
31 do MATLAB-a. Uwaga: to oprogramowanie nie ma nic wspólnego z firmą
32 AMD.
33
34 %package devel
35 Summary:        Header files for AMD library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AMD
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       SuiteSparse_config >= 4.3.0
40
41 %description devel
42 Header files for AMD library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki AMD.
46
47 %package static
48 Summary:        Static AMD library
49 Summary(pl.UTF-8):      Statyczna biblioteka AMD
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static AMD library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka AMD.
58
59 %package fortran
60 Summary:        Fortran version of AMD library
61 Summary(pl.UTF-8):      Wersja biblioteki AMD dla programów w Fortranie
62 Group:          Libraries
63
64 %description fortran
65 Fortran version of AMD library.
66
67 %description fortran -l pl.UTF-8
68 Wersja biblioteki AMD dla programów napisanych w Fortranie.
69
70 %package fortran-devel
71 Summary:        Fortran version of AMD library - development files
72 Summary(pl.UTF-8):      Wersja biblioteki AMD dla programów w Fortranie - pliki programistyczne
73 Group:          Development/Libraries
74 Requires:       %{name}-fortran = %{version}-%{release}
75
76 %description fortran-devel
77 Fortran version of AMD library - development files.
78
79 %description fortran-devel -l pl.UTF-8
80 Wersja biblioteki AMD dla programów w Fortranie - pliki
81 programistyczne.
82
83 %package fortran-static
84 Summary:        Fortran version of AMD static library
85 Summary(pl.UTF-8):      Wersja statycznej biblioteki AMD dla programów w Fortranie
86 Group:          Development/Libraries
87 Requires:       %{name}-fortran-devel = %{version}-%{release}
88
89 %description fortran-static
90 Fortran version of AMD static library.
91
92 %description fortran-static -l pl.UTF-8
93 Wersja statycznej biblioteki AMD dla programów napisanych w Fortranie.
94
95 %prep
96 %setup -q -n %{name}
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %{__make} \
103         CC="%{__cc}" \
104         CFLAGS="%{rpmcflags}" \
105         LDFLAGS="%{rpmldflags}" \
106         libdir=%{_libdir}
107
108 %{__make} fortran \
109         CC="%{__cc}" \
110         CFLAGS="%{rpmcflags}" \
111         LDFLAGS="%{rpmldflags}" \
112         libdir=%{_libdir}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_includedir}/amd
117
118 %{__make} -C Lib install install-fortran \
119         DESTDIR=$RPM_BUILD_ROOT \
120         libdir=%{_libdir}
121
122 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/amd
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc README.txt Doc/{ChangeLog,License}
133 %attr(755,root,root) %{_libdir}/libamd.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libamd.so.0
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc Doc/AMD_UserGuide.pdf
139 %attr(755,root,root) %{_libdir}/libamd.so
140 %{_libdir}/libamd.la
141 %{_includedir}/amd
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libamd.a
146
147 %files fortran
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libamdf77.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libamdf77.so.0
151
152 %files fortran-devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libamdf77.so
155 %{_libdir}/libamdf77.la
156
157 %files fortran-static
158 %defattr(644,root,root,755)
159 %{_libdir}/libamdf77.a
This page took 0.094621 seconds and 4 git commands to generate.