]> git.pld-linux.org Git - SPECS.git/blob - zita-resampler.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / zita-resampler.spec
1 Summary:        C++ library for sample rate conversion of audio signals
2 Name:           zita-resampler
3 Version:        1.6.0
4 Release:        1
5 License:        GPL v3+
6 Group:          Libraries
7 Source0:        http://kokkinizita.linuxaudio.org/linuxaudio/downloads/%{name}-%{version}.tar.bz2
8 # Source0-md5:  7b5ddc42f210985b29c8769111217e4c
9 URL:            http://kokkinizita.linuxaudio.org/linuxaudio/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Zita-resampler is a C++ library for sample rate conversion of audio
14 signals.
15
16 %package devel
17 Summary:        Header files for %{name} library
18 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
19 Group:          Development/Libraries
20 Requires:       %{name} = %{version}-%{release}
21
22 %description devel
23 Header files for %{name} library.
24
25 %description devel -l pl.UTF-8
26 Pliki nagłówkowe biblioteki %{name}.
27
28 %package apps
29 Summary:        Example applications using the %{name} library
30 Group:          Applications/Sound
31 Requires:       %{name} = %{version}-%{release}
32
33 %description apps
34 Example applications using the %{name} library.
35
36 %prep
37 %setup -q
38
39 %build
40 CXXFLAGS="%{rpmcxxflags}" \
41 CPPFLAGS="%{rpmcppflags}" \
42 LDFLAGS="%{rpmldflags}" \
43 %{__make} -C libs
44
45 ln -s "$(basename libs/libzita-resampler.so.*.*.*)" libs/libzita-resampler.so
46
47 CXXFLAGS="%{rpmcxxflags}" \
48 CPPFLAGS="-I../libs %{rpmcppflags}" \
49 LDFLAGS="-L../libs %{rpmldflags}" \
50 %{__make} -C apps
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
55
56 cp -p libs/lib%{name}.so.1.* $RPM_BUILD_ROOT%{_libdir}
57 /sbin/ldconfig -nN $RPM_BUILD_ROOT%{_libdir}
58 ln -s "$(basename libs/lib%{name}.so.1.*)" $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
59 cp -R libs/%{name} $RPM_BUILD_ROOT%{_includedir}
60
61 %{__make} -C apps install \
62         PREFIX="%{_prefix}" \
63         DESTDIR="$RPM_BUILD_ROOT"
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post   -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files
72 %defattr(644,root,root,755)
73 %doc AUTHORS README
74 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
75 %attr(755,root,root) %ghost %{_libdir}/lib%{name}.so.1
76
77 %files devel
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_libdir}/lib%{name}.so
80 %{_includedir}/%{name}
81
82 %files apps
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/*
85 %{_mandir}/man1/*.1*
This page took 0.161773 seconds and 3 git commands to generate.