]> git.pld-linux.org Git - SPECS.git/blob - yubico-piv-tool.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / yubico-piv-tool.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  tests           # unit tests
5
6 Summary:        Tool for interacting with the PIV applet on a YubiKey NEO
7 Summary(pl.UTF-8):      Narzędzie do komunikacji z apletem PIV na YubiKey NEO
8 Name:           yubico-piv-tool
9 Version:        1.5.0
10 Release:        3
11 License:        BSD
12 Group:          Applications
13 Source0:        https://developers.yubico.com/yubico-piv-tool/Releases/%{name}-%{version}.tar.gz
14 # Source0-md5:  bcfec9fa2454ba7f7be6cc80632bd41f
15 URL:            https://developers.yubico.com/yubico-piv-tool/
16 %{?with_tests:BuildRequires:    check-devel >= 0.9.6}
17 BuildRequires:  help2man
18 BuildRequires:  openssl-devel
19 BuildRequires:  pcsc-lite-devel
20 BuildRequires:  pkgconfig
21 Requires:       %{name}-libs = %{version}-%{release}
22 Requires:       pcsc-driver-ccid
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Yubico PIV tool is used for interacting with the Privilege and
27 Identification Card (PIV) applet on a YubiKey NEO.
28
29 With it you may generate keys on the device, importing keys and
30 certificates, and create certificate requests, and other operations.
31
32 %description -l pl.UTF-8
33 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
34 (Privilege and Identification card) na urządzeniach YubiKey NEO.
35
36 Przy jego pomocy można generować klucze na urządzeniu, importować
37 klucze i certyfikaty, tworzyć żądania certyfikatów oraz wykonywać inne
38 operacje.
39
40 %package libs
41 Summary:        Yubico PIV shared libraries
42 Summary(pl.UTF-8):      Biblioteki współdzielone Yubico PIV
43 Group:          Libraries
44
45 %description libs
46 The Yubico PIV tool is used for interacting with the Privilege and
47 Identification Card (PIV) applet on a YubiKey NEO. This package
48 contains shared libraries for the tool.
49
50 %description libs -l pl.UTF-8
51 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
52 (Privilege and Identification card) na urządzeniach YubiKey NEO. Ten
53 pakiet zawiera biblioteki współdzielone wykorzystywane przez
54 narzędzie.
55
56 %package devel
57 Summary:        Header files for Yubico PIV libraries
58 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Yubico PIV
59 Group:          Development/Libraries
60 Requires:       %{name}-libs = %{version}-%{release}
61 Requires:       openssl-devel
62
63 %description devel
64 The Yubico PIV tool is used for interacting with the Privilege and
65 Identification Card (PIV) applet on a YubiKey NEO. This package
66 includes development files.
67
68 %description devel -l pl.UTF-8
69 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
70 (Privilege and Identification card) na urządzeniach YubiKey NEO. Ten
71 pakiet zawiera pliki programistyczne.
72
73 %package static
74 Summary:        Yubico PIV static libraries
75 Summary(pl.UTF-8):      Biblioteki statyczne Yubico PIV
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 The Yubico PIV tool is used for interacting with the Privilege and
81 Identification Card (PIV) applet on a YubiKey NEO. This package
82 includes static libraries.
83
84 %description static -l pl.UTF-8
85 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
86 (Privilege and Identification card) na urządzeniach YubiKey NEO. Ten
87 pakiet zawiera biblioteki statyczne.
88
89 %prep
90 %setup -q
91
92 %build
93 %configure \
94         --with-backend="pcsc" \
95         --disable-silent-rules \
96         %{!?with_static_libs:--disable-static}
97
98 %{__make}
99
100 %if %{with tests}
101 # disable valgrind, it catches some issues in bash
102 %{__make} check \
103         LOG_COMPILER=
104 %endif
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{ykcs11,ykpiv}.la
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   libs -p /sbin/ldconfig
117 %postun libs -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc COPYING ChangeLog NEWS README doc/*.adoc
122 %attr(755,root,root) %{_bindir}/yubico-piv-tool
123 %{_mandir}/man1/yubico-piv-tool.1*
124
125 %files libs
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libykpiv.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libykpiv.so.1
129 %attr(755,root,root) %{_libdir}/libykcs11.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libykcs11.so.1
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libykpiv.so
135 %attr(755,root,root) %{_libdir}/libykcs11.so
136 %{_pkgconfigdir}/ykpiv.pc
137 %{_pkgconfigdir}/ykcs11.pc
138 %{_includedir}/ykpiv
139
140 %if %{with static_libs}
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libykpiv.a
144 %{_libdir}/libykcs11.a
145 %endif
This page took 0.048546 seconds and 3 git commands to generate.