]> git.pld-linux.org Git - SPECS.git/blob - xxHash.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / xxHash.spec
1 Summary:        xxHash - extremely fast hash algorithm
2 Summary(pl.UTF-8):      xxHash - bardzo szybki algorytm haszowania
3 Name:           xxHash
4 Version:        0.8.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/Cyan4973/xxHash/releases
9 Source0:        https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  62310678857c30fcef4128f41f711f49
11 Patch0:         %{name}-pc.patch
12 URL:            https://github.com/Cyan4973/xxHash
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %ifarch %{arm}
16 %define         archcflags      -DXXH_FORCE_MEMORY_ACCESS=1
17 %endif
18
19 %description
20 xxHash is an Extremely fast Hash algorithm, running at RAM speed
21 limits. It successfully completes the SMHasher test suite which
22 evaluates collision, dispersion and randomness qualities of hash
23 functions. Code is highly portable, and hashes are identical on all
24 platforms (little / big endian).
25
26 %description -l pl.UTF-8
27 xxHash to niezwykle szybki algorytm haszowania, dochodzący do
28 ograniczeń szybkości pamięci RAM. Przechodzi zestaw testów SMHasher,
29 oceniający współczynniki kolizji, dyspersji i losowości funkcji
30 haszujących. Kod jest przenośny, a wartości haszy identyczne na
31 wszystkich platformach (little- i big-endian).
32
33 %package devel
34 Summary:        Header files for xxHash library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki xxHash
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for xxHash library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki xxHash.
44
45 %package static
46 Summary:        Static xxHash library
47 Summary(pl.UTF-8):      Statyczna biblioteka xxHash
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static xxHash library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka xxHash.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 CFLAGS="%{rpmcflags}" \
63 CPPFLAGS="%{rpmcflags} %{?archcflags}" \
64 LDFLAGS="%{rpmldflags}" \
65 %{__make} \
66         prefix=%{_prefix} \
67         libdir=%{_libdir}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT \
74         prefix=%{_prefix} \
75         libdir=%{_libdir}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGELOG LICENSE README.md
86 %attr(755,root,root) %{_bindir}/xxhsum
87 %attr(755,root,root) %{_bindir}/xxh32sum
88 %attr(755,root,root) %{_bindir}/xxh64sum
89 %attr(755,root,root) %{_bindir}/xxh128sum
90 %attr(755,root,root) %{_libdir}/libxxhash.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libxxhash.so.0
92 %{_mandir}/man1/xxhsum.1*
93 %{_mandir}/man1/xxh32sum.1*
94 %{_mandir}/man1/xxh64sum.1*
95 %{_mandir}/man1/xxh128sum.1*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc doc/xxhash_spec.md
100 %attr(755,root,root) %{_libdir}/libxxhash.so
101 %{_includedir}/xxh3.h
102 %{_includedir}/xxhash.h
103 %{_pkgconfigdir}/libxxhash.pc
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libxxhash.a
This page took 0.405901 seconds and 3 git commands to generate.