]> git.pld-linux.org Git - SPECS.git/blob - xprint.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / xprint.spec
1 %define         _date           2002-12-01
2 %define         _rel            008
3 Summary:        Xprint - advanced print API for X11-based applications
4 Summary(pl.UTF-8):      Xprint - zaawansowane API do drukowania dla aplikacji opartych na X11
5 Name:           xprint
6 Version:        0.0.%{_rel}
7 Release:        2
8 License:        MIT
9 Group:          X11/XFree86
10 Source0:        http://puck.informatik.med.uni-giessen.de/download/%{name}_mozdev_org_source-%{_date}-trunk.tar.gz
11 # Source0-md5:  a196f07e60c381263d252f3a53f9f036
12 Requires:       rc-scripts
13 Requires:       xprint-initrc
14 Requires(post,preun):   /sbin/chkconfig
15 URL:            http://xprint.mozdev.org/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18
19 %description
20 Xprint provides an advanced print API for X11-based (incl. CDE,
21 Xt/Motif-, Xt/LessTif-, Xt/Athena-, Qt- and Mozilla-based)
22 applications.
23
24 %description -l pl.UTF-8
25 Xprint udostÄ™pnia zaawansowane API do drukowania dla aplikacji
26 opartych na X11 (w tym opartych na CDE, Xt/Motifie, Xt/LessTifie,
27 Xt/Athenie, Qt, Mozilli).
28
29 %prep
30 %setup -q -n %{name}
31
32 %build
33 cd src/xprint_main
34 %{__make} -S -C xc World DEFAULT_OS_CPU_FROB=%{_target_cpu} \
35         "BOOTSTRAPCFLAGS=%{rpmcflags}" \
36         "CCOPTIONS=%{rpmcflags}" \
37         "CXXOPTIONS=%{rpmcflags}" \
38         "CXXDEBUGFLAGS=" "CDEBUGFLAGS="
39 cd ../..
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_bindir}
44
45 install src/xprint_main/xc/programs/Xserver/Xprt $RPM_BUILD_ROOT%{_bindir}
46
47 cd src/xprint_main/xc/programs/Xserver/XpConfig
48 DIRS=`find C -type d | egrep -v "CVS|Imakefile|Makefile"`
49 for DIR in $DIRS; do mkdir -p $RPM_BUILD_ROOT/etc/X11/xserver/$DIR; done
50 FILES=`find C -type f | egrep -v "CVS|Imakefile|Makefile"`
51 for FILE in $FILES; do cp $FILE $RPM_BUILD_ROOT/etc/X11/xserver/$FILE; done
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/chkconfig --add xprint
58 if [ -f /var/lock/subsys/Xprint1 ]; then
59         /etc/rc.d/init.d/xprint restart 1>&2
60 else
61         echo "Run \"/etc/rc.d/init.d/xprint start\" to start Xprint daemon."
62 fi
63
64 %preun
65 if [ "$1" = "0" ]; then
66         if [ -f /var/lock/subsys/Xprint1 ]; then
67                 /etc/rc.d/init.d/xprint stop 1>&2
68         fi
69         /sbin/chkconfig --del xprint
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/*
75 %doc src/xprint_main/xc/doc/hardcopy/XPRINT/Xprint_FAQ.txt
76 /etc/X11/xserver/C/print/Xprinters
77 /etc/X11/xserver/C/print/attributes
78 /etc/X11/xserver/C/print/ddx-config
79 /etc/X11/xserver/C/print/models/HPDJ1600C
80 /etc/X11/xserver/C/print/models/HPLJ4family
81 /etc/X11/xserver/C/print/models/PSdefault
82 /etc/X11/xserver/C/print/models/PSspooldir/model-config
83 %attr(755,root,root) /etc/X11/xserver/C/print/models/PSspooldir/spooltodir.sh
84 /etc/X11/xserver/C/print/models/SPSPARC2
This page took 0.30985 seconds and 3 git commands to generate.