]> git.pld-linux.org Git - SPECS.git/blob - xpertmud.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / xpertmud.spec
1 %define         _rc     alpha2
2 %define         _snap   20050319
3 Summary:        Xpertmud - extensible MUD client
4 Summary(pl.UTF-8):      Xpertmud - elastyczny klient MUD
5 Name:           xpertmud
6 Version:        3.1
7 Release:        0.%{_rc}_%{_snap}.2
8 License:        GPL
9 Group:          X11/Applications/Games
10 Source0:        ftp://distfiles.pld-linux.org/src/%{name}-%{version}%{_rc}-%{_snap}.tar.bz2
11 # Source0-md5:  a8126a7d9420a6fa8fe4c244d00f2ea4
12 Source1:        %{name}.desktop
13 Patch0:         xpertmud-cvs.patch
14 URL:            http://xpertmud.sourceforge.net/
15 BuildRequires:  artsc-devel
16 BuildRequires:  automake
17 BuildRequires:  autoconf
18 BuildRequires:  fam-devel
19 BuildRequires:  kdelibs-devel
20 BuildRequires:  libart_lgpl-devel
21 BuildRequires:  libtool
22 BuildRequires:  pcre-devel
23 BuildRequires:  perl-devel
24 BuildRequires:  perl-perldoc
25 BuildRequires:  python-devel
26 BuildRequires:  qt-devel
27 BuildRequires:  rpmbuild(macros) >= 1.277
28 BuildRequires:  ruby-devel
29 Requires:       kdelibs >= 3.1
30 %{?ruby_mod_ver_requires_eq}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Xpertmud is an extensible perl, python and ruby (partialy) scriptable
35 MUD client. It supports multiple windows (which are scriptable, yeah),
36 and you can use triggers, aliases or whatever you want on every bit of
37 text that comes from or goes to the server. There's a stable and
38 intuitive plugin API, so you can extend the client with Qt-based C++
39 code.
40
41 %description -l pl.UTF-8
42 Xpertmud jest elastycznym klientem MUD. Wspiera takie języki skryptowe
43 jak perl, python oraz częściowo ruby. Posiada obsługę wielu okien
44 (które można do woli oskryptować!). Oczywiście można stosować
45 triggery, aliasy oraz jest możliwość zrobienia czego się tylko
46 zapragnie z wysyłanym do, bądź odbieranym z serwera mud tekstem. Poza
47 tym Xpertmud posiada stabilne oraz proste do poznania API do wtyczek.
48 Dzięki temu można poszerzyć jego możliwości pisząc dodatki oparte na
49 Qt.
50
51 %package scripting-python
52 Summary:        Xpertmud - Python scripting package
53 Summary(pl.UTF-8):      Xpertmud - biblioteka do pisania skryptów w pythonie
54 Group:          X11/Applications/Games
55 Requires:       xpertmud = %{version}-%{release}
56 Requires:       python >= 2.2.2
57
58 %description scripting-python
59 Python scripting library for Xpertmud.
60
61 %description scripting-python -l pl.UTF-8
62 Biblioteka Xpertmuda do pisania skryptów w Pythonie.
63
64 %package scripting-ruby
65 Summary:        Xpertmud - Ruby scripting package
66 Summary(pl.UTF-8):      Xpertmud - biblioteka do pisania skryptów w Ruby
67 Group:          X11/Applications/Games
68 Requires:       xpertmud = %{version}-%{release}
69 Requires:       ruby >= 1:1.6.8
70
71 %description scripting-ruby
72 Ruby scripting library for Xpertmud.
73
74 %description scripting-ruby -l pl.UTF-8
75 Biblioteka Xpertmuda do pisania skryptów w Ruby.
76
77 %package plugins-misc-BattleTech
78 Summary:        Xpertmud - BattleTech plugin
79 Summary(pl.UTF-8):      Xpertmud - wtyczka Xpertmuda do BattleTech
80 Group:          X11/Applications/Games
81 Requires:       xpertmud = %{version}-%{release}
82
83 %description plugins-misc-BattleTech
84 Xpertmud BattleTech plugin.
85
86 %description plugins-misc-BattleTech -l pl.UTF-8
87 Wtyczka Xpertmuda do BattleTech.
88
89 %package plugins-misc-html
90 Summary:        Xpertmud - Rapid Gui Development plugin
91 Summary(pl.UTF-8):      Xpertmud - wtyczka do szybkiego tworzenia GUI
92 Group:          X11/Applications/Games
93 Requires:       xpertmud = %{version}-%{release}
94
95 %description plugins-misc-html
96 Plugin for "Rapid Gui Development" utilizing (D)HTML and javascript.
97
98 %description plugins-misc-html -l pl.UTF-8
99 Wtyczka do szybkiego tworzenia GUI ("Rapid Gui Development"),
100 wykorzystująca do tego (D)HTML oraz javascript.
101
102 %prep
103 %setup -q -n %{name}-%{version}%{_rc}
104 %patch0 -p0
105
106 %build
107 kde_appsdir="%{_applnkdir}"; export kde_appsdir
108 kde_htmldir="%{_htmldir}"; export kde_htmldir
109 make -f Makefile.dist
110 %configure
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT%{_desktopdir}
120 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
121
122 install -d $RPM_BUILD_ROOT%{_kdedocdir}/en/xpertmud
123 install doc/en/{index.cache.bz2,index.docbook,perl-devel.docbook,python-devel.docbook} \
124         $RPM_BUILD_ROOT%{_kdedocdir}/en/xpertmud
125
126 %find_lang %{name} --with-kde
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog DESIGN TODO
137 %attr(755,root,root) %{_bindir}/*
138 %{_libdir}/kde3/kfile_xmud.la
139 %attr(755,root,root) %{_libdir}/kde3/kfile_xmud.so
140 %{_libdir}/kde3/libxmperlinterpreter.la
141 %attr(755,root,root) %{_libdir}/kde3/libxmperlinterpreter.so
142 %{_libdir}/kde3/xmud_example.la
143 %attr(755,root,root) %{_libdir}/kde3/xmud_example.so
144 %{_desktopdir}/%{name}.desktop
145 %dir %{_datadir}/apps/xpertmud
146 %{_datadir}/apps/xpertmud/artwork
147 %{_datadir}/apps/xpertmud/bookmarks
148 %dir %{_datadir}/apps/xpertmud/perl
149 %{_datadir}/apps/xpertmud/perl/XMExample.pm
150 %{_datadir}/apps/xpertmud/perl/pipes.pl
151 %{_datadir}/apps/xpertmud/perl/completion.pl
152 %{_datadir}/apps/xpertmud/perl/snake.pl
153 %{_datadir}/apps/xpertmud/perl/speedwalk.pl
154 %{_datadir}/apps/xpertmud/xpertmudui.rc
155 %{_datadir}/mimelnk/application/x-xpertmud-bookmark.desktop
156 %{_datadir}/services/kfile_xmud.desktop
157 %{_datadir}/services/xpertmud.protocol
158 %{_iconsdir}/hicolor/16x16/apps/xpertmud.png
159 %{_iconsdir}/hicolor/32x32/apps/xpertmud.png
160 # non-existent dir
161 #%{_iconsdir}/locolor/16x16/apps/xpertmud.png
162 #%{_iconsdir}/locolor/32x32/apps/xpertmud.png
163
164 %files scripting-python
165 %defattr(644,root,root,755)
166 %{_libdir}/kde3/libxmpythoninterpreter.la
167 %attr(755,root,root) %{_libdir}/kde3/libxmpythoninterpreter.so
168 %{_datadir}/apps/xpertmud/python/tapp.py
169
170 %files scripting-ruby
171 %defattr(644,root,root,755)
172 %{_libdir}/kde3/libxmrubyinterpreter.la
173 %attr(755,root,root) %{_libdir}/kde3/libxmrubyinterpreter.so
174
175 %files plugins-misc-BattleTech
176 %defattr(644,root,root,755)
177 %{_libdir}/kde3/xmud_battletech.la
178 %attr(755,root,root) %{_libdir}/kde3/xmud_battletech.so
179 %{_datadir}/apps/xpertmud/perl/XMBattleContacts.pm
180 %{_datadir}/apps/xpertmud/perl/XMBattleCore.pm
181 %{_datadir}/apps/xpertmud/perl/XMBattleHeat.pm
182 %{_datadir}/apps/xpertmud/perl/XMBattleMapView.pm
183 %{_datadir}/apps/xpertmud/perl/XMBattleSpeed.pm
184 %{_datadir}/apps/xpertmud/perl/XMBattleWeapons.pm
185 %{_datadir}/apps/xpertmud/perl/battlerecorder.pl
186 %{_datadir}/apps/xpertmud/perl/htmlmapper.pl
187 %{_datadir}/apps/xpertmud/perl/xperthud.pl
188 %dir %{_datadir}/apps/xpertmud/python
189 %{_datadir}/apps/xpertmud/python/battletech.py
190 %{_datadir}/apps/xpertmud/python/bt3030.py
191 %{_datadir}/apps/xpertmud/python/btcockpit.py
192 %{_datadir}/apps/xpertmud/python/claims.py
193 %{_datadir}/apps/xpertmud/python/contacts.py
194 %{_datadir}/apps/xpertmud/python/frequencies.py
195 %{_datadir}/apps/xpertmud/python/keybindings.py
196
197 %files plugins-misc-html
198 %defattr(644,root,root,755)
199 %{_libdir}/kde3/xmud_html.la
200 %attr(755,root,root) %{_libdir}/kde3/xmud_html.so
201 %{_datadir}/apps/xpertmud/perl/XMHTML.pm
This page took 0.128834 seconds and 3 git commands to generate.