]> git.pld-linux.org Git - SPECS.git/blob - xalan-c.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / xalan-c.spec
1 Summary:        C++ xslt library
2 Summary(pl.UTF-8):      Biblioteka xslt dla C++
3 Name:           xalan-c
4 Version:        1.11.0
5 Release:        1
6 License:        Apache v2.0
7 Group:          Applications/Publishing/XML
8 Source0:        http://www.apache.org/dist/xalan/xalan-c/sources/xalan_c-1.11-src.tar.gz
9 # Source0-md5:  9227d3e7ab375da3c643934b33a585b8
10 Patch1:         %{name}-soname.patch
11 URL:            https://xalan.apache.org/
12 BuildRequires:  util-linux
13 BuildRequires:  xerces-c-devel >= 3.1.1
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Apache Xalan Project is a collaborative software development project
18 dedicated to providing robust, full-featured, commercial-quality, and
19 freely available XSLT support on a wide variety of platforms.
20
21 This package contains C++ implementation of Xalan.
22
23 %description -l pl.UTF-8
24 Projekt Apache Xalan to wspólny projekt stworzenia oprogramowania
25 mającego zapewnic potężną, w pełni funkcjonalną, mającą komercyjną
26 jakość i jednocześnie wolnodostępną obsługę XSLT na szerokim zakresie
27 platform.
28
29 Ten pakiet zawiera bibliotekę Xalan dla języka C++.
30
31 %package devel
32 Summary:        xalan-c header files
33 Summary(pl.UTF-8):      Pliki nagłówkowe xalan-c
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 xalan-c header files.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe xalan-c.
42
43 %package docs
44 Summary:        Documentation for xalan-c
45 Summary(pl.UTF-8):      Dokumentacja xlan-c
46 Group:          Documentation
47 Requires:       %{name} = %{version}-%{release}
48
49 %description docs
50 Documentation for xalan-c.
51
52 %description docs -l pl.UTF-8
53 Dokumentacja xalan-c.
54
55 %package examples
56 Summary:        xalan-c examples
57 Summary(pl.UTF-8):      Przykłady dla xalan-c
58 Group:          Documentation
59 Requires:       %{name} = %{version}-%{release}
60
61 %description examples
62 xalan-c examples.
63
64 %description examples -l pl.UTF-8
65 Przykłady dla xalan-c.
66
67 %prep
68 %setup -q -n xalan-c-1.11
69 %patch1 -p1
70
71 sed -i -e 's#debugflag=".*";#debugflag="%{rpmcflags} %{rpmcppflags}";#' c/runConfigure
72
73 # cleanup backups after patching
74 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
75
76 %build
77 cd c
78 # create env.sh for easier debug from console
79 cat << EOF > env.sh
80 export XALANCROOT=$(pwd)
81 export XERCESCROOT=%{_prefix}
82 export ICUROOT=%{_prefix}
83 EOF
84
85 . ./env.sh
86
87 ./runConfigure \
88         -C "--libdir=%{_libdir}" \
89         -P %{_prefix} \
90         -p linux \
91         -c "%{__cc}" \
92         -x "%{__cxx}" \
93 %ifarch %{x8664} aarch64 alpha ppc64 s390x sparc64
94         -b 64 \
95 %else
96         -b 32 \
97 %endif
98         -t default \
99         -m inmem
100
101 %{__make} -j1
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 cd c
107
108 . ./env.sh
109
110 %{__make} -j1 install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install -d $RPM_BUILD_ROOT%{_libdir}
114 install -d $RPM_BUILD_ROOT%{_includedir}
115 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-docs-%{version}
116 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
117
118 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
119 cp -a xdocs/* $RPM_BUILD_ROOT%{_docdir}/%{name}-docs-%{version}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc c/{KEYS,NOTICE,README}
130 %attr(755,root,root) %{_bindir}/Xalan
131 %attr(755,root,root) %{_libdir}/libxalan-c.so.*.*
132 %attr(755,root,root) %{_libdir}/libxalanMsg.so.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libxalan-c.so.111
134 %attr(755,root,root) %ghost %{_libdir}/libxalanMsg.so.111
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libxalan-c.so
139 %attr(755,root,root) %{_libdir}/libxalanMsg.so
140 %{_includedir}/xalanc
141
142 %files docs
143 %defattr(644,root,root,755)
144 %{_docdir}/%{name}-docs-%{version}
145
146 %files examples
147 %defattr(644,root,root,755)
148 %{_examplesdir}/%{name}-%{version}
This page took 0.246255 seconds and 3 git commands to generate.