]> git.pld-linux.org Git - SPECS.git/blob - wvstreams.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / wvstreams.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # Doxygen documentation
4 %bcond_without  qt      # wvstreams-qt library
5
6 Summary:        A network programming library written in C++
7 Summary(pl.UTF-8):      Biblioteka programowania sieciowego napisana w C++
8 Name:           wvstreams
9 Version:        4.6.1
10 Release:        11
11 License:        LGPL v2
12 Group:          Libraries
13 #Source0Download: http://code.google.com/p/wvstreams/downloads/list
14 Source0:        http://wvstreams.googlecode.com/files/%{name}-%{version}.tar.gz
15 # Source0-md5:  2760dac31a43d452a19a3147bfde571c
16 Patch0:         %{name}-sort.patch
17 Patch1:         %{name}-tcl.patch
18 Patch2:         %{name}-qt.patch
19 Patch3:         %{name}-openssl.patch
20 Patch4:         %{name}-includes.patch
21 Patch5:         %{name}-4.2.2-multilib.patch
22 Patch6:         %{name}-4.5-noxplctarget.patch
23 Patch7:         %{name}-4.6.1-make.patch
24 Patch8:         %{name}-4.6.1-gcc47.patch
25 Patch9:         %{name}-4.6.1-magic.patch
26 Patch10:        gcc-6.patch
27 URL:            http://alumnit.ca/wiki/index.php?page=WvStreams
28 BuildRequires:  autoconf >= 2.50
29 BuildRequires:  boost-devel
30 BuildRequires:  dbus-devel >= 1.2.14
31 %{?with_apidocs:BuildRequires:  doxygen}
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  openssl-devel >= 0.9.7i
34 BuildRequires:  pam-devel
35 BuildRequires:  pkgconfig
36 %{?with_qt:BuildRequires:       qt-devel >= 3}
37 BuildRequires:  readline-devel
38 BuildRequires:  tcl-devel
39 BuildRequires:  zlib-devel
40 Obsoletes:      libwvstreams
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 WvStreams aims to be an efficient, secure, and easy-to-use library for
45 doing network applications development.
46
47 %description -l pl.UTF-8
48 WvStreams próbuje być wydajną, bezpieczną i łatwą w użyciu biblioteką
49 do tworzenia aplikacji sieciowych.
50
51 %package devel
52 Summary:        Development files for WvStreams
53 Summary(pl.UTF-8):      Pliki developerskie dla WvStreams
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libstdc++-devel
57 Obsoletes:      libwvstreams-devel
58
59 %description devel
60 WvStreams aims to be an efficient, secure, and easy-to-use library for
61 doing network applications development. This package contains the
62 files needed for developing applications which use WvStreams.
63
64 %description devel -l pl.UTF-8
65 WvStreams próbuje być wydajną, bezpieczną i łatwą w użyciu biblioteką
66 do tworzenia aplikacji sieciowych. Pakiet ten zawiera pliki niezbędne
67 do kompilowania oprogramowania używającego WvStreams.
68
69 %package static
70 Summary:        Static WvStreams library
71 Summary(pl.UTF-8):      Statyczna biblioteka WvStreams
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static WvStreams library.
77
78 %description static -l pl.UTF-8
79 Statyczna wersja biblioteki WvStreams.
80
81 %package qt
82 Summary:        WvStreams interface to Qt 3 library
83 Summary(pl.UTF-8):      Interfejs WvStreams do biblioteki Qt 3
84 Group:          X11/Libraries
85 Requires:       %{name} = %{version}-%{release}
86
87 %description qt
88 WvStreams interface to Qt 3 library.
89
90 %description qt -l pl.UTF-8
91 Interfejs WvStreams do biblioteki Qt 3.
92
93 %package qt-devel
94 Summary:        WvStreams interface to Qt 3 library - development files
95 Summary(pl.UTF-8):      Interfejs WvStreams do biblioteki Qt 3 - pliki programistyczne
96 Group:          X11/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Requires:       %{name}-qt = %{version}-%{release}
99 Requires:       qt-devel >= 3
100
101 %description qt-devel
102 WvStreams interface to Qt 3 library - development files.
103
104 %description qt-devel -l pl.UTF-8
105 Interfejs WvStreams do biblioteki Qt 3 - pliki programistyczne.
106
107 %package apidocs
108 Summary:        API documentation for WvStreams libraries
109 Summary(pl.UTF-8):      Dokumentacja API bibliotek WvStreams
110 Group:          Documentation
111 BuildArch:      noarch
112
113 %description apidocs
114 API documentation for WvStreams libraries.
115
116 %description apidocs -l pl.UTF-8
117 Dokumentacja API bibliotek WvStreams.
118
119 %package uniconfd
120 Summary:        Daemon for the UniConf configuration system
121 Summary(pl.UTF-8):      Demon dla systemu konfiguracji UniConf
122 Group:          Daemons
123 Requires:       %{name} = %{version}-%{release}
124
125 %description uniconfd
126 UniConf is the One True Configuration system that includes all the
127 others because it has plugin backends and frontends. Or, less
128 grandiosely, it's a lightweight, distributed, cacheable tree of
129 strings.
130
131 uniconfd is necessary when you have more than one application, or
132 multiple instances of an application, sharing one configuration.
133 UniConf-enabled applications contact uniconfd which provides
134 notifications when any of their watched keys change.
135
136 %description uniconfd -l pl.UTF-8
137 UniConf to system Jedynie Słusznej Konfiguracji zawierający
138 wszystkie inne, ponieważ ma wtyczki backendowe i frontendowe.
139 Mniej górnolotnie mówiąc, jest to lekkie, rozproszone, cache'owalne
140 drzewo łańcuchów znaków.
141
142 uniconfd jest potrzebny w przypadku korzystania z jednej konfiguracji
143 przez więcej niż jedną aplikację lub wiele instancji aplikacji. Wtedy
144 aplikacje korzystające z UniConfa kontaktują się z uniconfd, który
145 zapewnia powiadomienia w przypadku zmiany dowolnego z obserwowanych
146 kluczy.
147
148 %package -n valgrind-wvstreams
149 Summary:        WvStreams support for Valgrind
150 Summary(pl.UTF-8):      Obsługa WvStreams dla Valgrinda
151 Group:          Development/Libraries
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       valgrind
154
155 %description -n valgrind-wvstreams
156 WvStreams support for Valgrind.
157
158 %description -n valgrind-wvstreams -l pl.UTF-8
159 Obsługa WvStreams dla Valgrinda.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164 %patch1 -p1
165 %patch2 -p1
166 %patch3 -p1
167 %patch4 -p1
168 %patch5 -p1
169 %patch6 -p1
170 %patch7 -p1
171 %patch8 -p1
172 %patch9 -p1
173 %patch10 -p1
174
175 %build
176 %{__autoconf}
177 # disable-optimization disables -O2 override
178 %configure \
179         --disable-optimization \
180         %{!?with_qt:--without-qt}
181
182 %{__make} -j1 \
183         VPATH=%{_libdir} \
184         DEBUG=%{?debug:1}%{!?debug:0} \
185         CXX="%{__cxx}" \
186         VERBOSE=1 \
187         CXXOPTS="%{rpmcxxflags} -fPIC -fpermissive -fno-strict-aliasing -fno-tree-dce -fno-optimize-sibling-calls"
188         COPTS="%{rpmcflags} -fPIC -fPIC -fno-strict-aliasing"
189
190 %if %{with apidocs}
191 %{__make} doxygen
192 %endif
193
194 %install
195 rm -rf $RPM_BUILD_ROOT
196
197 %{__make} install \
198         DESTDIR=$RPM_BUILD_ROOT
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %files
207 %defattr(644,root,root,755)
208 %doc README ChangeLog
209 %attr(755,root,root) %{_bindir}/uni
210 %attr(755,root,root) %{_bindir}/wsd
211 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uniconf.conf
212 %attr(755,root,root) %{_libdir}/libuniconf.so.*.*
213 %attr(755,root,root) %{_libdir}/libwvbase.so.*.*
214 %attr(755,root,root) %{_libdir}/libwvdbus.so.*.*
215 %attr(755,root,root) %{_libdir}/libwvstreams.so.*.*
216 %attr(755,root,root) %{_libdir}/libwvutils.so.*.*
217 %{_mandir}/man8/uni.8*
218 %dir /var/lib/uniconf
219
220 %files devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/wvtestrun
223 %attr(755,root,root) %{_libdir}/libuniconf.so
224 %attr(755,root,root) %{_libdir}/libwvbase.so
225 %attr(755,root,root) %{_libdir}/libwvdbus.so
226 %attr(755,root,root) %{_libdir}/libwvstreams.so
227 %attr(755,root,root) %{_libdir}/libwvutils.so
228 %{_libdir}/libwvtest.a
229 %{_includedir}/wvstreams
230 %exclude %{_includedir}/wvstreams/wvqthook.h
231 %exclude %{_includedir}/wvstreams/wvqtstreamclone.h
232 %{_pkgconfigdir}/libuniconf.pc
233 %{_pkgconfigdir}/libwvbase.pc
234 %{_pkgconfigdir}/libwvdbus.pc
235 %{_pkgconfigdir}/libwvstreams.pc
236 %{_pkgconfigdir}/libwvtest.pc
237 %{_pkgconfigdir}/libwvutils.pc
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libwvstatic.a
242
243 %if %{with qt}
244 %files qt
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libwvqt.so.*.*
247
248 %files qt-devel
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_libdir}/libwvqt.so
251 %{_includedir}/wvstreams/wvqthook.h
252 %{_includedir}/wvstreams/wvqtstreamclone.h
253 %{_pkgconfigdir}/libwvqt.pc
254 %endif
255
256 %if %{with apidocs}
257 %files apidocs
258 %defattr(644,root,root,755)
259 %doc Docs/doxy-html/*
260 %endif
261
262 %files uniconfd
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_sbindir}/uniconfd
265 %config(noreplace) %verify(not md5 mtime size) /var/lib/uniconf/uniconfd.ini
266 %{_mandir}/man8/uniconfd.8*
267
268 %files -n valgrind-wvstreams
269 %defattr(644,root,root,755)
270 %{_libdir}/valgrind/wvstreams.supp
This page took 0.064271 seconds and 3 git commands to generate.