]> git.pld-linux.org Git - SPECS.git/blob - wv.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / wv.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # without static version
4
5 Summary:        MSWord Document to HTML converter
6 Summary(pl.UTF-8):      Konwerter dokumentów MS Worda do HTML
7 Summary(pt_BR.UTF-8):   Conversor de arquivos formato Word (6/7/8/9) para html
8 Name:           wv
9 Version:        1.2.9
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/Text
13 Source0:        http://www.abisource.com/downloads/wv/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  dbccf2e9f747e50c913b7e3d126b73f7
15 Patch0:         %{name}-format.patch
16 URL:            http://wvware.sourceforge.net/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 1:2.12.2
20 BuildRequires:  libgsf-devel >= 1.14.1
21 BuildRequires:  libpng-devel >= 1.2.12
22 BuildRequires:  libtool
23 BuildRequires:  libwmf-devel >= 2:0.2.8.4
24 BuildRequires:  libxml2-devel >= 1:2.6.26
25 BuildRequires:  pkgconfig
26 BuildRequires:  zlib-devel
27 # these are required for full libwmf
28 BuildRequires:  freetype-devel >= 2.0
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  xorg-lib-libX11-devel
31 Obsoletes:      mswordview
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags_ia32   -fomit-frame-pointer
35
36 %description
37 MSWordView is a program that understands the Microsoft Word 8 binary
38 file format (Office97, Office2000) and is able to convert Word
39 documents into HTML, which can then be read with a browser.
40
41 wv is a suite of programs to help convert Word Documents to HTML.
42
43 %description -l pl.UTF-8
44 MSWordView jest programem, który rozumie binarne dokumenty programu
45 Microsoft Word 8 (Office97, Office2000) i jest w stanie skonwertować
46 je do dokumentu HTML, który może być przeczytany w przeglądarce WWW.
47
48 wv jest elementem programów, które pomagają przekonwertować dokumenty
49 Worda do HTML.
50
51 %description -l pt_BR.UTF-8
52 Conversor de arquivos formato Word (6/7/8/9) para html.
53
54 %package devel
55 Summary:        Include files needed to compile
56 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki wv
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.12.2
60 Requires:       libgsf-devel >= 1.14.1
61 Requires:       libpng-devel >= 1.2.12
62 Requires:       libwmf-devel >= 2:0.2.8.4
63 Requires:       libxml2-devel >= 1:2.6.26
64 # these are required for full libwmf
65 Requires:       freetype-devel >= 2.0
66 Requires:       libjpeg-devel
67 Requires:       xorg-lib-libX11-devel
68
69 %description devel
70 Contains the header files.
71
72 %description devel -l pl.UTF-8
73 Pakiet tem zawiera pliki nagłówkowe wv.
74
75 %package static
76 Summary:        Static wv libraries
77 Summary(pl.UTF-8):      Biblioteki statyczne wv
78 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o wv
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Contains static wv libraries.
84
85 %description static -l pl.UTF-8
86 Pakiet zawiera statyczne biblioteki wv.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         %{!?with_static_libs:--disable-static} \
100         --with-zlib \
101         --with-png \
102         --with-libwmf
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # obsoleted by pkg-config
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwv.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README
124 %attr(755,root,root) %{_bindir}/wvAbw
125 %attr(755,root,root) %{_bindir}/wvCleanLatex
126 %attr(755,root,root) %{_bindir}/wvConvert
127 %attr(755,root,root) %{_bindir}/wvDVI
128 %attr(755,root,root) %{_bindir}/wvDocBook
129 %attr(755,root,root) %{_bindir}/wvHtml
130 %attr(755,root,root) %{_bindir}/wvLatex
131 %attr(755,root,root) %{_bindir}/wvMime
132 %attr(755,root,root) %{_bindir}/wvPDF
133 %attr(755,root,root) %{_bindir}/wvPS
134 %attr(755,root,root) %{_bindir}/wvRTF
135 %attr(755,root,root) %{_bindir}/wvSummary
136 %attr(755,root,root) %{_bindir}/wvText
137 %attr(755,root,root) %{_bindir}/wvVersion
138 %attr(755,root,root) %{_bindir}/wvWare
139 %attr(755,root,root) %{_bindir}/wvWml
140 %attr(755,root,root) %{_libdir}/libwv-1.2.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libwv-1.2.so.4
142 %{_datadir}/wv
143 %{_mandir}/man1/wvAbw.1*
144 %{_mandir}/man1/wvCleanLatex.1*
145 %{_mandir}/man1/wvDVI.1*
146 %{_mandir}/man1/wvHtml.1*
147 %{_mandir}/man1/wvLatex.1*
148 %{_mandir}/man1/wvMime.1*
149 %{_mandir}/man1/wvPDF.1*
150 %{_mandir}/man1/wvPS.1*
151 %{_mandir}/man1/wvRTF.1*
152 %{_mandir}/man1/wvSummary.1*
153 %{_mandir}/man1/wvText.1*
154 %{_mandir}/man1/wvVersion.1*
155 %{_mandir}/man1/wvWare.1*
156 %{_mandir}/man1/wvWml.1*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libwv.so
161 %{_includedir}/wv
162 %{_pkgconfigdir}/wv-1.0.pc
163
164 %if %{with static_libs}
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libwv.a
168 %endif
This page took 1.173806 seconds and 3 git commands to generate.