]> git.pld-linux.org Git - SPECS.git/blob - vitooki.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / vitooki.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        ViTooKi - The Video ToolKit
7 Name:           vitooki
8 Version:        0.1
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        %{name}-20100804.tar.bz2
13 Patch0:         gcc.patch
14 Patch1:         optflags.patch
15 # Source0-md5:  6fb92c80db72c61bd194da0ec15ddda2
16 URL:            http://vitooki.sourceforge.net/
17 BuildRequires:  SDL-devel
18 BuildRequires:  SDL_image-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  expat-devel
22 BuildRequires:  freetype-devel
23 BuildRequires:  libdvdcss-devel
24 BuildRequires:  libdvdread-devel
25 BuildRequires:  libmad-devel
26 BuildRequires:  libmatroska-devel
27 BuildRequires:  libogg-devel
28 BuildRequires:  libtheora-devel
29 BuildRequires:  nasm
30 BuildRequires:  openssl-devel
31 BuildRequires:  paragui-devel
32 BuildRequires:  qt-devel
33 BuildRequires:  slang-devel
34 ExclusiveArch:  %{ix86} %{x8664} arm
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Video-Toolkit is a operating system independent, powerful
39 high-level C++ multimedia library developed to simplify the
40 implementation of multimedia applications.
41
42 %prep
43 %setup -q -n %{name}
44 %patch0 -p1
45 %patch1 -p1
46
47 #sed -i -e '/all4itec:/s/ffmpeg//' Makefile # untouched
48 sed -i -e '/all4itec:/s/lame//' Makefile # untouched
49 sed -i -e '/all4itec:/s/paragui//' Makefile # untouched
50 sed -i -e '/all4itec:/s/isomp4lib//' Makefile # untouched
51 sed -i -e '/all4itec:/s/xvid//' Makefile # unknown
52 sed -i -e '/all4itec:/s/libdvdcss//' Makefile # untouched
53 sed -i -e '/all4itec:/s/libdvdread//' Makefile # untouched
54 sed -i -e '/all4itec:/s/libmatroska//' Makefile
55 sed -i -e '/all4itec:/s/libebml//' Makefile
56
57 install -d 3rdparty/system-libs
58 mv 3rdparty/{lame,paragui,libmad*,libtheora*,libdvdcss,libdvdread,libmatroska,libebml} 3rdparty/system-libs
59
60 # error with UINT64_C symbol
61 #mv 3rdparty/ffmpeg 3rdparty/system-libs
62 # need "bitstream/bitstream.h"
63 #mv 3rdparty/xvidcore* 3rdparty/system-libs
64
65 %build
66 cd 3rdparty/sord
67 if [ ! -f Makefile ]; then
68         CXX="%{__cxx}" \
69         CXXFLAGS="%{rpmcxxflags}" \
70                 %{__perl} configure.pl
71 fi
72 %{__make}
73 cd -
74
75
76 cd 3rdparty/ffmpeg
77         ./configure \
78         --enable-pp \
79         --enable-gpl \
80         --enable-mp3lame \
81         --enable-shared \
82         --disable-static \
83     --cc="%{__cc}" \
84 %if "%{?_x_libraries}" != "%{nil}"
85         --extra-ldflags="-L%{_x_libraries}"
86 %endif
87
88 #    --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
89 #    --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
90
91 %{__make}
92 cd -
93
94
95 %{__make} -j1 commonucl vitooki apps \
96         PWD=$(pwd) \
97         PREFIX=%{_prefix} \
98         GCC="%{__cc}" \
99         CPP="%{__cxx}" \
100         OPT_CFLAGS="%{rpmcflags}" \
101         OPT_CPPFLAGS="%{rpmcppflags} -funroll-loops -DVITOOKI_DEBUG_LEVEL=0 -fPIC" \
102         xRELEASE_CPPFLAGS="%{rpmcppflags} -funroll-loops -DVITOOKI_DEBUG_LEVEL=0 -fPIC" \
103         OPT_LDFLAGS="%{rpmldflags}" \
104         SDL_LIBS="" \
105         LIBMAD_LIBS="" \
106         LIBMAD_INCLUDES="" \
107         X11_LIBS="-L%{?_x_libraries}%{!?_x_libraries:%{_libdir}}" \
108         QT_LIBS="" \
109         EXPAT_LIBS="" \
110         EXPAT_INCLUDES="" \
111         QTDIR=/usr \
112         xFFMPEG="/usr/include" \
113         QT_INCLUDES="-I/usr/include/qt" \
114         XVIDLIB="-lxvidcore" \
115         PARALIB="$(pkg-config paragui --libs)" \
116         PARAINC="-I/usr/include/paragui $(pkg-config paragui --cflags)" \
117 %ifarch %{ix86}
118         VITOOKI_BUILD_ARCH=intel32 \
119 %endif
120 %ifarch %{x8664}
121         VITOOKI_BUILD_ARCH=intel64 \
122         EXTRA_FLAGS="-fPIC" \
123 %endif
124
125 %{?with_apidocs:doxygen doxygen.cfg}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS BUGLIST DOCUMENTATION INSTALL TODO
This page took 0.342295 seconds and 3 git commands to generate.