]> git.pld-linux.org Git - SPECS.git/blob - vim-plugin-coc.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / vim-plugin-coc.spec
1 %define         plugin coc
2 Summary:        Vim plugin: Intellisense engine, full language server protocol support as VSCode
3 Name:           vim-plugin-%{plugin}
4 Version:        0.0.80
5 Release:        1
6 License:        MIT
7 Group:          Applications/Editors/Vim
8 Source0:        https://github.com/neoclide/coc.nvim/archive/v%{version}/coc.nvim-%{version}.tar.gz
9 # Source0-md5:  f95c0a917d46d8c0ffa85dd6f5a93a98
10 URL:            https://github.com/neoclide/coc.nvim/
11 Requires:       nodejs >= 10.12
12 Requires:       vim-rt >= 4:8
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _vimdatadir     %{_datadir}/vim
17
18 %description
19 Coc.nvim enhances your (Neo)Vim to match the user experience provided
20 by VSCode through rich plugin ecosystem and Language Server Protocol
21 support.
22
23 Some of the features include:
24 - APIs that are compatible with both Vim (>= 8.0) and Neovim.
25 - Loading VSCode-like extensions.
26 - Configuring coc.nvim and its extensions by using JSON configuration
27   file.
28 - Configuring Language Servers that implement Language Server Protocol
29   (LSP).
30
31 %package doc
32 Summary:        Documentation for coc Vim plugin
33 Requires(post,postun):  /usr/bin/vim
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       vim-rt >= 4:7.4.2054-2
36
37 %description doc
38 Documentation for coc Vim plugin.
39
40 %prep
41 %setup -qn coc.nvim-%{version}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_vimdatadir}/{pack/coc/start/coc.nvim,doc}
46 cp -pr autoload bin build data plugin package.json $RPM_BUILD_ROOT%{_vimdatadir}/pack/coc/start/coc.nvim
47 cp -p doc/coc.* $RPM_BUILD_ROOT%{_vimdatadir}/doc
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post doc
53 %vim_doc_helptags
54
55 %postun doc
56 %vim_doc_helptags
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Readme.md history.md
61 %dir %{_vimdatadir}/pack/coc
62 %dir %{_vimdatadir}/pack/coc/start
63 %dir %{_vimdatadir}/pack/coc/start/coc.nvim
64 %{_vimdatadir}/pack/coc/start/coc.nvim/autoload
65 %dir %{_vimdatadir}/pack/coc/start/coc.nvim/bin
66 %attr(755,root,root) %{_vimdatadir}/pack/coc/start/coc.nvim/bin/prompt.js
67 %attr(755,root,root) %{_vimdatadir}/pack/coc/start/coc.nvim/bin/terminateProcess.sh
68 %{_vimdatadir}/pack/coc/start/coc.nvim/build
69 %{_vimdatadir}/pack/coc/start/coc.nvim/data
70 %{_vimdatadir}/pack/coc/start/coc.nvim/plugin
71 %{_vimdatadir}/pack/coc/start/coc.nvim/package.json
72
73 %files doc
74 %defattr(644,root,root,755)
75 %{_vimdatadir}/doc/coc.*
This page took 0.427853 seconds and 3 git commands to generate.